1 |
slords |
1.1 |
Summary: smserver rpm to setup mysql database and web link for wordpress weblog |
2 |
|
|
%define name smeserver-wordpress |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
|
|
%define release 5 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
Distribution: SME Server |
9 |
|
|
Copyright: GPL |
10 |
|
|
URL: http://www.dungog.net/sme |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
Packager: Stephen Noble <support@dungog.net> |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
Requires: e-smith-release >= 7.0 |
17 |
|
|
Requires: wordpress |
18 |
|
|
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
smserver rpm to setup mysql database and web link for wordpress weblog |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
25 |
|
|
- rpm %post events reordered, to enable clean install |
26 |
|
|
- [0.9-5] |
27 |
|
|
|
28 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
29 |
|
|
- http alias corrected |
30 |
|
|
- [0.9-4] |
31 |
|
|
|
32 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
33 |
|
|
- http PublicAccess setting added |
34 |
|
|
- [0.9-3] |
35 |
|
|
|
36 |
|
|
* Thu May 4 2006 Stephen Noble <support@dungog.net> |
37 |
|
|
- httpd fragment modified |
38 |
|
|
- rpm doesn't change file permissions |
39 |
|
|
- [0.9-2] |
40 |
|
|
|
41 |
|
|
* Sun Apr 16 2006 Stephen Noble <support@dungog.net> |
42 |
|
|
- initial release |
43 |
|
|
- [0.9-1] |
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
%setup |
47 |
|
|
|
48 |
|
|
%build |
49 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/wordpress |
50 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/wordpress/type |
51 |
|
|
|
52 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/wordpress |
53 |
|
|
echo "Wordpress weblog" > root/etc/e-smith/db/configuration/defaults/wordpress/Name |
54 |
|
|
echo "global" > root/etc/e-smith/db/configuration/defaults/wordpress/PublicAccess |
55 |
|
|
|
56 |
|
|
%install |
57 |
|
|
rm -rf $RPM_BUILD_ROOT |
58 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
59 |
|
|
rm -f %{name}-%{version}-filelist |
60 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
61 |
|
|
--dir '/opt/wordpress' 'attr(755,www,www)' \ |
62 |
|
|
> %{name}-%{version}-filelist |
63 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
64 |
|
|
|
65 |
|
|
%clean |
66 |
|
|
cd .. |
67 |
|
|
rm -rf %{name}-%{version} |
68 |
|
|
|
69 |
|
|
%pre |
70 |
|
|
%preun |
71 |
|
|
|
72 |
|
|
%post |
73 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
74 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80wordpress.sql |
75 |
|
|
/etc/rc.d/init.d/mysql.init start |
76 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
77 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
78 |
|
|
|
79 |
|
|
echo "" |
80 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
81 |
|
|
echo "current settings 'config show wordpress'..." |
82 |
|
|
/sbin/e-smith/config show wordpress |
83 |
|
|
|
84 |
|
|
%postun |
85 |
|
|
#uninstall |
86 |
|
|
if [ $1 = 0 ] ; then |
87 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
88 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
89 |
|
|
fi |
90 |
|
|
|
91 |
|
|
%files -f %{name}-%{version}-filelist |
92 |
|
|
%defattr(-,root,root) |
93 |
|
|
|