1 |
slords |
1.1 |
Summary: smserver rpm to setup mysql database and web link for wordpress weblog |
2 |
|
|
%define name smeserver-wordpress |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
|
|
%define release 5 |
6 |
|
|
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.2 |
License: GPL |
9 |
slords |
1.1 |
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
Requires: e-smith-release >= 7.0 |
15 |
|
|
Requires: wordpress |
16 |
slords |
1.5 |
BuildRequires: e-smith-devtools |
17 |
slords |
1.1 |
AutoReqProv: no |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
smserver rpm to setup mysql database and web link for wordpress weblog |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
24 |
|
|
- rpm %post events reordered, to enable clean install |
25 |
|
|
- [0.9-5] |
26 |
|
|
|
27 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
28 |
|
|
- http alias corrected |
29 |
|
|
- [0.9-4] |
30 |
|
|
|
31 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
32 |
|
|
- http PublicAccess setting added |
33 |
|
|
- [0.9-3] |
34 |
|
|
|
35 |
|
|
* Thu May 4 2006 Stephen Noble <support@dungog.net> |
36 |
|
|
- httpd fragment modified |
37 |
|
|
- rpm doesn't change file permissions |
38 |
|
|
- [0.9-2] |
39 |
|
|
|
40 |
|
|
* Sun Apr 16 2006 Stephen Noble <support@dungog.net> |
41 |
|
|
- initial release |
42 |
|
|
- [0.9-1] |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/wordpress |
49 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/wordpress/type |
50 |
|
|
|
51 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/wordpress |
52 |
|
|
echo "Wordpress weblog" > root/etc/e-smith/db/configuration/defaults/wordpress/Name |
53 |
|
|
echo "global" > root/etc/e-smith/db/configuration/defaults/wordpress/PublicAccess |
54 |
|
|
|
55 |
|
|
%install |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
58 |
|
|
rm -f %{name}-%{version}-filelist |
59 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
60 |
|
|
--dir '/opt/wordpress' 'attr(755,www,www)' \ |
61 |
|
|
> %{name}-%{version}-filelist |
62 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
63 |
|
|
|
64 |
|
|
%clean |
65 |
|
|
cd .. |
66 |
|
|
rm -rf %{name}-%{version} |
67 |
|
|
|
68 |
|
|
%pre |
69 |
|
|
%preun |
70 |
|
|
|
71 |
|
|
%post |
72 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
73 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80wordpress.sql |
74 |
|
|
/etc/rc.d/init.d/mysql.init start |
75 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
76 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
77 |
|
|
|
78 |
|
|
echo "" |
79 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
80 |
|
|
echo "current settings 'config show wordpress'..." |
81 |
|
|
/sbin/e-smith/config show wordpress |
82 |
|
|
|
83 |
|
|
%postun |
84 |
|
|
#uninstall |
85 |
|
|
if [ $1 = 0 ] ; then |
86 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
87 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
88 |
|
|
fi |
89 |
|
|
|
90 |
|
|
%files -f %{name}-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |
92 |
|
|
|