1 |
dungog |
1.6 |
# $Id: smeserver-wordpress.spec,v 1.5 2008/11/25 16:20:35 slords Exp $ |
2 |
slords |
1.3 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
%define name smeserver-wordpress |
6 |
|
|
%define version 1.0 |
7 |
dungog |
1.6 |
%define release 2 |
8 |
slords |
1.1 |
Summary: smserver rpm to setup mysql database and web link for wordpress weblog |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 2 |
13 |
dungog |
1.6 |
URL: http://www.dungog.net/wiki |
14 |
slords |
1.1 |
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
dungog |
1.6 |
Patch0: smeserver-wordpress-1.0-rm80opt.patch |
17 |
slords |
1.1 |
BuildArchitectures: noarch |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
20 |
|
|
Requires: e-smith-release >= 7.0 |
21 |
|
|
Requires: wordpress |
22 |
|
|
AutoReqProv: no |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
smserver rpm to setup mysql database and web link for wordpress weblog |
26 |
|
|
|
27 |
|
|
%changelog |
28 |
dungog |
1.6 |
* Sat Nov 29 2008 Stephen Noble <support@dungog.net> 1.0-2 |
29 |
|
|
- http alias 80opt removed |
30 |
|
|
|
31 |
slords |
1.1 |
* Fri Jul 06 2007 Stephen Noble <support@dungog.net> 1.0-1 |
32 |
|
|
- http alias, auto setup, template wp-config.php |
33 |
|
|
|
34 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
35 |
|
|
- rpm %post events reordered, to enable clean install |
36 |
|
|
- [0.9-5] |
37 |
|
|
|
38 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
39 |
|
|
- http alias corrected |
40 |
|
|
- [0.9-4] |
41 |
|
|
|
42 |
|
|
* Thu Nov 9 2006 Stephen Noble <support@dungog.net> |
43 |
|
|
- http PublicAccess setting added |
44 |
|
|
- [0.9-3] |
45 |
|
|
|
46 |
|
|
* Thu May 4 2006 Stephen Noble <support@dungog.net> |
47 |
|
|
- httpd fragment modified |
48 |
|
|
- rpm doesn't change file permissions |
49 |
|
|
- [0.9-2] |
50 |
|
|
|
51 |
|
|
* Sun Apr 16 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- initial release |
53 |
|
|
- [0.9-1] |
54 |
|
|
|
55 |
|
|
%prep |
56 |
|
|
%setup |
57 |
dungog |
1.6 |
%patch0 -p1 |
58 |
slords |
1.1 |
|
59 |
|
|
%build |
60 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/wordpress |
61 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/wordpress/type |
62 |
|
|
|
63 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/wordpress |
64 |
|
|
echo "Wordpress weblog" > root/etc/e-smith/db/configuration/defaults/wordpress/Name |
65 |
|
|
echo "global" > root/etc/e-smith/db/configuration/defaults/wordpress/PublicAccess |
66 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/wordpress/status |
67 |
|
|
echo "wordpress" > root/etc/e-smith/db/configuration/defaults/wordpress/DbName |
68 |
|
|
echo "wordpress" > root/etc/e-smith/db/configuration/defaults/wordpress/DbUser |
69 |
|
|
echo "en" > root/etc/e-smith/db/configuration/defaults/wordpress/WpLang |
70 |
|
|
|
71 |
|
|
mkdir -p root/etc/e-smith/templates.metadata/etc/e-smith/sql/init |
72 |
|
|
echo "PERMS=0750" > root/etc/e-smith/templates.metadata/etc/e-smith/sql/init/80wordpress |
73 |
|
|
|
74 |
|
|
#only needed so it is removed afterwards |
75 |
|
|
mkdir -p root/opt/wordpress |
76 |
|
|
touch root/opt/wordpress/wp-config.php |
77 |
|
|
|
78 |
|
|
%install |
79 |
|
|
rm -rf $RPM_BUILD_ROOT |
80 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
81 |
|
|
rm -f %{name}-%{version}-filelist |
82 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
83 |
|
|
> %{name}-%{version}-filelist |
84 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
85 |
|
|
|
86 |
|
|
%clean |
87 |
|
|
cd .. |
88 |
|
|
rm -rf %{name}-%{version} |
89 |
|
|
|
90 |
|
|
%pre |
91 |
|
|
%preun |
92 |
|
|
|
93 |
|
|
%post |
94 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
95 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80wordpress |
96 |
|
|
/etc/rc.d/init.d/mysql.init start |
97 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
98 |
|
|
/sbin/e-smith/expand-template /opt/wordpress/wp-config.php |
99 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
100 |
|
|
|
101 |
|
|
echo "" |
102 |
|
|
echo "see wiki.contribs.org/wordpress" |
103 |
|
|
|
104 |
|
|
%postun |
105 |
|
|
#uninstall |
106 |
|
|
if [ $1 = 0 ] ; then |
107 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
108 |
|
|
/usr/bin/sv h /service/httpd-e-smith |
109 |
|
|
fi |
110 |
|
|
|
111 |
|
|
%files -f %{name}-%{version}-filelist |
112 |
|
|
%defattr(-,root,root) |
113 |
|
|
|