1 |
jpp |
1.1 |
# $Id: smeserver-xinetd.spec,v 1.4 2018/11/30 11:49:22 jcrisp Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
%define name smeserver-xinetd |
6 |
|
|
%define version 0.3 |
7 |
|
|
%define release 4 |
8 |
|
|
Summary: Set up xinetd for services. |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 2 |
13 |
|
|
Group: SMEserver/addon |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
Patch0: smeserver-xinetd-0.3-bz7832.allowdir.patch |
16 |
|
|
Patch1: smeserver-xinetd-0.3-bz7832.new_template.patch |
17 |
|
|
Patch2: smeserver-xinetd-0.3-bz7832.smtp.patch |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
|
|
BuildArchitectures: noarch |
20 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
21 |
|
|
Requires: e-smith-release >= 7.0 |
22 |
|
|
Requires: e-smith-base >= 5.6.0-34 |
23 |
|
|
Requires: xinetd >= 2.3.13 |
24 |
|
|
AutoReqProv: no |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Integration package to enable xinetd on SME Server. |
28 |
|
|
|
29 |
|
|
%changelog |
30 |
|
|
* Fri Nov 30 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3-4.sme |
31 |
|
|
- Add configuration for smtp [SME: 10512] |
32 |
|
|
|
33 |
|
|
* Tue Feb 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.3-3.sme |
34 |
|
|
- add new template for the complete config file [SME: 7832] |
35 |
|
|
- requires e-smith-base >= 5.6.0-34 after other xinetd.conf fragment has been removed |
36 |
|
|
|
37 |
|
|
* Tue Feb 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.3-2.sme |
38 |
|
|
- fix double default template and missind xinetd.d [SME: 7832] |
39 |
|
|
|
40 |
|
|
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-1.sme |
41 |
|
|
- Initial release to contribs9 |
42 |
|
|
|
43 |
|
|
* Wed Apr 18 2008 Shad L. Lords <slords@mail.com> 0.1-1 |
44 |
|
|
- initial release |
45 |
|
|
|
46 |
|
|
%prep |
47 |
|
|
%setup |
48 |
|
|
%patch0 -p1 |
49 |
|
|
%patch1 -p1 |
50 |
|
|
%patch2 -p1 |
51 |
|
|
|
52 |
|
|
%build |
53 |
|
|
perl createlinks |
54 |
|
|
|
55 |
|
|
%install |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
58 |
|
|
rm -f %{name}-%{version}-filelist |
59 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
60 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
61 |
|
|
|
62 |
|
|
%clean |
63 |
|
|
rm -rf $RPM_BUILD_ROOT |
64 |
|
|
|
65 |
|
|
%files -f %{name}-%{version}-filelist |
66 |
|
|
%defattr(-,root,root) |
67 |
|
|
|
68 |
|
|
%post |
69 |
|
|
|
70 |
|
|
if ! [ -L /usr/sbin/in.qpsmtpd ]; then |
71 |
|
|
echo "Setting up symlink /usr/sbin/in.smtp /usr/sbin/in.qpsmtpd" |
72 |
|
|
ln -s in.smtp /usr/sbin/in.qpsmtpd |
73 |
|
|
else |
74 |
|
|
echo " in.qpsmtpd link exists" |
75 |
|
|
fi |