1 |
# $Id: smeserver-xinetd.spec,v 1.1 2021/02/24 01:45:35 jpp Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-xinetd |
6 |
%define version 0.3 |
7 |
%define release 5 |
8 |
Summary: Set up xinetd for services. |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
Group: SMEserver/addon |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
Patch0: smeserver-xinetd-0.3-bz7832.allowdir.patch |
16 |
Patch1: smeserver-xinetd-0.3-bz7832.new_template.patch |
17 |
Patch2: smeserver-xinetd-0.3-bz7832.smtp.patch |
18 |
Patch3: smeserver-xinetd-0.3-bz11387-systemd-update.patch |
19 |
|
20 |
BuildRoot: /var/tmp/%{name}-%{version} |
21 |
BuildArchitectures: noarch |
22 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
23 |
Requires: e-smith-release >= 7.0 |
24 |
Requires: e-smith-base >= 5.6.0-34 |
25 |
Requires: xinetd >= 2.3.13 |
26 |
AutoReqProv: no |
27 |
|
28 |
%description |
29 |
Integration package to enable xinetd on SME Server. |
30 |
|
31 |
%changelog |
32 |
* Tue Feb 23 2021 Jean-Philipe Pialasse <tests@pialasse.com> 0.3-5.sme |
33 |
- import for SME10 [SME: 11387] |
34 |
systemd compliant |
35 |
update event |
36 |
|
37 |
* Fri Nov 30 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3-4.sme |
38 |
- Add configuration for smtp [SME: 10512] |
39 |
|
40 |
* Tue Feb 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.3-3.sme |
41 |
- add new template for the complete config file [SME: 7832] |
42 |
- requires e-smith-base >= 5.6.0-34 after other xinetd.conf fragment has been removed |
43 |
|
44 |
* Tue Feb 13 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.3-2.sme |
45 |
- fix double default template and missind xinetd.d [SME: 7832] |
46 |
|
47 |
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.3-1.sme |
48 |
- Initial release to contribs9 |
49 |
|
50 |
* Wed Apr 18 2008 Shad L. Lords <slords@mail.com> 0.1-1 |
51 |
- initial release |
52 |
|
53 |
%prep |
54 |
%setup |
55 |
%patch0 -p1 |
56 |
%patch1 -p1 |
57 |
%patch2 -p1 |
58 |
%patch3 -p1 |
59 |
|
60 |
%build |
61 |
perl createlinks |
62 |
|
63 |
%install |
64 |
rm -rf $RPM_BUILD_ROOT |
65 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
66 |
rm -f %{name}-%{version}-filelist |
67 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
68 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
69 |
|
70 |
%clean |
71 |
rm -rf $RPM_BUILD_ROOT |
72 |
|
73 |
%files -f %{name}-%{version}-filelist |
74 |
%defattr(-,root,root) |
75 |
|
76 |
%post |
77 |
|
78 |
if ! [ -L /usr/sbin/in.qpsmtpd ]; then |
79 |
echo "Setting up symlink /usr/sbin/in.smtp /usr/sbin/in.qpsmtpd" |
80 |
ln -s in.smtp /usr/sbin/in.qpsmtpd |
81 |
else |
82 |
echo " in.qpsmtpd link exists" |
83 |
fi |