1 |
michel |
1.1 |
%define name smeserver-xt_geoip |
2 |
|
|
%define version 1.3.1 |
3 |
michel |
1.14 |
%define release 13 |
4 |
michel |
1.1 |
|
5 |
|
|
Summary: smserver rpm to setup database, update and configuration for xt_geoip module with a panel. |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GNU GPL version 2 |
10 |
|
|
URL: http://wiki.contribs.org/Main_Page |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.xz |
13 |
michel |
1.2 |
Patch0: %{name}-%{version}-comp_e-smith-manager.patch |
14 |
michel |
1.3 |
Patch1: %{name}-%{version}-update_base.patch |
15 |
jpp |
1.4 |
Patch2: smeserver-xt_geoip-1.3.1-update-event-oldManager.patch |
16 |
michel |
1.7 |
Patch3: %{name}-%{version}-logfiles_changes.patch |
17 |
terryfage |
1.8 |
Patch4: smeserver-xt_geoip-1.3.1-locale-2021-08-25.patch |
18 |
terryfage |
1.9 |
Patch5: smeserver-xt_geoip-1.3.1-locale-2021-09-23.patch |
19 |
michel |
1.10 |
Patch6: smeserver-xt_geoip-1.3.1-locale-2021-10-28.patch |
20 |
michel |
1.11 |
Patch7: smeserver-xt_geoip-1.3.1-SME_11676.patch |
21 |
brianr |
1.12 |
Patch8: smeserver-xt_geoip-1.3.1-Add-class-to-div-for-AdminLTE.patch |
22 |
michel |
1.14 |
Patch9: smeserver-xt_geoip-1.3.1-SME_11887.patch |
23 |
michel |
1.2 |
|
24 |
michel |
1.1 |
BuildArchitectures: noarch |
25 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
26 |
|
|
BuildRequires: e-smith-devtools |
27 |
|
|
Requires: e-smith-release >= 10.0 |
28 |
|
|
Requires: server-manager >= 0.1.0-23 |
29 |
|
|
Requires: xtables-addons = 2.14 |
30 |
jpp |
1.6 |
Requires: GeoIP >= 1.5.0 |
31 |
michel |
1.1 |
Requires: libmaxminddb >= 1.1.1 |
32 |
|
|
Requires: libmaxminddb-devel >= 1.1.1 |
33 |
|
|
Requires: geolite2-country |
34 |
|
|
Requires: geolite2-city |
35 |
|
|
AutoReqProv: no |
36 |
|
|
|
37 |
|
|
%description |
38 |
|
|
smserver rpm to setup database, update and configuration for xt_geoip module with a panel. |
39 |
|
|
|
40 |
|
|
|
41 |
|
|
%prep |
42 |
|
|
%setup |
43 |
michel |
1.2 |
%patch0 -p1 |
44 |
michel |
1.3 |
%patch1 -p1 |
45 |
jpp |
1.4 |
%patch2 -p1 |
46 |
michel |
1.7 |
%patch3 -p1 |
47 |
terryfage |
1.8 |
%patch4 -p1 |
48 |
terryfage |
1.9 |
%patch5 -p1 |
49 |
michel |
1.10 |
%patch6 -p1 |
50 |
michel |
1.11 |
# tmp fix before new source archive |
51 |
|
|
rm -rf root/etc/e-smith/events/bootstrap-console-save/templates2expand |
52 |
|
|
rm -rf root/etc/e-smith/events/console-save/templates2expand |
53 |
|
|
rm -rf root/etc/e-smith/events/xt_geoip-modify/templates2expand/usr |
54 |
|
|
rm -rf root/etc/e-smith/events/xt_geoip-update/templates2expand/usr |
55 |
|
|
%patch7 -p1 |
56 |
jpp |
1.13 |
%patch8 -p1 |
57 |
michel |
1.14 |
%patch9 -p1 |
58 |
michel |
1.11 |
|
59 |
michel |
1.1 |
%build |
60 |
|
|
perl createlinks |
61 |
|
|
|
62 |
|
|
|
63 |
|
|
%install |
64 |
|
|
rm -rf $RPM_BUILD_ROOT |
65 |
|
|
|
66 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
67 |
|
|
rm -f %{name}-%{version}-filelist |
68 |
jpp |
1.4 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
69 |
jpp |
1.5 |
--file /usr/share/xt_geoip/geoip_countries_list.txt 'attr(0755, root, root)'\ |
70 |
|
|
--file /usr/share/xt_geoip/geoip_exstat 'attr(0755, root, root)'\ |
71 |
|
|
--file /usr/share/xt_geoip/geoip_listat 'attr(0755, root, root)'\ |
72 |
|
|
--file /usr/share/xt_geoip/geoip_look 'attr(0755, root, root)'\ |
73 |
|
|
--file /usr/share/xt_geoip/geoip_stats 'attr(0755, root, root)'\ |
74 |
|
|
--file /usr/share/xt_geoip/xt_geoip_dl 'attr(0750, root, root)'\ |
75 |
|
|
--file /usr/share/xt_geoip/update_base 'attr(0750, root, root)'\ |
76 |
michel |
1.1 |
> %{name}-%{version}-filelist |
77 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
78 |
jpp |
1.5 |
|
79 |
michel |
1.1 |
%clean |
80 |
|
|
cd .. |
81 |
|
|
rm -rf %{name}-%{version} |
82 |
|
|
|
83 |
|
|
%pre |
84 |
|
|
%preun |
85 |
|
|
|
86 |
|
|
%post |
87 |
|
|
|
88 |
|
|
%postun |
89 |
|
|
|
90 |
|
|
%files -f %{name}-%{version}-filelist |
91 |
|
|
%defattr(-,root,root) |
92 |
|
|
|
93 |
jpp |
1.4 |
|
94 |
|
|
|
95 |
|
|
%changelog |
96 |
michel |
1.14 |
* Wed Mar 09 2022 Michel Begue <mab974@misouk.com> 1.3.1-13.sme |
97 |
|
|
- fix Other and Reverse parameters for SM2 [SME: 11887] |
98 |
|
|
|
99 |
brianr |
1.12 |
* Fri Jan 07 2022 Brian Read <brianr@bjsystems.co.uk> 1.3.1-12.sme |
100 |
|
|
- Add-class-to-div-for-AdminLTE [SME: 11839] |
101 |
|
|
|
102 |
michel |
1.11 |
* Fri Oct 29 2021 Michel Begue <mab974@misouk.com> 1.3.1-11.sme |
103 |
|
|
- fix multiple_rpm_owners [SME: 11676] |
104 |
|
|
- add event for smeserver-manager |
105 |
|
|
- delete expand-template for update_base |
106 |
|
|
|
107 |
michel |
1.10 |
* Thu Oct 28 2021 Michel Begue <mab974@gmail.com> 1.3.1-10.sme |
108 |
|
|
- apply locale 2021-10-28 patch |
109 |
|
|
|
110 |
terryfage |
1.9 |
* Fri Sep 24 2021 Terry Fage <tfage@yahoo.com.au> 1.3.1-09.sme |
111 |
|
|
- apply locale 2021-09-23 patch |
112 |
|
|
|
113 |
terryfage |
1.8 |
* Wed Aug 25 2021 Terry Fage <tfage@yahoo.com.au> 1.3.1-08.sme |
114 |
|
|
- apply locale 2021-08-25 patch |
115 |
|
|
|
116 |
michel |
1.7 |
* Tue Mar 16 2021 Michel Begue <mab974@gmail.com> 1.3.1-07.sme |
117 |
|
|
- Fix script as logfiles change (sshd - iptables) |
118 |
|
|
|
119 |
jpp |
1.6 |
* Sun Mar 14 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.3.1-06.sme |
120 |
|
|
- change Geoip requirement to >= 1.5 |
121 |
|
|
|
122 |
|
|
* Sat Mar 13 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.3.1-05.sme |
123 |
jpp |
1.4 |
- readded changelog from contribs9 |
124 |
|
|
- moved changelog to the end of spec |
125 |
|
|
- TODO review the two section of %files |
126 |
|
|
- added link to wrapper for e-smith-manager |
127 |
|
|
|
128 |
|
|
* Wed Jan 06 2021 Michel Begue <mab974@gmail.com> 1.3.1-03.sme |
129 |
|
|
- Back to compatibility with e-smith-manager |
130 |
|
|
- (s)qpsmtpd replace (s)smtpd (services) |
131 |
|
|
- remove 'update_base' script template |
132 |
|
|
|
133 |
|
|
* Fri Jul 31 2020 Michel Begue <mab974@gmail.com> 1.3.1-01.sme |
134 |
|
|
- initial release for smeserver-manager (sme10) |
135 |
|
|
- [1.0.1-26 sme9] |
136 |
|
|
- xtables-addons v2.14 |
137 |
|
|
|
138 |
|
|
* Mon Feb 24 2020 Michel Begue <mab974@gmail.com> 1.0.1-26.sme |
139 |
|
|
- add localhost to whitelist [SME: 10881] |
140 |
|
|
|
141 |
|
|
* Tue Jan 21 2020 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-25.sme |
142 |
|
|
- add requirement for mmdb provided by rpm to allow accounting [SME: 10860] |
143 |
|
|
|
144 |
|
|
* Sat Jan 18 2020 Michel Begue <mab974@gmail.com> 1.0.1-24.sme |
145 |
|
|
- new download script adapted to SME (from xtables-addons) [SME: 10860] |
146 |
|
|
- change geoiplookup to mmdblookup |
147 |
|
|
|
148 |
|
|
* Sat Jan 11 2020 Michel Begue <mab974@gmail.com> 1.0.1-23.sme |
149 |
|
|
- add license_key in config db and test in panel [SME: 10860] |
150 |
|
|
|
151 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.0.1-21.sme |
152 |
|
|
- apply locale 2019-12-07 patch |
153 |
|
|
|
154 |
|
|
* Wed Oct 16 2019 Michel Begue <mab974@gmail.com> 1.0.1-20.sme |
155 |
|
|
- panel to add services [SME: 10792] |
156 |
|
|
- french translation |
157 |
|
|
|
158 |
|
|
* Mon Sep 30 2019 Michel Begue <mab974@gmail.com> 1.0.1-19.sme |
159 |
|
|
- add country code list [SME: 10791] |
160 |
|
|
- fix stats SSH errors [SME: 10807] |
161 |
|
|
- improved panel [SME: 10788] |
162 |
|
|
|
163 |
|
|
* Sat Sep 21 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-18.sme |
164 |
|
|
- add more service [SME: 10789] |
165 |
|
|
- no email from log analysis by default [SME: 10797] |
166 |
|
|
|
167 |
|
|
* Sun Jul 28 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-17.sme |
168 |
|
|
- fix empty global filter disable all geoip iptables rules [SME: 10794] |
169 |
|
|
- tidy masq templates for xt geoip [SME: 10794] |
170 |
|
|
|
171 |
|
|
* Wed Jul 24 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-16.sme |
172 |
|
|
- add missing file to patch [SME: 10760] |
173 |
|
|
- workaround link issue in source [SME: 10790] |
174 |
|
|
|
175 |
|
|
* Tue Jul 23 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-15.sme |
176 |
|
|
- improved per service filtering [SME: 10760] |
177 |
|
|
- remove A1 forced as default and allow empty filter [SME: 10785] |
178 |
|
|
|
179 |
|
|
* Sun Jul 21 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-13.sme |
180 |
|
|
- fix network lock out on adjust [SME: 10760] |
181 |
|
|
this arised on initial install with a simple masq adjust |
182 |
|
|
or if XT_geoip is disbaled on any masq restart or adjust |
183 |
|
|
|
184 |
|
|
* Wed Apr 24 2019 Michel Begue <mab974@gmail.com> 1.0.1-12.sme |
185 |
|
|
- add per service management of GeoIP bans [SME: 10760] |
186 |
|
|
- move panel to Security [SME: 10773] |
187 |
|
|
|
188 |
|
|
* Wed Apr 17 2019 Michel Begue <mab974@gmail.com> 1.0.1-9.sme |
189 |
|
|
- add stats access in the panel [SME: 10745] |
190 |
|
|
- add control of maximum number of countries [SME: 10749] |
191 |
|
|
|
192 |
|
|
* Wed Mar 06 2019 Michel Begue <mab974@gmail.com> 1.0.1-7.sme |
193 |
|
|
- add stats of geoip blocked countries [SME: 10745] |
194 |
|
|
- add stats of ssh attacks not geoip blocked [SME: 10744] |
195 |
|
|
- expand /etc/crontab on update |
196 |
|
|
|
197 |
|
|
* Mon Feb 18 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-6.sme |
198 |
|
|
- fix unable to load iptables rules [SME: 10739] |
199 |
|
|
fix warning localtime |
200 |
|
|
fix warning "enabled" isn't numeric in numeric eq (==) |
201 |
|
|
|
202 |
|
|
* Wed Feb 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-5.sme |
203 |
|
|
- first import to SME buildsys |
204 |
|
|
|
205 |
|
|
* Sun Oct 29 2017 Michel Begue <mab974@gmail.com> |
206 |
|
|
- bug in crontab update job, |
207 |
|
|
- [1.0.1-4] |
208 |
|
|
|
209 |
|
|
* Mon Oct 16 2017 Michel Begue <mab974@gmail.com> |
210 |
|
|
- new message : inactive GeoIP, |
211 |
|
|
- value of country code added in message "country not found", |
212 |
|
|
- [1.0.1-3] |
213 |
|
|
|
214 |
|
|
* Sat Oct 07 2017 Michel Begue <mab974@gmail.com> |
215 |
|
|
- test kernel module presence in "/lib/modules/weak-updates" directory |
216 |
|
|
- [1.0.1-2] |
217 |
|
|
|
218 |
|
|
* Wed Sep 20 2017 Michel Begue <mab974@gmail.com> |
219 |
|
|
- panel added in server manager |
220 |
|
|
- [1.0.1-1] |
221 |
|
|
|
222 |
|
|
* Tue Sep 12 2017 Michel Begue <mab974@gmail.com> |
223 |
|
|
- initial release |
224 |
|
|
- [1.0.0-1] |