1 |
%define name smeserver-xt_geoip |
2 |
%define version 1.3.1 |
3 |
%define release 21 |
4 |
|
5 |
Summary: smserver rpm to setup database, update and configuration for xt_geoip module with a panel. |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release}%{?dist} |
9 |
License: GNU GPL version 2 |
10 |
URL: http://wiki.contribs.org/Main_Page |
11 |
Group: SMEserver/addon |
12 |
Source: %{name}-%{version}.tar.xz |
13 |
Patch0: %{name}-%{version}-comp_e-smith-manager.patch |
14 |
Patch1: %{name}-%{version}-update_base.patch |
15 |
Patch2: smeserver-xt_geoip-1.3.1-update-event-oldManager.patch |
16 |
Patch3: %{name}-%{version}-logfiles_changes.patch |
17 |
Patch4: smeserver-xt_geoip-1.3.1-locale-2021-08-25.patch |
18 |
Patch5: smeserver-xt_geoip-1.3.1-locale-2021-09-23.patch |
19 |
Patch6: smeserver-xt_geoip-1.3.1-locale-2021-10-28.patch |
20 |
Patch7: smeserver-xt_geoip-1.3.1-SME_11676.patch |
21 |
Patch8: smeserver-xt_geoip-1.3.1-Add-class-to-div-for-AdminLTE.patch |
22 |
Patch9: smeserver-xt_geoip-1.3.1-SME_11887.patch |
23 |
Patch10: smeserver-xt_geoip-1.3.1-bz12029_backup-bz10863_bases.patch |
24 |
Patch11: smeserver-xt_geoip-1.3.1-bz12097_fix_logs_date_test.patch |
25 |
Patch12: smeserver-xt_geoip-1.3.1-bz12098_add_fail2ban_stats.patch |
26 |
Patch13: smeserver-xt_geoip-1.3.1-locale-2022-11-11.patch |
27 |
Patch14: smeserver-xt_geoip-1.3.1-bz12291_module_state.patch |
28 |
Patch15: smeserver-xt_geoip-1.3.1-bz10793_module_load.patch |
29 |
Patch16: smeserver-xt_geoip-1.3.1-Alter-menu-category-for-new-arrangement.patch |
30 |
Patch17: smeserver-xt_geoip-1.3.1-locale-2024-09-06.patch |
31 |
|
32 |
BuildArchitectures: noarch |
33 |
BuildRoot: /var/tmp/%{name}-%{version} |
34 |
BuildRequires: e-smith-devtools |
35 |
Requires: e-smith-release >= 10.0 |
36 |
Requires: server-manager >= 0.1.0-23 |
37 |
Requires: xtables-addons = 2.14 |
38 |
Requires: GeoIP >= 1.5.0 |
39 |
Requires: libmaxminddb >= 1.1.1 |
40 |
Requires: libmaxminddb-devel >= 1.1.1 |
41 |
Requires: geolite2-country |
42 |
Requires: geolite2-city |
43 |
AutoReqProv: no |
44 |
|
45 |
%description |
46 |
smserver rpm to setup database, update and configuration for xt_geoip module with a panel. |
47 |
|
48 |
|
49 |
%prep |
50 |
%setup |
51 |
%patch0 -p1 |
52 |
%patch1 -p1 |
53 |
%patch2 -p1 |
54 |
%patch3 -p1 |
55 |
%patch4 -p1 |
56 |
%patch5 -p1 |
57 |
%patch6 -p1 |
58 |
# tmp fix before new source archive |
59 |
rm -rf root/etc/e-smith/events/bootstrap-console-save/templates2expand |
60 |
rm -rf root/etc/e-smith/events/console-save/templates2expand |
61 |
rm -rf root/etc/e-smith/events/xt_geoip-modify/templates2expand/usr |
62 |
rm -rf root/etc/e-smith/events/xt_geoip-update/templates2expand/usr |
63 |
%patch7 -p1 |
64 |
%patch8 -p1 |
65 |
%patch9 -p1 |
66 |
%patch10 -p1 |
67 |
%patch11 -p1 |
68 |
%patch12 -p1 |
69 |
%patch13 -p1 |
70 |
%patch14 -p1 |
71 |
%patch15 -p1 |
72 |
%patch16 -p1 |
73 |
%patch17 -p1 |
74 |
|
75 |
%build |
76 |
perl createlinks |
77 |
|
78 |
|
79 |
%install |
80 |
rm -rf $RPM_BUILD_ROOT |
81 |
|
82 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
83 |
rm -f %{name}-%{version}-filelist |
84 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
85 |
--file /usr/share/xt_geoip/geoip_countries_list.txt 'attr(0755, root, root)'\ |
86 |
--file /usr/share/xt_geoip/geoip_exstat 'attr(0755, root, root)'\ |
87 |
--file /usr/share/xt_geoip/geoip_listat 'attr(0755, root, root)'\ |
88 |
--file /usr/share/xt_geoip/geoip_look 'attr(0755, root, root)'\ |
89 |
--file /usr/share/xt_geoip/geoip_stats 'attr(0755, root, root)'\ |
90 |
--file /usr/share/xt_geoip/xt_geoip_dl 'attr(0750, root, root)'\ |
91 |
--file /usr/share/xt_geoip/update_base 'attr(0750, root, root)'\ |
92 |
> %{name}-%{version}-filelist |
93 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
94 |
|
95 |
%clean |
96 |
cd .. |
97 |
rm -rf %{name}-%{version} |
98 |
|
99 |
%pre |
100 |
%preun |
101 |
|
102 |
%post |
103 |
|
104 |
if (systemctl list-unit-files |grep smanager) then |
105 |
echo "Smanager restart in spec file" |
106 |
/sbin/e-smith/signal-event smanager-refresh; |
107 |
fi |
108 |
|
109 |
%postun |
110 |
|
111 |
%files -f %{name}-%{version}-filelist |
112 |
%defattr(-,root,root) |
113 |
|
114 |
|
115 |
|
116 |
%changelog |
117 |
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.3.1-21.sme |
118 |
- apply locale 2024-09-06 patch |
119 |
|
120 |
* Sat Mar 02 2024 Brian Read <brianr@koozali.org> 1.3.1-20.sme |
121 |
- Edit SM2 Menu entry to conform to new arrangements [SME: 12493] |
122 |
|
123 |
* Wed Feb 15 2023 Michel Begue <mab974@misouk.com> 1.3.1-19.sme |
124 |
- fix module not loaded after update [SME: 10793] |
125 |
|
126 |
* Wed Jan 11 2023 Michel Begue <mab974@misouk.com> 1.3.1-18.sme |
127 |
- add a message if module xt_geoip is missing or not loaded [SME: 12291] |
128 |
- add a message if chain XTGeoIP is missing (iptables) [SME: 12291] |
129 |
|
130 |
* Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.3.1-17.sme |
131 |
- apply locale 2022-11-11 patch |
132 |
|
133 |
* Wed Jul 13 2022 Michel Begue <mab974@misouk.com> 1.3.1-16.sme |
134 |
- add fail2ban stats [SME: 12098] |
135 |
|
136 |
* Mon Jul 11 2022 Michel Begue <mab974@misouk.com> 1.3.1-15.sme |
137 |
- fix logs date test [SME: 12097] |
138 |
|
139 |
* Thu Jul 07 2022 Michel Begue <mab974@misouk.com> 1.3.1-14.sme |
140 |
- add xt_geoip to backup list [SME: 12029] |
141 |
- archive and clean up Ip & Country bases [SME: 10863] |
142 |
|
143 |
* Wed Mar 09 2022 Michel Begue <mab974@misouk.com> 1.3.1-13.sme |
144 |
- fix Other and Reverse parameters for SM2 [SME: 11887] |
145 |
|
146 |
* Fri Jan 07 2022 Brian Read <brianr@bjsystems.co.uk> 1.3.1-12.sme |
147 |
- Add-class-to-div-for-AdminLTE [SME: 11839] |
148 |
|
149 |
* Fri Oct 29 2021 Michel Begue <mab974@misouk.com> 1.3.1-11.sme |
150 |
- fix multiple_rpm_owners [SME: 11676] |
151 |
- add event for smeserver-manager |
152 |
- delete expand-template for update_base |
153 |
|
154 |
* Thu Oct 28 2021 Michel Begue <mab974@gmail.com> 1.3.1-10.sme |
155 |
- apply locale 2021-10-28 patch |
156 |
|
157 |
* Fri Sep 24 2021 Terry Fage <tfage@yahoo.com.au> 1.3.1-09.sme |
158 |
- apply locale 2021-09-23 patch |
159 |
|
160 |
* Wed Aug 25 2021 Terry Fage <tfage@yahoo.com.au> 1.3.1-08.sme |
161 |
- apply locale 2021-08-25 patch |
162 |
|
163 |
* Tue Mar 16 2021 Michel Begue <mab974@gmail.com> 1.3.1-07.sme |
164 |
- Fix script as logfiles change (sshd - iptables) |
165 |
|
166 |
* Sun Mar 14 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.3.1-06.sme |
167 |
- change Geoip requirement to >= 1.5 |
168 |
|
169 |
* Sat Mar 13 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.3.1-05.sme |
170 |
- readded changelog from contribs9 |
171 |
- moved changelog to the end of spec |
172 |
- TODO review the two section of %files |
173 |
- added link to wrapper for e-smith-manager |
174 |
|
175 |
* Wed Jan 06 2021 Michel Begue <mab974@gmail.com> 1.3.1-03.sme |
176 |
- Back to compatibility with e-smith-manager |
177 |
- (s)qpsmtpd replace (s)smtpd (services) |
178 |
- remove 'update_base' script template |
179 |
|
180 |
* Fri Jul 31 2020 Michel Begue <mab974@gmail.com> 1.3.1-01.sme |
181 |
- initial release for smeserver-manager (sme10) |
182 |
- [1.0.1-26 sme9] |
183 |
- xtables-addons v2.14 |
184 |
|
185 |
* Mon Feb 24 2020 Michel Begue <mab974@gmail.com> 1.0.1-26.sme |
186 |
- add localhost to whitelist [SME: 10881] |
187 |
|
188 |
* Tue Jan 21 2020 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-25.sme |
189 |
- add requirement for mmdb provided by rpm to allow accounting [SME: 10860] |
190 |
|
191 |
* Sat Jan 18 2020 Michel Begue <mab974@gmail.com> 1.0.1-24.sme |
192 |
- new download script adapted to SME (from xtables-addons) [SME: 10860] |
193 |
- change geoiplookup to mmdblookup |
194 |
|
195 |
* Sat Jan 11 2020 Michel Begue <mab974@gmail.com> 1.0.1-23.sme |
196 |
- add license_key in config db and test in panel [SME: 10860] |
197 |
|
198 |
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.0.1-21.sme |
199 |
- apply locale 2019-12-07 patch |
200 |
|
201 |
* Wed Oct 16 2019 Michel Begue <mab974@gmail.com> 1.0.1-20.sme |
202 |
- panel to add services [SME: 10792] |
203 |
- french translation |
204 |
|
205 |
* Mon Sep 30 2019 Michel Begue <mab974@gmail.com> 1.0.1-19.sme |
206 |
- add country code list [SME: 10791] |
207 |
- fix stats SSH errors [SME: 10807] |
208 |
- improved panel [SME: 10788] |
209 |
|
210 |
* Sat Sep 21 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-18.sme |
211 |
- add more service [SME: 10789] |
212 |
- no email from log analysis by default [SME: 10797] |
213 |
|
214 |
* Sun Jul 28 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-17.sme |
215 |
- fix empty global filter disable all geoip iptables rules [SME: 10794] |
216 |
- tidy masq templates for xt geoip [SME: 10794] |
217 |
|
218 |
* Wed Jul 24 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-16.sme |
219 |
- add missing file to patch [SME: 10760] |
220 |
- workaround link issue in source [SME: 10790] |
221 |
|
222 |
* Tue Jul 23 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-15.sme |
223 |
- improved per service filtering [SME: 10760] |
224 |
- remove A1 forced as default and allow empty filter [SME: 10785] |
225 |
|
226 |
* Sun Jul 21 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-13.sme |
227 |
- fix network lock out on adjust [SME: 10760] |
228 |
this arised on initial install with a simple masq adjust |
229 |
or if XT_geoip is disbaled on any masq restart or adjust |
230 |
|
231 |
* Wed Apr 24 2019 Michel Begue <mab974@gmail.com> 1.0.1-12.sme |
232 |
- add per service management of GeoIP bans [SME: 10760] |
233 |
- move panel to Security [SME: 10773] |
234 |
|
235 |
* Wed Apr 17 2019 Michel Begue <mab974@gmail.com> 1.0.1-9.sme |
236 |
- add stats access in the panel [SME: 10745] |
237 |
- add control of maximum number of countries [SME: 10749] |
238 |
|
239 |
* Wed Mar 06 2019 Michel Begue <mab974@gmail.com> 1.0.1-7.sme |
240 |
- add stats of geoip blocked countries [SME: 10745] |
241 |
- add stats of ssh attacks not geoip blocked [SME: 10744] |
242 |
- expand /etc/crontab on update |
243 |
|
244 |
* Mon Feb 18 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-6.sme |
245 |
- fix unable to load iptables rules [SME: 10739] |
246 |
fix warning localtime |
247 |
fix warning "enabled" isn't numeric in numeric eq (==) |
248 |
|
249 |
* Wed Feb 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.1-5.sme |
250 |
- first import to SME buildsys |
251 |
|
252 |
* Sun Oct 29 2017 Michel Begue <mab974@gmail.com> |
253 |
- bug in crontab update job, |
254 |
- [1.0.1-4] |
255 |
|
256 |
* Mon Oct 16 2017 Michel Begue <mab974@gmail.com> |
257 |
- new message : inactive GeoIP, |
258 |
- value of country code added in message "country not found", |
259 |
- [1.0.1-3] |
260 |
|
261 |
* Sat Oct 07 2017 Michel Begue <mab974@gmail.com> |
262 |
- test kernel module presence in "/lib/modules/weak-updates" directory |
263 |
- [1.0.1-2] |
264 |
|
265 |
* Wed Sep 20 2017 Michel Begue <mab974@gmail.com> |
266 |
- panel added in server manager |
267 |
- [1.0.1-1] |
268 |
|
269 |
* Tue Sep 12 2017 Michel Begue <mab974@gmail.com> |
270 |
- initial release |
271 |
- [1.0.0-1] |