1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
slords |
1.1 |
%define name smeserver-zabbix-proxy |
6 |
|
|
%define version 0.1 |
7 |
|
|
%define release 4 |
8 |
|
|
Summary: sme server integration of zabbix proxy |
9 |
|
|
Name: %{name} |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GNU GPL version 3 |
13 |
|
|
URL: http://www.zabbix.com/ |
14 |
|
|
Group: SMEserver/addon |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
|
|
Patch0: smeserver-zabbix-server-0.1-sendxmpp_template.patch |
17 |
|
|
Patch1: smeserver-zabbix-server-0.1-sendxmpp_shell_script_header.patch |
18 |
|
|
Patch2: smeserver-zabbix-server-0.1-disable_web_access.patch |
19 |
|
|
Patch3: smeserver-zabbix-server-0.1-mysql_db_pass.patch |
20 |
|
|
Patch4: smeserver-zabbix-server-0.1-script_and_tmp_location.patch |
21 |
|
|
Patch5: smeserver-zabbix-server-0.1-event_zabbix-server-update.patch |
22 |
|
|
Patch6: smeserver-zabbix-proxy-0.1-server2proxy.patch |
23 |
|
|
Patch7: smeserver-zabbix-proxy-0.1-createlinks_fixes.patch |
24 |
|
|
Patch8: smeserver-zabbix-proxy-0.1-enable_db_cache.patch |
25 |
|
|
|
26 |
|
|
BuildArchitectures: noarch |
27 |
|
|
BuildRequires: e-smith-devtools |
28 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
29 |
|
|
Requires: e-smith-release >= 7.0 |
30 |
|
|
Requires: fping |
31 |
|
|
Requires: zabbix-server |
32 |
|
|
Requires: zabbix-proxy |
33 |
|
|
Conflicts: smeserver-zabbix-server |
34 |
|
|
AutoReqProv: no |
35 |
|
|
|
36 |
|
|
%description |
37 |
|
|
smserver integration of zabbix proxy |
38 |
|
|
Zabbix is an entreprise-class open source distributed monitoring |
39 |
|
|
solution |
40 |
|
|
|
41 |
|
|
%changelog |
42 |
|
|
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-4 |
43 |
|
|
- Disable DB cache as it seems to caus IPC problems |
44 |
|
|
|
45 |
|
|
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-3 |
46 |
|
|
- enable DB cache with StartDBSyncers directive |
47 |
|
|
|
48 |
|
|
* Sun Mar 01 2009 Daniel B. <daniel@firewall-services.com> 0.1-2 |
49 |
|
|
- Fix permissions on /var/lib/zabbix/tmp |
50 |
|
|
|
51 |
|
|
* Fri Feb 24 2009 Daniel B. <daniel@firewall-services.com> 0.1-1 |
52 |
|
|
- Fix createlinks |
53 |
|
|
|
54 |
|
|
* Fri Feb 24 2009 Daniel B. <daniel@firewall-services.com> 0.1-0 |
55 |
|
|
- initial release |
56 |
|
|
|
57 |
|
|
%prep |
58 |
|
|
%setup |
59 |
|
|
%patch0 -p1 |
60 |
|
|
%patch1 -p1 |
61 |
|
|
%patch2 -p1 |
62 |
|
|
%patch3 -p1 |
63 |
|
|
%patch4 -p1 |
64 |
|
|
%patch5 -p1 |
65 |
|
|
%patch6 -p1 |
66 |
|
|
%patch7 -p1 |
67 |
|
|
#%patch8 -p1 |
68 |
|
|
|
69 |
|
|
%build |
70 |
|
|
perl ./createlinks |
71 |
|
|
%{__mkdir_p} root/var/lib/zabbix/tmp |
72 |
|
|
|
73 |
|
|
%install |
74 |
|
|
rm -rf $RPM_BUILD_ROOT |
75 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
76 |
|
|
rm -f %{name}-%{version}-filelist |
77 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
78 |
|
|
--file /var/lib/zabbix/bin/fping 'attr(0750,root,zabbix)' \ |
79 |
|
|
--file /var/lib/zabbix/bin/fping6 'attr(0750,root,zabbix)' \ |
80 |
|
|
--dir /var/lib/zabbix/tmp 'attr(0755,zabbix,zabbix)' \ |
81 |
|
|
> %{name}-%{version}-filelist |
82 |
|
|
|
83 |
|
|
%files -f %{name}-%{version}-filelist |
84 |
|
|
%defattr(-,root,root) |
85 |
|
|
|
86 |
|
|
%clean |
87 |
|
|
rm -rf $RPM_BUILD_ROOT |
88 |
|
|
|
89 |
|
|
|
90 |
|
|
%postun |
91 |
|
|
#uninstall |
92 |
|
|
if [ $1 = 0 ] ; then |
93 |
|
|
/sbin/e-smith/db configuration setprop zabbix-proxy status disabled |
94 |
|
|
/etc/init.d/zabbix-proxy stop |
95 |
|
|
fi |
96 |
|
|
|
97 |
|
|
true |