1 |
# $Id: smeserver-zabbix-server.spec,v 1.19 2022/12/11 03:04:05 jpp Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
|
5 |
%define name smeserver-zabbix-server |
6 |
%define version 0.1 |
7 |
%define release 31 |
8 |
Summary: sme server integration of zabbix server and web front-end |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.zabbix.com/ |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
|
17 |
Patch0: smeserver-zabbix-server-0.1-sendxmpp_template.patch |
18 |
Patch1: smeserver-zabbix-server-0.1-sendxmpp_shell_script_header.patch |
19 |
Patch2: smeserver-zabbix-server-0.1-disable_web_access.patch |
20 |
Patch3: smeserver-zabbix-server-0.1-mysql_db_pass.patch |
21 |
Patch4: smeserver-zabbix-server-0.1-script_and_tmp_location.patch |
22 |
Patch5: smeserver-zabbix-server-0.1-event_zabbix-server-update.patch |
23 |
Patch6: smeserver-zabbix-server-0.1-enable_db_cache.patch |
24 |
Patch7: smeserver-zabbix-server-0.1-adjust_masq.patch |
25 |
Patch8: smeserver-zabbix-server-0.1-sendxmpprc.patch |
26 |
Patch9: smeserver-zabbix-server-0.1-sendxmpprc_template_fix.patch |
27 |
Patch10: smeserver-zabbix-server-0.1-path2sendxmpprc.patch |
28 |
Patch11: smeserver-zabbix-server-0.1-multiple_dbpatches.patch |
29 |
Patch12: smeserver-zabbix-server-0.1-use_global_tz.patch |
30 |
Patch13: smeserver-zabbix-server-0.1-php_mem_limit.patch |
31 |
Patch14: smeserver-zabbix-server-0.1-sme9db.patch |
32 |
Patch15: smeserver-zabbix-server-0.1-sme9zabb3.2.4.patch |
33 |
Patch16: smeserver-zabbix-server-0.1-SME10458-SenderFrequency.deprecated.patch |
34 |
Patch17: smeserver-zabbix-server-0.1-zabbix4.4.6.patch |
35 |
Patch18: smeserver-zabbix-server-0.1-Update-httpd-createlinks-and-adduser.ini.patch |
36 |
Patch19: smeserver-zabbix-server-0.1-Template-user-dot-ini-and-override-service-file-change-pid-in-conf-file.patch |
37 |
Patch20: smeserver-zabbix-server-0.1-Add-in-zabbix-conf-expansion-to-createlinks.patch |
38 |
Patch21: smeserver-zabbix-server-0.1-Switch-to-specific-php-fpm.patch |
39 |
Patch22: smeserver-zabbix-server-0.1-bz11232-installSME10.patch |
40 |
Patch23: smeserver-zabbix-server-0.1-bz10802-checkcert-telegram.patch |
41 |
Patch24: smeserver-zabbix-server-0.1-bz11749-adminpass.patch |
42 |
Patch25: smeserver-zabbix-server-0.1-bz12068-httpd24.patch |
43 |
Patch26: smeserver-zabbix-server-0.1-bz12031-backup.patch |
44 |
Patch27: smeserver-zabbix-server-0.1-z50.patch |
45 |
|
46 |
BuildArchitectures: noarch |
47 |
BuildRequires: e-smith-devtools |
48 |
BuildRoot: /var/tmp/%{name}-%{version} |
49 |
Requires: e-smith-release >= 10.0 |
50 |
Requires: e-smith-apache >= 2.6.0-19 |
51 |
Requires: smeserver-php >= 3.0.0-43 |
52 |
Requires: fping |
53 |
Requires: zabbix-server-mysql >= 4.4.6 |
54 |
Requires: zabbix-web-mysql >= 4.4.6 |
55 |
Requires: zabbix-web >= 4.4.6 |
56 |
Requires: sendxmpp |
57 |
Requires: smeserver-remoteuseraccess |
58 |
Requires: smeserver-mariadb105 |
59 |
# for telegram bot |
60 |
Requires: python2-pysocks python-requests python2-requests-oauthlib |
61 |
Obsoletes: zabbix-server |
62 |
Conflicts: smeserver-zabbix-proxy |
63 |
AutoReqProv: no |
64 |
|
65 |
%description |
66 |
smserver integration of zabbix server and web front-end. |
67 |
Zabbix is an entreprise-class open source distributed monitoring |
68 |
solution |
69 |
|
70 |
%package z50 |
71 |
%define provscl 5.0.30-1.el7 |
72 |
#5.0.30-1 |
73 |
Summary: SME Server integration of zabbix server 5.0 and web front-end using Remi SCLO |
74 |
Group: Applications/Internet |
75 |
#common |
76 |
BuildArchitectures: noarch |
77 |
BuildRequires: e-smith-devtools |
78 |
Requires: e-smith-release >= 10.0 |
79 |
Requires: e-smith-apache >= 2.6.0-19 |
80 |
Requires: smeserver-php >= 3.0.0-43 |
81 |
Requires: fping |
82 |
Requires: zabbix-server-mysql >= 5.0.0 |
83 |
#Requires: zabbix-web-mysql-scl >= 5.0.0 |
84 |
#Requires: zabbix-web >= 5.0.0 |
85 |
Requires: sendxmpp |
86 |
Requires: smeserver-remoteuseraccess |
87 |
Requires: smeserver-mariadb105 |
88 |
# specific |
89 |
#Provides: rh-php72-php-fpm rh-php72-php-mbstring rh-php72 rh-php72-php-mysqlnd rh-php72-php-gd rh-php72-php-xml rh-php72-php-ldap rh-php72-php-bcmath |
90 |
Provides: zabbix-web-database-scl-php74 = %{provscl} |
91 |
Provides: zabbix-web-deps-scl = %{provscl} |
92 |
Provides: zabbix-web-deps-scl-php73 = %{provscl} |
93 |
Requires: zabbix-web = %{provscl} |
94 |
Requires: php74-php-mysqlnd php74 php74-php-gd php74-php-bcmath php74-php-mbstring php74-php-xml php74-php-ldap php74-php-fpm php74-php-mysqlnd |
95 |
|
96 |
%description z50 |
97 |
SME Server integration of zabbix server 5.0 and web front-end using Remi SCLO. |
98 |
Zabbix is an entreprise-class open source distributed monitoring |
99 |
solution |
100 |
|
101 |
%changelog |
102 |
* Sat Dec 10 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-31.sme |
103 |
- original package build for Zabbix 5.0 using Remi SCLO [SME: 11748] |
104 |
support for LTS 5.0 EOL May 31, 2025 |
105 |
needs mariadb105. |
106 |
manual migration from mariadb55 to mariadb105 needed for existing installs |
107 |
|
108 |
* Mon Aug 01 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-30.sme |
109 |
- update to httpd 2.4 access syntax [SME: 12068] |
110 |
thanks to Vasarhelyi Zsolt |
111 |
- add to core backup [SME: 12031] |
112 |
non rpm owned files in /etc/zabbix, /etc/zabbix/zabbix_agentd.conf.d/ |
113 |
and /var/lib/zabbix/bin/ |
114 |
|
115 |
* Tue Nov 09 2021 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-29.sme |
116 |
- set random password to Admin i fuser exists and password is zabbix [SME: 11749] |
117 |
|
118 |
* Mon Nov 08 2021 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-28.sme |
119 |
- add check cert scripts and telegram [SME: 10802] |
120 |
no template provided to use with |
121 |
|
122 |
* Sun Nov 07 2021 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-27.sme |
123 |
- fix init sql, typo and reload deamon [SME: 11232] |
124 |
|
125 |
* Sun Nov 07 2021 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-26.sme |
126 |
- fix session and log issue [SME: 11232] |
127 |
fix mysql-init not launched |
128 |
|
129 |
* Mon Nov 01 2021 BogusDateBot |
130 |
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday, |
131 |
by assuming the date is correct and changing the weekday. |
132 |
Tue Mar 02 2009 --> Tue Feb 24 2009 or Mon Mar 02 2009 or Tue Mar 03 2009 or .... |
133 |
Wed Feb 07 2016 --> Wed Feb 03 2016 or Sun Feb 07 2016 or Wed Feb 10 2016 or .... |
134 |
|
135 |
* Mon Nov 01 2021 Brian Read <brianr@bjsystems.co.uk> 0.1-25.sme |
136 |
- Switch-to-specific-php-fpm [SME: 11232] |
137 |
|
138 |
* Mon Nov 01 2021 Brian Read <brianr@bjsystems.co.uk> 0.1-24.sme |
139 |
- Remove post and postun command in spec file [SME: 11232] |
140 |
|
141 |
* Thu Dec 10 2020 Brian Read <brianr@bjsystems.co.uk> 0.1-23.sme |
142 |
- Add in post instructions to spec for SQL db creation [SME: 11232] |
143 |
|
144 |
* Tue Dec 08 2020 Brian Read <brianr@bjsystems.co.uk> 0.1-22.sme |
145 |
- Add expand zabbix-server.conf and .user.ini to creatlinks update event [SME:11232] |
146 |
|
147 |
* Tue Dec 08 2020 Brian Read <brianr@bjsystems.co.uk> 0.1-21.sme |
148 |
- Template-user-dot-ini-and-override-service-file-change-pid-in-conf-file [SME: 11232] |
149 |
|
150 |
* Mon Dec 07 2020 Brian Read <brianr@bjsystems.co.uk> 0.1-20.sme |
151 |
- Import to SME10 tree [SME: 11232] |
152 |
- Update createlinks for systemd |
153 |
- Update httpd.conf for php-fpw |
154 |
- Add .user.ini for php-admin-flags that where in httpd.conf |
155 |
|
156 |
* Sun May 10 2020 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-19.sme |
157 |
- adapt for zabbix 4.4.6 [SME: 10944] |
158 |
|
159 |
* Thu Sep 05 2019 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-17.sme |
160 |
- remove deprecated option preventing from starting service [SME: 10458] |
161 |
|
162 |
* Wed Mar 29 2017 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-16.sme |
163 |
- fix sql init not finding default sql dump to import [SME: 9569] |
164 |
- NodeID support droped as per zabbix 2.4.0 and higher |
165 |
- requires smeserver-php-scl as Zabbix-server 3.2.4 requires php 5.4 or higher |
166 |
|
167 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.1-15.sme |
168 |
- finitial import [SME: 9569] |
169 |
- fix php requirement |
170 |
- fix add path to new db |
171 |
|
172 |
* Sun Feb 07 2016 stephane de Labrusse <stephdl@de-labrusse.fr> 0.1-14.sme |
173 |
Wed Feb 07 2016 --> Wed Feb 03 2016 or Sun Feb 07 2016 or Wed Feb 10 2016 or .... |
174 |
- New roll for sme9 |
175 |
|
176 |
* Mon Apr 29 2013 Daniel B. <daniel@firewall-services.com> 0.1-13 |
177 |
- Increase PHP mem limit to 128M |
178 |
|
179 |
* Mon Mar 8 2010 Daniel B. <daniel@firewall-services.com> 0.1-12 |
180 |
- Use global TimeZone |
181 |
|
182 |
* Wed Dec 2 2009 Daniel B. <daniel@firewall-services.com> 0.1-11 |
183 |
- Support several mysql DB patches |
184 |
|
185 |
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> 0.1-10 |
186 |
- Add smeserver-remoteuseraccess as a dependencie (sudoers template problem) |
187 |
|
188 |
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-9 |
189 |
- specify path to .sendxmpprc file in the script sendxmpp |
190 |
|
191 |
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-8 |
192 |
- move .sendxmpprc template to the correct directory |
193 |
|
194 |
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-7 |
195 |
- Move jabber account informations to xmpprc |
196 |
|
197 |
* Mon Mar 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-6 |
198 |
- Adjust service masq during zabbix-server-update event |
199 |
- Enable DB cache module with StartDBSyncers directive |
200 |
|
201 |
* Sun Mar 01 2009 Daniel B. <daniel@firewall-services.com> 0.1-5 |
202 |
- Fix permissions on /var/lib/zabbix/tmp |
203 |
|
204 |
* Tue Feb 17 2009 Daniel B. <daniel@firewall-services.com> 0.1-4 |
205 |
- rename event zabbix-update to zabbix-server-update |
206 |
|
207 |
* Wed Feb 11 2009 Daniel B. <daniel@firewall-services.com> 0.1-3 |
208 |
- disable web access (usefull for distributed monitoring) |
209 |
- Use stronger password for mysql database |
210 |
- Use /var/lib/zabbix/bin as default location for scripts |
211 |
- Use /var/lib/zabbix/tmp for temp dir |
212 |
|
213 |
* Fri Feb 06 2009 Daniel B. <daniel@firewall-services.com> 0.1-2 |
214 |
- Link template-begin-shell to template-begin for sendxmpp script |
215 |
|
216 |
* Fri Feb 06 2009 Daniel B. <daniel@firewall-services.com> 0.1-1 |
217 |
- templatize sendxmpp as zabbix user doesn't have access to SME db |
218 |
- Add JabberTLS option in the db |
219 |
|
220 |
* Mon Feb 02 2009 Daniel B. <daniel@firewall-services.com> 0.1-0 |
221 |
- initial release |
222 |
|
223 |
%prep |
224 |
%setup |
225 |
%patch0 -p1 |
226 |
%patch1 -p1 |
227 |
%patch2 -p1 |
228 |
%patch3 -p1 |
229 |
%patch4 -p1 |
230 |
%patch5 -p1 |
231 |
%patch6 -p1 |
232 |
%patch7 -p1 |
233 |
%patch8 -p1 |
234 |
%patch9 -p1 |
235 |
%patch10 -p1 |
236 |
%patch11 -p1 |
237 |
%patch12 -p1 |
238 |
%patch13 -p1 |
239 |
%patch14 -p1 |
240 |
%patch15 -p1 |
241 |
%patch16 -p1 |
242 |
%patch17 -p1 |
243 |
%patch18 -p1 |
244 |
%patch19 -p1 |
245 |
%patch20 -p1 |
246 |
%patch21 -p1 |
247 |
%patch22 -p1 |
248 |
%patch23 -p1 |
249 |
%patch24 -p1 |
250 |
%patch25 -p1 |
251 |
%patch26 -p1 |
252 |
%patch27 -p1 |
253 |
|
254 |
%build |
255 |
perl ./createlinks |
256 |
%{__mkdir_p} root/var/lib/zabbix/tmp |
257 |
#%{__mkdir_p} root/var/log/zabbix - conflict with zabbix-server-mysql |
258 |
%{__mkdir_p} root/var/log/php/zabbix |
259 |
%{__mkdir_p} root/var/lib/php/zabbix/{tmp,wsdlcache,opcache,session} |
260 |
|
261 |
|
262 |
%install |
263 |
rm -rf $RPM_BUILD_ROOT |
264 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
265 |
rm -f %{name}-%{version}-filelist |
266 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
267 |
--file /var/lib/zabbix/bin/fping 'attr(0750,root,zabbix)' \ |
268 |
--file /var/lib/zabbix/bin/fping6 'attr(0750,root,zabbix)' \ |
269 |
--dir /var/lib/zabbix/tmp 'attr(0750,zabbix,zabbix)' \ |
270 |
--dir /var/log/php/zabbix 'attr(0770,www,www)' \ |
271 |
--dir /var/lib/php/zabbix 'attr(0755,root,www)' \ |
272 |
--dir /var/lib/php/zabbix/tmp 'attr(0770,root,www)' \ |
273 |
--dir /var/lib/php/zabbix/opcache 'attr(0770,root,www)' \ |
274 |
--dir /var/lib/php/zabbix/session 'attr(0770,root,www)' \ |
275 |
|grep -v '.pyc'|grep -v '.pyo' \ |
276 |
> %{name}-%{version}-filelist |
277 |
|
278 |
%files -f %{name}-%{version}-filelist |
279 |
%defattr(-,root,root) |
280 |
|
281 |
%files z50 -f %{name}-%{version}-filelist |
282 |
%defattr(-,root,root) |
283 |
|
284 |
%clean |
285 |
rm -rf $RPM_BUILD_ROOT |
286 |
|
287 |
%post |
288 |
|
289 |
%postun |
290 |
|