1 |
# $Id: smeserver-zarafa.spec,v 1.57 10/16/2011 pfloor Exp $ |
2 |
# Authority: pfloor |
3 |
# Name: Paul Floor |
4 |
|
5 |
%define name smeserver-zarafa-unix |
6 |
%define version 1.0.1 |
7 |
%define release 5 |
8 |
Summary: smserver rpm to setup zarafa with unix plugin |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GNU GPL version 2 |
13 |
URL: http://contribs.org |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
BuildArchitectures: noarch |
18 |
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
20 |
Requires: e-smith-release >= 9.0 |
21 |
Requires: zarafa >= 7.1.3, zarafa < 8 |
22 |
Requires: zarafa-webaccess |
23 |
AutoReqProv: no |
24 |
|
25 |
%description |
26 |
This is mainly used to setup zarafa7 using unix plugin although |
27 |
you can still use the db plugin if wanted but the server manager |
28 |
panels have been removed so db administration is purely commandline. |
29 |
Unix plugin syncs all unix users to zarafa automatically and allows |
30 |
"Global" or fine grained implementation. The unix plugin also |
31 |
keeps the user's passwords in sync so there is only one place to |
32 |
create or change a password, the server or user manage panels. |
33 |
|
34 |
%changelog |
35 |
* Mon Feb 18 2013 Paul Floor <paul@smeserverpro.com> - 1.0.1-5 |
36 |
- Update all config file templates. Change zarafa-indexer to |
37 |
- zarafa-search and clean up services. |
38 |
|
39 |
* Mon Feb 18 2013 Paul Floor <paul@smeserverpro.com> - 1.0.1-4 |
40 |
- Remove php53-mapi reqirement for use on SME9 (el6). Add support |
41 |
- for new zarafa-webapp. Remove script call after install |
42 |
- and make it an event. |
43 |
|
44 |
* Fri Nov 23 2012 Paul Floor <paul@smeserverpro.com> - 1.0.1-3 |
45 |
- correct lib directory for x86_64 arch. |
46 |
|
47 |
* Sun Jan 29 2012 Paul Floor <paul@smeserverpro.com> - 1.0.1-2 |
48 |
- Remove support for webaccess-mobile, it is no longer supported |
49 |
- Add DB entry for Outlook Client Update. |
50 |
|
51 |
* Fri Nov 25 2011 Paul Floor <paul@smeserverpro.com> - 1.0.1-1 |
52 |
- Removed beta tag and removed release specific requires, now only |
53 |
- version specific. Minor bug fixes concerning z-push. |
54 |
|
55 |
* Sat Oct 15 2011 Paul Floor <paul@smeserverpro.com> - 1.0.0-7.0.2_29470_beta1 |
56 |
- Initial release with contributions from dmay and snoble THANKS! |
57 |
- Unix plugin refined to eliminate duplicate entries. Many small fixes. |
58 |
- Combined several scripts and added a 64 char random password generator. |
59 |
- This has release specific requirements due to multiple complications |
60 |
- that happen when zarafa is allowed to update on its own. |
61 |
|
62 |
%prep |
63 |
%setup |
64 |
|
65 |
%build |
66 |
/usr/bin/perl createlinks |
67 |
|
68 |
%install |
69 |
rm -rf $RPM_BUILD_ROOT |
70 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
71 |
rm -f %{name}-%{version}-filelist |
72 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
73 |
> %{name}-%{version}-filelist |
74 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
75 |
echo To complete instalation, run /etc/e-smith/events/actions/zarafa-install |
76 |
|
77 |
%clean |
78 |
cd .. |
79 |
rm -rf %{name}-%{version} |
80 |
|
81 |
%files -f %{name}-%{version}-filelist |
82 |
%defattr(-,root,root) |