1 |
jpp |
1.1 |
%define majorversion 4 |
2 |
jpp |
1.2 |
%define minorversion 34 |
3 |
|
|
%define buildversion 9744 |
4 |
|
|
%define dateversion 2020.03.20 |
5 |
jpp |
1.1 |
%define buildrelease beta |
6 |
jpp |
1.2 |
%define version %{majorversion}.%{minorversion}.%{buildversion} |
7 |
jpp |
1.3 |
%define release 1 |
8 |
|
|
|
9 |
jpp |
1.1 |
Name: softethervpn |
10 |
|
|
Version: %{majorversion}.%{minorversion}.%{buildversion} |
11 |
jpp |
1.3 |
Release: %{release}%{dist} |
12 |
jpp |
1.1 |
Summary: An Open-Source Free Cross-platform Multi-protocol VPN Program |
13 |
|
|
|
14 |
|
|
Group: Applications/Internet |
15 |
|
|
License: GPLv2 |
16 |
|
|
URL: http://www.softether.org/ |
17 |
|
|
Source0: http://www.softether-download.com/files/softether/v%{majorversion}.%{minorversion}-%{buildversion}-%{buildrelease}-%{dateversion}-tree/Source_Code/softether-src-v%{majorversion}.%{minorversion}-%{buildversion}-%{buildrelease}.tar.gz |
18 |
|
|
|
19 |
|
|
BuildRequires: ncurses-devel |
20 |
|
|
BuildRequires: openssl-devel |
21 |
|
|
BuildRequires: readline-devel |
22 |
|
|
|
23 |
|
|
Requires(post): chkconfig |
24 |
|
|
Requires(postun): initscripts |
25 |
|
|
Requires(preun): chkconfig |
26 |
|
|
Requires(preun): initscripts |
27 |
|
|
|
28 |
|
|
%description |
29 |
|
|
SoftEther VPN is one of the world's most powerful and easy-to-use multi-protocol VPN software. It runs on Windows, Linux, Mac, FreeBSD, and Solaris. |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup -q -n v%{majorversion}.%{minorversion}-%{buildversion} |
33 |
|
|
|
34 |
jpp |
1.3 |
%ifarch i386 i686 |
35 |
|
|
cp centos/SOURCES/linux_32bit.mak Makefile |
36 |
|
|
%else |
37 |
|
|
cp centos/SOURCES/linux_64bit.mak Makefile |
38 |
|
|
%endif |
39 |
|
|
|
40 |
jpp |
1.1 |
%build |
41 |
|
|
%ifarch i386 i686 |
42 |
jpp |
1.3 |
#cp $RPM_SOURCE_DIR/v%{majorversion}.%{minorversion}-%{buildversion}/linux_32bit.mak Makefile |
43 |
jpp |
1.1 |
%else |
44 |
jpp |
1.3 |
#cp $RPM_SOURCE_DIR/v%{majorversion}.%{minorversion}-%{buildversion}/linux_64bit.mak Makefile |
45 |
jpp |
1.1 |
%endif |
46 |
|
|
make |
47 |
|
|
|
48 |
|
|
%install |
49 |
|
|
rm -rf $RPM_BUILD_ROOT |
50 |
|
|
make install DESTDIR=$RPM_BUILD_ROOT |
51 |
|
|
install -m 755 -d $RPM_BUILD_ROOT/usr/bin/ |
52 |
|
|
install -m 755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d |
53 |
jpp |
1.3 |
pwd |
54 |
|
|
ls -lR |
55 |
|
|
install -m 755 centos/SOURCES/scripts/vpnserver $RPM_BUILD_ROOT/usr/bin/vpnserver |
56 |
|
|
install -m 755 centos/SOURCES/scripts/vpnbridge $RPM_BUILD_ROOT/usr/bin/vpnbridge |
57 |
|
|
install -m 755 centos/SOURCES/scripts/vpnclient $RPM_BUILD_ROOT/usr/bin/vpnclient |
58 |
|
|
install -m 755 centos/SOURCES/scripts/vpncmd $RPM_BUILD_ROOT/usr/bin/vpncmd |
59 |
|
|
install -m 755 centos/SOURCES/init.d/vpnserver $RPM_BUILD_ROOT/etc/rc.d/init.d/vpnserver |
60 |
jpp |
1.1 |
|
61 |
|
|
%clean |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
|
64 |
|
|
%files |
65 |
|
|
%defattr(-,root,root,-) |
66 |
|
|
%{_usr}/bin/vpnserver |
67 |
|
|
%{_usr}/bin/vpnbridge |
68 |
|
|
%{_usr}/bin/vpnclient |
69 |
|
|
%{_usr}/bin/vpncmd |
70 |
|
|
%{_usr}/vpnserver/hamcore.se2 |
71 |
|
|
%{_usr}/vpnserver/vpnserver |
72 |
|
|
%{_usr}/vpnbridge/hamcore.se2 |
73 |
|
|
%{_usr}/vpnbridge/vpnbridge |
74 |
|
|
%{_usr}/vpnclient/hamcore.se2 |
75 |
|
|
%{_usr}/vpnclient/vpnclient |
76 |
|
|
%{_usr}/vpncmd/hamcore.se2 |
77 |
|
|
%{_usr}/vpncmd/vpncmd |
78 |
|
|
%{_usr}/vpnserver/ |
79 |
|
|
%{_usr}/vpnbridge/ |
80 |
|
|
%{_usr}/vpnclient/ |
81 |
|
|
%{_usr}/vpncmd/ |
82 |
|
|
%{_initddir}/vpnserver |
83 |
|
|
%doc AUTHORS.TXT BUILD_UNIX.TXT BUILD_WINDOWS.TXT ChangeLog ChangeLog.txt LICENSE LICENSE.TXT README README.TXT THIRD_PARTY.TXT WARNING.TXT |
84 |
|
|
|
85 |
|
|
%post |
86 |
|
|
/sbin/chkconfig --add vpnserver |
87 |
|
|
|
88 |
|
|
#%postun |
89 |
|
|
#if [ "$1" -ge "1" ]; then |
90 |
|
|
# /sbin/service vpnserver condrestart >/dev/null 2>&1 || : |
91 |
|
|
#fi |
92 |
|
|
|
93 |
|
|
%preun |
94 |
|
|
if [ $1 -eq 0 ]; then |
95 |
|
|
/sbin/service vpnserver stop >/dev/null 2>&1 |
96 |
|
|
/sbin/chkconfig --del vpnserver |
97 |
|
|
fi |
98 |
|
|
|
99 |
|
|
%changelog |
100 |
jpp |
1.3 |
* Fri Mar 27 2020 Jean-Philipe Pialasse <tests@pialasse.com> 4.34.9744-1.sme |
101 |
|
|
- initial release SME 9 |
102 |
|
|
|
103 |
jpp |
1.1 |
* Wed Sep 30 2015 Jeff Tang <mrjefftang@gmail.com> - 4.19.9582-1 |
104 |
|
|
- Update upstream to 4.19.9582-beta |
105 |
|
|
|
106 |
|
|
* Wed Sep 30 2015 Jeff Tang <mrjefftang@gmail.com> - 4.19.9577-1 |
107 |
|
|
- Update upstream to 4.19.9577 |
108 |
|
|
|
109 |
|
|
* Wed Jan 29 2014 Dexter Ang <thepoch@gmail.com> - 4.04.9412-2 |
110 |
|
|
- Made initscript more Fedora/RH-like. |
111 |
|
|
- initscript currently using killall. Need to fix this. |
112 |
|
|
|
113 |
|
|
* Tue Jan 21 2014 Dexter Ang <thepoch@gmail.com> |
114 |
|
|
- Initial release |
115 |
|
|
|