1 |
%define release 6 |
2 |
%define version 0.1.1 |
3 |
|
4 |
Name: soxr |
5 |
Version: %{version} |
6 |
Release: %{release}%{?dist} |
7 |
Summary: The SoX Resampler library |
8 |
|
9 |
License: LGPLv2+ |
10 |
URL: https://sourceforge.net/p/soxr/wiki/Home/ |
11 |
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-Source.tar.xz |
12 |
|
13 |
BuildRequires: cmake |
14 |
|
15 |
%description |
16 |
The SoX Resampler library `libsoxr' performs one-dimensional sample-rate |
17 |
conversion -- it may be used, for example, to resample PCM-encoded audio. |
18 |
|
19 |
|
20 |
%package devel |
21 |
Summary: Development files for %{name} |
22 |
Requires: %{name}%{?_isa} = %{version}-%{release} |
23 |
|
24 |
%description devel |
25 |
The %{name}-devel package contains libraries and header files for |
26 |
developing applications that use %{name}. |
27 |
|
28 |
|
29 |
%prep |
30 |
%setup -q -n %{name}-%{version}-Source |
31 |
|
32 |
|
33 |
%build |
34 |
rm -rf build && mkdir build && pushd build |
35 |
export LDFLAGS="-Wl,--as-needed" |
36 |
%cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \ |
37 |
../ |
38 |
make %{?_smp_mflags} |
39 |
|
40 |
|
41 |
%install |
42 |
pushd build |
43 |
%make_install |
44 |
|
45 |
# Remove docs and use the rpmbuild macro instead |
46 |
rm -rf %{buildroot}%{_docdir}/* |
47 |
|
48 |
|
49 |
%check |
50 |
pushd build |
51 |
LD_LIBRARY_PATH=`pwd`/src make test |
52 |
|
53 |
|
54 |
%post -p /sbin/ldconfig |
55 |
|
56 |
%postun -p /sbin/ldconfig |
57 |
|
58 |
|
59 |
%files |
60 |
%doc LICENCE NEWS README |
61 |
%{_libdir}/*.so.* |
62 |
|
63 |
%files devel |
64 |
%doc examples |
65 |
%{_includedir}/* |
66 |
%{_libdir}/*.so |
67 |
%{_libdir}/pkgconfig/soxr-lsr.pc |
68 |
%{_libdir}/pkgconfig/soxr.pc |
69 |
|
70 |
|
71 |
%changelog |
72 |
* Sat Apr 25 2020 Jean-Philipe Pialasse <tests@pialasse.com> 0.1.1-6.sme |
73 |
- first build for SME |
74 |
|
75 |
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3 |
76 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
77 |
|
78 |
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-2 |
79 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
80 |
|
81 |
* Mon Apr 29 2013 Richard Shaw <hobbes1069@gmail.com> - 0.1.1-1 |
82 |
- Initial packaging. |