1 |
jpp |
1.1 |
%undefine __cmake_in_source_build |
2 |
|
|
|
3 |
|
|
Name: spdlog |
4 |
|
|
Version: 1.8.5 |
5 |
|
|
Release: 1%{?dist} |
6 |
|
|
Summary: Super fast C++ logging library |
7 |
|
|
License: MIT |
8 |
|
|
URL: https://github.com/gabime/%{name} |
9 |
|
|
Source0: %{url}/archive/v%{version}.tar.gz |
10 |
|
|
|
11 |
|
|
BuildRequires: google-benchmark-devel |
12 |
|
|
BuildRequires: fmt-devel >= 7.0.0 |
13 |
|
|
BuildRequires: ninja-build |
14 |
|
|
BuildRequires: gcc-c++ |
15 |
|
|
BuildRequires: cmake |
16 |
|
|
BuildRequires: gcc |
17 |
|
|
|
18 |
|
|
%description |
19 |
|
|
This is a packaged version of the gabime/spdlog C++ logging |
20 |
|
|
library available at Github. |
21 |
|
|
|
22 |
|
|
%package devel |
23 |
|
|
Summary: Development files for %{name} |
24 |
|
|
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} |
25 |
|
|
Requires: libstdc++-devel%{?_isa} |
26 |
|
|
Requires: fmt-devel%{?_isa} |
27 |
|
|
|
28 |
|
|
%description devel |
29 |
|
|
The %{name}-devel package contains C++ header files for developing |
30 |
|
|
applications that use %{name}. |
31 |
|
|
|
32 |
|
|
%prep |
33 |
|
|
%autosetup -p1 |
34 |
|
|
find . -name '.gitignore' -delete |
35 |
|
|
sed -i -e "s,\r,," README.md |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
%cmake -G Ninja \ |
39 |
|
|
-DCMAKE_INSTALL_LIBDIR=%{_lib} \ |
40 |
|
|
-DCMAKE_BUILD_TYPE=Release \ |
41 |
|
|
-DSPDLOG_BUILD_SHARED=ON \ |
42 |
|
|
-DSPDLOG_BUILD_EXAMPLE=OFF \ |
43 |
|
|
-DSPDLOG_BUILD_BENCH=OFF \ |
44 |
|
|
-DSPDLOG_BUILD_TESTS=ON \ |
45 |
|
|
-DSPDLOG_INSTALL=ON \ |
46 |
|
|
-DSPDLOG_FMT_EXTERNAL=ON |
47 |
|
|
%cmake_build |
48 |
|
|
|
49 |
|
|
%check |
50 |
|
|
%ctest |
51 |
|
|
|
52 |
|
|
%install |
53 |
|
|
%cmake_install |
54 |
|
|
|
55 |
|
|
%files |
56 |
|
|
%license LICENSE |
57 |
|
|
%doc README.md |
58 |
|
|
%{_libdir}/lib%{name}.so.1* |
59 |
|
|
|
60 |
|
|
%files devel |
61 |
|
|
%doc example |
62 |
|
|
%{_includedir}/%{name} |
63 |
|
|
%{_libdir}/lib%{name}.so |
64 |
|
|
%{_libdir}/cmake/%{name} |
65 |
|
|
%{_libdir}/pkgconfig/%{name}.pc |
66 |
|
|
|
67 |
|
|
%changelog |
68 |
|
|
* Fri Apr 02 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.5-1 |
69 |
|
|
- Updated to version 1.8.5. |
70 |
|
|
|
71 |
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-2 |
72 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
73 |
|
|
|
74 |
|
|
* Sat Dec 12 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.2-1 |
75 |
|
|
- Updated to version 1.8.2. |
76 |
|
|
|
77 |
|
|
* Tue Oct 13 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.1-1 |
78 |
|
|
- Updated to version 1.8.1. |
79 |
|
|
|
80 |
|
|
* Sat Sep 05 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.0-1 |
81 |
|
|
- Updated to version 1.8.0. |
82 |
|
|
|
83 |
|
|
* Tue Jul 21 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.7.0-1 |
84 |
|
|
- Updated to version 1.7.0. |
85 |
|
|
|
86 |
|
|
* Tue Jun 02 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.6.1-1 |
87 |
|
|
- Updated to version 1.6.1. |
88 |
|
|
|
89 |
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2 |
90 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
91 |
|
|
|
92 |
|
|
* Mon Jan 27 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.5.0-1 |
93 |
|
|
- Updated to version 1.5.0. |
94 |
|
|
|
95 |
|
|
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 1.4.2-1 |
96 |
|
|
- Updated to version 1.4.2. |
97 |
|
|
|
98 |
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-3 |
99 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
100 |
|
|
|
101 |
|
|
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2 |
102 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
103 |
|
|
|
104 |
|
|
* Sun Jan 20 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 1.3.1-1 |
105 |
|
|
- Updated to version 1.3.1. |
106 |
|
|
|
107 |
|
|
* Mon Nov 05 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.2.1-1 |
108 |
|
|
- Updated to version 1.2.1. |
109 |
|
|
|
110 |
|
|
* Sun Sep 02 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.1.0-1 |
111 |
|
|
- Updated to version 1.1.0. |
112 |
|
|
|
113 |
|
|
* Thu Aug 09 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.0.0-1 |
114 |
|
|
- Updated to version 1.0.0. |
115 |
|
|
|
116 |
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2 |
117 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
118 |
|
|
|
119 |
|
|
* Mon Jun 18 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.17.0-1 |
120 |
|
|
- Updated to version 0.17.0. |
121 |
|
|
- Added tests support. |
122 |
|
|
- Added cmake and pkg-config support. |
123 |
|
|
|
124 |
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-5 |
125 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
126 |
|
|
|
127 |
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-4 |
128 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
129 |
|
|
|
130 |
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-3 |
131 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
132 |
|
|
|
133 |
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2 |
134 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild |
135 |
|
|
|
136 |
|
|
* Sun Sep 04 2016 Daniel Kopecek <dkopecek@redhat.com> - 0.10.0-1 |
137 |
|
|
- Update to 0.10.0 |
138 |
|
|
|
139 |
|
|
* Fri Jul 08 2016 Daniel Kopecek <dkopecek@redhat.com> - 0-8.20160703git34bb86b |
140 |
|
|
- update to rev 34bb86b |
141 |
|
|
|
142 |
|
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0-7.20151110gitcbc8ba7 |
143 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild |
144 |
|
|
|
145 |
|
|
* Tue Nov 10 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-6.20151110gitcbc8ba7 |
146 |
|
|
- update to rev cbc8ba7 |
147 |
|
|
|
148 |
|
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-5.20150410git211ce99 |
149 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
150 |
|
|
|
151 |
|
|
* Thu Apr 30 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-4.20150410git211ce99 |
152 |
|
|
- don't build the base package |
153 |
|
|
- remove a dot from the release tag |
154 |
|
|
- corrected -devel subpackage description |
155 |
|
|
|
156 |
|
|
* Mon Apr 20 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-3.20150410git.211ce99 |
157 |
|
|
- use the -p option when copying the header files |
158 |
|
|
|
159 |
|
|
* Tue Apr 14 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-2.20150410git.211ce99 |
160 |
|
|
- don't build the debuginfo subpackage |
161 |
|
|
- require libstdc++-devel |
162 |
|
|
- don't generate a distribution specific pkg-config file |
163 |
|
|
|
164 |
|
|
* Fri Apr 10 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-1.20150410git.211ce99 |
165 |
|
|
- Initial package |