1 |
jpp |
1.1 |
%undefine __cmake_in_source_build |
2 |
|
|
|
3 |
|
|
Name: spdlog |
4 |
|
|
Version: 1.8.5 |
5 |
|
|
Release: 1%{?dist} |
6 |
|
|
Summary: Super fast C++ logging library |
7 |
|
|
License: MIT |
8 |
|
|
URL: https://github.com/gabime/%{name} |
9 |
|
|
Source0: %{url}/archive/v%{version}.tar.gz |
10 |
|
|
|
11 |
|
|
BuildRequires: google-benchmark-devel |
12 |
|
|
BuildRequires: fmt-devel >= 7.0.0 |
13 |
|
|
BuildRequires: ninja-build |
14 |
|
|
BuildRequires: gcc-c++ |
15 |
|
|
BuildRequires: cmake |
16 |
|
|
BuildRequires: gcc |
17 |
jpp |
1.2 |
BuildRequires: devtoolset-9-gcc |
18 |
|
|
BuildRequires: devtoolset-9-gcc-c++ |
19 |
|
|
BuildRequires: cmake3 |
20 |
jpp |
1.1 |
|
21 |
|
|
%description |
22 |
|
|
This is a packaged version of the gabime/spdlog C++ logging |
23 |
|
|
library available at Github. |
24 |
|
|
|
25 |
|
|
%package devel |
26 |
|
|
Summary: Development files for %{name} |
27 |
|
|
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} |
28 |
|
|
Requires: libstdc++-devel%{?_isa} |
29 |
|
|
Requires: fmt-devel%{?_isa} |
30 |
|
|
|
31 |
|
|
%description devel |
32 |
|
|
The %{name}-devel package contains C++ header files for developing |
33 |
|
|
applications that use %{name}. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
37 |
jpp |
1.1 |
%autosetup -p1 |
38 |
|
|
find . -name '.gitignore' -delete |
39 |
|
|
sed -i -e "s,\r,," README.md |
40 |
|
|
|
41 |
|
|
%build |
42 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
43 |
|
|
%cmake3 -G Ninja \ |
44 |
jpp |
1.1 |
-DCMAKE_INSTALL_LIBDIR=%{_lib} \ |
45 |
|
|
-DCMAKE_BUILD_TYPE=Release \ |
46 |
|
|
-DSPDLOG_BUILD_SHARED=ON \ |
47 |
|
|
-DSPDLOG_BUILD_EXAMPLE=OFF \ |
48 |
|
|
-DSPDLOG_BUILD_BENCH=OFF \ |
49 |
|
|
-DSPDLOG_BUILD_TESTS=ON \ |
50 |
|
|
-DSPDLOG_INSTALL=ON \ |
51 |
|
|
-DSPDLOG_FMT_EXTERNAL=ON |
52 |
jpp |
1.2 |
%cmake3_build |
53 |
jpp |
1.1 |
|
54 |
jpp |
1.2 |
#%check |
55 |
|
|
#%ctest |
56 |
jpp |
1.1 |
|
57 |
|
|
%install |
58 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
59 |
|
|
%cmake3_install |
60 |
jpp |
1.1 |
|
61 |
|
|
%files |
62 |
|
|
%license LICENSE |
63 |
|
|
%doc README.md |
64 |
|
|
%{_libdir}/lib%{name}.so.1* |
65 |
|
|
|
66 |
|
|
%files devel |
67 |
|
|
%doc example |
68 |
|
|
%{_includedir}/%{name} |
69 |
|
|
%{_libdir}/lib%{name}.so |
70 |
|
|
%{_libdir}/cmake/%{name} |
71 |
|
|
%{_libdir}/pkgconfig/%{name}.pc |
72 |
|
|
|
73 |
|
|
%changelog |
74 |
|
|
* Fri Apr 02 2021 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.5-1 |
75 |
|
|
- Updated to version 1.8.5. |
76 |
|
|
|
77 |
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-2 |
78 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
79 |
|
|
|
80 |
|
|
* Sat Dec 12 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.2-1 |
81 |
|
|
- Updated to version 1.8.2. |
82 |
|
|
|
83 |
|
|
* Tue Oct 13 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.1-1 |
84 |
|
|
- Updated to version 1.8.1. |
85 |
|
|
|
86 |
|
|
* Sat Sep 05 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.8.0-1 |
87 |
|
|
- Updated to version 1.8.0. |
88 |
|
|
|
89 |
|
|
* Tue Jul 21 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.7.0-1 |
90 |
|
|
- Updated to version 1.7.0. |
91 |
|
|
|
92 |
|
|
* Tue Jun 02 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.6.1-1 |
93 |
|
|
- Updated to version 1.6.1. |
94 |
|
|
|
95 |
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2 |
96 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
97 |
|
|
|
98 |
|
|
* Mon Jan 27 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 1.5.0-1 |
99 |
|
|
- Updated to version 1.5.0. |
100 |
|
|
|
101 |
|
|
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 1.4.2-1 |
102 |
|
|
- Updated to version 1.4.2. |
103 |
|
|
|
104 |
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-3 |
105 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
106 |
|
|
|
107 |
|
|
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2 |
108 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
109 |
|
|
|
110 |
|
|
* Sun Jan 20 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 1.3.1-1 |
111 |
|
|
- Updated to version 1.3.1. |
112 |
|
|
|
113 |
|
|
* Mon Nov 05 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.2.1-1 |
114 |
|
|
- Updated to version 1.2.1. |
115 |
|
|
|
116 |
|
|
* Sun Sep 02 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.1.0-1 |
117 |
|
|
- Updated to version 1.1.0. |
118 |
|
|
|
119 |
|
|
* Thu Aug 09 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 1.0.0-1 |
120 |
|
|
- Updated to version 1.0.0. |
121 |
|
|
|
122 |
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2 |
123 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
124 |
|
|
|
125 |
|
|
* Mon Jun 18 2018 Vitaly Zaitsev <vitaly@easycoding.org> - 0.17.0-1 |
126 |
|
|
- Updated to version 0.17.0. |
127 |
|
|
- Added tests support. |
128 |
|
|
- Added cmake and pkg-config support. |
129 |
|
|
|
130 |
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-5 |
131 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
132 |
|
|
|
133 |
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-4 |
134 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
135 |
|
|
|
136 |
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-3 |
137 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
138 |
|
|
|
139 |
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2 |
140 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild |
141 |
|
|
|
142 |
|
|
* Sun Sep 04 2016 Daniel Kopecek <dkopecek@redhat.com> - 0.10.0-1 |
143 |
|
|
- Update to 0.10.0 |
144 |
|
|
|
145 |
|
|
* Fri Jul 08 2016 Daniel Kopecek <dkopecek@redhat.com> - 0-8.20160703git34bb86b |
146 |
|
|
- update to rev 34bb86b |
147 |
|
|
|
148 |
|
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0-7.20151110gitcbc8ba7 |
149 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild |
150 |
|
|
|
151 |
|
|
* Tue Nov 10 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-6.20151110gitcbc8ba7 |
152 |
|
|
- update to rev cbc8ba7 |
153 |
|
|
|
154 |
|
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-5.20150410git211ce99 |
155 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
156 |
|
|
|
157 |
|
|
* Thu Apr 30 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-4.20150410git211ce99 |
158 |
|
|
- don't build the base package |
159 |
|
|
- remove a dot from the release tag |
160 |
|
|
- corrected -devel subpackage description |
161 |
|
|
|
162 |
|
|
* Mon Apr 20 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-3.20150410git.211ce99 |
163 |
|
|
- use the -p option when copying the header files |
164 |
|
|
|
165 |
|
|
* Tue Apr 14 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-2.20150410git.211ce99 |
166 |
|
|
- don't build the debuginfo subpackage |
167 |
|
|
- require libstdc++-devel |
168 |
|
|
- don't generate a distribution specific pkg-config file |
169 |
|
|
|
170 |
|
|
* Fri Apr 10 2015 Daniel Kopecek <dkopecek@redhat.com> - 0-1.20150410git.211ce99 |
171 |
|
|
- Initial package |