1 |
jpp |
1.1 |
# bcond default logic is nicely backwards... |
2 |
|
|
%bcond_without tcl |
3 |
|
|
%bcond_with static |
4 |
|
|
%bcond_without check |
5 |
|
|
|
6 |
|
|
%define realver 3071700 |
7 |
|
|
%define docver 3071700 |
8 |
|
|
%define rpmver 3.7.17 |
9 |
jpp |
1.2 |
%define release 9 |
10 |
jpp |
1.1 |
Summary: Library that implements an embeddable SQL database engine |
11 |
|
|
Name: sqlite |
12 |
|
|
Version: %{rpmver} |
13 |
jpp |
1.2 |
Release: %{release}%{?dist} |
14 |
jpp |
1.1 |
License: Public Domain |
15 |
|
|
Group: Applications/Databases |
16 |
|
|
URL: http://www.sqlite.org/ |
17 |
|
|
Source0: http://www.sqlite.org/sqlite-src-%{realver}.zip |
18 |
|
|
Source1: http://www.sqlite.org/sqlite-doc-%{docver}.zip |
19 |
|
|
# Support a system-wide lemon template |
20 |
|
|
Patch1: sqlite-3.6.23-lemon-system-template.patch |
21 |
|
|
# Shut up stupid tests depending on system settings of allowed open fd's |
22 |
|
|
Patch2: sqlite-3.7.7.1-stupid-openfiles-test.patch |
23 |
|
|
# Shut up pagecache overflow test whose expected result depends on compile |
24 |
|
|
# options and whatnot. Dunno why this started failing in 3.7.10 but |
25 |
|
|
# doesn't seem particularly critical... |
26 |
|
|
Patch3: sqlite-3.7.10-pagecache-overflow-test.patch |
27 |
|
|
# sqlite >= 3.7.10 is buggy if malloc_usable_size() is detected, disable it: |
28 |
|
|
# https://bugzilla.redhat.com/show_bug.cgi?id=801981 |
29 |
|
|
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665363 |
30 |
|
|
Patch4: sqlite-3.7.15-no-malloc-usable-size.patch |
31 |
|
|
# Man page completion |
32 |
|
|
Patch5: sqlite-3.7.16-man-missing-options.patch |
33 |
|
|
# Fix for test failure on aarch64 |
34 |
|
|
Patch6: sqlite-3.7.17-real-cast.patch |
35 |
|
|
# Fix for 64k pages |
36 |
|
|
Patch7: sqlite-3.7.17-large-pages.patch |
37 |
|
|
# Fixes for CVE-2015-3415 CVE-2015-3414 CVE-2015-3416 sqlite: various flaws |
38 |
|
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1244732 |
39 |
|
|
Patch8: sqlite-3.7.17-collation-sequence.patch |
40 |
|
|
Patch9: sqlite-3.7.17-vdbe-free.patch |
41 |
|
|
Patch10: sqlite-3.7.14-printf-overflow.patch |
42 |
|
|
|
43 |
|
|
BuildRequires: ncurses-devel readline-devel glibc-devel |
44 |
|
|
BuildRequires: autoconf |
45 |
|
|
%if %{with tcl} |
46 |
|
|
BuildRequires: /usr/bin/tclsh |
47 |
|
|
BuildRequires: tcl-devel |
48 |
|
|
%{!?tcl_version: %global tcl_version 8.5} |
49 |
|
|
%{!?tcl_sitearch: %global tcl_sitearch %{_libdir}/tcl%{tcl_version}} |
50 |
|
|
%endif |
51 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
52 |
|
|
|
53 |
|
|
%description |
54 |
|
|
SQLite is a C library that implements an SQL database engine. A large |
55 |
|
|
subset of SQL92 is supported. A complete database is stored in a |
56 |
|
|
single disk file. The API is designed for convenience and ease of use. |
57 |
|
|
Applications that link against SQLite can enjoy the power and |
58 |
|
|
flexibility of an SQL database without the administrative hassles of |
59 |
|
|
supporting a separate database server. Version 2 and version 3 binaries |
60 |
|
|
are named to permit each to be installed on a single host |
61 |
|
|
|
62 |
|
|
%package devel |
63 |
|
|
Summary: Development tools for the sqlite3 embeddable SQL database engine |
64 |
|
|
Group: Development/Libraries |
65 |
|
|
Requires: %{name} = %{version}-%{release} |
66 |
|
|
Requires: pkgconfig |
67 |
|
|
|
68 |
|
|
%description devel |
69 |
|
|
This package contains the header files and development documentation |
70 |
|
|
for %{name}. If you like to develop programs using %{name}, you will need |
71 |
|
|
to install %{name}-devel. |
72 |
|
|
|
73 |
|
|
%package doc |
74 |
|
|
Summary: Documentation for sqlite |
75 |
|
|
Group: Documentation |
76 |
|
|
BuildArch: noarch |
77 |
|
|
|
78 |
|
|
%description doc |
79 |
|
|
This package contains most of the static HTML files that comprise the |
80 |
|
|
www.sqlite.org website, including all of the SQL Syntax and the |
81 |
|
|
C/C++ interface specs and other miscellaneous documentation. |
82 |
|
|
|
83 |
|
|
%package -n lemon |
84 |
|
|
Summary: A parser generator |
85 |
|
|
Group: Development/Tools |
86 |
|
|
|
87 |
|
|
%description -n lemon |
88 |
|
|
Lemon is an LALR(1) parser generator for C or C++. It does the same |
89 |
|
|
job as bison and yacc. But lemon is not another bison or yacc |
90 |
|
|
clone. It uses a different grammar syntax which is designed to reduce |
91 |
|
|
the number of coding errors. Lemon also uses a more sophisticated |
92 |
|
|
parsing engine that is faster than yacc and bison and which is both |
93 |
|
|
reentrant and thread-safe. Furthermore, Lemon implements features |
94 |
|
|
that can be used to eliminate resource leaks, making is suitable for |
95 |
|
|
use in long-running programs such as graphical user interfaces or |
96 |
|
|
embedded controllers. |
97 |
|
|
|
98 |
|
|
%if %{with tcl} |
99 |
|
|
%package tcl |
100 |
|
|
Summary: Tcl module for the sqlite3 embeddable SQL database engine |
101 |
|
|
Group: Development/Languages |
102 |
|
|
Requires: %{name} = %{version}-%{release} |
103 |
|
|
Requires: tcl(abi) = %{tcl_version} |
104 |
|
|
|
105 |
|
|
%description tcl |
106 |
|
|
This package contains the tcl modules for %{name}. |
107 |
|
|
%endif |
108 |
|
|
|
109 |
|
|
%prep |
110 |
|
|
%setup -q -a1 -n %{name}-src-%{realver} |
111 |
|
|
%patch1 -p1 -b .lemon-system-template |
112 |
|
|
%patch2 -p1 -b .stupid-openfiles-test |
113 |
|
|
%patch3 -p1 -b .pagecache-overflow-test |
114 |
|
|
%patch4 -p1 -b .no-malloc-usable-size |
115 |
|
|
%patch5 -p1 -b .man-missing-options |
116 |
|
|
%patch6 -p1 -b .largest-integer |
117 |
|
|
%patch7 -p0 -b .large-pages |
118 |
|
|
%patch8 -p1 -b .collation |
119 |
|
|
%patch9 -p1 -b .vdbe-free |
120 |
|
|
%patch10 -p1 -b .printf-overflow |
121 |
|
|
|
122 |
|
|
# Remove cgi-script erroneously included in sqlite-doc-3070500 |
123 |
|
|
rm -f %{name}-doc-%{realver}/search |
124 |
|
|
|
125 |
|
|
autoconf # Rerun with new autoconf to add support for aarm64 |
126 |
|
|
|
127 |
|
|
%build |
128 |
jpp |
1.2 |
export CFLAGS="$RPM_OPT_FLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -Wall -fno-strict-aliasing -DSQLITE_ENABLE_UNLOCK_NOTIFY=1" |
129 |
jpp |
1.1 |
%configure %{!?with_tcl:--disable-tcl} \ |
130 |
|
|
--enable-threadsafe \ |
131 |
|
|
--enable-threads-override-locks \ |
132 |
|
|
--enable-load-extension \ |
133 |
|
|
%{?with_tcl:TCLLIBDIR=%{tcl_sitearch}/sqlite3} |
134 |
|
|
|
135 |
|
|
# rpath removal |
136 |
|
|
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool |
137 |
|
|
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
138 |
|
|
|
139 |
|
|
make %{?_smp_mflags} |
140 |
|
|
|
141 |
|
|
%install |
142 |
|
|
rm -rf $RPM_BUILD_ROOT |
143 |
|
|
|
144 |
|
|
make DESTDIR=${RPM_BUILD_ROOT} install |
145 |
|
|
|
146 |
|
|
install -D -m0644 sqlite3.1 $RPM_BUILD_ROOT/%{_mandir}/man1/sqlite3.1 |
147 |
|
|
install -D -m0755 lemon $RPM_BUILD_ROOT/%{_bindir}/lemon |
148 |
|
|
install -D -m0644 tool/lempar.c $RPM_BUILD_ROOT/%{_datadir}/lemon/lempar.c |
149 |
|
|
|
150 |
|
|
%if %{with tcl} |
151 |
|
|
# fix up permissions to enable dep extraction |
152 |
|
|
chmod 0755 ${RPM_BUILD_ROOT}/%{tcl_sitearch}/sqlite3/*.so |
153 |
|
|
%endif |
154 |
|
|
|
155 |
|
|
%if ! %{with static} |
156 |
|
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.{la,a} |
157 |
|
|
%endif |
158 |
|
|
|
159 |
|
|
%if %{with check} |
160 |
|
|
%check |
161 |
|
|
# XXX shell tests are broken due to loading system libsqlite3, work around... |
162 |
|
|
export LD_LIBRARY_PATH=`pwd`/.libs |
163 |
|
|
export MALLOC_CHECK_=3 |
164 |
|
|
%ifarch s390 s390x ppc ppc64 %{sparc} %{arm} |
165 |
|
|
make test || : |
166 |
|
|
%else |
167 |
|
|
make test |
168 |
|
|
%endif |
169 |
|
|
%endif |
170 |
|
|
|
171 |
|
|
%clean |
172 |
|
|
rm -rf $RPM_BUILD_ROOT |
173 |
|
|
|
174 |
|
|
%post -p /sbin/ldconfig |
175 |
|
|
|
176 |
|
|
%postun -p /sbin/ldconfig |
177 |
|
|
|
178 |
|
|
%files |
179 |
|
|
%defattr(-, root, root) |
180 |
|
|
%doc README |
181 |
|
|
%{_bindir}/sqlite3 |
182 |
|
|
%{_libdir}/*.so.* |
183 |
|
|
%{_mandir}/man?/* |
184 |
|
|
|
185 |
|
|
%files devel |
186 |
|
|
%defattr(-, root, root) |
187 |
|
|
%{_includedir}/*.h |
188 |
|
|
%{_libdir}/*.so |
189 |
|
|
%{_libdir}/pkgconfig/*.pc |
190 |
|
|
%if %{with static} |
191 |
|
|
%{_libdir}/*.a |
192 |
|
|
%exclude %{_libdir}/*.la |
193 |
|
|
%endif |
194 |
|
|
|
195 |
|
|
%files doc |
196 |
|
|
%defattr(-, root, root) |
197 |
|
|
%doc %{name}-doc-%{docver}/* |
198 |
|
|
|
199 |
|
|
%files -n lemon |
200 |
|
|
%defattr(-, root, root) |
201 |
|
|
%{_bindir}/lemon |
202 |
|
|
%{_datadir}/lemon |
203 |
|
|
|
204 |
|
|
%if %{with tcl} |
205 |
|
|
%files tcl |
206 |
|
|
%defattr(-, root, root) |
207 |
|
|
%{tcl_sitearch}/sqlite3 |
208 |
|
|
%endif |
209 |
|
|
|
210 |
|
|
%changelog |
211 |
jpp |
1.2 |
* Tue Feb 27 2018 Jean-Philipe Pialasse <tests@pialasse.com> 3.7.17-9.sme |
212 |
|
|
- first import for SME SERVER |
213 |
|
|
- add support for DSQLITE_ENABLE_UNLOCK_NOTIFY [SME: 10527] |
214 |
|
|
|
215 |
jpp |
1.1 |
* Thu Jul 23 2015 Jan Stanek <jstanek@redhat.com> 3.7.17-8 |
216 |
|
|
- Fixes for CVE-2015-3415 CVE-2015-3414 CVE-2015-3416 |
217 |
|
|
Resolves: rhbz#1244732 |
218 |
|
|
|
219 |
|
|
* Fri May 8 2015 Peter Robinson <pbrobinson@redhat.com> 3.7.17-7 |
220 |
|
|
- Release bump |
221 |
|
|
|
222 |
|
|
* Tue Oct 21 2014 Dan Horák <dhorak@redhat.com> - 3.7.17-6 |
223 |
|
|
- Release bump for ppc64le |
224 |
|
|
|
225 |
|
|
* Tue Aug 19 2014 Jan Stanek <jstanek@redhat.com> - 3.7.17-5 |
226 |
|
|
- Release bump |
227 |
|
|
|
228 |
|
|
* Thu Jul 10 2014 Yaakov Selkowitz <yselkowi@redhat.com> - 3.7.17-4.1 |
229 |
|
|
- Backport 64k page fix from latest upstream (#1118151) |
230 |
|
|
|
231 |
|
|
* Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 3.7.17-4 |
232 |
|
|
- Mass rebuild 2014-01-24 |
233 |
|
|
|
234 |
|
|
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 3.7.17-3 |
235 |
|
|
- Mass rebuild 2013-12-27 |
236 |
|
|
|
237 |
|
|
* Thu Dec 05 2013 Jan Stanek <jstanek@redhat.com> - 3.7.17-2 |
238 |
|
|
- Backported CAST fix from latest upstream |
239 |
|
|
|
240 |
|
|
* Wed May 22 2013 Jan Stanek <jstanek@redhat.com> - 3.7.17-1 |
241 |
|
|
- Update to 3.7.17 (http://www.sqlite.org/releaselog/3_7_17.html) |
242 |
|
|
|
243 |
|
|
* Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 3.7.16.2-2 |
244 |
|
|
- Added missing options to man page (#948862) |
245 |
|
|
|
246 |
|
|
* Mon Apr 29 2013 Jan Stanek <jstanek@redhat.com> - 3.7.16.2-1 |
247 |
|
|
- update to 3.7.16.2 (http://www.sqlite.org/releaselog/3_7_16_2.html) |
248 |
|
|
- add support for aarch64 (rerunning autoconf) (#926568) |
249 |
|
|
|
250 |
|
|
* Sun Mar 31 2013 Panu Matilainen <pmatilai@redhat.com> - 3.7.16.1-1 |
251 |
|
|
- update to 3.7.16.1 (https://www.sqlite.org/releaselog/3_7_16_1.html) |
252 |
|
|
|
253 |
|
|
* Wed Mar 20 2013 Panu Matilainen <pmatilai@redhat.com> - 3.7.16-1 |
254 |
|
|
- update to 3.7.16 (http://www.sqlite.org/releaselog/3_7_16.html) |
255 |
|
|
|
256 |
|
|
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.15.2-2 |
257 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
258 |
|
|
|
259 |
|
|
* Thu Jan 10 2013 Panu Matilainen <pmatilai@redhat.com> - 3.7.15.2-1 |
260 |
|
|
- update to 3.7.15.2 (http://www.sqlite.org/releaselog/3_7_15_2.html) |
261 |
|
|
|
262 |
|
|
* Thu Dec 13 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.15-1 |
263 |
|
|
- update to 3.7.15 (http://www.sqlite.org/releaselog/3_7_15.html) |
264 |
|
|
- fix an old incorrect date in spec changelog |
265 |
|
|
|
266 |
|
|
* Tue Nov 06 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.14.1-1 |
267 |
|
|
- update to 3.7.14.1 (http://www.sqlite.org/releaselog/3_7_14_1.html) |
268 |
|
|
|
269 |
|
|
* Wed Oct 03 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.14-1 |
270 |
|
|
- update to 3.7.14 (http://www.sqlite.org/releaselog/3_7_14.html) |
271 |
|
|
|
272 |
|
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.13-2 |
273 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
274 |
|
|
|
275 |
|
|
* Mon Jun 25 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.13-1 |
276 |
|
|
- update to 3.7.13 (http://www.sqlite.org/releaselog/3_7_13.html) |
277 |
|
|
- drop no longer needed savepoint relase patch |
278 |
|
|
|
279 |
|
|
* Fri Jun 01 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.11-3 |
280 |
|
|
- don't abort pending queries on release of nested savepoint (#821642) |
281 |
|
|
|
282 |
|
|
* Wed Apr 25 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.11-2 |
283 |
|
|
- run test-suite with MALLOC_CHECK_=3 |
284 |
|
|
- disable buggy malloc_usable_size code (#801981) |
285 |
|
|
|
286 |
|
|
* Mon Mar 26 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.11-1 |
287 |
|
|
- update to 3.7.11 (http://www.sqlite.org/releaselog/3_7_11.html) |
288 |
|
|
|
289 |
|
|
* Wed Mar 07 2012 Panu Matilainen <pmatilai@redhat.com> - 3.7.10-1 |
290 |
|
|
- update to 3.7.10 (http://www.sqlite.org/releaselog/3_7_10.html) |
291 |
|
|
|
292 |
|
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.9-2 |
293 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
294 |
|
|
|
295 |
|
|
* Tue Nov 22 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.9-1 |
296 |
|
|
- update to 3.7.9 (http://www.sqlite.org/releaselog/3_7_9.html) |
297 |
|
|
|
298 |
|
|
* Fri Oct 28 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.8-1 |
299 |
|
|
- update to 3.7.8 (http://www.sqlite.org/releaselog/3_7_8.html) |
300 |
|
|
|
301 |
|
|
* Wed Jul 13 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.7.1-1 |
302 |
|
|
- update to 3.7.7.1 (http://www.sqlite.org/releaselog/3_7_7_1.html) |
303 |
|
|
- autoconf no longer needed for build, libdl check finally upstreamed |
304 |
|
|
|
305 |
|
|
* Wed May 25 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.6.3-1 |
306 |
|
|
- update to 3.7.6.3 (http://www.sqlite.org/releaselog/3_7_6_3.html) |
307 |
|
|
|
308 |
|
|
* Sat May 21 2011 Peter Robinson <pbrobinson@gmail.com> - 3.7.6.2-3 |
309 |
|
|
- add arm to the exclude from tests list |
310 |
|
|
|
311 |
|
|
* Fri Apr 29 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.6.2-2 |
312 |
|
|
- comment out stupid tests causing very bogus build failure on koji |
313 |
|
|
|
314 |
|
|
* Thu Apr 21 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.6.2-1 |
315 |
|
|
- update to 3.7.6.2 (http://www.sqlite.org/releaselog/3_7_6_2.html) |
316 |
|
|
|
317 |
|
|
* Fri Feb 25 2011 Dennis Gilmore <dennis@ausil.us> - 3.7.5-4 |
318 |
|
|
- build tests on sparc expecting failures same as the other big endian arches |
319 |
|
|
|
320 |
|
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.7.5-3 |
321 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
322 |
|
|
|
323 |
|
|
* Wed Feb 2 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.5-2 |
324 |
|
|
- unwanted cgi-script in docs creating broken dependencies, remove it |
325 |
|
|
- make doc sub-package noarch |
326 |
|
|
|
327 |
|
|
* Tue Feb 1 2011 Panu Matilainen <pmatilai@redhat.com> - 3.7.5-1 |
328 |
|
|
- update to 3.7.5 (http://www.sqlite.org/releaselog/3_7_5.html) |
329 |
|
|
|
330 |
|
|
* Thu Dec 9 2010 Panu Matilainen <pmatilai@redhat.com> - 3.7.4-1 |
331 |
|
|
- update to 3.7.4 (http://www.sqlite.org/releaselog/3_7_4.html) |
332 |
|
|
- deal with upstream source naming, versioning and format changing |
333 |
|
|
- fixup wal2-test expections wrt SQLITE_DISABLE_DIRSYNC use |
334 |
|
|
|
335 |
|
|
* Fri Nov 5 2010 Dan Horák <dan[at]danny.cz> - 3.7.3-2 |
336 |
|
|
- expect test failures also on s390x |
337 |
|
|
|
338 |
|
|
* Mon Nov 1 2010 Panu Matilainen <pmatilai@redhat.com> - 3.7.3-1 |
339 |
|
|
- update to 3.7.3 (http://www.sqlite.org/releaselog/3_7_3.html) |
340 |
|
|
|
341 |
|
|
* Thu Sep 2 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 3.7.0.1-2 |
342 |
|
|
- enable SQLITE_SECURE_DELETE, SQLITE_ENABLE_UNLOCK_NOTIFY for firefox 4 |
343 |
|
|
|
344 |
|
|
* Fri Aug 13 2010 Panu Matilainen <pmatilai@redhat.com> - 3.7.0.1-1 |
345 |
|
|
- update to 3.7.0.1 (http://www.sqlite.org/releaselog/3_7_0_1.html) |
346 |
|
|
|
347 |
|
|
* Sat Jul 3 2010 Dan Horák <dan[at]danny.cz> - 3.6.23.1-2 |
348 |
|
|
- some tests are failing on s390 and ppc/ppc64 so don't fail the whole build there |
349 |
|
|
|
350 |
|
|
* Mon Apr 19 2010 Panu Matilainen <pmatilai@redhat.com> - 3.6.23.1-1 |
351 |
|
|
- update to 3.6.23.1 (http://www.sqlite.org/releaselog/3_6_23_1.html) |
352 |
|
|
|
353 |
|
|
* Wed Mar 10 2010 Panu Matilainen <pmatilai@redhat.com> - 3.6.23-1 |
354 |
|
|
- update to 3.6.23 (http://www.sqlite.org/releaselog/3_6_23.html) |
355 |
|
|
- drop the lemon sprintf patch, upstream doesn't want it |
356 |
|
|
- make test-suite errors fail build finally |
357 |
|
|
|
358 |
|
|
* Mon Jan 18 2010 Panu Matilainen <pmatilai@redhat.com> - 3.6.22-1 |
359 |
|
|
- update to 3.6.22 (http://www.sqlite.org/releaselog/3_6_22.html) |
360 |
|
|
|
361 |
|
|
* Tue Dec 08 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.21-1 |
362 |
|
|
- update to 3.6.21 (http://www.sqlite.org/releaselog/3_6_21.html) |
363 |
|
|
|
364 |
|
|
* Tue Nov 17 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.20-1 |
365 |
|
|
- update to 3.6.20 (http://www.sqlite.org/releaselog/3_6_20.html) |
366 |
|
|
|
367 |
|
|
* Tue Oct 06 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.18-1 |
368 |
|
|
- update to 3.6.18 (http://www.sqlite.org/releaselog/3_6_18.html) |
369 |
|
|
- drop no longer needed test-disabler patches |
370 |
|
|
|
371 |
|
|
* Fri Aug 21 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.17-1 |
372 |
|
|
- update to 3.6.17 (http://www.sqlite.org/releaselog/3_6_17.html) |
373 |
|
|
- disable to failing tests until upstream fixes |
374 |
|
|
|
375 |
|
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.14.2-2 |
376 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
377 |
|
|
|
378 |
|
|
* Fri Jun 12 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.14.2-1 |
379 |
|
|
- update to 3.6.14.2 (#505229) |
380 |
|
|
|
381 |
|
|
* Mon May 18 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.14-2 |
382 |
|
|
- disable rpath |
383 |
|
|
- add -doc subpackage instead of patching out reference to it |
384 |
|
|
|
385 |
|
|
* Thu May 14 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.14-1 |
386 |
|
|
- update to 3.6.14 (http://www.sqlite.org/releaselog/3_6_14.html) |
387 |
|
|
- merge-review cosmetics (#226429) |
388 |
|
|
- drop ancient sqlite3 obsoletes |
389 |
|
|
- fix tab vs space whitespace issues |
390 |
|
|
- remove commas from summaries |
391 |
|
|
- fixup io-test fsync expectations wrt SQLITE_DISABLE_DIRSYNC |
392 |
|
|
|
393 |
|
|
* Wed Apr 15 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.13-1 |
394 |
|
|
- update to 3.6.13 |
395 |
|
|
|
396 |
|
|
* Thu Apr 09 2009 Dennis Gilmore <dennis@ausil.us> - 3.6.12-3 |
397 |
|
|
- apply upstream patch for memory alignment issue (#494906) |
398 |
|
|
|
399 |
|
|
* Tue Apr 07 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.12-2 |
400 |
|
|
- disable strict aliasing to work around brokenness on 3.6.12 (#494266) |
401 |
|
|
- run test-suite on build but let it fail for now |
402 |
|
|
|
403 |
|
|
* Fri Apr 03 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.12-1 |
404 |
|
|
- update to 3.6.12 (#492662) |
405 |
|
|
- remove reference to non-existent sqlite-doc from manual (#488883) |
406 |
|
|
|
407 |
|
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.10-4 |
408 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
409 |
|
|
|
410 |
|
|
* Wed Feb 04 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.10-3 |
411 |
|
|
- enable RTREE and FTS3 extensions (#481417) |
412 |
|
|
|
413 |
|
|
* Thu Jan 22 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.10-2 |
414 |
|
|
- upstream fix yum breakage caused by new keywords (#481189) |
415 |
|
|
|
416 |
|
|
* Thu Jan 22 2009 Panu Matilainen <pmatilai@redhat.com> - 3.6.10-1 |
417 |
|
|
- update to 3.6.10 |
418 |
|
|
|
419 |
|
|
* Wed Dec 31 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.7-1 |
420 |
|
|
- update to 3.6.7 |
421 |
|
|
- avoid lemon ending up in main sqlite package too |
422 |
|
|
|
423 |
|
|
* Fri Dec 05 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.6.2-4 |
424 |
|
|
- add lemon subpackage |
425 |
|
|
|
426 |
|
|
* Thu Dec 4 2008 Matthias Clasen <mclasen@redhat.com> - 3.6.6.2-3 |
427 |
|
|
- Rebuild for pkg-config provides |
428 |
|
|
|
429 |
|
|
* Tue Dec 02 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.6.2-2 |
430 |
|
|
- require tcl(abi) in sqlite-tcl subpackage (#474034) |
431 |
|
|
- move tcl extensions to arch-specific location |
432 |
|
|
- enable dependency extraction on the tcl dso |
433 |
|
|
- require pkgconfig in sqlite-devel |
434 |
|
|
|
435 |
|
|
* Sat Nov 29 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.6.2-1 |
436 |
|
|
- update to 3.6.6.2 |
437 |
|
|
|
438 |
|
|
* Sat Nov 08 2008 Panu Matilainen <pmatilai@redhat.com> - 3.6.4-1 |
439 |
|
|
- update to 3.6.4 |
440 |
|
|
- drop patches already upstream |
441 |
|
|
|
442 |
|
|
* Mon Sep 22 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.9-2 |
443 |
|
|
- Remove references to temporary registers from cache on release (#463061) |
444 |
|
|
- Enable loading of external extensions (#457433) |
445 |
|
|
|
446 |
|
|
* Tue Jun 17 2008 Stepan Kasal <skasal@redhat.com> - 3.5.9-1 |
447 |
|
|
- update to 3.5.9 |
448 |
|
|
|
449 |
|
|
* Wed Apr 23 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.8-1 |
450 |
|
|
- update to 3.5.8 |
451 |
|
|
- provide full version in pkg-config (#443692) |
452 |
|
|
|
453 |
|
|
* Mon Mar 31 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.6-2 |
454 |
|
|
- remove reference to static libs from -devel description (#439376) |
455 |
|
|
|
456 |
|
|
* Tue Feb 12 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.6-1 |
457 |
|
|
- update to 3.5.6 |
458 |
|
|
- also fixes #432447 |
459 |
|
|
|
460 |
|
|
* Fri Jan 25 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.4-3 |
461 |
|
|
- enable column metadata API (#430258) |
462 |
|
|
|
463 |
|
|
* Tue Jan 08 2008 Panu Matilainen <pmatilai@redhat.com> - 3.5.4-2 |
464 |
|
|
- avoid packaging CVS directory as documentation (#427755) |
465 |
|
|
|
466 |
|
|
* Fri Dec 21 2007 Panu Matilainen <pmatilai@redhat.com> - 3.5.4-1 |
467 |
|
|
- Update to 3.5.4 (#413801) |
468 |
|
|
|
469 |
|
|
* Fri Sep 28 2007 Panu Matilainen <pmatilai@redhat.com> - 3.4.2-3 |
470 |
|
|
- Add another build conditional for enabling %%check |
471 |
|
|
|
472 |
|
|
* Fri Sep 28 2007 Panu Matilainen <pmatilai@redhat.com> - 3.4.2-2 |
473 |
|
|
- Use bconds for the spec build conditionals |
474 |
|
|
- Enable -tcl subpackage again (#309041) |
475 |
|
|
|
476 |
|
|
* Wed Aug 15 2007 Paul Nasrat <pnasrat@redhat.com> - 3.4.2-1 |
477 |
|
|
- Update to 3.4.2 |
478 |
|
|
|
479 |
|
|
* Sat Jul 21 2007 Paul Nasrat <pnasrat@redhat.com> - 3.4.1-1 |
480 |
|
|
- Update to 3.4.1 |
481 |
|
|
|
482 |
|
|
* Sun Jun 24 2007 Paul Nasrat <pnsarat@redhat.com> - 3.4.0-2 |
483 |
|
|
- Disable load for now (#245486) |
484 |
|
|
|
485 |
|
|
* Tue Jun 19 2007 Paul Nasrat <pnasrat@redhat.com> - 3.4.0-1 |
486 |
|
|
- Update to 3.4.0 |
487 |
|
|
|
488 |
|
|
* Fri Jun 01 2007 Paul Nasrat <pnasrat@redhat.com> - 3.3.17-2 |
489 |
|
|
- Enable load |
490 |
|
|
- Build fts1 and fts2 |
491 |
|
|
- Don't sync on dirs (#237427) |
492 |
|
|
|
493 |
|
|
* Tue May 29 2007 Paul Nasrat <pnasrat@redhat.com> - 3.3.17-1 |
494 |
|
|
- Update to 3.3.17 |
495 |
|
|
|
496 |
|
|
* Mon Mar 19 2007 Paul Nasrat <pnasrat@redhat.com> - 3.3.13-1 |
497 |
|
|
- Update to 3.3.13 |
498 |
|
|
|
499 |
|
|
* Fri Aug 11 2006 Paul Nasrat <pnasrat@redhat.com> - 3.3.6-2 |
500 |
|
|
- Fix conditional typo (patch from Gareth Armstrong) |
501 |
|
|
|
502 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.3.6-1.1 |
503 |
|
|
- rebuild |
504 |
|
|
|
505 |
|
|
* Mon Jun 26 2006 Paul Nasrat <pnasrat@redhat.com> - 3.3.6-1 |
506 |
|
|
- Update to 3.3.6 |
507 |
|
|
- Fix typo (#189647) |
508 |
|
|
- Enable threading fixes (#181298) |
509 |
|
|
- Conditionalize static library |
510 |
|
|
|
511 |
|
|
* Mon Apr 17 2006 Paul Nasrat <pnasrat@redhat.com> - 3.3.5-1 |
512 |
|
|
- Update to 3.3.5 |
513 |
|
|
|
514 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.3.3-1.2 |
515 |
|
|
- bump again for double-long bug on ppc(64) |
516 |
|
|
|
517 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.3.3-1.1 |
518 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
519 |
|
|
|
520 |
|
|
* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 3.3.3-1 |
521 |
|
|
- Update to 3.3.3 |
522 |
|
|
|
523 |
|
|
* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 3.3.2-1 |
524 |
|
|
- Update to 3.3.2 |
525 |
|
|
|
526 |
|
|
* Tue Jan 24 2006 Paul Nasrat <pnasrat@redhat.com> - 3.2.8-1 |
527 |
|
|
- Add --enable-threadsafe (Nicholas Miell) |
528 |
|
|
- Update to 3.2.8 |
529 |
|
|
|
530 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
531 |
|
|
- rebuilt |
532 |
|
|
|
533 |
|
|
* Tue Oct 4 2005 Jeremy Katz <katzj@redhat.com> - 3.2.7-2 |
534 |
|
|
- no more static file or libtool archive (#169874) |
535 |
|
|
|
536 |
|
|
* Wed Sep 28 2005 Florian La Roche <laroche@redhat.com> |
537 |
|
|
- Upgrade to 3.2.7 release. |
538 |
|
|
|
539 |
|
|
* Thu Sep 22 2005 Florian La Roche <laroche@redhat.com> |
540 |
|
|
- Upgrade to 3.2.6 release. |
541 |
|
|
|
542 |
|
|
* Sun Sep 11 2005 Florian La Roche <laroche@redhat.com> |
543 |
|
|
- Upgrade to 3.2.5 release. |
544 |
|
|
|
545 |
|
|
* Fri Jul 8 2005 Roland McGrath <roland@redhat.com> - 3.2.2-1 |
546 |
|
|
- Upgrade to 3.2.2 release. |
547 |
|
|
|
548 |
|
|
* Sat Apr 9 2005 Warren Togami <wtogami@redhat.com> - 3.1.2-3 |
549 |
|
|
- fix buildreqs (#154298) |
550 |
|
|
|
551 |
|
|
* Mon Apr 4 2005 Jeremy Katz <katzj@redhat.com> - 3.1.2-2 |
552 |
|
|
- disable tcl subpackage |
553 |
|
|
|
554 |
|
|
* Wed Mar 9 2005 Jeff Johnson <jbj@redhat.com> 3.1.2-1 |
555 |
|
|
- rename to "sqlite" from "sqlite3" (#149719, #150012). |
556 |
|
|
|
557 |
|
|
* Wed Feb 16 2005 Jeff Johnson <jbj@jbj.org> 3.1.2-1 |
558 |
|
|
- upgrade to 3.1.2. |
559 |
|
|
- add sqlite3-tcl sub-package. |
560 |
|
|
|
561 |
|
|
* Sat Feb 5 2005 Jeff Johnson <jbj@jbj.org> 3.0.8-3 |
562 |
|
|
- repackage for fc4. |
563 |
|
|
|
564 |
|
|
* Mon Jan 17 2005 R P Herrold <info@owlriver.com> 3.0.8-2orc |
565 |
|
|
- fix a man page nameing conflict when co-installed with sqlite-2, as |
566 |
|
|
is permissible |