/[smecontribs]/rpms/trac/contribs7/trac.spec
ViewVC logotype

Annotation of /rpms/trac/contribs7/trac.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Mon Dec 29 15:51:38 2008 UTC (15 years, 5 months ago) by marcohess
Branch: MAIN
CVS Tags: trac-0_10_5-1_el4_sme, HEAD
Changes since 1.4: +5 -2 lines
Updated to trac release 0.10.5

1 marcohess 1.5 # $Id: trac.spec,v 1.4 2008/11/25 16:20:36 slords Exp $
2 slords 1.2 # Authority: marcohess
3     # Name: Marco Hess
4 slords 1.1
5     %define python_sitelib %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib()')
6    
7     Name: trac
8     Summary: Integrated SCM and project management tool
9 marcohess 1.5 Version: 0.10.5
10 slords 1.1 Release: 1%{?dist}
11     License: GPL
12     Group: Development/Tools
13     URL: http://projects.edgewall.com/trac/
14    
15     Source: http://ftp.edgewall.com/pub/trac/trac-%{version}.tar.gz
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17    
18     BuildArch: noarch
19     BuildRequires: python >= 2.3
20     Requires: python >= 2.3, python-sqlite >= 0.4.3, subversion >= 1.0.0
21     Requires: python-clearsilver >= 0.9.3, webserver
22     #Requires: subversion-python >= 1.0.0
23    
24     Patch0: trac-0.10.4-TrueHttpBasicAuthenticationLogout.patch
25    
26     %description
27     Trac is a minimalistic web-based software project management and
28     bug/issue tracking system. It provides an interface to revision
29     control systems (Subversion), an integrated Wiki and convenient
30     report facilities.
31    
32     Trac allows wiki markup in issue descriptions and commit messages,
33     to create links and seamless references between bugs, tasks,
34     changesets, files and wiki pages. A timeline shows all project
35     events in order, making getting an overview of the project and
36     tracking progress very easy.
37    
38     This version is imported from the Dag Wiers repository and has
39     patchers to make it suitable to work on SME Server.
40    
41     %prep
42     %setup
43     %patch0 -p1
44    
45     %{__perl} -pi.orig -e 's|/usr/lib/|%{_libdir}|g' setup.py
46    
47     %{__cat} <<EOF >trac.httpd
48     Alias /trac/ "%{_datadir}/trac/htdocs/"
49    
50     ### Trac need to know where the database is located
51     <Location "/cgi-bin/trac.cgi">
52     SetEnv TRAC_ENV "%{_datadir}/trac/myproject.db"
53     </Location>
54    
55     ### You need this to allow users to authenticate
56     <Location "/cgi-bin/trac.cgi/login">
57     AuthType Basic
58     AuthName "trac"
59     AuthUserFile %{_datadir}/trac/trac.htpasswd
60     Require valid-user
61     </location>
62     EOF
63    
64     %build
65    
66     %install
67     %{__rm} -rf %{buildroot}
68     %{__python} setup.py install --root="%{buildroot}"
69    
70     %{__install} -Dp -m0644 trac.httpd %{buildroot}%{_sysconfdir}/httpd/conf.d/trac.conf
71     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/lib/trac/
72    
73     %clean
74     %{__rm} -rf %{buildroot}
75    
76     %files
77     %defattr(-, root, root, 0755)
78     %doc AUTHORS ChangeLog COPYING INSTALL README THANKS UPGRADE
79     %doc %{_mandir}/man1/trac*.1*
80     %config(noreplace) %{_sysconfdir}/httpd/conf.d/trac.conf
81     %{_bindir}/trac*
82     %{_datadir}/trac/
83     %{python_sitelib}/trac/
84     %{_localstatedir}/lib/trac/
85    
86     %changelog
87 marcohess 1.5 * Tue Dec 30 2008 Marco Hess <marco.hess@through-ip.com>
88     - Updated to release 0.10.5
89    
90 slords 1.1 * Mon Aug 13 2007 Marco Hess <marco.hess@through-ip.com>
91     - Update package to trac 0.10.4
92    
93     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
94     - Clean up spec so package can be built by koji/plague
95    
96     * Mon Apr 2 2007 Marco Hess <marco.hess@through-ip.com>
97     - 0.10.3.1-2.rf.sme01
98     - Imported into smecontribs CVS and applied patch to support
99     true http authenticated logout as described in Trac Ticket
100     3577 <http://trac.edgewall.org/ticket/3577>
101    
102     * Sat Mar 10 2007 Dag Wieers <dag@wieers.com> - 0.10.3.1-1 - 4994+/dag
103     - Updated to release 0.10.3.1.
104    
105     * Wed Dec 13 2006 Dag Wieers <dag@wieers.com> - 0.10.3-1
106     - Updated to release 0.10.3.
107    
108     * Wed Nov 15 2006 Dag Wieers <dag@wieers.com> - 0.10.2-1
109     - Updated to release 0.10.2.
110    
111     * Thu Nov 09 2006 Dag Wieers <dag@wieers.com> - 0.10.1-1
112     - Updated to release 0.10.1.
113    
114     * Sat Sep 30 2006 Dag Wieers <dag@wieers.com> - 0.10-1
115     - Updated to release 0.10.
116    
117     * Sun Jul 09 2006 Dag Wieers <dag@wieers.com> - 0.9.6-1
118     - Updated to release 0.9.6.
119    
120     * Sat Apr 22 2006 Dries Verachtert <dries@ulyssis.org> - 0.9.5-1
121     - Updated to release 0.9.5.
122    
123     * Sat Feb 18 2006 Dag Wieers <dag@wieers.com> - 0.9.4-1
124     - Updated to release 0.9.4.
125    
126     * Wed Jan 11 2006 Dag Wieers <dag@wieers.com> - 0.9.3-1
127     - Updated to release 0.9.3.
128    
129     * Tue Dec 06 2005 Dries Verachtert <dries@ulyssis.org> - 0.9.2-1
130     - Updated to release 0.9.2.
131    
132     * Tue Nov 15 2005 Dries Verachtert <dries@ulyssis.org> - 0.9-1
133     - Updated to release 0.9.
134    
135     * Tue Jul 19 2005 Dag Wieers <dag@wieers.com> - 0.8.4-1
136     - Updated to release 0.8.4.
137    
138     * Mon Jul 11 2005 Matt Whiteley <mattw@cat.pdx.edu> - 0.8.3-1
139     - Updated to release 0.8.3.
140    
141     * Wed Jun 01 2005 Matt Whiteley <mattw@cat.pdx.edu> - 0.8.2-1
142     - Updated to release 0.8.2.
143     - Fixed env in apache conf.d file.
144    
145     * Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 0.8.1-1
146     - Updated to release 0.8.1.
147    
148     * Wed Jan 19 2005 Dag Wieers <dag@wieers.com> - 0.8-4
149     - Fixed typo causing missing trac.conf. (Simon Perreault)
150    
151     * Mon Nov 29 2004 Dag Wieers <dag@wieers.com> - 0.8-3
152     - Fixed buildroot in %%install phase. (Dimiter Manevski)
153    
154     * Mon Nov 29 2004 Dag Wieers <dag@wieers.com> - 0.8-2
155     - Remove the deprecated subversion-python requirement. (Dimiter Manevski)
156    
157     * Sun Nov 21 2004 Dag Wieers <dag@wieers.com> - 0.8-1
158     - Updated to release 0.8.
159    
160     * Fri Jun 04 2004 Dag Wieers <dag@wieers.com> - 0.7.1-1
161     - Updated to release 0.7.1.
162    
163     * Sun May 30 2004 Dag Wieers <dag@wieers.com> - 0.7.0-1
164     - Updated to release 0.7.0.
165    
166     * Fri Apr 30 2004 Dag Wieers <dag@wieers.com> - 0.6.1-1
167     - Initial package. (using DAR)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed