1 |
slords |
1.10 |
# $Id: translate-toolkit.spec,v 1.9 2009/10/20 15:29:55 slords Exp $ |
2 |
slords |
1.5 |
# Authority: slords |
3 |
slords |
1.4 |
# Name: Shad L. Lords |
4 |
|
|
|
5 |
slords |
1.6 |
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} |
6 |
slords |
1.1 |
|
7 |
slords |
1.6 |
Name: translate-toolkit |
8 |
slords |
1.9 |
Version: 1.4.1 |
9 |
slords |
1.6 |
Release: 1%{?dist} |
10 |
slords |
1.9 |
Summary: Tools to assist with translation and software localization |
11 |
slords |
1.6 |
|
12 |
|
|
Group: Development/Tools |
13 |
|
|
License: GPLv2+ |
14 |
|
|
URL: http://translate.sourceforge.net/wiki/toolkit/index |
15 |
slords |
1.9 |
Source0: http://downloads.sourceforge.net/project/translate/Translate%20Toolkit/1.4.0/%{name}-%{version}.tar.bz2 |
16 |
slords |
1.6 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
17 |
|
|
|
18 |
slords |
1.9 |
Patch0: translate-toolkit-1.2.1-stoplist.patch |
19 |
slords |
1.6 |
|
20 |
|
|
BuildArch: noarch |
21 |
|
|
BuildRequires: python-devel |
22 |
slords |
1.9 |
# The following are needed for man page generation |
23 |
|
|
BuildRequires: python-lxml |
24 |
|
|
BuildRequires: python-iniparse |
25 |
|
|
BuildRequires: python-simplejson |
26 |
|
|
BuildRequires: python-vobject |
27 |
slords |
1.10 |
Requires: gettext |
28 |
slords |
1.6 |
Requires: python-enchant |
29 |
slords |
1.9 |
Requires: python-iniparse |
30 |
slords |
1.6 |
Requires: python-Levenshtein |
31 |
|
|
Requires: python-lxml |
32 |
slords |
1.9 |
%ifarch %{ix86} |
33 |
|
|
Requires: python-psyco |
34 |
|
|
%endif |
35 |
|
|
Requires: python-simplejson |
36 |
slords |
1.6 |
Requires: python-vobject |
37 |
slords |
1.1 |
|
38 |
|
|
|
39 |
slords |
1.6 |
%description |
40 |
slords |
1.9 |
A set of tools for managing translation and software localization via |
41 |
|
|
Gettext PO or XLIFF format files. |
42 |
|
|
|
43 |
slords |
1.6 |
Including: |
44 |
|
|
* Convertors: convert from various formats to PO or XLIFF |
45 |
|
|
* Formats: |
46 |
|
|
* Core localization formats - XLIFF and Gettext PO |
47 |
|
|
* Other localization formats - TMX, TBX, Qt Linguist (.ts), |
48 |
|
|
Java .properties, Wordfast TM |
49 |
|
|
* Compiled formats: Gettext MO, Qt .qm |
50 |
slords |
1.9 |
* Other formats - OpenDocument Format (ODF), text, HTML, CSV, INI, |
51 |
|
|
wiki (MediaWiki, DokuWiki), iCal |
52 |
slords |
1.6 |
* Specialised - OpenOffice.org GSI/SDF, PHP, |
53 |
slords |
1.9 |
Mozilla (.dtd, .properties, etc), Symbian, |
54 |
|
|
Innosetup, tikiwiki, subtitles |
55 |
|
|
* Tools: count, search, debug, segment and pretranslate localization |
56 |
|
|
files. Extract terminology. Pseudo-localize |
57 |
|
|
* Checkers: validate translations with over 45 checks |
58 |
slords |
1.6 |
|
59 |
|
|
%package devel |
60 |
|
|
Summary: Development API for %{name} applications |
61 |
|
|
Group: Development/Tools |
62 |
|
|
License: GPLv2+ |
63 |
|
|
Requires: %{name} = %{version}-%{release} |
64 |
|
|
|
65 |
|
|
%description devel |
66 |
slords |
1.9 |
The %{name}-devel package contains Translate Toolkit API |
67 |
|
|
documentation for developers wishing to build new tools for the |
68 |
|
|
toolkit or to use the libraries in other localization tools. |
69 |
slords |
1.1 |
|
70 |
|
|
|
71 |
|
|
%prep |
72 |
slords |
1.9 |
%setup -q |
73 |
slords |
1.6 |
%patch0 -p1 |
74 |
|
|
|
75 |
slords |
1.1 |
|
76 |
|
|
%build |
77 |
slords |
1.6 |
%{__python} setup.py build |
78 |
|
|
|
79 |
slords |
1.1 |
|
80 |
|
|
%install |
81 |
slords |
1.6 |
rm -rf $RPM_BUILD_ROOT |
82 |
|
|
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT |
83 |
|
|
|
84 |
slords |
1.9 |
# create manpages |
85 |
slords |
1.6 |
mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1 |
86 |
slords |
1.9 |
for program in $RPM_BUILD_ROOT/%{_bindir}/*; do |
87 |
slords |
1.6 |
case $(basename $program) in |
88 |
slords |
1.9 |
pocompendium|poen|pomigrate2|popuretext|poreencode|posplit|pocount|poglossary|lookupclient.py|tmserver|build_tmdb) |
89 |
|
|
;; |
90 |
|
|
*) |
91 |
slords |
1.6 |
LC_ALL=C PYTHONPATH=. $program --manpage \ |
92 |
slords |
1.9 |
> $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \ |
93 |
|
|
|| rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 |
94 |
|
|
;; |
95 |
slords |
1.6 |
esac |
96 |
|
|
done |
97 |
|
|
|
98 |
|
|
# remove documentation files from site-packages |
99 |
|
|
rm -r $RPM_BUILD_ROOT/%{python_sitelib}/translate/doc |
100 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{COPYING,ChangeLog,LICENSE,README} |
101 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{convert,filters,tools}/TODO |
102 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/misc/README |
103 |
|
|
|
104 |
|
|
# Move data files to /usr/share |
105 |
|
|
mkdir $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit |
106 |
|
|
mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/stoplist* $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit |
107 |
|
|
|
108 |
slords |
1.1 |
|
109 |
|
|
%clean |
110 |
|
|
rm -rf $RPM_BUILD_ROOT |
111 |
|
|
|
112 |
slords |
1.6 |
|
113 |
|
|
%files |
114 |
|
|
%defattr(-,root,root,-) |
115 |
slords |
1.9 |
%doc translate/ChangeLog translate/COPYING translate/README |
116 |
slords |
1.6 |
%doc translate/doc/user/toolkit-[a-z]* |
117 |
|
|
%{_bindir}/* |
118 |
|
|
%{_mandir}/man1/* |
119 |
|
|
%{_datadir}/translate-toolkit |
120 |
|
|
%{python_sitelib}/translate* |
121 |
|
|
|
122 |
|
|
%files devel |
123 |
slords |
1.9 |
%defattr(-,root,root,-) |
124 |
slords |
1.6 |
%doc translate/doc/api/* |
125 |
|
|
|
126 |
|
|
|
127 |
|
|
%changelog |
128 |
slords |
1.9 |
* Tue Oct 20 2009 Shad L. Lords <slords@mail.com> - 1.4.1-1 |
129 |
|
|
- Update to 1.4.1 final |
130 |
|
|
|
131 |
|
|
* Mon Aug 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-2 |
132 |
|
|
- Upstream bug #1114 - obsolete messages should not be translatable |
133 |
|
|
|
134 |
|
|
* Wed Aug 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-1 |
135 |
|
|
- Update to 1.4.0 final |
136 |
slords |
1.6 |
|
137 |
slords |
1.9 |
* Fri Jul 31 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.4.rc2 |
138 |
|
|
- Update to 1.4.0 rc2: |
139 |
|
|
- Some small fixes for XLIFF support |
140 |
|
|
- API documentation has been augmented with diagrams |
141 |
slords |
1.6 |
|
142 |
slords |
1.9 |
* Fri Jul 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.3.rc1 |
143 |
|
|
- Update to 1.4.0 rc1: |
144 |
slords |
1.6 |
|
145 |
slords |
1.9 |
Improvements since beta 1: |
146 |
|
|
* Improved support for Windows .rc files. |
147 |
|
|
* Small fixes to Mozilla support. |
148 |
|
|
* Improvements to some pofilter checks. |
149 |
|
|
* The tmserver now has more startup options to control behaviour. |
150 |
|
|
* Better handling of spaces between inline elements in XLIFF |
151 |
|
|
|
152 |
|
|
There were also other bugfixes and small improvements, especially for |
153 |
|
|
the sake of the rich editing features in the upcoming version of |
154 |
|
|
Virtaal. |
155 |
slords |
1.6 |
|
156 |
slords |
1.9 |
* Mon Jun 29 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.2.beta1 |
157 |
|
|
- Retag |
158 |
slords |
1.6 |
|
159 |
slords |
1.9 |
* Sat Jun 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.1.beta1 |
160 |
|
|
- Update to 1.4.0 beta1 |
161 |
slords |
1.6 |
|
162 |
slords |
1.9 |
* Fri Jun 12 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-3 |
163 |
|
|
- Remove old excludes for /usr/bin/*.py{o,c} |
164 |
slords |
1.6 |
|
165 |
slords |
1.9 |
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2 |
166 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
167 |
|
|
|
168 |
|
|
* Wed Feb 18 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-1 |
169 |
|
|
- Update to 1.3.0 final release |
170 |
|
|
|
171 |
|
|
* Tue Feb 3 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2.rc1 |
172 |
|
|
- Update to 1.3.0 rc1 |
173 |
|
|
|
174 |
|
|
* Thu Jan 22 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1.beta1 |
175 |
|
|
- Update to 1.3.0 beta1 |
176 |
|
|
|
177 |
|
|
* Sat Dec 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.1-1 |
178 |
|
|
- Update to 1.2.1 |
179 |
|
|
- Refresh poterminology patch |
180 |
|
|
|
181 |
|
|
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-4 |
182 |
|
|
- Rebuild for Python 2.6 |
183 |
|
|
|
184 |
|
|
* Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-3 |
185 |
|
|
- Rebuild using %%{ix86} instead of i386 |
186 |
|
|
|
187 |
|
|
* Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-2 |
188 |
|
|
- python-psyco is only available on i386 |
189 |
|
|
|
190 |
|
|
* Wed Nov 12 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1 |
191 |
|
|
- Update to 1.2.0 |
192 |
|
|
- Patch poterminology to read stoplist-en from /usr/share/ |
193 |
slords |
1.6 |
- Add devel package to include generated Translate Toolkit API documentation |
194 |
slords |
1.9 |
- Add dependencies: python-iniparse, python-Levenshtein, python-lxml, |
195 |
|
|
python-psyco, python-vobject, gettext-libs |
196 |
slords |
1.6 |
|
197 |
slords |
1.9 |
* Fri Jun 06 2008 Roozbeh Pournader <roozbeh@gmail.com> - 1.1.1-1 |
198 |
|
|
- update to 1.1.1 |
199 |
slords |
1.6 |
|
200 |
slords |
1.9 |
* Mon Jan 21 2008 Jens Petersen <petersen@redhat.com> - 1.0.1-1 |
201 |
|
|
- update license field to GPLv2+ |
202 |
|
|
- update to 1.0.1 with changes from Dwayne Bailey (#315021): |
203 |
slords |
1.6 |
|
204 |
slords |
1.9 |
* Thu Dec 20 2007 Dwayne Bailey <dwayne@translate.org.za> |
205 |
|
|
- Update spec to upstream 1.0.1 |
206 |
slords |
1.6 |
- Update patch for Python 2.5 ElementTree |
207 |
|
|
- Cleanup the doc installation |
208 |
slords |
1.9 |
- Create man pages |
209 |
|
|
- Update description |
210 |
slords |
1.6 |
|
211 |
|
|
* Sat May 05 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.11-1 |
212 |
|
|
- Update to upstream 0.11, adding HTML documentation |
213 |
|
|
|
214 |
|
|
* Tue Jan 09 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-4 |
215 |
|
|
- Patch to use Python 2.5's built-in ElementTree |
216 |
|
|
|
217 |
|
|
* Sat Dec 30 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-3 |
218 |
|
|
- Rebuild to fix dependency problem |
219 |
|
|
|
220 |
|
|
* Sat Dec 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-2 |
221 |
|
|
- Rebuild for Python 2.5 |
222 |
|
|
|
223 |
|
|
* Thu Nov 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-1 |
224 |
|
|
- Update to upstream 0.10.1 |
225 |
|
|
- Cleanup based on latest Python packaging guidelines |
226 |
|
|
|
227 |
|
|
* Wed Nov 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-2 |
228 |
|
|
- Rebuild to get into Rawhide |
229 |
|
|
|
230 |
|
|
* Mon Feb 20 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-1 |
231 |
|
|
- Update to final 0.8 |
232 |
|
|
|
233 |
|
|
* Sun Feb 19 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.10.rc6 |
234 |
|
|
- Fix a typo in po2dtd that made po2moz fail |
235 |
|
|
|
236 |
|
|
* Tue Feb 14 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.9.rc6 |
237 |
|
|
- Rebuild for Fedora Extras 5 |
238 |
|
|
|
239 |
|
|
* Tue Feb 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.8.rc6 |
240 |
|
|
- Require python-enchant for spellchecking support in pofilter |
241 |
|
|
|
242 |
|
|
* Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.7.rc6 |
243 |
|
|
- Rebuild |
244 |
|
|
|
245 |
|
|
* Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.6.rc6 |
246 |
|
|
- Update to 0.8rc6 |
247 |
|
|
|
248 |
|
|
* Sat Jan 21 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.5.rc5 |
249 |
|
|
- Use sed instead of dos2unix |
250 |
|
|
|
251 |
|
|
* Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.4.rc5 |
252 |
|
|
- Own forgotten subdirectories |
253 |
|
|
|
254 |
|
|
* Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.3.rc5 |
255 |
|
|
- Fix the jToolkit requirement |
256 |
|
|
|
257 |
|
|
* Sun Jan 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.2.rc5 |
258 |
|
|
- Add %%{?dist} tag |
259 |
|
|
|
260 |
|
|
* Sat Jan 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.1.rc5 |
261 |
|
|
- Initial packaging |