/[smecontribs]/rpms/translate-toolkit/contribs8/translate-toolkit.spec
ViewVC logotype

Annotation of /rpms/translate-toolkit/contribs8/translate-toolkit.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.13 - (hide annotations) (download)
Wed Feb 24 18:19:19 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: translate-toolkit-1_5_3-2_el5_sme
Changes since 1.12: +4 -0 lines
Update spec

1 slords 1.13 # $Id: translate-toolkit.spec,v 1.11 2009/10/20 21:41:47 slords Exp $
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.6 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6 slords 1.1
7 slords 1.6 Name: translate-toolkit
8 slords 1.12 Version: 1.5.3
9 slords 1.11 Release: 2%{?dist}
10 slords 1.9 Summary: Tools to assist with translation and software localization
11 slords 1.6
12     Group: Development/Tools
13     License: GPLv2+
14     URL: http://translate.sourceforge.net/wiki/toolkit/index
15 slords 1.12 Source0: http://downloads.sourceforge.net/project/translate/Translate%20Toolkit/%{version}/%{name}-%{version}.tar.bz2
16 slords 1.6 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17    
18 slords 1.12 Patch0: translate-toolkit-1.5.3-stoplist.patch
19     Patch1: translate-toolkit-1.5.0-langmodel_dir.patch
20     Patch2: translate-toolkit-1.5.3-bug1372_filesystem_encoding.patch
21 slords 1.6
22     BuildArch: noarch
23     BuildRequires: python-devel
24 slords 1.9 # The following are needed for man page generation
25     BuildRequires: python-lxml
26     BuildRequires: python-simplejson
27     BuildRequires: python-vobject
28 slords 1.12 Requires: gettext-libs
29 slords 1.6 Requires: python-enchant
30 slords 1.9 Requires: python-iniparse
31 slords 1.6 Requires: python-Levenshtein
32     Requires: python-lxml
33 slords 1.9 %ifarch %{ix86}
34     Requires: python-psyco
35     %endif
36     Requires: python-simplejson
37 slords 1.6 Requires: python-vobject
38 slords 1.1
39    
40 slords 1.6 %description
41 slords 1.9 A set of tools for managing translation and software localization via
42     Gettext PO or XLIFF format files.
43    
44 slords 1.6 Including:
45     * Convertors: convert from various formats to PO or XLIFF
46     * Formats:
47     * Core localization formats - XLIFF and Gettext PO
48     * Other localization formats - TMX, TBX, Qt Linguist (.ts),
49 slords 1.12 Java .properties, Wordfast TM, OmegaT glossary
50 slords 1.6 * Compiled formats: Gettext MO, Qt .qm
51 slords 1.9 * Other formats - OpenDocument Format (ODF), text, HTML, CSV, INI,
52     wiki (MediaWiki, DokuWiki), iCal
53 slords 1.6 * Specialised - OpenOffice.org GSI/SDF, PHP,
54 slords 1.9 Mozilla (.dtd, .properties, etc), Symbian,
55     Innosetup, tikiwiki, subtitles
56     * Tools: count, search, debug, segment and pretranslate localization
57     files. Extract terminology. Pseudo-localize
58     * Checkers: validate translations with over 45 checks
59 slords 1.6
60     %package devel
61     Summary: Development API for %{name} applications
62     Group: Development/Tools
63     License: GPLv2+
64     Requires: %{name} = %{version}-%{release}
65    
66     %description devel
67 slords 1.9 The %{name}-devel package contains Translate Toolkit API
68     documentation for developers wishing to build new tools for the
69     toolkit or to use the libraries in other localization tools.
70 slords 1.1
71    
72     %prep
73 slords 1.9 %setup -q
74 slords 1.6 %patch0 -p1
75 slords 1.11 %patch1 -p1
76 slords 1.12 %patch2 -p2
77 slords 1.6
78 slords 1.1
79     %build
80 slords 1.6 %{__python} setup.py build
81    
82 slords 1.1
83     %install
84 slords 1.6 rm -rf $RPM_BUILD_ROOT
85     %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
86    
87 slords 1.9 # create manpages
88 slords 1.6 mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
89 slords 1.9 for program in $RPM_BUILD_ROOT/%{_bindir}/*; do
90 slords 1.6 case $(basename $program) in
91 slords 1.9 pocompendium|poen|pomigrate2|popuretext|poreencode|posplit|pocount|poglossary|lookupclient.py|tmserver|build_tmdb)
92     ;;
93     *)
94 slords 1.6 LC_ALL=C PYTHONPATH=. $program --manpage \
95 slords 1.9 > $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \
96     || rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1
97     ;;
98 slords 1.6 esac
99     done
100    
101     # remove documentation files from site-packages
102     rm -r $RPM_BUILD_ROOT/%{python_sitelib}/translate/doc
103     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{COPYING,ChangeLog,LICENSE,README}
104     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{convert,filters,tools}/TODO
105     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/misc/README
106    
107     # Move data files to /usr/share
108     mkdir $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
109     mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/stoplist* $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
110 slords 1.12 mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/langmodels $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
111     rmdir $RPM_BUILD_ROOT/%{python_sitelib}/translate/share
112 slords 1.6
113 slords 1.1
114     %clean
115     rm -rf $RPM_BUILD_ROOT
116    
117 slords 1.6
118     %files
119     %defattr(-,root,root,-)
120 slords 1.9 %doc translate/ChangeLog translate/COPYING translate/README
121 slords 1.6 %doc translate/doc/user/toolkit-[a-z]*
122     %{_bindir}/*
123     %{_mandir}/man1/*
124     %{_datadir}/translate-toolkit
125     %{python_sitelib}/translate*
126    
127     %files devel
128 slords 1.9 %defattr(-,root,root,-)
129 slords 1.6 %doc translate/doc/api/*
130    
131    
132     %changelog
133 slords 1.12 * Mon Feb 22 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.3-2
134     - Bug #1372: Decode fulesystem paths correctly
135    
136     * Thu Feb 4 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.3-1
137     - Update to 1.5.3
138     - Plural information for more languages
139     - Cleaner language names (for the benefit of Pootle and Virtaal)
140     - Skype support for prop2po and po2prop [by Filip Miletić]
141     - Small improvement to Qt .ts support
142     - Other small bugfixes
143     - Redo stoplist patch
144     - Drop gaupol and iniparse from BuildRequires
145    
146     * Mon Jan 11 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.2-1
147     - Update to 1.5.2
148     - Initial support for '#' type comments in the PHP converters (#1298)
149     - Reliability improvements for Pootle concerning Xapian and Python 2.4
150     - A small fix affecting searching in Virtaal
151     - Classify XML tags as editable placeables for Virtaal (#1287)
152     - Correctly handle language codes with '@' in them (like ca@valencia)
153     - Don't unnecessarily add empty 'note' nodes in XLIFF (#1319)
154     - Allow for the translation of 'title' attributes in XML (#1294)
155    
156     * Thu Nov 26 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.5.1-1
157     - Update to 1.5.1
158     - Support for OmegaT glossary files
159     - Fixes for the fast (but still experimental) C PO parser
160     - Fixes for the LRU cache
161     - Fixes for correct and faster language identification
162     - Remove backports introduced in 1.5.0-1
163    
164     * Tue Nov 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.5.0-1
165     - Update to 1.5.0
166     - The tmserver will now be multithreaded if cherrypy is installed
167     - New faster PO parser for testing
168     - Optionally preserve HTML comments in html2po. Bug #1183
169     - Many reliability and API improvements for the upcoming versions of Pootle and Virtaal
170     - Move langmodels into /usr/share/translate-toolkit
171     - Remove backports introduced in 1.4.1-2
172     - Backports:
173     - r13226, r13234 - fix and optimise language identification
174     - r13225 - check for units based on source and target text
175    
176     * Fri Nov 6 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-3
177     - Backport various fixes needed for Pootle 1.3
178     - r12685 index speedup
179     - r12686 id index
180     - r12724 hassuggestion speedup
181     - r12727 msgidcomment
182    
183     * Thu Oct 15 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-2
184     - Retag
185    
186     * Thu Oct 15 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-1
187     - Update to 1.4.1
188     - Better support for printf (including numbered) variables (bug 1118)
189     - Fixes for the upcoming Pootle, including combined searches (bug 1036)
190     - subtle bug in tmserver handling of the percent sign (%) (bug 1101)
191     - obsolete messages seen as translatable (bug 1114)
192     - Drop patch bug#1114 - obsolete messages should not be translatable
193 slords 1.9
194     * Mon Aug 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-2
195     - Upstream bug #1114 - obsolete messages should not be translatable
196    
197     * Wed Aug 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-1
198     - Update to 1.4.0 final
199 slords 1.6
200 slords 1.12 * Fri Jul 31 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.5.rc2
201     - Fix tarball reference
202    
203 slords 1.9 * Fri Jul 31 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.4.rc2
204 slords 1.12 - Update to 1.4.0 rc2
205 slords 1.9 - Some small fixes for XLIFF support
206     - API documentation has been augmented with diagrams
207 slords 1.6
208 slords 1.12 * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-0.3.rc1
209     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
210 slords 1.6
211 slords 1.12 * Fri Jul 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.2.rc1
212     - Update to 1.4.0 rc1
213 slords 1.6
214 slords 1.9 * Sat Jun 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.1.beta1
215     - Update to 1.4.0 beta1
216 slords 1.6
217 slords 1.9 * Fri Jun 12 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-3
218     - Remove old excludes for /usr/bin/*.py{o,c}
219 slords 1.6
220 slords 1.9 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
221     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
222    
223     * Wed Feb 18 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-1
224     - Update to 1.3.0 final release
225    
226     * Tue Feb 3 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2.rc1
227     - Update to 1.3.0 rc1
228    
229     * Thu Jan 22 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1.beta1
230     - Update to 1.3.0 beta1
231    
232     * Sat Dec 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.1-1
233     - Update to 1.2.1
234     - Refresh poterminology patch
235    
236     * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-4
237     - Rebuild for Python 2.6
238    
239     * Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-3
240     - Rebuild using %%{ix86} instead of i386
241    
242     * Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-2
243     - python-psyco is only available on i386
244    
245     * Wed Nov 12 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1
246     - Update to 1.2.0
247     - Patch poterminology to read stoplist-en from /usr/share/
248 slords 1.6 - Add devel package to include generated Translate Toolkit API documentation
249 slords 1.9 - Add dependencies: python-iniparse, python-Levenshtein, python-lxml,
250     python-psyco, python-vobject, gettext-libs
251 slords 1.6
252 slords 1.9 * Fri Jun 06 2008 Roozbeh Pournader <roozbeh@gmail.com> - 1.1.1-1
253     - update to 1.1.1
254 slords 1.6
255 slords 1.9 * Mon Jan 21 2008 Jens Petersen <petersen@redhat.com> - 1.0.1-1
256     - update license field to GPLv2+
257     - update to 1.0.1 with changes from Dwayne Bailey (#315021):
258 slords 1.6
259 slords 1.9 * Thu Dec 20 2007 Dwayne Bailey <dwayne@translate.org.za>
260     - Update spec to upstream 1.0.1
261 slords 1.6 - Update patch for Python 2.5 ElementTree
262     - Cleanup the doc installation
263 slords 1.9 - Create man pages
264     - Update description
265 slords 1.6
266     * Sat May 05 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.11-1
267     - Update to upstream 0.11, adding HTML documentation
268    
269     * Tue Jan 09 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-4
270     - Patch to use Python 2.5's built-in ElementTree
271    
272     * Sat Dec 30 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-3
273     - Rebuild to fix dependency problem
274    
275     * Sat Dec 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-2
276     - Rebuild for Python 2.5
277    
278     * Thu Nov 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-1
279     - Update to upstream 0.10.1
280     - Cleanup based on latest Python packaging guidelines
281    
282     * Wed Nov 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-2
283     - Rebuild to get into Rawhide
284    
285     * Mon Feb 20 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-1
286     - Update to final 0.8
287    
288     * Sun Feb 19 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.10.rc6
289     - Fix a typo in po2dtd that made po2moz fail
290    
291     * Tue Feb 14 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.9.rc6
292     - Rebuild for Fedora Extras 5
293    
294     * Tue Feb 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.8.rc6
295     - Require python-enchant for spellchecking support in pofilter
296    
297     * Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.7.rc6
298     - Rebuild
299    
300     * Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.6.rc6
301     - Update to 0.8rc6
302    
303     * Sat Jan 21 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.5.rc5
304     - Use sed instead of dos2unix
305    
306     * Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.4.rc5
307     - Own forgotten subdirectories
308    
309     * Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.3.rc5
310     - Fix the jToolkit requirement
311    
312     * Sun Jan 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.2.rc5
313     - Add %%{?dist} tag
314    
315     * Sat Jan 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.1.rc5
316     - Initial packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed