/[smecontribs]/rpms/translate-toolkit/contribs8/translate-toolkit.spec
ViewVC logotype

Annotation of /rpms/translate-toolkit/contribs8/translate-toolkit.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.15 - (hide annotations) (download)
Mon Mar 1 15:05:01 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: translate-toolkit-1_5_3-2_1_el5_sme, HEAD
Changes since 1.14: +7 -2 lines
* Wed Feb 24 2010 Shad L. Lords <slords@mail.com> 1.5.3-2.1
- Test correctly for the case of an empty string (es)

1 slords 1.15 # $Id: translate-toolkit.spec,v 1.14 2010/02/24 19:48:09 slords Exp $
2 slords 1.13 # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.6 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6 slords 1.1
7 slords 1.6 Name: translate-toolkit
8 slords 1.12 Version: 1.5.3
9 slords 1.15 Release: 2.1%{?dist}
10 slords 1.9 Summary: Tools to assist with translation and software localization
11 slords 1.6
12     Group: Development/Tools
13     License: GPLv2+
14     URL: http://translate.sourceforge.net/wiki/toolkit/index
15 slords 1.12 Source0: http://downloads.sourceforge.net/project/translate/Translate%20Toolkit/%{version}/%{name}-%{version}.tar.bz2
16 slords 1.6 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17    
18 slords 1.12 Patch0: translate-toolkit-1.5.3-stoplist.patch
19     Patch1: translate-toolkit-1.5.0-langmodel_dir.patch
20     Patch2: translate-toolkit-1.5.3-bug1372_filesystem_encoding.patch
21 slords 1.15 Patch3: translate-toolkit-1.5.3-es_empty_string.patch
22 slords 1.6
23     BuildArch: noarch
24     BuildRequires: python-devel
25 slords 1.9 # The following are needed for man page generation
26     BuildRequires: python-lxml
27     BuildRequires: python-simplejson
28     BuildRequires: python-vobject
29 slords 1.14 Requires: gettext
30 slords 1.6 Requires: python-enchant
31 slords 1.9 Requires: python-iniparse
32 slords 1.6 Requires: python-Levenshtein
33     Requires: python-lxml
34 slords 1.9 %ifarch %{ix86}
35     Requires: python-psyco
36     %endif
37     Requires: python-simplejson
38 slords 1.6 Requires: python-vobject
39 slords 1.1
40    
41 slords 1.6 %description
42 slords 1.9 A set of tools for managing translation and software localization via
43     Gettext PO or XLIFF format files.
44    
45 slords 1.6 Including:
46     * Convertors: convert from various formats to PO or XLIFF
47     * Formats:
48     * Core localization formats - XLIFF and Gettext PO
49     * Other localization formats - TMX, TBX, Qt Linguist (.ts),
50 slords 1.12 Java .properties, Wordfast TM, OmegaT glossary
51 slords 1.6 * Compiled formats: Gettext MO, Qt .qm
52 slords 1.9 * Other formats - OpenDocument Format (ODF), text, HTML, CSV, INI,
53     wiki (MediaWiki, DokuWiki), iCal
54 slords 1.6 * Specialised - OpenOffice.org GSI/SDF, PHP,
55 slords 1.9 Mozilla (.dtd, .properties, etc), Symbian,
56     Innosetup, tikiwiki, subtitles
57     * Tools: count, search, debug, segment and pretranslate localization
58     files. Extract terminology. Pseudo-localize
59     * Checkers: validate translations with over 45 checks
60 slords 1.6
61     %package devel
62     Summary: Development API for %{name} applications
63     Group: Development/Tools
64     License: GPLv2+
65     Requires: %{name} = %{version}-%{release}
66    
67     %description devel
68 slords 1.9 The %{name}-devel package contains Translate Toolkit API
69     documentation for developers wishing to build new tools for the
70     toolkit or to use the libraries in other localization tools.
71 slords 1.1
72    
73     %prep
74 slords 1.9 %setup -q
75 slords 1.6 %patch0 -p1
76 slords 1.11 %patch1 -p1
77 slords 1.12 %patch2 -p2
78 slords 1.15 %patch3 -p2
79 slords 1.6
80 slords 1.1
81     %build
82 slords 1.6 %{__python} setup.py build
83    
84 slords 1.1
85     %install
86 slords 1.6 rm -rf $RPM_BUILD_ROOT
87     %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
88    
89 slords 1.9 # create manpages
90 slords 1.6 mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
91 slords 1.9 for program in $RPM_BUILD_ROOT/%{_bindir}/*; do
92 slords 1.6 case $(basename $program) in
93 slords 1.9 pocompendium|poen|pomigrate2|popuretext|poreencode|posplit|pocount|poglossary|lookupclient.py|tmserver|build_tmdb)
94     ;;
95     *)
96 slords 1.6 LC_ALL=C PYTHONPATH=. $program --manpage \
97 slords 1.9 > $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \
98     || rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1
99     ;;
100 slords 1.6 esac
101     done
102    
103     # remove documentation files from site-packages
104     rm -r $RPM_BUILD_ROOT/%{python_sitelib}/translate/doc
105     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{COPYING,ChangeLog,LICENSE,README}
106     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{convert,filters,tools}/TODO
107     rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/misc/README
108    
109     # Move data files to /usr/share
110     mkdir $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
111     mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/stoplist* $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
112 slords 1.12 mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/langmodels $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit
113     rmdir $RPM_BUILD_ROOT/%{python_sitelib}/translate/share
114 slords 1.6
115 slords 1.1
116     %clean
117     rm -rf $RPM_BUILD_ROOT
118    
119 slords 1.6
120     %files
121     %defattr(-,root,root,-)
122 slords 1.9 %doc translate/ChangeLog translate/COPYING translate/README
123 slords 1.6 %doc translate/doc/user/toolkit-[a-z]*
124     %{_bindir}/*
125     %{_mandir}/man1/*
126     %{_datadir}/translate-toolkit
127     %{python_sitelib}/translate*
128    
129     %files devel
130 slords 1.9 %defattr(-,root,root,-)
131 slords 1.6 %doc translate/doc/api/*
132    
133    
134     %changelog
135 slords 1.15 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> 1.5.3-2.1
136     - Test correctly for the case of an empty string (es)
137    
138 slords 1.14 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> 1.5.3-2.0
139     - Update Requires to match el5 requirements
140    
141 slords 1.12 * Mon Feb 22 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.3-2
142     - Bug #1372: Decode fulesystem paths correctly
143    
144     * Thu Feb 4 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.3-1
145     - Update to 1.5.3
146     - Plural information for more languages
147     - Cleaner language names (for the benefit of Pootle and Virtaal)
148     - Skype support for prop2po and po2prop [by Filip Miletić]
149     - Small improvement to Qt .ts support
150     - Other small bugfixes
151     - Redo stoplist patch
152     - Drop gaupol and iniparse from BuildRequires
153    
154     * Mon Jan 11 2010 Dwayne Bailey <dwayne@translate.org.za> - 1.5.2-1
155     - Update to 1.5.2
156     - Initial support for '#' type comments in the PHP converters (#1298)
157     - Reliability improvements for Pootle concerning Xapian and Python 2.4
158     - A small fix affecting searching in Virtaal
159     - Classify XML tags as editable placeables for Virtaal (#1287)
160     - Correctly handle language codes with '@' in them (like ca@valencia)
161     - Don't unnecessarily add empty 'note' nodes in XLIFF (#1319)
162     - Allow for the translation of 'title' attributes in XML (#1294)
163    
164     * Thu Nov 26 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.5.1-1
165     - Update to 1.5.1
166     - Support for OmegaT glossary files
167     - Fixes for the fast (but still experimental) C PO parser
168     - Fixes for the LRU cache
169     - Fixes for correct and faster language identification
170     - Remove backports introduced in 1.5.0-1
171    
172     * Tue Nov 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.5.0-1
173     - Update to 1.5.0
174     - The tmserver will now be multithreaded if cherrypy is installed
175     - New faster PO parser for testing
176     - Optionally preserve HTML comments in html2po. Bug #1183
177     - Many reliability and API improvements for the upcoming versions of Pootle and Virtaal
178     - Move langmodels into /usr/share/translate-toolkit
179     - Remove backports introduced in 1.4.1-2
180     - Backports:
181     - r13226, r13234 - fix and optimise language identification
182     - r13225 - check for units based on source and target text
183    
184     * Fri Nov 6 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-3
185     - Backport various fixes needed for Pootle 1.3
186     - r12685 index speedup
187     - r12686 id index
188     - r12724 hassuggestion speedup
189     - r12727 msgidcomment
190    
191     * Thu Oct 15 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-2
192     - Retag
193    
194     * Thu Oct 15 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.1-1
195     - Update to 1.4.1
196     - Better support for printf (including numbered) variables (bug 1118)
197     - Fixes for the upcoming Pootle, including combined searches (bug 1036)
198     - subtle bug in tmserver handling of the percent sign (%) (bug 1101)
199     - obsolete messages seen as translatable (bug 1114)
200     - Drop patch bug#1114 - obsolete messages should not be translatable
201 slords 1.9
202     * Mon Aug 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-2
203     - Upstream bug #1114 - obsolete messages should not be translatable
204    
205     * Wed Aug 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-1
206     - Update to 1.4.0 final
207 slords 1.6
208 slords 1.12 * Fri Jul 31 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.5.rc2
209     - Fix tarball reference
210    
211 slords 1.9 * Fri Jul 31 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.4.rc2
212 slords 1.12 - Update to 1.4.0 rc2
213 slords 1.9 - Some small fixes for XLIFF support
214     - API documentation has been augmented with diagrams
215 slords 1.6
216 slords 1.12 * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-0.3.rc1
217     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
218 slords 1.6
219 slords 1.12 * Fri Jul 24 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.2.rc1
220     - Update to 1.4.0 rc1
221 slords 1.6
222 slords 1.9 * Sat Jun 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.4.0-0.1.beta1
223     - Update to 1.4.0 beta1
224 slords 1.6
225 slords 1.9 * Fri Jun 12 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-3
226     - Remove old excludes for /usr/bin/*.py{o,c}
227 slords 1.6
228 slords 1.9 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
229     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
230    
231     * Wed Feb 18 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-1
232     - Update to 1.3.0 final release
233    
234     * Tue Feb 3 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2.rc1
235     - Update to 1.3.0 rc1
236    
237     * Thu Jan 22 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1.beta1
238     - Update to 1.3.0 beta1
239    
240     * Sat Dec 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.1-1
241     - Update to 1.2.1
242     - Refresh poterminology patch
243    
244     * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-4
245     - Rebuild for Python 2.6
246    
247     * Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-3
248     - Rebuild using %%{ix86} instead of i386
249    
250     * Mon Nov 17 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-2
251     - python-psyco is only available on i386
252    
253     * Wed Nov 12 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1
254     - Update to 1.2.0
255     - Patch poterminology to read stoplist-en from /usr/share/
256 slords 1.6 - Add devel package to include generated Translate Toolkit API documentation
257 slords 1.9 - Add dependencies: python-iniparse, python-Levenshtein, python-lxml,
258     python-psyco, python-vobject, gettext-libs
259 slords 1.6
260 slords 1.9 * Fri Jun 06 2008 Roozbeh Pournader <roozbeh@gmail.com> - 1.1.1-1
261     - update to 1.1.1
262 slords 1.6
263 slords 1.9 * Mon Jan 21 2008 Jens Petersen <petersen@redhat.com> - 1.0.1-1
264     - update license field to GPLv2+
265     - update to 1.0.1 with changes from Dwayne Bailey (#315021):
266 slords 1.6
267 slords 1.9 * Thu Dec 20 2007 Dwayne Bailey <dwayne@translate.org.za>
268     - Update spec to upstream 1.0.1
269 slords 1.6 - Update patch for Python 2.5 ElementTree
270     - Cleanup the doc installation
271 slords 1.9 - Create man pages
272     - Update description
273 slords 1.6
274     * Sat May 05 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.11-1
275     - Update to upstream 0.11, adding HTML documentation
276    
277     * Tue Jan 09 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-4
278     - Patch to use Python 2.5's built-in ElementTree
279    
280     * Sat Dec 30 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-3
281     - Rebuild to fix dependency problem
282    
283     * Sat Dec 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-2
284     - Rebuild for Python 2.5
285    
286     * Thu Nov 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-1
287     - Update to upstream 0.10.1
288     - Cleanup based on latest Python packaging guidelines
289    
290     * Wed Nov 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-2
291     - Rebuild to get into Rawhide
292    
293     * Mon Feb 20 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-1
294     - Update to final 0.8
295    
296     * Sun Feb 19 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.10.rc6
297     - Fix a typo in po2dtd that made po2moz fail
298    
299     * Tue Feb 14 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.9.rc6
300     - Rebuild for Fedora Extras 5
301    
302     * Tue Feb 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.8.rc6
303     - Require python-enchant for spellchecking support in pofilter
304    
305     * Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.7.rc6
306     - Rebuild
307    
308     * Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.6.rc6
309     - Update to 0.8rc6
310    
311     * Sat Jan 21 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.5.rc5
312     - Use sed instead of dos2unix
313    
314     * Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.4.rc5
315     - Own forgotten subdirectories
316    
317     * Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.3.rc5
318     - Fix the jToolkit requirement
319    
320     * Sun Jan 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.2.rc5
321     - Add %%{?dist} tag
322    
323     * Sat Jan 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.1.rc5
324     - Initial packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed