1 |
slords |
1.6 |
# $Id: translate-toolkit.spec,v 1.5 2008/04/02 15:22:04 slords Exp $ |
2 |
slords |
1.5 |
# Authority: slords |
3 |
slords |
1.4 |
# Name: Shad L. Lords |
4 |
|
|
|
5 |
slords |
1.6 |
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} |
6 |
slords |
1.1 |
|
7 |
slords |
1.6 |
%define prerelease "" |
8 |
slords |
1.1 |
|
9 |
slords |
1.6 |
Name: translate-toolkit |
10 |
|
|
Version: 1.2.0 |
11 |
|
|
Release: 1%{?dist} |
12 |
|
|
Summary: Tools to assist with localization |
13 |
|
|
|
14 |
|
|
Group: Development/Tools |
15 |
|
|
License: GPLv2+ |
16 |
|
|
URL: http://translate.sourceforge.net/wiki/toolkit/index |
17 |
|
|
Source0: http://downloads.sourceforge.net/translate/%{name}-%{version}.tar.bz2 |
18 |
|
|
#Source0: http://translate.sourceforge.net/snapshots/%{name}-%{version}%{prerelease}/%{name}-%{version}%{prerelease}.tar.bz2 |
19 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
20 |
|
|
|
21 |
|
|
Patch0: translate-poterminology-stoplist.diff |
22 |
|
|
|
23 |
|
|
BuildArch: noarch |
24 |
|
|
BuildRequires: python-devel |
25 |
|
|
Requires: python-enchant |
26 |
|
|
Requires: python-psyco |
27 |
|
|
Requires: python-Levenshtein |
28 |
|
|
Requires: python-lxml |
29 |
|
|
Requires: python-iniparse |
30 |
|
|
Requires: python-vobject |
31 |
|
|
Requires: gettext-devel |
32 |
slords |
1.1 |
|
33 |
|
|
|
34 |
slords |
1.6 |
%description |
35 |
|
|
A set of tools for managing localization via Gettext PO or XLIFF format files. |
36 |
|
|
|
37 |
|
|
Including: |
38 |
|
|
* Convertors: convert from various formats to PO or XLIFF |
39 |
|
|
* Formats: |
40 |
|
|
* Core localization formats - XLIFF and Gettext PO |
41 |
|
|
* Other localization formats - TMX, TBX, Qt Linguist (.ts), |
42 |
|
|
Java .properties, Wordfast TM |
43 |
|
|
* Compiled formats: Gettext MO, Qt .qm |
44 |
|
|
* Other formats - text, HTML, CSV, INI, wiki (MediaWiki, DokuWiki), iCal |
45 |
|
|
* Specialised - OpenOffice.org GSI/SDF, PHP, |
46 |
|
|
Mozilla (.dtd, .properties, etc) |
47 |
|
|
* Tools: count, search, debug, segment and extract terminology from |
48 |
|
|
localization files. |
49 |
|
|
* Checkers: validate translations with over 46 checks |
50 |
|
|
|
51 |
|
|
%package devel |
52 |
|
|
Summary: Development API for %{name} applications |
53 |
|
|
Group: Development/Tools |
54 |
|
|
License: GPLv2+ |
55 |
|
|
Requires: %{name} = %{version}-%{release} |
56 |
|
|
|
57 |
|
|
%description devel |
58 |
|
|
The %{name}-devel package contains Translate Toolkit API documentation for |
59 |
|
|
developers wishing to build new tools or reuse the libraries in other tools. |
60 |
slords |
1.1 |
|
61 |
|
|
|
62 |
|
|
%prep |
63 |
slords |
1.6 |
%setup -q -n %{name}-%{version}%{prerelease} |
64 |
|
|
%patch0 -p1 |
65 |
|
|
|
66 |
slords |
1.1 |
|
67 |
|
|
%build |
68 |
slords |
1.6 |
%{__python} setup.py build |
69 |
|
|
|
70 |
slords |
1.1 |
|
71 |
|
|
%install |
72 |
slords |
1.6 |
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT |
74 |
|
|
|
75 |
|
|
# Create the manpages |
76 |
|
|
mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1 |
77 |
|
|
for program in $RPM_BUILD_ROOT/%{_bindir}/*; |
78 |
|
|
do |
79 |
|
|
case $(basename $program) in |
80 |
|
|
pocompendium|poen|pomigrate2|popuretext|poreencode|posplit|pocount|poglossary|lookupclient.py) |
81 |
|
|
;; |
82 |
|
|
*) |
83 |
|
|
LC_ALL=C PYTHONPATH=. $program --manpage \ |
84 |
|
|
> $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \ |
85 |
|
|
|| rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 |
86 |
|
|
;; |
87 |
|
|
esac |
88 |
|
|
done |
89 |
|
|
|
90 |
|
|
# remove documentation files from site-packages |
91 |
|
|
rm -r $RPM_BUILD_ROOT/%{python_sitelib}/translate/doc |
92 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{COPYING,ChangeLog,LICENSE,README} |
93 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/{convert,filters,tools}/TODO |
94 |
|
|
rm $RPM_BUILD_ROOT/%{python_sitelib}/translate/misc/README |
95 |
|
|
|
96 |
|
|
# Move data files to /usr/share |
97 |
|
|
mkdir $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit |
98 |
|
|
mv $RPM_BUILD_ROOT/%{python_sitelib}/translate/share/stoplist* $RPM_BUILD_ROOT/%{_datadir}/translate-toolkit |
99 |
|
|
|
100 |
slords |
1.1 |
|
101 |
|
|
%clean |
102 |
|
|
rm -rf $RPM_BUILD_ROOT |
103 |
|
|
|
104 |
slords |
1.6 |
|
105 |
|
|
%files |
106 |
|
|
%defattr(-,root,root,-) |
107 |
|
|
%doc translate/doc/user/toolkit-[a-z]* |
108 |
|
|
%doc translate/ChangeLog translate/COPYING translate/README |
109 |
|
|
%{_bindir}/* |
110 |
|
|
%{_mandir}/man1/* |
111 |
|
|
%{_datadir}/translate-toolkit |
112 |
|
|
%{python_sitelib}/translate* |
113 |
|
|
|
114 |
|
|
%files devel |
115 |
|
|
%doc translate/doc/api/* |
116 |
|
|
|
117 |
|
|
|
118 |
|
|
%changelog |
119 |
|
|
* Mon Oct 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1.fc9 |
120 |
|
|
- Update to 1.2.0 final |
121 |
|
|
- Include stoplist-en and adjust poterminology to read it from the |
122 |
|
|
/usr/share/ location |
123 |
|
|
|
124 |
|
|
* Tue Sep 30 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.3.rc1.fc9 |
125 |
|
|
- Update to 1.2.0-rc1 |
126 |
|
|
- Include ical2po dependencies |
127 |
|
|
|
128 |
|
|
* Tue Aug 26 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2-0.2.beta2.fc9 |
129 |
|
|
- Update to 1.2-beta2 |
130 |
|
|
|
131 |
|
|
* Mon Aug 25 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2-0.1.beta1.fc9 |
132 |
|
|
- Update to 1.2-beta1 |
133 |
|
|
|
134 |
|
|
* Tue Jun 3 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-1.fc9 |
135 |
|
|
- Rebuild for fc9 |
136 |
|
|
|
137 |
|
|
* Thu Mar 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-1.fc8 |
138 |
|
|
- Update to official 1.1.1 release |
139 |
|
|
- Patches to fix internal project rename wordforge -> locamotion |
140 |
|
|
- Use included API documentation |
141 |
|
|
|
142 |
|
|
* Wed Mar 12 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-0.4.rc4.fc8 |
143 |
|
|
- Update to 1.1.1rc4 |
144 |
|
|
|
145 |
|
|
* Wed Mar 5 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-0.3.rc3.fc8 |
146 |
|
|
- Add devel package to include generated Translate Toolkit API documentation |
147 |
|
|
|
148 |
|
|
* Mon Feb 25 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-0.2.rc3.fc8 |
149 |
|
|
- Update to 1.1.1rc3 |
150 |
|
|
- Remove ini2po patch |
151 |
|
|
|
152 |
|
|
* Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.1-0.1.rc2.fc8 |
153 |
|
|
- Update to 1.1.1rc2 |
154 |
|
|
|
155 |
|
|
* Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.1.0-1.fc8 |
156 |
|
|
- Update to 1.1.0 |
157 |
|
|
- Remove old ElementTree patch |
158 |
|
|
- Add dependencies: python-Levenshtein, python-lxml, python-iniparse, |
159 |
|
|
gettext-devel |
160 |
|
|
- Package ini2po |
161 |
|
|
|
162 |
|
|
* Tue Jan 22 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.1-4.fc8 |
163 |
|
|
- Remove python-Levenshtein dependency: rhbz#429882 and rhbz#430887 |
164 |
|
|
|
165 |
|
|
* Tue Jan 22 2008 Caius Chance <cchance@redhat.com> - 1.0.1-3.fc8 |
166 |
|
|
- Resolves: rhbz#315021 |
167 |
|
|
- Update license field to GPLv2+. |
168 |
|
|
- Update to 1.0.1 with changes from Dwayne Bailey. |
169 |
|
|
|
170 |
|
|
* Thu Dec 20 2007 Dwayne Bailey <dwayne@translate.org.za> - 1.0.1-2 |
171 |
|
|
- Create man pages |
172 |
|
|
|
173 |
|
|
* Thu Dec 19 2007 Dwayne Bailey <dwayne@translate.org.za> - 1.0.1-1 |
174 |
|
|
- Update to upstream 1.0.1 |
175 |
|
|
- Update patch for Python 2.5 ElementTree |
176 |
|
|
- Cleanup the doc installation |
177 |
|
|
|
178 |
|
|
* Sat May 05 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.11-1 |
179 |
|
|
- Update to upstream 0.11, adding HTML documentation |
180 |
|
|
|
181 |
|
|
* Tue Jan 09 2007 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-4 |
182 |
|
|
- Patch to use Python 2.5's built-in ElementTree |
183 |
|
|
|
184 |
|
|
* Sat Dec 30 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-3 |
185 |
|
|
- Rebuild to fix dependency problem |
186 |
|
|
|
187 |
|
|
* Sat Dec 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-2 |
188 |
|
|
- Rebuild for Python 2.5 |
189 |
|
|
|
190 |
|
|
* Thu Nov 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.10.1-1 |
191 |
|
|
- Update to upstream 0.10.1 |
192 |
|
|
- Cleanup based on latest Python packaging guidelines |
193 |
|
|
|
194 |
|
|
* Wed Nov 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-2 |
195 |
|
|
- Rebuild to get into Rawhide |
196 |
|
|
|
197 |
|
|
* Mon Feb 20 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-1 |
198 |
|
|
- Update to final 0.8 |
199 |
|
|
|
200 |
|
|
* Sun Feb 19 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.10.rc6 |
201 |
|
|
- Fix a typo in po2dtd that made po2moz fail |
202 |
|
|
|
203 |
|
|
* Tue Feb 14 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.9.rc6 |
204 |
|
|
- Rebuild for Fedora Extras 5 |
205 |
|
|
|
206 |
|
|
* Tue Feb 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.8.rc6 |
207 |
|
|
- Require python-enchant for spellchecking support in pofilter |
208 |
|
|
|
209 |
|
|
* Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.7.rc6 |
210 |
|
|
- Rebuild |
211 |
|
|
|
212 |
|
|
* Sat Feb 04 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.6.rc6 |
213 |
|
|
- Update to 0.8rc6 |
214 |
|
|
|
215 |
|
|
* Sat Jan 21 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.5.rc5 |
216 |
|
|
- Use sed instead of dos2unix |
217 |
|
|
|
218 |
|
|
* Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.4.rc5 |
219 |
|
|
- Own forgotten subdirectories |
220 |
|
|
|
221 |
|
|
* Mon Jan 09 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.3.rc5 |
222 |
|
|
- Fix the jToolkit requirement |
223 |
|
|
|
224 |
|
|
* Sun Jan 08 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.2.rc5 |
225 |
|
|
- Add %%{?dist} tag |
226 |
|
|
|
227 |
|
|
* Sat Jan 07 2006 Roozbeh Pournader <roozbeh@farsiweb.info> - 0.8-0.1.rc5 |
228 |
|
|
- Initial packaging |