1 |
slords |
1.1 |
%define apachedir /etc/httpd |
2 |
|
|
%define apacheuser www |
3 |
|
|
%define apachegroup www |
4 |
|
|
%define contentdir /home/httpd |
5 |
|
|
|
6 |
|
|
Summary: A bookmark application for use under the horde framework. |
7 |
|
|
Name: trean |
8 |
|
|
Version: 0.1 |
9 |
|
|
Release: 0%{?dist} |
10 |
|
|
License: LGPL |
11 |
|
|
Group: Applications/Horde |
12 |
|
|
Source: ftp://ftp.horde.org/pub/trean/tarballs/trean-%{version}.tar.gz |
13 |
|
|
Vendor: The Horde Project |
14 |
|
|
URL: http://www.horde.org/ |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRoot: /tmp/horde-root |
17 |
|
|
AutoReq: no |
18 |
|
|
Requires: horde >= 3.0 |
19 |
|
|
Requires: php >= 4.3.0 |
20 |
|
|
Requires: httpd >= 2.0.46 |
21 |
|
|
Prereq: /usr/bin/perl |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
The Trean (Bookmarks) application allows you to store, organize and manage, |
25 |
|
|
and most importantly access your web browser bookmarks on-line and in one |
26 |
|
|
central place accessible from any web browser. |
27 |
|
|
|
28 |
|
|
The Horde Project writes web applications in PHP and releases them under |
29 |
|
|
Open Source licenses. For more information (including help with Horde |
30 |
|
|
and its modules) please visit http://www.horde.org/. |
31 |
|
|
|
32 |
|
|
This package contains customizations for SME Server |
33 |
|
|
and will probably not work properly on other Linux systems. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
|
37 |
|
|
%setup -q -n %{name}-%{version} |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
|
41 |
|
|
%install |
42 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
43 |
|
|
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
44 |
|
|
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/trean |
45 |
|
|
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/trean |
46 |
|
|
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/trean/config |
47 |
|
|
|
48 |
|
|
|
49 |
|
|
for d in *.dist; do |
50 |
|
|
d0=`basename $d .dist` |
51 |
|
|
if [ ! -f "$d0" ]; then |
52 |
|
|
cp -p $d $d0 |
53 |
|
|
fi |
54 |
|
|
done |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
|
61 |
|
|
%postun |
62 |
|
|
|
63 |
|
|
%files |
64 |
|
|
%defattr(-,root,root) |
65 |
|
|
# Include top level with %dir so not all files are sucked in |
66 |
|
|
%dir %{contentdir}/html/horde/trean |
67 |
|
|
# Include top-level files by hand |
68 |
|
|
%{contentdir}/html/horde/trean/*.php |
69 |
|
|
# Include these dirs so that all files _will_ get sucked in |
70 |
|
|
%{contentdir}/html/horde/trean/lib |
71 |
|
|
%{contentdir}/html/horde/trean/locale |
72 |
|
|
%{contentdir}/html/horde/trean/po |
73 |
|
|
%{contentdir}/html/horde/trean/templates |
74 |
|
|
%{contentdir}/html/horde/trean/themes |
75 |
|
|
%{contentdir}/html/horde/trean/scripts |
76 |
|
|
# Mark documentation files with %doc and %docdir |
77 |
|
|
#%doc %{contentdir}/html/horde/trean/COPYING |
78 |
|
|
%doc %{contentdir}/html/horde/trean/LICENSE |
79 |
|
|
%doc %{contentdir}/html/horde/trean/README |
80 |
|
|
%docdir %{contentdir}/html/horde/trean/docs |
81 |
|
|
%{contentdir}/html/horde/trean/docs |
82 |
|
|
# Mark configuration files with %config and use secure permissions |
83 |
|
|
# (note that .dist files are considered software; don't mark %config) |
84 |
|
|
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/trean/config |
85 |
|
|
%defattr(640,root,%{apachegroup}) |
86 |
|
|
%{contentdir}/html/horde/trean/config/.htaccess |
87 |
|
|
%{contentdir}/html/horde/trean/config/*.dist |
88 |
|
|
%config %{contentdir}/html/horde/trean/config/*.php |
89 |
|
|
%config %{contentdir}/html/horde/trean/config/*.xml |
90 |
|
|
#%config %{contentdir}/html/horde/trean/config/*.txt |
91 |
|
|
|
92 |
|
|
%changelog |
93 |
|
|
* Sun Jun 04 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
94 |
|
|
- [0.0.1-1sme01] |
95 |
|
|
- Initial Release from CVS 2006-06-04 |
96 |
|
|
|