/[smecontribs]/rpms/trean/contribs7/trean.spec
ViewVC logotype

Annotation of /rpms/trean/contribs7/trean.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Apr 23 19:18:55 2008 UTC (16 years, 1 month ago) by slords
Branch: MAIN
Changes since 1.2: +1 -2 lines
Spec cleanup

1 slords 1.3 # $Id: trean.spec,v 1.2 2008/04/02 15:04:00 slords Exp $
2 slords 1.2 # Authority: mrjhb3
3     # Name: John H. Bennett III
4    
5 slords 1.1 %define apachedir /etc/httpd
6     %define apacheuser www
7     %define apachegroup www
8     %define contentdir /home/httpd
9    
10     Summary: A bookmark application for use under the horde framework.
11     Name: trean
12     Version: 0.1
13     Release: 0%{?dist}
14     License: LGPL
15     Group: Applications/Horde
16     Source: ftp://ftp.horde.org/pub/trean/tarballs/trean-%{version}.tar.gz
17     URL: http://www.horde.org/
18     BuildArchitectures: noarch
19     BuildRoot: /tmp/horde-root
20     AutoReq: no
21     Requires: horde >= 3.0
22     Requires: php >= 4.3.0
23     Requires: httpd >= 2.0.46
24     Prereq: /usr/bin/perl
25    
26     %description
27     The Trean (Bookmarks) application allows you to store, organize and manage,
28     and most importantly access your web browser bookmarks on-line and in one
29     central place accessible from any web browser.
30    
31     The Horde Project writes web applications in PHP and releases them under
32     Open Source licenses. For more information (including help with Horde
33     and its modules) please visit http://www.horde.org/.
34    
35     This package contains customizations for SME Server
36     and will probably not work properly on other Linux systems.
37    
38     %prep
39    
40     %setup -q -n %{name}-%{version}
41    
42     %build
43    
44     %install
45     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
46     mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf
47     mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/trean
48     cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/trean
49     cd $RPM_BUILD_ROOT%{contentdir}/html/horde/trean/config
50    
51    
52     for d in *.dist; do
53     d0=`basename $d .dist`
54     if [ ! -f "$d0" ]; then
55     cp -p $d $d0
56     fi
57     done
58    
59     %clean
60     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
61    
62     %post
63    
64     %postun
65    
66     %files
67     %defattr(-,root,root)
68     # Include top level with %dir so not all files are sucked in
69     %dir %{contentdir}/html/horde/trean
70     # Include top-level files by hand
71     %{contentdir}/html/horde/trean/*.php
72     # Include these dirs so that all files _will_ get sucked in
73     %{contentdir}/html/horde/trean/lib
74     %{contentdir}/html/horde/trean/locale
75     %{contentdir}/html/horde/trean/po
76     %{contentdir}/html/horde/trean/templates
77     %{contentdir}/html/horde/trean/themes
78     %{contentdir}/html/horde/trean/scripts
79     # Mark documentation files with %doc and %docdir
80     #%doc %{contentdir}/html/horde/trean/COPYING
81     %doc %{contentdir}/html/horde/trean/LICENSE
82     %doc %{contentdir}/html/horde/trean/README
83     %docdir %{contentdir}/html/horde/trean/docs
84     %{contentdir}/html/horde/trean/docs
85     # Mark configuration files with %config and use secure permissions
86     # (note that .dist files are considered software; don't mark %config)
87     %attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/trean/config
88     %defattr(640,root,%{apachegroup})
89     %{contentdir}/html/horde/trean/config/.htaccess
90     %{contentdir}/html/horde/trean/config/*.dist
91     %config %{contentdir}/html/horde/trean/config/*.php
92     %config %{contentdir}/html/horde/trean/config/*.xml
93     #%config %{contentdir}/html/horde/trean/config/*.txt
94    
95     %changelog
96     * Sun Jun 04 2006 John H. Bennett III <bennettj@johnbennettservices.com>
97     - [0.0.1-1sme01]
98     - Initial Release from CVS 2006-06-04
99    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed