/[smecontribs]/rpms/tt-rss/contribs10/tt-rss.spec
ViewVC logotype

Annotation of /rpms/tt-rss/contribs10/tt-rss.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Mon Nov 1 13:05:13 2021 UTC (2 years, 7 months ago) by michel
Branch: MAIN
CVS Tags: tt-rss-20211029_git9714c4fbcf-1_el7_sme, HEAD
Initial import tt-rss

1 michel 1.1 %define name tt-rss
2     %define version 20211029.git9714c4fbcf
3     %define release 1
4     %define httpuser apache
5    
6     Summary: Web based RSS reader
7     Name: %{name}
8     Version: %{version}
9     Release: %{release}%{?dist}
10     License: GPLv3
11     URL: https://tt-rss.org/
12     Group: Applications/Internet
13     Source: %{name}-%{version}.tar.xz
14     Source1: httpd.conf
15     Source2: cron
16     Source3: logrotate.conf
17    
18     BuildArch: noarch
19     BuildRoot: %{_tmppath}/%{name}-%{version}
20    
21     Requires: php-gd
22     Requires: httpd
23     Requires: logrotate
24    
25     %description
26     Tiny Tiny RSS is an open source web-based news feed (RSS/Atom)
27     aggregator, designed to allow you to read news from any location,
28     while feeling as close to a real desktop application as possible.
29    
30     %prep
31     %setup -q -n tt-rss
32    
33     %build
34     # empty build
35    
36     %install
37     %{__rm} -rf $RPM_BUILD_ROOT
38     %{__mkdir} -p %{buildroot}/%{_datadir}/%{name}
39     for a in $(find ./ -mindepth 1 -maxdepth 1 -type d -print); do
40     cp -r $a %{buildroot}/%{_datadir}/%{name}/
41     done
42     #cp {*.php,*.xsl} %{buildroot}/%{_datadir}/%{name}/
43     cp *.php %{buildroot}/%{_datadir}/%{name}/
44     %{__rm} -rf .buildpath .gitignore .project
45    
46     # rename icons to rssicons so it won't clash with the global icons directory
47     %{__mv} %{buildroot}/%{_datadir}/%{name}/feed-icons %{buildroot}/%{_datadir}/%{name}/rssicons
48    
49     # remove cache and lock directories
50     %{__rm} -Rf %{buildroot}/%{_datadir}/%{name}/{cache,lock}
51    
52     # And create them at the correct place
53     %{__mkdir} -p %{buildroot}/%{_localstatedir}/cache/%{name}/{simplepie,images,export,js,upload,starred-images}
54     %{__mkdir} -p %{buildroot}/%{_localstatedir}/lock/%{name}
55     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/tmpfiles.d
56     /bin/echo "d %{_localstatedir}/lock/%{name} 0775 root www 0" > %{buildroot}/%{_sysconfdir}/tmpfiles.d/%{name}.conf
57    
58     sed -e "s|\"pgsql\"|\"mysql\"|g" \
59     -e "s|cache|%{_localstatedir}/cache/%{name}/|g" \
60     -e "s|\"feed-icons\"|\"rssicons\"|g" \
61     -e "s|'lock'|'%{_localstatedir}/lock/%{name}'|g" \
62     config.php-dist \
63     > %{buildroot}/%{_datadir}/%{name}/config.php
64    
65     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/httpd/conf.d/
66     %{__install} -m 0644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/httpd/conf.d/%{name}.conf
67     sed -i -e "s|__ROOT_DIR__|%{_datadir}/%{name}|g" \
68     -e "s|__CACHE_DIR__|%{_localstatedir}/cache/%{name}|g" \
69     -e "s|__LOCK_DIR__|%{_localstatedir}/lock/%{name}|g" \
70     %{buildroot}/%{_sysconfdir}/httpd/conf.d/%{name}.conf
71    
72     %{__mkdir} -p %{buildroot}/%{_localstatedir}/log/
73     touch %{buildroot}/%{_localstatedir}/log/%{name}.log
74    
75     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/cron.d
76     %{__install} -m 0644 %{SOURCE2} %{buildroot}/%{_sysconfdir}/cron.d/%{name}
77     sed -i -e "s|__APACHE__|%{httpuser}|g" \
78     -e "s|__ROOT_DIR__|%{_datadir}/%{name}|g" \
79     -e "s|__LOG_FILE__|%{_localstatedir}/log/%{name}.log|g" \
80     %{buildroot}/%{_sysconfdir}/cron.d/%{name}
81    
82     %{__mkdir} -p %{buildroot}/%{_sysconfdir}/logrotate.d/
83     %{__install} -m 644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
84     sed -i -e "s|__LOG_DIR__|%{_localstatedir}/log/%{name}.log|g" \
85     -e "s|__APACHE__|%{httpuser}|g" \
86     %{SOURCE3} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
87    
88     %clean
89     rm -rf %{buildroot}
90    
91     %post
92    
93     %postun
94    
95     %files
96     %defattr(-,root,root)
97     %doc README.md
98     %{_datadir}/%{name}
99     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/simplepie
100     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/images
101     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/export
102     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/js
103     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/upload
104     %dir %attr(770,root,%{httpuser}) %{_localstatedir}/cache/%{name}/starred-images
105     %dir %attr(775,root,%{httpuser}) %{_localstatedir}/lock/%{name}/
106     %dir %attr(775,root,%{httpuser}) %{_datadir}/%{name}/rssicons
107     %attr(660,root,%{httpuser}) %{_localstatedir}/log/%{name}.log
108     %config(noreplace) %attr(660,root,%{httpuser}) %{_datadir}/%{name}/config.php
109     %config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
110     %config(noreplace) %{_sysconfdir}/cron.d/%{name}
111     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
112     %config(noreplace) %{_sysconfdir}/tmpfiles.d/%{name}.conf
113    
114    
115     %changelog
116     * Mon Nov 1 2021 Michel Begue <mab974@misouk.com> 20211029.git9714c4fbcf-1
117     - first import to Sme 10
118     - Declare /var/lock/tt-rss directory in tmpfiles.d to be created at boot
119    
120     * Thu Jul 13 2017 Daniel Berteaud <daniel@firewall-services.com> 20170713.gite6d77d2b-1
121     - Update to GIT e6d77d2b
122     - Remove SELinux tests in spec file
123    
124     * Tue Feb 16 2016 Daniel Berteaud <daniel@firewall-services.com> 20151028.gitd38cd412-2
125     - fix item_id not being properly escaped in pref_feeds::process_category_order()
126     (possible sql injection), backport a5556c2471973e292dce615fe0c77fdbbc54405b
127    
128     * Wed Oct 28 2015 Daniel Berteaud <daniel@firewall-services.com> 20151028.gitd38cd412-1
129     - Update to GIT d38cd412
130    
131     * Wed Sep 2 2015 Daniel Berteaud <daniel@firewall-services.com> 20150902.git2606a4e3-1
132     - Update to GIT 2606a4e3
133    
134     * Mon Jun 29 2015 Daniel Berteaud <daniel@firewall-services.com> 20150629.git87c67f-1
135     - Switch to the new rolling release model
136     - Update to 2015-06-29
137    
138     * Sat Dec 13 2014 Daniel Berteaud <daniel@firewall-services.com> 1.15.3-1
139     - Update to 1.15.3
140    
141     * Mon Dec 8 2014 Daniel Berteaud <daniel@firewall-services.com> 1.15-1
142     - Update to 1.15
143    
144     * Tue Oct 21 2014 Daniel Berteaud <daniel@firewall-services.com> 1.14-1
145     - update to 1.14
146    
147     * Mon Jul 21 2014 Daniel Berteaud <daniel@firewall-services.com> 1.13-1
148     - update to 1.13
149    
150     * Fri Mar 21 2014 Daniel Berteaud <daniel@firewall-services.com> 1.12-1
151     - update to 1.12
152    
153     * Wed Dec 18 2013 Daniel Berteaud <daniel@firewall-services.com> 1.11-1
154     - Update to 1.11
155    
156     * Fri Nov 15 2013 Daniel Berteaud <daniel@firewall-services.com> 1.10-3
157     - Spec file cleanup
158    
159     * Tue Sep 24 2013 Daniel Berteaud <daniel@firewall-services.com> 1.10-2
160     - Create missing starred-images cache dir
161    
162     * Mon Sep 23 2013 Daniel Berteaud <daniel@firewall-services.com> 1.10-1
163     - udpate to 1.10
164    
165     * Sun Jul 21 2013 Daniel Berteaud <daniel@firewall-services.com> 1.9-1
166     - update to 1.9
167    
168     * Wed Jun 12 2013 Daniel Berteaud <daniel@firewall-services.com> 1.8-1
169     - update to 1.8
170    
171     * Tue May 14 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.9-2
172     - Add upload subdir in cache
173    
174     * Tue May 14 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.9-1
175     - upstream upgrade to 1.7.9
176    
177     * Thu Apr 4 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.8-1
178     - upstream upgrade to 1.7.8
179    
180     * Thu Apr 4 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.7-1
181     - upstream upgrade to 1.7.7
182    
183     * Wed Apr 3 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.6-2
184     - upstream upgrade to 1.7.6
185    
186     * Sat Mar 23 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.5-2
187     - Add missing js directory in /var/cache/tt-rss
188    
189     * Sat Mar 23 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.5-1
190     - upstream upgrade to 1.7.5
191    
192     * Sun Mar 17 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.4-1
193     - upstream upgrade to 1.7.4
194    
195     * Tue Mar 5 2013 Daniel Berteaud <daniel@firewall-services.com> 1.7.1-1
196     - upstream upgrade to 1.7.1
197    
198     * Thu Dec 20 2012 Daniel B. <daniel@firewall-services.com> 1.6.2-1
199     - upstream upgrade to 1.6.2
200    
201     * Wed Nov 14 2012 Daniel B. <daniel@firewall-services.com> 1.6.1-1
202     - upstream upgrade to 1.6.1
203    
204     * Mon May 21 2012 Daniel B. <daniel@firewall-services.com> 1.5.11-12
205     - upstream upgrade to 1.5.11
206    
207     * Fri Mar 02 2012 Daniel B. <daniel@firewall-services.com> 1.5.10-11
208     - upstream upgrade to 1.5.10
209    
210     * Thu Feb 02 2012 Daniel B. <daniel@firewall-services.com> 1.5.9-11
211     - upstream upgrade to 1.5.9
212    
213     * Fri Jan 06 2012 Daniel B. <daniel@firewall-services.com> 1.5.8.1-11
214     - upstream upgrade to 1.5.8.1
215    
216     * Fri Nov 25 2011 Daniel B. <daniel@firewall-services.com> 1.5.7-10
217     - upstream upgrade to 1.5.7
218    
219     * Wed Sep 28 2011 Daniel B. <daniel@firewall-services.com> 1.5.5-8
220     - Don't exit with error if SELinux is disabled
221    
222     * Fri Jul 22 2011 Daniel B. <daniel@firewall-services.com> 1.5.5-7
223     - Upstream upgrade to 1.5.5
224    
225     * Mon Jul 04 2011 Daniel B. <daniel@firewall-services.com> 1.5.3-6
226     - Don't restart apache on install/remove/upgrade
227    
228     * Sat Jul 2 2011 Daniel B. <daniel@firewall-services.com> 1.5.3-5
229     - create htmlpurifier cache directory
230    
231     * Tue May 17 2011 Daniel B. <daniel@firewall-services.com> 1.5.3-4
232     - Upstream upgrade to 1.5.3
233    
234     * Mon Mar 21 2011 Daniel B. <daniel@firewall-services.com> 1.5.2-4
235     - upstream upgrade to 1.5.2
236     - Read HTTP_TTRSS_LEVEL from LemonLDAP
237    
238     * Wed Jan 26 2011 Daniel B. <daniel@firewall-services.com> 1.5.1-3
239     - Completly disable sanity checks (which are far too strict)
240    
241     * Wed Jan 26 2011 Daniel B. <daniel@firewall-services.com> 1.5.1-2
242     - Allow open_basedir restriction
243    
244     * Wed Jan 26 2011 Daniel B. <daniel@firewall-services.com> 1.5.1-1
245     - upstream upgrade to 1.5.1
246    
247     * Mon Jan 03 2011 Daniel B. <daniel@firewall-services.com> 1.5.0-0
248     - initial release
249     - include patches for a better integration with LemonLDP::NG

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed