1 |
slords |
1.1 |
Summary: Software and/or Hardware watchdog daemon |
2 |
|
|
Name: watchdog |
3 |
|
|
Version: 5.6 |
4 |
|
|
Release: 1%{?dist} |
5 |
|
|
License: GPL+ |
6 |
|
|
Group: System Environment/Daemons |
7 |
|
|
|
8 |
|
|
URL: http://sourceforge.net/projects/watchdog/ |
9 |
|
|
Source0: http://dl.sf.net/watchdog/watchdog-%{version}.tar.gz |
10 |
|
|
Source1: watchdog.init |
11 |
|
|
Source2: README.watchdog.ipmi |
12 |
|
|
|
13 |
|
|
Patch0: watchdog-5.6-cleanup.patch |
14 |
|
|
Patch1: watchdog-5.6-quiet-write-warnings.patch |
15 |
|
|
|
16 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
17 |
|
|
|
18 |
|
|
Requires(post): /sbin/chkconfig |
19 |
|
|
Requires(postun): /sbin/chkconfig |
20 |
|
|
Requires(post): /sbin/service |
21 |
|
|
Requires(postun): /sbin/service |
22 |
|
|
|
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
The watchdog program can be used as a powerful software watchdog daemon |
26 |
|
|
or may be alternately used with a hardware watchdog device such as the |
27 |
|
|
IPMI hardware watchdog driver interface to a resident Baseboard |
28 |
|
|
Management Controller (BMC). watchdog periodically writes to /dev/watchdog; |
29 |
|
|
the interval between writes to /dev/watchdog is configurable through settings |
30 |
|
|
in the watchdog sysconfig file. This configuration file is also used to |
31 |
|
|
set the watchdog to be used as a hardware watchdog instead of its default |
32 |
|
|
software watchdog operation. In either case, if the device is open but not |
33 |
|
|
written to within the configured time period, the watchdog timer expiration |
34 |
|
|
will trigger a machine reboot. When operating as a software watchdog, the |
35 |
|
|
ability to reboot will depend on the state of the machine and interrupts. |
36 |
|
|
When operating as a hardware watchdog, the machine will experience a hard |
37 |
|
|
reset (or whatever action was configured to be taken upon watchdog timer |
38 |
|
|
expiration) initiated by the BMC. |
39 |
|
|
|
40 |
|
|
|
41 |
|
|
%prep |
42 |
|
|
%setup -q -n %{name}-%{version} |
43 |
|
|
|
44 |
|
|
%patch0 -p1 -b .cleanup |
45 |
|
|
%patch1 -p1 -b .quiet-write-warnings |
46 |
|
|
|
47 |
|
|
cp %{SOURCE2} . |
48 |
|
|
|
49 |
|
|
mv README README.orig |
50 |
|
|
iconv -f ISO-8859-1 -t UTF-8 < README.orig > README |
51 |
|
|
|
52 |
|
|
|
53 |
|
|
%build |
54 |
|
|
%configure |
55 |
|
|
make %{?_smp_mflags} |
56 |
|
|
|
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -rf ${RPM_BUILD_ROOT} |
60 |
|
|
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir} |
61 |
|
|
make DESTDIR=${RPM_BUILD_ROOT} install |
62 |
|
|
install -Dp -m0644 %{name}.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/watchdog |
63 |
|
|
install -Dp -m0755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/watchdog |
64 |
|
|
|
65 |
|
|
|
66 |
|
|
%clean |
67 |
|
|
rm -Rf ${RPM_BUILD_ROOT} |
68 |
|
|
|
69 |
|
|
|
70 |
|
|
%post |
71 |
|
|
if [ $1 -eq 1 ]; then |
72 |
|
|
/sbin/chkconfig --add %{name} |
73 |
|
|
fi |
74 |
|
|
|
75 |
|
|
|
76 |
|
|
%preun |
77 |
|
|
if [ $1 -eq 0 ]; then |
78 |
|
|
/sbin/service %{name} stop >/dev/null 2>&1 |
79 |
|
|
/sbin/chkconfig --del %{name} |
80 |
|
|
fi |
81 |
|
|
|
82 |
|
|
|
83 |
|
|
%postun |
84 |
|
|
if [ $1 -ge 1 ]; then |
85 |
|
|
/sbin/service %{name} condrestart >/dev/null 2>&1 |
86 |
|
|
fi |
87 |
|
|
|
88 |
|
|
|
89 |
|
|
%files |
90 |
|
|
%defattr(-, root, root, -) |
91 |
|
|
%doc AUTHORS ChangeLog COPYING examples/ IAFA-PACKAGE NEWS README TODO README.watchdog.ipmi |
92 |
|
|
%config(noreplace) %{_sysconfdir}/watchdog.conf |
93 |
|
|
%config(noreplace) %{_sysconfdir}/sysconfig/watchdog |
94 |
|
|
%{_sysconfdir}/rc.d/init.d/watchdog |
95 |
|
|
%{_sbindir}/watchdog |
96 |
|
|
%{_sbindir}/wd_keepalive |
97 |
|
|
%{_mandir}/man5/watchdog.conf.5* |
98 |
|
|
%{_mandir}/man8/watchdog.8* |
99 |
|
|
%{_mandir}/man8/wd_keepalive.8* |
100 |
|
|
|
101 |
|
|
|
102 |
|
|
%changelog |
103 |
|
|
* Thu Mar 26 2009 Richard W.M. Jones <rjones@redhat.com> - 5.6-1 |
104 |
|
|
- Rebase to watchdog 5.6. |
105 |
|
|
- Drop cleanup patch, since it is now upstream. |
106 |
|
|
- Drop NFS cleanup patch, since it breaks NFS support for one call. |
107 |
|
|
- Add patch for general cleanups (sent upstream 2009-03-26). |
108 |
|
|
- Add patch to quiet write warnings about unused return values. |
109 |
|
|
|
110 |
|
|
* Thu Mar 12 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-1 |
111 |
|
|
- New upstream release 5.5 - Resolves: 446123 |
112 |
|
|
- Synchronize the spec file formatting with Fedora. |
113 |
|
|
- Upstream source URL has changed (_ into -). |
114 |
|
|
- Convert README file to UTF-8. |
115 |
|
|
- Fix defattr line. |
116 |
|
|
- Manpages shouldn't be marked as doc. |
117 |
|
|
- Added wd_keepalive manpage. |
118 |
|
|
|
119 |
|
|
* Mon Jun 11 2007 Lon Hohberger <lhh@redhat.com> - 5.3.1-7 |
120 |
|
|
- Rebuild for RHEL5 Update 1 - Resolves: 227401 |
121 |
|
|
|
122 |
|
|
* Wed May 30 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-6 |
123 |
|
|
- Fixed the init script file. |
124 |
|
|
|
125 |
|
|
* Tue May 29 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-5 |
126 |
|
|
- Fixed a compile warning in nfsmount_xdr file. |
127 |
|
|
|
128 |
|
|
* Wed May 23 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-4 |
129 |
|
|
- Fixed rpmlint warnings. |
130 |
|
|
|
131 |
|
|
* Wed May 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-3 |
132 |
|
|
- Changes to spec, init script and README file per Carol Hebert recommendation. |
133 |
|
|
|
134 |
|
|
* Thu Apr 19 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-2 |
135 |
|
|
- Added README.watchdog.ipmi |
136 |
|
|
|
137 |
|
|
* Mon Apr 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-1 |
138 |
|
|
- Initial copy. |