/[smecontribs]/rpms/watchdog/contribs7/watchdog.spec
ViewVC logotype

Annotation of /rpms/watchdog/contribs7/watchdog.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Sat Dec 4 16:31:53 2010 UTC (13 years, 5 months ago) by slords
Branch: MAIN
Changes since 1.1: +4 -0 lines
Spec cleanups

1 slords 1.2 # $Id$
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 Summary: Software and/or Hardware watchdog daemon
6     Name: watchdog
7     Version: 5.6
8     Release: 1%{?dist}
9     License: GPL+
10     Group: System Environment/Daemons
11    
12     URL: http://sourceforge.net/projects/watchdog/
13     Source0: http://dl.sf.net/watchdog/watchdog-%{version}.tar.gz
14     Source1: watchdog.init
15     Source2: README.watchdog.ipmi
16    
17     Patch0: watchdog-5.6-cleanup.patch
18     Patch1: watchdog-5.6-quiet-write-warnings.patch
19    
20     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21    
22     Requires(post): /sbin/chkconfig
23     Requires(postun): /sbin/chkconfig
24     Requires(post): /sbin/service
25     Requires(postun): /sbin/service
26    
27    
28     %description
29     The watchdog program can be used as a powerful software watchdog daemon
30     or may be alternately used with a hardware watchdog device such as the
31     IPMI hardware watchdog driver interface to a resident Baseboard
32     Management Controller (BMC). watchdog periodically writes to /dev/watchdog;
33     the interval between writes to /dev/watchdog is configurable through settings
34     in the watchdog sysconfig file. This configuration file is also used to
35     set the watchdog to be used as a hardware watchdog instead of its default
36     software watchdog operation. In either case, if the device is open but not
37     written to within the configured time period, the watchdog timer expiration
38     will trigger a machine reboot. When operating as a software watchdog, the
39     ability to reboot will depend on the state of the machine and interrupts.
40     When operating as a hardware watchdog, the machine will experience a hard
41     reset (or whatever action was configured to be taken upon watchdog timer
42     expiration) initiated by the BMC.
43    
44    
45     %prep
46     %setup -q -n %{name}-%{version}
47    
48     %patch0 -p1 -b .cleanup
49     %patch1 -p1 -b .quiet-write-warnings
50    
51     cp %{SOURCE2} .
52    
53     mv README README.orig
54     iconv -f ISO-8859-1 -t UTF-8 < README.orig > README
55    
56    
57     %build
58     %configure
59     make %{?_smp_mflags}
60    
61    
62     %install
63     rm -rf ${RPM_BUILD_ROOT}
64     install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir}
65     make DESTDIR=${RPM_BUILD_ROOT} install
66     install -Dp -m0644 %{name}.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/watchdog
67     install -Dp -m0755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/watchdog
68    
69    
70     %clean
71     rm -Rf ${RPM_BUILD_ROOT}
72    
73    
74     %post
75     if [ $1 -eq 1 ]; then
76     /sbin/chkconfig --add %{name}
77     fi
78    
79    
80     %preun
81     if [ $1 -eq 0 ]; then
82     /sbin/service %{name} stop >/dev/null 2>&1
83     /sbin/chkconfig --del %{name}
84     fi
85    
86    
87     %postun
88     if [ $1 -ge 1 ]; then
89     /sbin/service %{name} condrestart >/dev/null 2>&1
90     fi
91    
92    
93     %files
94     %defattr(-, root, root, -)
95     %doc AUTHORS ChangeLog COPYING examples/ IAFA-PACKAGE NEWS README TODO README.watchdog.ipmi
96     %config(noreplace) %{_sysconfdir}/watchdog.conf
97     %config(noreplace) %{_sysconfdir}/sysconfig/watchdog
98     %{_sysconfdir}/rc.d/init.d/watchdog
99     %{_sbindir}/watchdog
100     %{_sbindir}/wd_keepalive
101     %{_mandir}/man5/watchdog.conf.5*
102     %{_mandir}/man8/watchdog.8*
103     %{_mandir}/man8/wd_keepalive.8*
104    
105    
106     %changelog
107     * Thu Mar 26 2009 Richard W.M. Jones <rjones@redhat.com> - 5.6-1
108     - Rebase to watchdog 5.6.
109     - Drop cleanup patch, since it is now upstream.
110     - Drop NFS cleanup patch, since it breaks NFS support for one call.
111     - Add patch for general cleanups (sent upstream 2009-03-26).
112     - Add patch to quiet write warnings about unused return values.
113    
114     * Thu Mar 12 2009 Richard W.M. Jones <rjones@redhat.com> - 5.5-1
115     - New upstream release 5.5 - Resolves: 446123
116     - Synchronize the spec file formatting with Fedora.
117     - Upstream source URL has changed (_ into -).
118     - Convert README file to UTF-8.
119     - Fix defattr line.
120     - Manpages shouldn't be marked as doc.
121     - Added wd_keepalive manpage.
122    
123     * Mon Jun 11 2007 Lon Hohberger <lhh@redhat.com> - 5.3.1-7
124     - Rebuild for RHEL5 Update 1 - Resolves: 227401
125    
126     * Wed May 30 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-6
127     - Fixed the init script file.
128    
129     * Tue May 29 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-5
130     - Fixed a compile warning in nfsmount_xdr file.
131    
132     * Wed May 23 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-4
133     - Fixed rpmlint warnings.
134    
135     * Wed May 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-3
136     - Changes to spec, init script and README file per Carol Hebert recommendation.
137    
138     * Thu Apr 19 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-2
139     - Added README.watchdog.ipmi
140    
141     * Mon Apr 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-1
142     - Initial copy.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed