1 |
slords |
1.3 |
# $Id: watchdog.spec,v 1.2 2010/12/04 16:31:53 slords Exp $ |
2 |
slords |
1.2 |
# Authority: slords |
3 |
|
|
# Name: Shad L. Lords |
4 |
|
|
|
5 |
slords |
1.3 |
Summary: Software and/or Hardware watchdog daemon |
6 |
|
|
Name: watchdog |
7 |
|
|
Version: 5.3.1 |
8 |
|
|
Release: 7%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
Group: System Environment/Daemons |
11 |
|
|
URL: http://sourceforge.net/projects/watchdog/ |
12 |
|
|
Source0: http://dl.sf.net/watchdog/watchdog_%{version}.tar.gz |
13 |
|
|
Source1: watchdog.init |
14 |
|
|
Source2: README.watchdog.ipmi |
15 |
|
|
Patch0: %{name}-%{version}-cleanup.patch |
16 |
|
|
Patch1: %{name}-%{version}-cleanup-nfs.patch |
17 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
18 |
|
|
Requires(post): /sbin/chkconfig |
19 |
slords |
1.1 |
Requires(postun): /sbin/chkconfig |
20 |
slords |
1.3 |
Requires(post): /sbin/service |
21 |
slords |
1.1 |
Requires(postun): /sbin/service |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
The watchdog program can be used as a powerful software watchdog daemon |
25 |
|
|
or may be alternately used with a hardware watchdog device such as the |
26 |
|
|
IPMI hardware watchdog driver interface to a resident Baseboard |
27 |
|
|
Management Controller (BMC). watchdog periodically writes to /dev/watchdog; |
28 |
|
|
the interval between writes to /dev/watchdog is configurable through settings |
29 |
|
|
in the watchdog sysconfig file. This configuration file is also used to |
30 |
|
|
set the watchdog to be used as a hardware watchdog instead of its default |
31 |
|
|
software watchdog operation. In either case, if the device is open but not |
32 |
|
|
written to within the configured time period, the watchdog timer expiration |
33 |
|
|
will trigger a machine reboot. When operating as a software watchdog, the |
34 |
|
|
ability to reboot will depend on the state of the machine and interrupts. |
35 |
|
|
When operating as a hardware watchdog, the machine will experience a hard |
36 |
|
|
reset (or whatever action was configured to be taken upon watchdog timer |
37 |
|
|
expiration) initiated by the BMC. |
38 |
slords |
1.3 |
|
39 |
slords |
1.1 |
%prep |
40 |
|
|
%setup -q -n %{name}-%{version} |
41 |
|
|
cp %{SOURCE2} . |
42 |
slords |
1.3 |
%patch0 -p1 |
43 |
|
|
%patch1 -p1 |
44 |
slords |
1.1 |
%build |
45 |
|
|
%configure |
46 |
|
|
make %{?_smp_mflags} |
47 |
|
|
|
48 |
|
|
%install |
49 |
slords |
1.3 |
rm -Rf ${RPM_BUILD_ROOT} |
50 |
slords |
1.1 |
install -d -m0755 ${RPM_BUILD_ROOT}%{_sysconfdir} |
51 |
|
|
make DESTDIR=${RPM_BUILD_ROOT} install |
52 |
|
|
install -Dp -m0644 %{name}.sysconfig ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/watchdog |
53 |
|
|
install -Dp -m0755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/watchdog |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
rm -Rf ${RPM_BUILD_ROOT} |
57 |
|
|
|
58 |
|
|
%post |
59 |
|
|
if [ $1 -eq 1 ]; then |
60 |
slords |
1.3 |
/sbin/chkconfig --add %{name} |
61 |
slords |
1.1 |
fi |
62 |
|
|
|
63 |
|
|
%preun |
64 |
|
|
if [ $1 -eq 0 ]; then |
65 |
slords |
1.3 |
/sbin/service %{name} stop >/dev/null 2>&1 |
66 |
|
|
/sbin/chkconfig --del %{name} |
67 |
slords |
1.1 |
fi |
68 |
|
|
|
69 |
|
|
%postun |
70 |
|
|
if [ $1 -ge 1 ]; then |
71 |
slords |
1.3 |
/sbin/service %{name} condrestart >/dev/null 2>&1 |
72 |
slords |
1.1 |
fi |
73 |
|
|
|
74 |
|
|
|
75 |
|
|
%files |
76 |
slords |
1.3 |
%defattr(-, root, root, 0755) |
77 |
slords |
1.1 |
%doc AUTHORS ChangeLog COPYING examples/ IAFA-PACKAGE NEWS README TODO README.watchdog.ipmi |
78 |
slords |
1.3 |
%doc %{_mandir}/man5/watchdog.conf.5* |
79 |
|
|
%doc %{_mandir}/man8/watchdog.8* |
80 |
slords |
1.1 |
%config(noreplace) %{_sysconfdir}/watchdog.conf |
81 |
|
|
%config(noreplace) %{_sysconfdir}/sysconfig/watchdog |
82 |
|
|
%{_sysconfdir}/rc.d/init.d/watchdog |
83 |
|
|
%{_sbindir}/watchdog |
84 |
|
|
%{_sbindir}/wd_keepalive |
85 |
|
|
|
86 |
|
|
%changelog |
87 |
|
|
* Mon Jun 11 2007 Lon Hohberger <lhh@redhat.com> - 5.3.1-7 |
88 |
|
|
- Rebuild for RHEL5 Update 1 - Resolves: 227401 |
89 |
|
|
* Wed May 30 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-6 |
90 |
|
|
- Fixed the init script file. |
91 |
|
|
* Tue May 29 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-5 |
92 |
|
|
- Fixed a compile warning in nfsmount_xdr file. |
93 |
|
|
* Wed May 23 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-4 |
94 |
|
|
- Fixed rpmlint warnings. |
95 |
|
|
* Wed May 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-3 |
96 |
|
|
- Changes to spec, init script and README file per Carol Hebert recommendation. |
97 |
|
|
* Thu Apr 19 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-2 |
98 |
|
|
- Added README.watchdog.ipmi |
99 |
|
|
* Mon Apr 16 2007 Konrad Rzeszutek <konradr@redhat.com> - 5.3.1-1 |
100 |
|
|
- Initial copy. |