1 |
slords |
1.1 |
# $Id$ |
2 |
|
|
# Authority: slords |
3 |
|
|
# Name: Shad L. Lords |
4 |
|
|
|
5 |
|
|
%define python_ver %(%{__python} -c "import sys; print sys.version[:3]") |
6 |
|
|
|
7 |
|
|
Summary: Bindings for the Xapian Probabilistic Information Retrieval Library |
8 |
|
|
Name: xapian-bindings |
9 |
|
|
Version: 1.0.6 |
10 |
|
|
Release: 1%{?dist} |
11 |
|
|
License: GPLv2+ |
12 |
|
|
Group: Development/Libraries |
13 |
|
|
URL: http://www.xapian.org/ |
14 |
|
|
BuildRequires: python-devel >= 2.2 |
15 |
|
|
BuildRequires: autoconf automake libtool |
16 |
|
|
BuildRequires: xapian-core-devel == %{version} |
17 |
|
|
Source0: http://www.oligarchy.co.uk/xapian/%{version}/%{name}-%{version}.tar.gz |
18 |
|
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
Xapian is an Open Source Probabilistic Information Retrieval Library. It |
22 |
|
|
offers a highly adaptable toolkit that allows developers to easily add advanced |
23 |
|
|
indexing and search facilities to applications. This package provides the |
24 |
|
|
files needed for scripts which use Xapian |
25 |
|
|
|
26 |
|
|
%package python |
27 |
|
|
Group: Development/Libraries |
28 |
|
|
Summary: Files needed for developing Python scripts which use Xapian |
29 |
|
|
|
30 |
|
|
%description python |
31 |
|
|
Xapian is an Open Source Probabilistic Information Retrieval framework. It |
32 |
|
|
offers a highly adaptable toolkit that allows developers to easily add advanced |
33 |
|
|
indexing and search facilities to applications. This package provides the |
34 |
|
|
files needed for developing Python scripts which use Xapian |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup -q -n %{name}-%{version} |
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
%configure --with-python |
41 |
|
|
make %{?_smp_mflags} |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf %{buildroot} |
45 |
|
|
mkdir -p %{buildroot} |
46 |
|
|
# Installation of some files does not obey prefix, DESTDIR is required |
47 |
|
|
%makeinstall DESTDIR=%{buildroot} |
48 |
|
|
# Move the docs to the right place, and correct the effects of prefix+DESTDIR |
49 |
|
|
mkdir -p %{buildroot}/usr/share/doc/ |
50 |
|
|
mv %{buildroot}%{buildroot}/usr/share/doc/%{name}/python %{buildroot}/usr/share/doc/%{name}-python-%{version} |
51 |
|
|
rm -rf %{buildroot}%{buildroot}/usr/share/doc/%{name}/ |
52 |
|
|
|
53 |
|
|
%clean |
54 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
55 |
|
|
|
56 |
|
|
%files python |
57 |
|
|
%defattr(-, root, root) |
58 |
|
|
%doc AUTHORS ChangeLog COPYING NEWS README |
59 |
|
|
%{_libdir}/python%{python_ver}/site-packages/_xapian.so |
60 |
|
|
%{_libdir}/python%{python_ver}/site-packages/xapian.py |
61 |
|
|
%{_libdir}/python%{python_ver}/site-packages/xapian.pyc |
62 |
|
|
%{_libdir}/python%{python_ver}/site-packages/xapian.pyo |
63 |
|
|
|
64 |
|
|
|
65 |
|
|
|
66 |
|
|
%changelog |
67 |
|
|
* Sun Mar 30 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.6-1 |
68 |
|
|
- Update to 1.0.6 |
69 |
|
|
|
70 |
|
|
* Sat Feb 09 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.5-2 |
71 |
|
|
- Rebuild for gcc-4.3 |
72 |
|
|
|
73 |
|
|
* Thu Dec 27 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.5-1 |
74 |
|
|
- Update to 1.0.5 |
75 |
|
|
|
76 |
|
|
* Tue Oct 30 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.4-1 |
77 |
|
|
- Update to 1.0.4 |
78 |
|
|
|
79 |
|
|
* Thu Aug 16 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-4 |
80 |
|
|
- License is GPLv2+ not GPLv2 |
81 |
|
|
|
82 |
|
|
* Sun Aug 12 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-3 |
83 |
|
|
- Remove vendor tag RH #251832 |
84 |
|
|
|
85 |
|
|
* Wed Aug 08 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-2 |
86 |
|
|
- Fix license tag |
87 |
|
|
- Minor cleanups |
88 |
|
|
- Add disttag |
89 |
|
|
|
90 |
|
|
* Fri Jul 13 2007 Marco Pesenti Gritti <mpg@redhat.com> - 1.0.2-1 |
91 |
|
|
- Update to 1.0.2 |
92 |
|
|
|
93 |
|
|
* Tue Jun 19 2007 Marco Pesenti Gritti <mpg@redhat.com> 1.0.1-2 |
94 |
|
|
- Remove req on xapian-bindings |
95 |
|
|
|
96 |
|
|
* Mon Jun 18 2007 Marco Pesenti Gritti <mpg@redhat.com> 1.0.1-1 |
97 |
|
|
- Initial build |