1 |
# $Id: xapian-bindings.spec,v 1.3 2008/11/25 16:20:36 slords Exp $ |
2 |
# Authority: slords |
3 |
# Name: Shad L. Lords |
4 |
|
5 |
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")} |
6 |
%define ruby_sitelib %(ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']") |
7 |
%define ruby_sitearch %(ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']") |
8 |
|
9 |
Name: xapian-bindings |
10 |
Version: 1.0.17 |
11 |
Release: 3%{?dist} |
12 |
Summary: Bindings for the Xapian Probabilistic Information Retrieval Library |
13 |
|
14 |
Group: Development/Libraries |
15 |
License: GPLv2+ |
16 |
URL: http://www.xapian.org/ |
17 |
Source0: http://www.oligarchy.co.uk/xapian/%{version}/%{name}-%{version}.tar.gz |
18 |
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
19 |
|
20 |
BuildRequires: python-devel >= 2.2 |
21 |
BuildRequires: ruby-devel ruby |
22 |
BuildRequires: xapian-core-devel == %{version} |
23 |
|
24 |
%description |
25 |
Xapian is an Open Source Probabilistic Information Retrieval Library. It |
26 |
offers a highly adaptable toolkit that allows developers to easily add advanced |
27 |
indexing and search facilities to applications. This package provides the |
28 |
files needed for scripts which use Xapian |
29 |
|
30 |
%package python |
31 |
Group: Development/Libraries |
32 |
Summary: Files needed for developing Python scripts which use Xapian |
33 |
Obsoletes: pyxapian |
34 |
|
35 |
%description python |
36 |
Xapian is an Open Source Probabilistic Information Retrieval framework. It |
37 |
offers a highly adaptable toolkit that allows developers to easily add advanced |
38 |
indexing and search facilities to applications. This package provides the |
39 |
files needed for developing Python scripts which use Xapian |
40 |
|
41 |
%package ruby |
42 |
Group: Development/Libraries |
43 |
Summary: Files needed for developing Ruby scripts which use Xapian |
44 |
|
45 |
%description ruby |
46 |
Xapian is an Open Source Probabilistic Information Retrieval framework. It |
47 |
offers a highly adaptable toolkit that allows developers to easily add advanced |
48 |
indexing and search facilities to applications. This package provides the |
49 |
files needed for developing Ruby scripts which use Xapian |
50 |
|
51 |
%prep |
52 |
%setup -q |
53 |
|
54 |
%build |
55 |
%configure --with-python --with-ruby |
56 |
make %{?_smp_mflags} V=1 |
57 |
|
58 |
%install |
59 |
rm -rf %{buildroot} |
60 |
make install DESTDIR=%{buildroot} INSTALL='install -p' |
61 |
|
62 |
# Remove the dev docs, we pick them up below |
63 |
rm -rf %{buildroot}%{_datadir}/doc/%{name} |
64 |
|
65 |
%clean |
66 |
rm -rf %{buildroot} |
67 |
|
68 |
%files python |
69 |
%defattr(-, root, root) |
70 |
%doc AUTHORS ChangeLog COPYING NEWS README |
71 |
%doc python/docs/examples |
72 |
%{python_sitearch}/* |
73 |
|
74 |
%files ruby |
75 |
%defattr(-, root, root) |
76 |
%doc AUTHORS ChangeLog COPYING NEWS README |
77 |
%doc ruby/docs/rdocs ruby/docs/examples |
78 |
%{ruby_sitearch}/_xapian.so |
79 |
%{ruby_sitelib}/xapian.rb |
80 |
|
81 |
%changelog |
82 |
* Sat Jan 9 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.17-3 |
83 |
- Updated to the new python sysarch spec file reqs |
84 |
|
85 |
* Wed Dec 2 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.17-2 |
86 |
- Drop upstreamed patch |
87 |
|
88 |
* Wed Dec 2 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.17-1 |
89 |
- Update to 1.0.17 |
90 |
|
91 |
* Sat Sep 19 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.16-1 |
92 |
- Update to 1.0.16, some spec file cleanups |
93 |
|
94 |
* Sun Sep 6 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.15-2 |
95 |
- Patch to fix python bindings build |
96 |
|
97 |
* Thu Aug 27 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.15-1 |
98 |
- Update to 1.0.15 |
99 |
|
100 |
* Wed Jul 29 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.14-1 |
101 |
- Update to 1.0.14 |
102 |
|
103 |
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.13-2 |
104 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
105 |
|
106 |
* Fri Jun 5 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.13-1 |
107 |
- Update to 1.0.13 |
108 |
|
109 |
* Sun Apr 19 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.12-1 |
110 |
- Update to 1.0.12 |
111 |
|
112 |
* Tue Apr 07 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.11-2 |
113 |
- Obsolete pyxapian |
114 |
|
115 |
* Mon Apr 06 2009 Peter Robinson<pbrobinson@gmail.com> 1.0.11-1 |
116 |
- Update to 1.0.11 |
117 |
|
118 |
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.9-3 |
119 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
120 |
|
121 |
* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> 1.0.9-2 |
122 |
- Rebuild for Python 2.6 |
123 |
|
124 |
* Sat Nov 29 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.9-1 |
125 |
- Update to 1.0.9 |
126 |
|
127 |
* Sat Oct 11 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.8-1 |
128 |
- Update to 1.0.8 |
129 |
|
130 |
* Mon Jul 28 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.7-2 |
131 |
- Enable ruby bindings RH #456951, patch by Scott Seago |
132 |
|
133 |
* Sun Jul 20 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.7-1 |
134 |
- Update to 1.0.7 |
135 |
|
136 |
* Sun Mar 30 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.6-1 |
137 |
- Update to 1.0.6 |
138 |
|
139 |
* Sat Feb 09 2008 Adel Gadllah <adel.gadllah@gmail.com> 1.0.5-2 |
140 |
- Rebuild for gcc-4.3 |
141 |
|
142 |
* Thu Dec 27 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.5-1 |
143 |
- Update to 1.0.5 |
144 |
|
145 |
* Tue Oct 30 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.4-1 |
146 |
- Update to 1.0.4 |
147 |
|
148 |
* Thu Aug 16 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-4 |
149 |
- License is GPLv2+ not GPLv2 |
150 |
|
151 |
* Sun Aug 12 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-3 |
152 |
- Remove vendor tag RH #251832 |
153 |
|
154 |
* Wed Aug 08 2007 Adel Gadllah <adel.gadllah@gmail.com> 1.0.2-2 |
155 |
- Fix license tag |
156 |
- Minor cleanups |
157 |
- Add disttag |
158 |
|
159 |
* Fri Jul 13 2007 Marco Pesenti Gritti <mpg@redhat.com> - 1.0.2-1 |
160 |
- Update to 1.0.2 |
161 |
|
162 |
* Tue Jun 19 2007 Marco Pesenti Gritti <mpg@redhat.com> 1.0.1-2 |
163 |
- Remove req on xapian-bindings |
164 |
|
165 |
* Mon Jun 18 2007 Marco Pesenti Gritti <mpg@redhat.com> 1.0.1-1 |
166 |
- Initial build |