1 |
jcrisp |
1.1 |
Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661) |
2 |
|
|
Name: xl2tpd |
3 |
|
|
Version: 1.3.15 |
4 |
|
|
Release: 2 |
5 |
|
|
License: GPLv2 |
6 |
|
|
Url: http://www.xelerance.com/software/xl2tpd/ |
7 |
|
|
Group: System Environment/Daemons |
8 |
|
|
Source0: https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz |
9 |
|
|
Patch1: xl2tpd-init.patch |
10 |
|
|
|
11 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
12 |
|
|
Requires: ppp |
13 |
|
|
BuildRequires: kernel-headers => 2.6.23 |
14 |
|
|
%if 0%{?el3}%{?el4} |
15 |
|
|
BuildRequires: libpcap |
16 |
|
|
%else |
17 |
|
|
BuildRequires: libpcap-devel |
18 |
|
|
%endif |
19 |
|
|
Obsoletes: l2tpd <= 0.69-0.6.20051030.fc6 |
20 |
|
|
Provides: l2tpd = 0.69-0.6.20051030.fc7 |
21 |
|
|
Requires(post): /sbin/chkconfig |
22 |
|
|
Requires(preun): /sbin/chkconfig |
23 |
|
|
Requires(preun): /sbin/service |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661). |
27 |
|
|
L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user |
28 |
|
|
sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP |
29 |
|
|
servers. Another important application is Virtual Private Networks where |
30 |
|
|
the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec, |
31 |
|
|
RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and |
32 |
|
|
Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec |
33 |
|
|
implementations such as Openswan. |
34 |
|
|
Example configuration files for such a setup are included in this RPM. |
35 |
|
|
|
36 |
|
|
xl2tpd works by opening a pseudo-tty for communicating with pppd. |
37 |
|
|
It runs completely in userspace but supports kernel mode L2TP. |
38 |
|
|
|
39 |
|
|
xl2tpd supports IPsec SA Reference tracking to enable overlapping internak |
40 |
|
|
NAT'ed IP's by different clients (eg all clients connecting from their |
41 |
|
|
linksys internal IP 192.168.1.101) as well as multiple clients behind |
42 |
|
|
the same NAT router. |
43 |
|
|
|
44 |
|
|
xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher, |
45 |
|
|
or via a patch in contrib for 2.4.x kernels. |
46 |
|
|
|
47 |
|
|
Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com> |
48 |
|
|
It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003. |
49 |
|
|
|
50 |
|
|
%prep |
51 |
|
|
%setup -q |
52 |
|
|
|
53 |
|
|
%patch1 -p1 |
54 |
|
|
|
55 |
|
|
%build |
56 |
|
|
# Customer test case proved the first make line failed, the second one worked |
57 |
|
|
# the failing one had incoming l2tp packets, but never got a tunnel up. |
58 |
|
|
#make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_PPPD -DDEBUG_CONTROL -DDEBUG_ENTROPY" |
59 |
|
|
make DFLAGS="-g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH" |
60 |
|
|
|
61 |
|
|
%install |
62 |
|
|
rm -rf %{buildroot} |
63 |
|
|
make DESTDIR=%{buildroot} PREFIX=%{_prefix} install |
64 |
|
|
install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf |
65 |
|
|
install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd |
66 |
|
|
install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets |
67 |
|
|
install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample |
68 |
|
|
install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd |
69 |
|
|
install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd |
70 |
|
|
|
71 |
|
|
|
72 |
|
|
%clean |
73 |
|
|
rm -rf %{buildroot} |
74 |
|
|
|
75 |
|
|
%post |
76 |
|
|
/sbin/chkconfig --add xl2tpd |
77 |
|
|
# if we migrate from l2tpd to xl2tpd, copy the configs |
78 |
|
|
if [ -f /etc/l2tpd/l2tpd.conf ] |
79 |
|
|
then |
80 |
|
|
echo "Old /etc/l2tpd configuration found, migrating to /etc/xl2tpd" |
81 |
|
|
mv /etc/xl2tpd/xl2tpd.conf /etc/xl2tpd/xl2tpd.conf.rpmsave |
82 |
|
|
cat /etc/l2tpd/l2tpd.conf | sed "s/options.l2tpd/options.xl2tpd/" > /etc/xl2tpd/xl2tpd.conf |
83 |
|
|
mv /etc/ppp/options.xl2tpd /etc/ppp/options.xl2tpd.rpmsave |
84 |
|
|
mv /etc/ppp/options.l2tpd /etc/ppp/options.xl2tpd |
85 |
|
|
mv /etc/xl2tpd/l2tp-secrets /etc/xl2tpd/l2tpd-secrets.rpmsave |
86 |
|
|
cp -pa /etc/l2tpd/l2tp-secrets /etc/xl2tpd/l2tp-secrets |
87 |
|
|
|
88 |
|
|
fi |
89 |
|
|
|
90 |
|
|
|
91 |
|
|
%preun |
92 |
|
|
if [ $1 -eq 0 ]; then |
93 |
|
|
/sbin/service xl2tpd stop > /dev/null 2>&1 |
94 |
|
|
/sbin/chkconfig --del xl2tpd |
95 |
|
|
fi |
96 |
|
|
|
97 |
|
|
%postun |
98 |
|
|
if [ $1 -ge 1 ]; then |
99 |
|
|
/sbin/service xl2tpd condrestart 2>&1 >/dev/null |
100 |
|
|
fi |
101 |
|
|
|
102 |
|
|
%files |
103 |
|
|
%defattr(-,root,root) |
104 |
|
|
%doc BUGS CHANGES CREDITS LICENSE README.* TODO |
105 |
|
|
%doc doc/README.patents examples/chapsecrets.sample |
106 |
|
|
%attr(0755,root,root) %{_sbindir}/xl2tpd |
107 |
|
|
%attr(0755,root,root) %{_sbindir}/xl2tpd-control |
108 |
|
|
%attr(0755,root,root) %{_bindir}/pfc |
109 |
|
|
%{_mandir}/*/* |
110 |
|
|
%dir %{_sysconfdir}/xl2tpd |
111 |
|
|
%config(noreplace) %{_sysconfdir}/xl2tpd/* |
112 |
|
|
%config(noreplace) %{_sysconfdir}/ppp/* |
113 |
|
|
%attr(0755,root,root) %{_initrddir}/xl2tpd |
114 |
|
|
%dir %{_localstatedir}/run/xl2tpd |
115 |
|
|
%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control |
116 |
|
|
|
117 |
|
|
%changelog |
118 |
|
|
* Wed Feb 12 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 1.3.15-2 |
119 |
|
|
- Lots of changes in git |
120 |
|
|
- Code from latest commit 481cf05 on 13 Oct 2019 |
121 |
|
|
- First import to build sys |
122 |
|
|
- Fix init script |
123 |
|
|
|
124 |
|
|
* Sun Oct 26 2008 Paul Wouters <paul@xelerance.com> 1.2.2-1 |
125 |
|
|
- Updated Suse init scripts and spec file |
126 |
|
|
- Added pfc for pppd's precompiled-active-filter |
127 |
|
|
|
128 |
|
|
* Tue Jun 26 2007 Paul Wouters <paul@xelerance.com> 1.1.11-1 |
129 |
|
|
- Minor changes to spec file to accomodate new README files |
130 |
|
|
|
131 |
|
|
* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1 |
132 |
|
|
- Upgraded to 1.1.08 |
133 |
|
|
- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM |
134 |
|
|
|
135 |
|
|
* Mon Feb 19 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2 |
136 |
|
|
- Upgraded to 1.1.07 |
137 |
|
|
- Fixes from Tuomo Soini for pidfile handling with Fedora |
138 |
|
|
- Fix hardcoded version for Source in spec file. |
139 |
|
|
|
140 |
|
|
* Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5 |
141 |
|
|
- Changed space/tab replacing method |
142 |
|
|
|
143 |
|
|
* Wed Dec 6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4 |
144 |
|
|
- Added -p to keep original timestamps |
145 |
|
|
- Added temporary hack to change space/tab in init file. |
146 |
|
|
- Added /sbin/service dependancy |
147 |
|
|
|
148 |
|
|
* Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3 |
149 |
|
|
- Added Requires(post) / Requires(preun) |
150 |
|
|
- changed init file to create /var/run/xl2tpd fixed a tab/space |
151 |
|
|
- changed control file to be within /var/run/xl2tpd/ |
152 |
|
|
|
153 |
|
|
* Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2 |
154 |
|
|
- Changed Mr. Karlsen's name to not be a utf8 problem |
155 |
|
|
- Fixed Obosoletes/Provides to be more specific wrt l2tpd. |
156 |
|
|
- Added dist tag which accidentally got deleted. |
157 |
|
|
|
158 |
|
|
* Mon Dec 4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1 |
159 |
|
|
- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name |
160 |
|
|
|
161 |
|
|
* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030 |
162 |
|
|
- Pulled up sourceforget.net CVS fixes. |
163 |
|
|
- various debugging added, but debugging should not be on by default. |
164 |
|
|
- async/sync conversion routines must be ready for possibility that the read |
165 |
|
|
will block due to routing loops. |
166 |
|
|
- refactor control socket handling. |
167 |
|
|
- move all logic about pty usage to pty.c. Try ptmx first, if it fails try |
168 |
|
|
legacy ptys |
169 |
|
|
- rename log() to l2tp_log(), as "log" is a math function. |
170 |
|
|
- if we aren't deamonized, then log to stderr. |
171 |
|
|
- added install: and DESTDIR support. |
172 |
|
|
|
173 |
|
|
* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13 |
174 |
|
|
- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines |
175 |
|
|
|
176 |
|
|
* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl |
177 |
|
|
- Added log() patch by Paul Wouters so that l2tpd compiles on FC4. |
178 |
|
|
|
179 |
|
|
* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl> |
180 |
|
|
- l2tpd.org has been hijacked. Project moved back to SourceForge: |
181 |
|
|
http://l2tpd.sourceforge.net |
182 |
|
|
|
183 |
|
|
* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl> |
184 |
|
|
- Small Makefile fixes. Explicitly use gcc instead of cc. |
185 |
|
|
Network services library was not linked on Solaris due to typo. |
186 |
|
|
|
187 |
|
|
* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl |
188 |
|
|
- Choosing between SysV or BSD style ptys is now configurable through |
189 |
|
|
a compile-time boolean "unix98pty". |
190 |
|
|
|
191 |
|
|
* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl> |
192 |
|
|
- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys. |
193 |
|
|
Requires the N_HDLC kernel module. |
194 |
|
|
|
195 |
|
|
* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl> |
196 |
|
|
- Updated the README. |
197 |
|
|
|
198 |
|
|
* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl |
199 |
|
|
- Patch by Marald Klein and Roger Luethi. Fixes writing PID file. |
200 |
|
|
(http://l2tpd.graffl.net/msg01790.html) |
201 |
|
|
Long overdue. Rereleasing 10jdl. |
202 |
|
|
|
203 |
|
|
* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl |
204 |
|
|
- [SECURITY FIX] Added fix from Debian because of a bss-based |
205 |
|
|
buffer overflow. |
206 |
|
|
(http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html) |
207 |
|
|
- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration |
208 |
|
|
directories /etc/{freeswan,openswan,strongswan}. Install our |
209 |
|
|
configuration files to /etc/ipsec.d and create symbolic links in |
210 |
|
|
those directories. |
211 |
|
|
|
212 |
|
|
* Tue Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl> |
213 |
|
|
- Removed 'leftnexthop=' lines. Not relevant for recent versions |
214 |
|
|
of FreeS/WAN and derivates. |
215 |
|
|
|
216 |
|
|
* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-9jdl |
217 |
|
|
- Added "noccp" because of too much MPPE/CCP messages sometimes. |
218 |
|
|
|
219 |
|
|
* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl> |
220 |
|
|
- Added patch in order to prevent StopCCN messages. |
221 |
|
|
|
222 |
|
|
* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl> |
223 |
|
|
- MTU/MRU 1410 seems to be the lowest possible for MSL2TP. |
224 |
|
|
For Windows 2000/XP it doesn't seem to matter. |
225 |
|
|
- Typo in l2tpd.conf (192.168.128/25). |
226 |
|
|
|
227 |
|
|
* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-8jdl |
228 |
|
|
- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal |
229 |
|
|
value but some apps had problems with the default value. |
230 |
|
|
|
231 |
|
|
* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl> |
232 |
|
|
- Added workaround for the missing hostname bug in the MSL2TP client |
233 |
|
|
('Specify your hostname', error 629: "You have been disconnected |
234 |
|
|
from the computer you are dialing"). |
235 |
|
|
|
236 |
|
|
* Thu Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-7jdl |
237 |
|
|
- Added the "listen-addr" global parameter for l2tpd.conf. By |
238 |
|
|
default, the daemon listens on *all* interfaces. Use |
239 |
|
|
"listen-addr" if you want it to bind to one specific |
240 |
|
|
IP address (interface), for security reasons. (See also: |
241 |
|
|
http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning) |
242 |
|
|
- Explained in l2tpd.conf that two different IP addresses should be |
243 |
|
|
used for 'listen-addr' and 'local ip'. |
244 |
|
|
- Modified init script. Upgrades should work better now. You |
245 |
|
|
still need to start/chkconfig l2tpd manually. |
246 |
|
|
- Renamed the example Openswan .conf files to better reflect |
247 |
|
|
the situation. There are two variants using different portselectors. |
248 |
|
|
Previously I thought Windows 2000/XP used portselector 17/0 |
249 |
|
|
and the rest used 17/1701. But with the release of an updated |
250 |
|
|
IPsec client by Microsoft, it turns out that 17/0 must have |
251 |
|
|
been a mistake: the updated client now also uses 17/1701. |
252 |
|
|
|
253 |
|
|
* Mon Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-6jdl |
254 |
|
|
- Changed sample chap-secrets to be valid only for specific |
255 |
|
|
IP addresses. |
256 |
|
|
|
257 |
|
|
* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de> |
258 |
|
|
- Adjustments for SuSE8.x (thanks, Bernhard!) |
259 |
|
|
- Added sample chap-secrets. |
260 |
|
|
|
261 |
|
|
* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl |
262 |
|
|
- Replaced Dominique's patch by Damion de Soto's, which does not |
263 |
|
|
depend on the N_HDLC kernel module. |
264 |
|
|
|
265 |
|
|
* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl |
266 |
|
|
- Seperate example config files for Win9x (MSL2TP) and Win2K/XP |
267 |
|
|
due to left/rightprotoport differences. |
268 |
|
|
Fixing preun for Red Hat. |
269 |
|
|
|
270 |
|
|
* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl |
271 |
|
|
- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/ |
272 |
|
|
Error fixed: source6 was used for both PSK and CERT. |
273 |
|
|
|
274 |
|
|
* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl |
275 |
|
|
- Added Dominique Cressatti's pty patch in another attempt to |
276 |
|
|
prevent the Windows 2000 Professional "loopback detected" error. |
277 |
|
|
Seems to work! |
278 |
|
|
|
279 |
|
|
* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl |
280 |
|
|
- Added 'connect-delay' to PPP parameters in an attempt to |
281 |
|
|
prevent the Windows 2000 Professional "loopback detected" error. |
282 |
|
|
Didn't seem to work. |
283 |
|
|
|
284 |
|
|
* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl |
285 |
|
|
- Did not build on Red Hat 8.0. Solved by adding comments(?!). |
286 |
|
|
Bug detected in spec file: chkconfig --list l2tpd does not work |
287 |
|
|
on Red Hat 8.0. Not important enough to look into yet. |
288 |
|
|
|
289 |
|
|
* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl |
290 |
|
|
- Tested on Red Hat, required some changes. No gprintf. Used different |
291 |
|
|
pty patch, otherwise wouldn't run. Added buildroot sanity check. |
292 |
|
|
|
293 |
|
|
* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl> |
294 |
|
|
- Specfile adapted from Mandrake Cooker. The original RPM can be |
295 |
|
|
retrieved through: |
296 |
|
|
http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd |
297 |
|
|
- Config path changed from /etc/l2tp/ to /etc/l2tpd/ |
298 |
|
|
(Seems more logical and rp-l2tp already uses /etc/l2tp/). |
299 |
|
|
- Do not run at boot or install. The original RPM uses a config file |
300 |
|
|
which is completely commented out, but it still starts l2tpd on all |
301 |
|
|
interfaces. Could be a security risk. This RPM does not start l2tpd, |
302 |
|
|
the sysadmin has to edit the config file and start l2tpd explicitly. |
303 |
|
|
- Renamed patches to start with l2tpd- |
304 |
|
|
- Added dependencies for pppd, glibc-devel. |
305 |
|
|
- Use %%{name} as much as possible. |
306 |
|
|
- l2tp-secrets contains passwords, thus should not be world readable. |
307 |
|
|
- Removed dependency on rpm-helper. |
308 |
|
|
|
309 |
|
|
* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk |
310 |
|
|
- from Per 0yvind Karlsen <peroyvind@delonic.no> : |
311 |
|
|
- PreReq and Requires |
312 |
|
|
- Fix preun_service |
313 |
|
|
|
314 |
|
|
* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk |
315 |
|
|
- Move l2tpd from /usr/bin to /usr/sbin |
316 |
|
|
- Added SysV initscript |
317 |
|
|
- Patch0 |
318 |
|
|
- Patch1 |
319 |
|
|
|
320 |
|
|
* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk |
321 |
|
|
- Initial release |