1 |
jcrisp |
1.1 |
Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661) |
2 |
|
|
Name: xl2tpd |
3 |
|
|
Version: 1.3.15 |
4 |
|
|
Release: 1%{?dist} |
5 |
|
|
License: GPLv2 |
6 |
|
|
Url: http://www.xelerance.com/software/xl2tpd/ |
7 |
|
|
Group: System Environment/Daemons |
8 |
|
|
Source0: https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz |
9 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
10 |
|
|
Requires: ppp |
11 |
|
|
BuildRequires: kernel-headers => 2.6.23 |
12 |
|
|
%if 0%{?el3}%{?el4} |
13 |
|
|
BuildRequires: libpcap |
14 |
|
|
%else |
15 |
|
|
BuildRequires: libpcap-devel |
16 |
|
|
%endif |
17 |
|
|
Obsoletes: l2tpd <= 0.69-0.6.20051030.fc6 |
18 |
|
|
Provides: l2tpd = 0.69-0.6.20051030.fc7 |
19 |
|
|
Requires(post): /sbin/chkconfig |
20 |
|
|
Requires(preun): /sbin/chkconfig |
21 |
|
|
Requires(preun): /sbin/service |
22 |
|
|
|
23 |
|
|
%description |
24 |
|
|
xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661). |
25 |
|
|
L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user |
26 |
|
|
sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP |
27 |
|
|
servers. Another important application is Virtual Private Networks where |
28 |
|
|
the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec, |
29 |
|
|
RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and |
30 |
|
|
Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec |
31 |
|
|
implementations such as Openswan. |
32 |
|
|
Example configuration files for such a setup are included in this RPM. |
33 |
|
|
|
34 |
|
|
xl2tpd works by opening a pseudo-tty for communicating with pppd. |
35 |
|
|
It runs completely in userspace but supports kernel mode L2TP. |
36 |
|
|
|
37 |
|
|
xl2tpd supports IPsec SA Reference tracking to enable overlapping internak |
38 |
|
|
NAT'ed IP's by different clients (eg all clients connecting from their |
39 |
|
|
linksys internal IP 192.168.1.101) as well as multiple clients behind |
40 |
|
|
the same NAT router. |
41 |
|
|
|
42 |
|
|
xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher, |
43 |
|
|
or via a patch in contrib for 2.4.x kernels. |
44 |
|
|
|
45 |
|
|
Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com> |
46 |
|
|
It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003. |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%setup -q |
50 |
|
|
|
51 |
|
|
%build |
52 |
|
|
# Customer test case proved the first make line failed, the second one worked |
53 |
|
|
# the failing one had incoming l2tp packets, but never got a tunnel up. |
54 |
|
|
#make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_PPPD -DDEBUG_CONTROL -DDEBUG_ENTROPY" |
55 |
|
|
make DFLAGS="-g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH" |
56 |
|
|
|
57 |
|
|
%install |
58 |
|
|
rm -rf %{buildroot} |
59 |
|
|
make DESTDIR=%{buildroot} PREFIX=%{_prefix} install |
60 |
|
|
install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf |
61 |
|
|
install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd |
62 |
|
|
install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets |
63 |
|
|
install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample |
64 |
|
|
install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd |
65 |
|
|
install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
%clean |
69 |
|
|
rm -rf %{buildroot} |
70 |
|
|
|
71 |
|
|
%post |
72 |
|
|
/sbin/chkconfig --add xl2tpd |
73 |
|
|
# if we migrate from l2tpd to xl2tpd, copy the configs |
74 |
|
|
if [ -f /etc/l2tpd/l2tpd.conf ] |
75 |
|
|
then |
76 |
|
|
echo "Old /etc/l2tpd configuration found, migrating to /etc/xl2tpd" |
77 |
|
|
mv /etc/xl2tpd/xl2tpd.conf /etc/xl2tpd/xl2tpd.conf.rpmsave |
78 |
|
|
cat /etc/l2tpd/l2tpd.conf | sed "s/options.l2tpd/options.xl2tpd/" > /etc/xl2tpd/xl2tpd.conf |
79 |
|
|
mv /etc/ppp/options.xl2tpd /etc/ppp/options.xl2tpd.rpmsave |
80 |
|
|
mv /etc/ppp/options.l2tpd /etc/ppp/options.xl2tpd |
81 |
|
|
mv /etc/xl2tpd/l2tp-secrets /etc/xl2tpd/l2tpd-secrets.rpmsave |
82 |
|
|
cp -pa /etc/l2tpd/l2tp-secrets /etc/xl2tpd/l2tp-secrets |
83 |
|
|
|
84 |
|
|
fi |
85 |
|
|
|
86 |
|
|
|
87 |
|
|
%preun |
88 |
|
|
if [ $1 -eq 0 ]; then |
89 |
|
|
/sbin/service xl2tpd stop > /dev/null 2>&1 |
90 |
|
|
/sbin/chkconfig --del xl2tpd |
91 |
|
|
fi |
92 |
|
|
|
93 |
|
|
%postun |
94 |
|
|
if [ $1 -ge 1 ]; then |
95 |
|
|
/sbin/service xl2tpd condrestart 2>&1 >/dev/null |
96 |
|
|
fi |
97 |
|
|
|
98 |
|
|
%files |
99 |
|
|
%defattr(-,root,root) |
100 |
|
|
%doc BUGS CHANGES CREDITS LICENSE README.* TODO |
101 |
|
|
%doc doc/README.patents examples/chapsecrets.sample |
102 |
|
|
%attr(0755,root,root) %{_sbindir}/xl2tpd |
103 |
|
|
%attr(0755,root,root) %{_sbindir}/xl2tpd-control |
104 |
|
|
%attr(0755,root,root) %{_bindir}/pfc |
105 |
|
|
%{_mandir}/*/* |
106 |
|
|
%dir %{_sysconfdir}/xl2tpd |
107 |
|
|
%config(noreplace) %{_sysconfdir}/xl2tpd/* |
108 |
|
|
%config(noreplace) %{_sysconfdir}/ppp/* |
109 |
|
|
%attr(0755,root,root) %{_initrddir}/xl2tpd |
110 |
|
|
%dir %{_localstatedir}/run/xl2tpd |
111 |
|
|
%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control |
112 |
|
|
|
113 |
|
|
%changelog |
114 |
|
|
* Sun Oct 26 2008 Paul Wouters <paul@xelerance.com> 1.2.2-1 |
115 |
|
|
- Updated Suse init scripts and spec file |
116 |
|
|
- Added pfc for pppd's precompiled-active-filter |
117 |
|
|
|
118 |
|
|
* Tue Jun 26 2007 Paul Wouters <paul@xelerance.com> 1.1.11-1 |
119 |
|
|
- Minor changes to spec file to accomodate new README files |
120 |
|
|
|
121 |
|
|
* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1 |
122 |
|
|
- Upgraded to 1.1.08 |
123 |
|
|
- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM |
124 |
|
|
|
125 |
|
|
* Mon Feb 19 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2 |
126 |
|
|
- Upgraded to 1.1.07 |
127 |
|
|
- Fixes from Tuomo Soini for pidfile handling with Fedora |
128 |
|
|
- Fix hardcoded version for Source in spec file. |
129 |
|
|
|
130 |
|
|
* Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5 |
131 |
|
|
- Changed space/tab replacing method |
132 |
|
|
|
133 |
|
|
* Wed Dec 6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4 |
134 |
|
|
- Added -p to keep original timestamps |
135 |
|
|
- Added temporary hack to change space/tab in init file. |
136 |
|
|
- Added /sbin/service dependancy |
137 |
|
|
|
138 |
|
|
* Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3 |
139 |
|
|
- Added Requires(post) / Requires(preun) |
140 |
|
|
- changed init file to create /var/run/xl2tpd fixed a tab/space |
141 |
|
|
- changed control file to be within /var/run/xl2tpd/ |
142 |
|
|
|
143 |
|
|
* Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2 |
144 |
|
|
- Changed Mr. Karlsen's name to not be a utf8 problem |
145 |
|
|
- Fixed Obosoletes/Provides to be more specific wrt l2tpd. |
146 |
|
|
- Added dist tag which accidentally got deleted. |
147 |
|
|
|
148 |
|
|
* Mon Dec 4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1 |
149 |
|
|
- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name |
150 |
|
|
|
151 |
|
|
* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030 |
152 |
|
|
- Pulled up sourceforget.net CVS fixes. |
153 |
|
|
- various debugging added, but debugging should not be on by default. |
154 |
|
|
- async/sync conversion routines must be ready for possibility that the read |
155 |
|
|
will block due to routing loops. |
156 |
|
|
- refactor control socket handling. |
157 |
|
|
- move all logic about pty usage to pty.c. Try ptmx first, if it fails try |
158 |
|
|
legacy ptys |
159 |
|
|
- rename log() to l2tp_log(), as "log" is a math function. |
160 |
|
|
- if we aren't deamonized, then log to stderr. |
161 |
|
|
- added install: and DESTDIR support. |
162 |
|
|
|
163 |
|
|
* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13 |
164 |
|
|
- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines |
165 |
|
|
|
166 |
|
|
* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl |
167 |
|
|
- Added log() patch by Paul Wouters so that l2tpd compiles on FC4. |
168 |
|
|
|
169 |
|
|
* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl> |
170 |
|
|
- l2tpd.org has been hijacked. Project moved back to SourceForge: |
171 |
|
|
http://l2tpd.sourceforge.net |
172 |
|
|
|
173 |
|
|
* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl> |
174 |
|
|
- Small Makefile fixes. Explicitly use gcc instead of cc. |
175 |
|
|
Network services library was not linked on Solaris due to typo. |
176 |
|
|
|
177 |
|
|
* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl |
178 |
|
|
- Choosing between SysV or BSD style ptys is now configurable through |
179 |
|
|
a compile-time boolean "unix98pty". |
180 |
|
|
|
181 |
|
|
* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl> |
182 |
|
|
- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys. |
183 |
|
|
Requires the N_HDLC kernel module. |
184 |
|
|
|
185 |
|
|
* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl> |
186 |
|
|
- Updated the README. |
187 |
|
|
|
188 |
|
|
* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl |
189 |
|
|
- Patch by Marald Klein and Roger Luethi. Fixes writing PID file. |
190 |
|
|
(http://l2tpd.graffl.net/msg01790.html) |
191 |
|
|
Long overdue. Rereleasing 10jdl. |
192 |
|
|
|
193 |
|
|
* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl |
194 |
|
|
- [SECURITY FIX] Added fix from Debian because of a bss-based |
195 |
|
|
buffer overflow. |
196 |
|
|
(http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html) |
197 |
|
|
- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration |
198 |
|
|
directories /etc/{freeswan,openswan,strongswan}. Install our |
199 |
|
|
configuration files to /etc/ipsec.d and create symbolic links in |
200 |
|
|
those directories. |
201 |
|
|
|
202 |
|
|
* Tue Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl> |
203 |
|
|
- Removed 'leftnexthop=' lines. Not relevant for recent versions |
204 |
|
|
of FreeS/WAN and derivates. |
205 |
|
|
|
206 |
|
|
* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-9jdl |
207 |
|
|
- Added "noccp" because of too much MPPE/CCP messages sometimes. |
208 |
|
|
|
209 |
|
|
* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl> |
210 |
|
|
- Added patch in order to prevent StopCCN messages. |
211 |
|
|
|
212 |
|
|
* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl> |
213 |
|
|
- MTU/MRU 1410 seems to be the lowest possible for MSL2TP. |
214 |
|
|
For Windows 2000/XP it doesn't seem to matter. |
215 |
|
|
- Typo in l2tpd.conf (192.168.128/25). |
216 |
|
|
|
217 |
|
|
* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-8jdl |
218 |
|
|
- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal |
219 |
|
|
value but some apps had problems with the default value. |
220 |
|
|
|
221 |
|
|
* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl> |
222 |
|
|
- Added workaround for the missing hostname bug in the MSL2TP client |
223 |
|
|
('Specify your hostname', error 629: "You have been disconnected |
224 |
|
|
from the computer you are dialing"). |
225 |
|
|
|
226 |
|
|
* Thu Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-7jdl |
227 |
|
|
- Added the "listen-addr" global parameter for l2tpd.conf. By |
228 |
|
|
default, the daemon listens on *all* interfaces. Use |
229 |
|
|
"listen-addr" if you want it to bind to one specific |
230 |
|
|
IP address (interface), for security reasons. (See also: |
231 |
|
|
http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning) |
232 |
|
|
- Explained in l2tpd.conf that two different IP addresses should be |
233 |
|
|
used for 'listen-addr' and 'local ip'. |
234 |
|
|
- Modified init script. Upgrades should work better now. You |
235 |
|
|
still need to start/chkconfig l2tpd manually. |
236 |
|
|
- Renamed the example Openswan .conf files to better reflect |
237 |
|
|
the situation. There are two variants using different portselectors. |
238 |
|
|
Previously I thought Windows 2000/XP used portselector 17/0 |
239 |
|
|
and the rest used 17/1701. But with the release of an updated |
240 |
|
|
IPsec client by Microsoft, it turns out that 17/0 must have |
241 |
|
|
been a mistake: the updated client now also uses 17/1701. |
242 |
|
|
|
243 |
|
|
* Mon Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-6jdl |
244 |
|
|
- Changed sample chap-secrets to be valid only for specific |
245 |
|
|
IP addresses. |
246 |
|
|
|
247 |
|
|
* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de> |
248 |
|
|
- Adjustments for SuSE8.x (thanks, Bernhard!) |
249 |
|
|
- Added sample chap-secrets. |
250 |
|
|
|
251 |
|
|
* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl |
252 |
|
|
- Replaced Dominique's patch by Damion de Soto's, which does not |
253 |
|
|
depend on the N_HDLC kernel module. |
254 |
|
|
|
255 |
|
|
* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl |
256 |
|
|
- Seperate example config files for Win9x (MSL2TP) and Win2K/XP |
257 |
|
|
due to left/rightprotoport differences. |
258 |
|
|
Fixing preun for Red Hat. |
259 |
|
|
|
260 |
|
|
* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl |
261 |
|
|
- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/ |
262 |
|
|
Error fixed: source6 was used for both PSK and CERT. |
263 |
|
|
|
264 |
|
|
* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl |
265 |
|
|
- Added Dominique Cressatti's pty patch in another attempt to |
266 |
|
|
prevent the Windows 2000 Professional "loopback detected" error. |
267 |
|
|
Seems to work! |
268 |
|
|
|
269 |
|
|
* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl |
270 |
|
|
- Added 'connect-delay' to PPP parameters in an attempt to |
271 |
|
|
prevent the Windows 2000 Professional "loopback detected" error. |
272 |
|
|
Didn't seem to work. |
273 |
|
|
|
274 |
|
|
* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl |
275 |
|
|
- Did not build on Red Hat 8.0. Solved by adding comments(?!). |
276 |
|
|
Bug detected in spec file: chkconfig --list l2tpd does not work |
277 |
|
|
on Red Hat 8.0. Not important enough to look into yet. |
278 |
|
|
|
279 |
|
|
* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl |
280 |
|
|
- Tested on Red Hat, required some changes. No gprintf. Used different |
281 |
|
|
pty patch, otherwise wouldn't run. Added buildroot sanity check. |
282 |
|
|
|
283 |
|
|
* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl> |
284 |
|
|
- Specfile adapted from Mandrake Cooker. The original RPM can be |
285 |
|
|
retrieved through: |
286 |
|
|
http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd |
287 |
|
|
- Config path changed from /etc/l2tp/ to /etc/l2tpd/ |
288 |
|
|
(Seems more logical and rp-l2tp already uses /etc/l2tp/). |
289 |
|
|
- Do not run at boot or install. The original RPM uses a config file |
290 |
|
|
which is completely commented out, but it still starts l2tpd on all |
291 |
|
|
interfaces. Could be a security risk. This RPM does not start l2tpd, |
292 |
|
|
the sysadmin has to edit the config file and start l2tpd explicitly. |
293 |
|
|
- Renamed patches to start with l2tpd- |
294 |
|
|
- Added dependencies for pppd, glibc-devel. |
295 |
|
|
- Use %%{name} as much as possible. |
296 |
|
|
- l2tp-secrets contains passwords, thus should not be world readable. |
297 |
|
|
- Removed dependency on rpm-helper. |
298 |
|
|
|
299 |
|
|
* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk |
300 |
|
|
- from Per 0yvind Karlsen <peroyvind@delonic.no> : |
301 |
|
|
- PreReq and Requires |
302 |
|
|
- Fix preun_service |
303 |
|
|
|
304 |
|
|
* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk |
305 |
|
|
- Move l2tpd from /usr/bin to /usr/sbin |
306 |
|
|
- Added SysV initscript |
307 |
|
|
- Patch0 |
308 |
|
|
- Patch1 |
309 |
|
|
|
310 |
|
|
* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk |
311 |
|
|
- Initial release |