/[smeserver]/rpms/LPRng/sme7/LPRng.spec
ViewVC logotype

Annotation of /rpms/LPRng/sme7/LPRng.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 16:31:11 2007 UTC (17 years ago) by slords
Branch: MAIN
CVS Tags: LPRng-3_8_29-3_el4_sme
Import on branch sme7 of package LPRng-3.8.29-3.el4.sme.src.rpm

1 slords 1.1 #$Id: LPRng.spec,v 1.3 2005/04/27 18:59:49 dominik Exp $
2    
3     Summary: The LPRng print spooler.
4     Name: LPRng
5     Version: 3.8.29
6     Release: 3%{?dist}
7     %define nokerberos 1
8     License: GPL and Artistic
9     Group: System Environment/Daemons
10     Source0: ftp://ftp.lprng.com/pub/LPRng/LPRng/%{name}-%{version}-RC2.tar.gz
11     Source1: lpd.init
12     Patch0: LPRng-3.8.4-nonblock.patch
13     Patch1: LPRng-3.7.4-lpd-perms.patch
14     Patch2: LPRng-3.8.15-krb5.patch
15     URL: http://www.lprng.com
16     Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
17     Obsoletes: lpr
18     Provides: lpr
19     Provides: lpd
20     Prereq: /etc/rc.d/init.d, mktemp, fileutils, textutils, gawk
21     Prereq: /usr/sbin/alternatives
22     # Alternatives is provided by chkconfig at the moment. 1.3.4 is the
23     # minimum we need (see bug #62342).
24     PreReq: chkconfig >= 1.3.4-1
25     BuildPreReq: gettext ed autoconf
26     BuildPrereq: krb5-devel
27    
28     # We don't ship these files, but create symlinks to them. Other
29     # packages aren't to know though.
30     Provides: %{_bindir}/lp
31     Provides: %{_bindir}/lpq
32     Provides: %{_bindir}/lpr
33     Provides: %{_bindir}/lprm
34     Provides: %{_bindir}/lpstat
35     Provides: %{_bindir}/cancel
36     Provides: %{_sbindir}/lpc
37    
38     %description
39     LPRng is an enhanced, extended, and portable implementation of the
40     Berkeley LPR print spooler functionality. LPRng provides the same
41     interface and meeting RFC1179 requirements, but the implementation is
42     completely new and provides support for the following features:
43     lightweight (no databases needed) lpr, lpc, and lprm programs; dynamic
44     redirection of print queues; automatic job holding; highly verbose
45     diagnostics; multiple printers serving a single queue; client programs
46     do not need to run SUID root; greatly enhanced security checks; and a
47     greatly improved permission and authorization mechanism.
48    
49     LPRng is compatible with other print spoolers and network printers
50     that use the LPR interface and meet RFC1179 requirements. LPRng
51     provides emulation packages for the SVR4 lp and lpstat programs,
52     eliminating the need for another print spooler package. These
53     emulation packages can be modified according to local requirements, in
54     order to support vintage printing systems.
55    
56     For users who require secure and/or authenticated printing support,
57     LPRng supports Kerberos V, MIT Kerberos IV Print Support, and PGP
58     authentication. Additional authentication support is extremely simple
59     to add.
60    
61     %package devel
62     Summary: The LPRng print spooler - devel/static libs
63     Group: Development/Libraries
64     Requires: %{name} = %{epoch}:%{version}
65    
66     %description devel
67     This package contains the libtool files and the static version of LPRng's
68     liblpr.
69    
70     %prep
71     %setup -q
72     %patch0 -p1 -b .nonblock
73     # Remove remote job submissions
74     #%patch1 -p1 -b .lpd-perms
75     #%patch2 -p1 -b .krb5
76    
77     %build
78     test -f /usr/share/libtool/config.guess && cp /usr/share/libtool/config.guess .
79     test -f /usr/share/libtool/config.sub && cp /usr/share/libtool/config.sub .
80     CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
81     PSHOWALL="-ax" ; export PSHOWALL # So that we don't need /proc mounted
82     %configure --enable-nls \
83     --with-userid=lp \
84     --with-groupid=lp \
85     --enable-shared \
86     --disable-gdbm \
87     --disable-strip \
88     --disable-werror \
89     %{!?nokerberos:--enable-kerberos}
90     make MAKEPACKAGE=YES
91    
92     %install
93     rm -rf %{buildroot}
94     make SUID_ROOT_PERMS=" 04755" DESTDIR=${RPM_BUILD_ROOT} MAKEPACKAGE=YES mandir=%{_mandir} install
95     %__cp src/monitor ${RPM_BUILD_ROOT}%{_prefix}/sbin/monitor
96    
97     # Remove files we don't ship
98     rm -f %{buildroot}%{_sysconfdir}/*.sample
99     rm -f %{buildroot}%{_sysconfdir}/lpd/*.sample
100     rm -f %{buildroot}%{_sysconfdir}/lpd/lpd
101     rm -f %{buildroot}%{_sysconfdir}/printcap
102     #rm -f %{buildroot}%{_libdir}/liblpr.*a
103     rm -f %{buildroot}%{_sbindir}/lprng_{index_,}certs
104    
105     # install init script
106     mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
107     install -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/lpd
108    
109     # Adjust defaults
110     mkdir -p %{buildroot}%{_sysconfdir}/lpd
111     install -m644 src/lpd.conf %{buildroot}%{_sysconfdir}/lpd
112     cat << EOF | ed %{buildroot}%{_sysconfdir}/lpd/lpd.conf
113     /default mc=/a
114     mc#128
115     .
116     wq
117     EOF
118     install -m644 conf/lpd.perms %{buildroot}%{_sysconfdir}/lpd
119    
120     # Alternatives, to avoid conflicting with cups.
121     for f in %{_bindir}/{cancel,lp,lp{q,r,rm,stat}} %{_sbindir}/lpc
122     do
123     mv %{buildroot}${f} %{buildroot}${f}.LPRng
124     done
125     for f in cancel lp lpq lpr lprm lpstat
126     do
127     mv %{buildroot}%{_mandir}/man1/${f}.1 %{buildroot}%{_mandir}/man1/${f}-LPRng.1
128     done
129     mv %{buildroot}%{_mandir}/man8/lpc.8 %{buildroot}%{_mandir}/man8/lpc-LPRng.8
130    
131     %find_lang %{name}
132    
133     %clean
134     rm -rf %{buildroot}
135    
136     %post
137     /sbin/ldconfig
138     /sbin/chkconfig --add lpd
139     if [ -w /etc/printcap ] ; then
140     TMP1=`mktemp /etc/printcap.XXXXXX`
141     gawk '
142     BEGIN { first = 1; cont = 0; last = "" }
143     /^[:space:]*#/ { if(cont) sub("\\\\$", "", last)}
144     { if(first == 0) print last }
145     { first = 0 }
146     { last = $0 }
147     { cont = 0 }
148     /\\$/ { cont = 1 }
149     END {sub("\\\\$", "", last); print last}
150     ' /etc/printcap > ${TMP1} && cat ${TMP1} > /etc/printcap && rm -f ${TMP1}
151     fi
152    
153     # Alternatives
154     /usr/sbin/alternatives --install %{_bindir}/lpr print %{_bindir}/lpr.LPRng 41 \
155     --slave %{_bindir}/lp print-lp %{_bindir}/lp.LPRng \
156     --slave %{_bindir}/lpq print-lpq %{_bindir}/lpq.LPRng \
157     --slave %{_bindir}/lprm print-lprm %{_bindir}/lprm.LPRng \
158     --slave %{_bindir}/lpstat print-lpstat %{_bindir}/lpstat.LPRng \
159     --slave %{_bindir}/cancel print-cancel %{_bindir}/cancel.LPRng \
160     --slave %{_sbindir}/lpc print-lpc %{_sbindir}/lpc.LPRng \
161     --slave %{_mandir}/man1/cancel.1.gz print-cancelman %{_mandir}/man1/cancel-LPRng.1.gz \
162     --slave %{_mandir}/man1/lp.1.gz print-lpman %{_mandir}/man1/lp-LPRng.1.gz \
163     --slave %{_mandir}/man8/lpc.8.gz print-lpcman %{_mandir}/man8/lpc-LPRng.8.gz \
164     --slave %{_mandir}/man1/lpq.1.gz print-lpqman %{_mandir}/man1/lpq-LPRng.1.gz \
165     --slave %{_mandir}/man1/lpr.1.gz print-lprman %{_mandir}/man1/lpr-LPRng.1.gz \
166     --slave %{_mandir}/man1/lprm.1.gz print-lprmman %{_mandir}/man1/lprm-LPRng.1.gz \
167     --slave %{_mandir}/man1/lpstat.1.gz print-lpstatman %{_mandir}/man1/lpstat-LPRng.1.gz \
168     --initscript lpd
169    
170     %preun
171     if [ "$1" = 0 ]; then
172     /sbin/service lpd stop >/dev/null 2>&1
173     /sbin/chkconfig --del lpd
174     /usr/sbin/alternatives --remove print %{_bindir}/lpr.LPRng
175     fi
176    
177     %postun
178     /sbin/ldconfig
179     if [ "$1" -ge "1" ]; then
180     /sbin/service lpd condrestart >/dev/null 2>&1
181     fi
182    
183     %triggerpostun -- LPRng < 3.8.5-2
184     # Deal with pre-alternatives packages
185     /usr/sbin/alternatives --auto print
186    
187     %files -f %{name}.lang
188     %defattr(644,root,root,755)
189     %doc CHANGES CONTRIBUTORS COPYRIGHT INSTALL LICENSE
190     %doc README*
191     #%doc DOCS/LPRng-Reference.html DOCS/*.jpg
192     %dir %{_sysconfdir}/lpd
193     %config(noreplace) %{_sysconfdir}/lpd/lpd.conf
194     %config(noreplace) %{_sysconfdir}/lpd/lpd.perms
195     %attr(755,root,root) %config %{_sysconfdir}/rc.d/init.d/lpd
196     %{_mandir}/*/*
197     %attr(755,lp,lp) %{_bindir}/cancel.LPRng
198     %attr(755,lp,lp) %{_bindir}/lp.LPRng
199     %attr(755,lp,lp) %{_bindir}/lpq.LPRng
200     %attr(755,lp,lp) %{_bindir}/lprm.LPRng
201     %attr(755,lp,lp) %{_bindir}/lpr.LPRng
202     %attr(755,lp,lp) %{_bindir}/lpstat.LPRng
203     %{_bindir}/lp.LPRng
204     %{_bindir}/cancel.LPRng
205     %attr(755,lp,lp) %{_sbindir}/lpc.LPRng
206     %attr(755,root,root) %{_sbindir}/lpd
207     %attr(755,root,root) %{_sbindir}/checkpc
208     %attr(755,root,root) %{_sbindir}/monitor
209     #%attr(755,root,root) %{_libdir}/*.so.*
210     %dir /usr/libexec/filters
211     %attr(755,root,root) /usr/libexec/filters/*
212    
213     %files devel
214     %defattr(644,root,root,755)
215     #%{_libdir}/*.so
216     #%{_libdir}/liblpr.a
217     #%attr(755,root,root) %{_libdir}/liblpr.la
218    
219     %changelog
220     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
221     - Clean up spec so package can be built by koji/plague
222    
223     * Thu Apr 05 2007 Shad L. Lords <slords@mail.com> 3.8.29-3
224     - Add missing lp and cancel to files section [SME: 2714]
225    
226     * Thu Mar 22 2007 Shad L. Lords <slords@mail.com> 3.8.29-2
227     - Clean cb from relase numbering.
228    
229     * Thu Mar 22 2007 Charlie Brady <charlieb@e-smith.com> 3.8.29-1
230     - Switch to new upstream source, and fix for build on CentOS5. [SME: 2509]
231    
232     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
233     - Update to new release naming. No functional changes.
234     - Make Packager generic
235    
236     * Wed Apr 27 2005 Dominik Mierzejewski <dominik@rangers.eu.org> 3.8.28-2
237     - 3.8.28
238     - fix compilation (bad include path)
239     - new conf file dir (/etc/lpd/)
240     - cups thinks it's better, let's fix it
241    
242     * Wed Apr 9 2003 Tim Waugh <twaugh@redhat.com> 3.8.19-3.1
243     - Fix temporary file vulnerability in psbanner.
244    
245     * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 3.8.19-3
246     - Fix localedir (bug #82492).
247    
248     * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 3.8.19-2
249     - rebuilt
250    
251     * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 3.8.19-1
252     - 3.8.19 (bug #81970).
253     - No longer need werror patch.
254    
255     * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 3.8.15-4
256     - Rebuild
257    
258     * Fri Dec 20 2002 Tim Waugh <twaugh@redhat.com> 3.8.15-3
259     - Make 'service lpd reload' update the configuration first (bug #79953).
260    
261     * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 3.8.15-2
262     - Change build requirement from autoconf253 to autoconf.
263    
264     * Thu Nov 7 2002 Tim Waugh <twaugh@redhat.com> 3.8.15-1
265     - Updated krb5 patch.
266     - 3.8.15.
267     - Removed manpage, jobfilescan, pr patches: no longer needed.
268     - Updated werror patch.
269     - Don't install files not shipped.
270     - Use %%find_lang.
271    
272     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
273     - automated rebuild
274    
275     * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 3.8.9-5
276     - Rebuild in new environment.
277    
278     * Thu May 16 2002 Tim Waugh <twaugh@redhat.com> 3.8.9-4
279     - Reject remote job submissions by default.
280    
281     * Tue Apr 2 2002 Tim Waugh <twaugh@redhat.com> 3.8.9-3
282     - PreReq chkconfig 1.3.4-1 or later (bug #62342).
283     - Don't strip binaries by default during build/install.
284    
285     * Tue Mar 12 2002 Tim Waugh <twaugh@redhat.com> 3.8.9-2
286     - AC_C_VOLATILE comes from autoconf 2.52. Use it.
287    
288     * Mon Mar 11 2002 Tim Waugh <twaugh@redhat.com> 3.8.9-1
289     - 3.8.9.
290     - Patch to fix bug #55376 reverted (documentation now corrected).
291     - Remove AC_C_VOLATILE (doesn't seem to be defined).
292     - Conflict with chkconfig < 1.3.1 (alternatives --initscript).
293    
294     * Fri Mar 8 2002 Bill Nottingham <notting@redhat.com> 3.8.7-3
295     - use alternatives --initscript support
296    
297     * Thu Feb 28 2002 Bill Nottingham <notting@redhat.com> 3.8.7-2
298     - agree with cups about alternative name for lpr man page
299     - move alternatives removal to %preun
300    
301     * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 3.8.7-1
302     - 3.8.7.
303     - No longer need coredump patch.
304    
305     * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 3.8.5-4
306     - Rebuild in new environment.
307    
308     * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 3.8.5-3
309     - Better default for maximum copies (bug #59433).
310     - Skip over non-existent entries, like the documentation says we
311     do (bug #55376).
312    
313     * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 3.8.5-2
314     - Don't conflict with other print spoolers.
315    
316     * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 3.8.5-1
317     - 3.8.5.
318     - Stop lpstat from dumping core.
319    
320     * Mon Jan 21 2002 Tim Waugh <twaugh@redhat.com> 3.8.4-1
321     - 3.8.4 (bug #35636, bug #47865).
322     - Drop explicit 'Requires: krb5', since it is picked up automatically
323     (bug #57458).
324     - Patches no longer needed: lockfile, nointl, inet_ntop, shutdown, direct,
325     setgroup, s390,
326     - Fix path to pr (bug #39130).
327     - HOWTO GIFs now replaced by JPEGs.
328    
329     * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 3.7.4-30
330     - automated rebuild
331    
332     * Wed Jan 02 2002 Florian La Roche <Florian.LaRoche@redhat.de> 3.7.4-29
333     - require krb5 instead of krb5-libs
334    
335     * Fri Aug 10 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.7.4-28
336     - disabled gdbm support, changed CFLAGS; #41652
337    
338     * Thu Aug 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.7.4-27
339     - ownz /usr/libexec/filters; #51158
340     - make checkpc nonblocking on its tests; #37995
341    
342     * Thu Aug 2 2001 Crutcher Dunnavant <crutcher@redhat.com> 3.7.4-26
343     - added gdbm-devel dep; #44885
344    
345     * Fri Jun 29 2001 Bernhard Rosenkraenzer <bero@redhat.com>
346     - Fix build on s390
347    
348     * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
349     - Bump release + rebuild.
350    
351     * Thu Jun 07 2001 Crutcher Dunnavant <crutcher@redhat.com>
352     - setgroups droping patch
353    
354     * Thu Mar 29 2001 Crutcher Dunnavant <crutcher@redhat.com>
355     - told checkpc to only Check_file() job files. (keeping it from zapping the master-filter)
356    
357     * Fri Mar 9 2001 Crutcher Dunnavant <crutcher@redhat.com>
358     - applied elliot's patch (which i got idependently from the lprng list as well)
359     - that fixes a thinko that killed LPRng on 64 arches.
360    
361     * Fri Mar 9 2001 Crutcher Dunnavant <crutcher@redhat.com>
362     - fixed the URLs for the LPRng project
363    
364     * Thu Mar 8 2001 Crutcher Dunnavant <crutcher@redhat.com>
365     - reverted the shutdown call in Local_job to make device filters work.
366     - all your base are belong to us
367    
368     * Wed Mar 07 2001 Philipp Knirsch <pknirsch@redhat.de>
369     - Removed the shutdown patch for common/linksupport:Link_close() as ii
370     generated a deadlock between lpr and lpd for none existing printers.
371    
372     * Sun Feb 25 2001 Crutcher Dunnavant <crutcher@redhat.com>
373     - hacked out the shutdown(sock, 1) calls that killed stupid network printers.
374    
375     * Wed Feb 15 2001 Crutcher Dunnavant <crutcher@redhat.com>
376     - tweak to ldp.init's display messages
377    
378     * Fri Feb 9 2001 Crutcher Dunnavant <crutcher@redhat.com>
379     - man page tweak
380    
381     * Thu Feb 8 2001 Crutcher Dunnavant <crutcher@redhat.com>
382     - (yet) further tweaks to lpd.init's display format.
383    
384     * Tue Feb 6 2001 Crutcher Dunnavant <crutcher@redhat.com>
385     - further tweaks to lpd.init's display format.
386    
387     * Tue Feb 6 2001 Crutcher Dunnavant <crutcher@redhat.com>
388     - cleaned up lpd.init to do translations correctly, and stop screwing up
389     - result values.
390    
391     * Thu Feb 1 2001 Crutcher Dunnavant <crutcher@redhat.com>
392     - added lpd init back (ick!)
393    
394     * Wed Jan 24 2001 Crutcher Dunnavant <crutcher@redhat.com>
395     - removed req for printconf (It should go the other way)
396    
397     * Thu Jan 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
398     - fixed file list
399    
400     * Thu Jan 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
401     - removed lpd.init, set requirement of printconf
402    
403     * Thu Jan 11 2001 Crutcher Dunnavant <crutcher@redhat.com>
404     - upgraded to LPRng-3.7.4
405    
406     * Tue Dec 12 2000 Crutcher Dunnavant <crutcher@redhat.com>
407     - rebuild for kerb
408    
409     * Mon Oct 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
410     - Upgraded to LPRng-3.6.26
411     - Removed syslog patch, as .24 fixes the problem
412    
413     * Mon Sep 25 2000 Crutcher Dunnavant <crutcher@redhat.com>
414     - Patched use_syslog to avoid a format string exploit.
415     - Resolves bug #17756
416    
417     * Mon Sep 18 2000 Crutcher Dunnavant <crutcher@redhat.com>
418     - Upgraded to LPRng-3.6.24
419    
420     * Mon Sep 11 2000 Crutcher Dunnavant <crutcher@redhat.com>
421     - Added gettext to the BuildPreReq list
422    
423     * Mon Sep 11 2000 Crutcher Dunnavant <crutcher@redhat.com>
424     - Fixed lpd.init to use /etc/rc.d/init.d/, instead of /etc/init.d
425    
426     * Mon Sep 11 2000 Crutcher Dunnavant <crutcher@redhat.com>
427     - changed the prereq: /etc/init.d to: /etc/rc.d/init.d
428     - we are not changing that over (yet?)
429    
430     * Mon Aug 14 2000 Crutcher Dunnavant <crutcher@redhat.com>
431     - removed the sticky bit from lpc
432    
433     * Mon Aug 14 2000 Crutcher Dunnavant <crutcher@redhat.com>
434     - removed the sticky bit from the client programs (LPRng doesn't need them)
435    
436     * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
437     - condrestart fixes
438    
439     * Fri Aug 4 2000 Bill Nottingham <notting@redhat.com>
440     - triggerpostun on lpr
441    
442     * Sun Jul 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
443     - 3.6.22 (some fixes)
444    
445     * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
446     - fix prereq
447    
448     * Sat Jul 22 2000 Nalin Dahyabhai <nalin@redhat.com>
449     - fix bogus checkpc error messages when the lockfile doesn't exist because
450     init scripts clear /var/run (#14472)
451    
452     * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
453     - fix chkconfig comments in the init script
454    
455     * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
456     - move the init script to /etc/rc.d/init.d
457     - fix perms on setuid binaries
458    
459     * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
460     - patch checkpc to not complain when filter is executable and in the
461     spool directory
462     - remove --disable-force_localhost from configure invocation for better
463     compatibility with BSD LPR and rhs-printfilters
464     - change group back to lp, which is what printtool expects
465    
466     * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
467     - change default group to 'daemon' to match 6.2
468     - enable NLS support
469     - remove Prefix: tag
470     - break init script out into a separate file
471     - fix up broken printcaps in post-install
472     - run checkpc -f at start-time
473    
474     * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
475     - automatic rebuild
476    
477     * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
478     - 3.6.21
479     - get rid of the notypedef patch - gcc has been fixed at last.
480    
481     * Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
482     - sample config files removed from /etc.
483     - initscript moved to /etc/init.d
484    
485     * Wed Jun 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
486     - 3.6.18
487    
488     * Sat Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
489     - 3.6.16
490     - adapt Kerberos and fixmake patches
491     - get rid of CFLAGS="-O"; gcc has been fixed
492     - fix build with glibc 2.2
493    
494     * Mon Jun 05 2000 Preston Brown <pbrown@redhat.com>
495     - ifdef 0 is illegal, changed to if 0.
496     - work around compiler typdef bug.
497    
498     * Thu Jun 01 2000 Preston Brown <pbrown@redhat.com>
499     - start, stop, and restart are functions not switch statements now.
500     reduces overhead.
501     - patch to allow autoconf to choose which user/group to run as
502    
503     * Wed May 31 2000 Preston Brown <pbrown@redhat.com>
504     - remove init.d symbolic links.
505     - remove txt/ps/info versions of the HOWTO from the pkg
506     - use new fhs paths
507    
508     * Thu May 25 2000 Nalin Dahyabhai <nalin@redhat.com>
509     - change free() to krb5_free_data_contents() when patching for Kerberos 5
510     - detect libcrypto or libk5crypto when looking for Kerberos 5
511    
512     * Tue May 16 2000 Nalin Dahyabhai <nalin@redhat.com>
513     - enable Kerberos support
514     - remove extra defattr in files list
515     - add --disable-force_localhost to configure invocation
516     - remove "-o root" at install-time
517    
518     * Tue May 16 2000 Matt Wilson <msw@redhat.com>
519     - add Prereq of /sbin/chkconfig
520     - fix broken conflicting declaration on alpha
521    
522     * Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
523     - initial Red Hat packaging, fix up the spec file
524    
525     * Mon Sep 13 1999 Patrick Powell <papowell@astart.com>
526     - resolved problems with symbolic links to /etc/init.d
527     files - used the chkconfig facility
528    
529     * Sat Sep 4 1999 Patrick Powell <papowell@astart.com>
530     - did ugly things to put the script in the spec file
531    
532     * Sat Aug 28 1999 Giulio Orsero <giulioo@tiscalinet.it>
533     - 3.6.8
534    
535     * Fri Aug 27 1999 Giulio Orsero <giulioo@tiscalinet.it>
536     - 3.6.7 First RPM build.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed