/[smeserver]/rpms/appletalk-kmod/sme7/appletalk-kmod.spec
ViewVC logotype

Annotation of /rpms/appletalk-kmod/sme7/appletalk-kmod.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.23 - (hide annotations) (download)
Tue May 26 17:12:40 2009 UTC (15 years, 1 month ago) by slords
Branch: MAIN
CVS Tags: appletalk-kmod-1_0-4_el4_sme
Changes since 1.22: +62 -32 lines
Update to kABI tracking module

1 slords 1.23 # $Id: appletalk-kmod.spec,v 1.22 2009/05/02 10:09:04 bytegw Exp $
2    
3     # Define the kmod package name here.
4     %define kmod_name appletalk
5 slords 1.10
6 slords 1.1 # hint: this can he overridden with "--define kversion foo" on the rpmbuild command line, e.g.
7     # --define "kversion 2.6.16-1.2096_FC5"
8 slords 1.23 %{!?kversion: %define kversion 2.6.9-78.0.22.EL}
9 slords 1.1
10 slords 1.23 Name: %{kmod_name}-kmod
11     Version: 1.0
12     Release: 4%{?dist}
13     Group: System Environment/Kernel
14     License: GPL
15     Summary: %{kmod_name} kernel modules
16    
17     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18     ExclusiveArch: i586 i686 x86_64
19    
20     # Sources.
21     Source0: %{kmod_name}-%{version}-src.tgz
22     Source10: kmodtool-%{kmod_name}
23 slords 1.1
24 slords 1.23 # Define the variants for each architecture.
25 slords 1.1 %define upvar ""
26 slords 1.23 %define smpvar smp
27 slords 1.1 %ifarch i686
28     %define hugememvar hugemem
29     %define xenvar xenU
30     %endif
31     %ifarch x86_64
32     %define largesmpvar largesmp
33     %define xenvar xenU
34     %endif
35 slords 1.23
36     # If kvariants isn't defined on the rpmbuild line, build all variants for this architecture.
37     %{!?kvariants: %define kvariants %{?upvar} %{?smpvar} %{?xenvar} %{?hugememvar} %{?largesmpvar}}
38    
39     # Magic hidden here.
40     %define kmodtool sh %{SOURCE10}
41     %{expand:%(%{kmodtool} rpmtemplate_kmp %{kmod_name} %{kversion} %{kvariants} 2>/dev/null)}
42 slords 1.1
43     %description
44     %{summary}.
45    
46     %prep
47     %setup -q -c
48     for kvariant in %{kvariants} ; do
49     cp -a %{kmod_name} _kmod_build_$kvariant
50     if [ "$kvariant" == "xenU" ]; then
51     echo 'obj-$(CONFIG_ATALK) += psnap.o llc.o' >> _kmod_build_$kvariant/Makefile
52     echo 'llc-y := llc_core.o llc_input.o llc_output.o' >> _kmod_build_$kvariant/Makefile
53     fi
54     done
55    
56     %build
57     for kvariant in %{kvariants} ; do
58 slords 1.23 # ksrc=%{_usrsrc}/kernels/%{kversion}${kvariant:+-$kvariant}-%{_target_cpu}
59     # pushd _kmod_build_$kvariant
60     # make -C "${ksrc}" modules M=$PWD
61     # popd
62     ksrc=/lib/modules/"%{kversion}${kvariant:+$kvariant}"/build
63     cd _kmod_build_$kvariant
64     # make TOPDIR=${ksrc} modules %{?_smp_mflags}
65     make -C "${ksrc}" SUBDIRS=${PWD} CONFIG_ATALK=m CONFIG_PROC_FS=y CONFIG_SYSCTL=y modules %{?_smp_mflags}
66     cd ..
67     done
68    
69     %install
70     export INSTALL_MOD_PATH=$RPM_BUILD_ROOT
71     export INSTALL_MOD_DIR=extra/%{kmod_name}
72     for kvariant in %{kvariants} ; do
73     # ksrc=%{_usrsrc}/kernels/%{kversion}${kvariant:+-$kvariant}-%{_target_cpu}
74     # pushd _kmod_build_$kvariant
75     # make -C "${ksrc}" modules_install M=$PWD
76     # install -d ${INSTALL_MOD_PATH}/usr/lib/debug
77     # popd
78     ksrc=/lib/modules/"%{kversion}${kvariant:+$kvariant}"/build
79     cd _kmod_build_$kvariant
80     make -C ${ksrc} SUBDIRS=`pwd` INSTALL_MOD_PATH=$RPM_BUILD_ROOT modinst_dir='$(MODLIB)/extra/'%{kmod_name} modules_install
81     # make TOPDIR=${ksrc} INSTALL_MOD_PATH=$RPM_BUILD_ROOT INSTALL_MOD_DIR=extra/%{kmod_name}/ modules_install %{?_smp_mflags}
82     cd ..
83 slords 1.1 done
84 slords 1.23
85     # Strip the module(s).
86     find ${INSTALL_MOD_PATH} -type f -name \*.ko -exec strip --strip-debug \{\} \;
87     #
88 slords 1.1
89     %clean
90     rm -rf $RPM_BUILD_ROOT
91    
92     %changelog
93 slords 1.23 * Tue May 26 2009 Shad L. Lords <slords@mail.com> 1.0-4.sme
94     - Initial build of the kABI-tracking version from 1.0.
95     - Modified spec and kmodtool(-appletalk)
96     - Note: weak-modules became available as of CentOS-4.7
97     - Strip the module(s) added
98    
99 snetram 1.20 * Thu Feb 5 2009 Shad L. Lords <slords@mail.com>
100     - Fix post scripts [SME: 4864]
101    
102 slords 1.1 * Mon May 7 2007 Shad L. Lords <slords@mail.com>
103     - Update to use kmodtool
104    
105     * Fri Dec 01 2006 Shad L. Lords <slords@mail.com>
106     - Initial package.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed