1 |
%define basedir /usr/local/bglibs |
2 |
%define _libdir %{basedir}/lib |
3 |
%define _includedir %{basedir}/include |
4 |
|
5 |
Name: bglibs |
6 |
Summary: BG Libraries Collection |
7 |
Version: 2.04 |
8 |
Release: 1 |
9 |
License: GPL |
10 |
Group: Development/Libraries |
11 |
Source: http://untroubled.org/%{name}/%{name}-%{version}.tar.gz |
12 |
Patch0: bglibs-2.04-mock.patch |
13 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
BuildRequires: libtool |
15 |
BuildRequires: glibc glibc-static glibc-devel |
16 |
BuildRequires: mtools autoconf |
17 |
URL: http://untroubled.org/%{name}/ |
18 |
Packager: Bruce Guenter <bruce@untroubled.org> |
19 |
|
20 |
%description |
21 |
BG Libraries Collection |
22 |
|
23 |
%package devel |
24 |
Summary: Development includes and libraries for bglibs |
25 |
Requires: bglibs = %{version} |
26 |
Group: Development/Libraries |
27 |
|
28 |
%description devel |
29 |
The bglibs-devel package contains the header and object files necessary |
30 |
for developing programs which use the bglibs libraries. |
31 |
|
32 |
%prep |
33 |
%setup |
34 |
%patch0 -p1 |
35 |
echo gcc "%{optflags}" -g >conf-cc |
36 |
echo gcc -g -L. >conf-ld |
37 |
echo %{_includedir} >conf-include |
38 |
echo %{_libdir} >conf-lib |
39 |
echo %{_bindir} >conf-bin |
40 |
echo %{_mandir} >conf-man |
41 |
|
42 |
%build |
43 |
make |
44 |
|
45 |
%install |
46 |
rm -fr %{buildroot} |
47 |
make install_prefix=%{buildroot} install |
48 |
|
49 |
cp -a doc %{buildroot}%{basedir} |
50 |
|
51 |
%clean |
52 |
rm -rf %{buildroot} |
53 |
|
54 |
%post |
55 |
fgrep -x /usr/local/bglibs/lib /etc/ld.so.conf >/dev/null \ |
56 |
|| echo /usr/local/bglibs/lib >>/etc/ld.so.conf |
57 |
/sbin/ldconfig |
58 |
|
59 |
%files |
60 |
%defattr(-,root,root) |
61 |
%doc ANNOUNCEMENT COPYING NEWS README |
62 |
%{basedir}/lib/*.so.* |
63 |
%{_bindir}/bg-installer |
64 |
|
65 |
%files devel |
66 |
%defattr(-,root,root) |
67 |
%{basedir}/doc |
68 |
%{basedir}/include |
69 |
%{basedir}/lib/*.a |
70 |
%{basedir}/lib/*.la |
71 |
#%{basedir}/lib/*.lib |
72 |
%{basedir}/lib/*.so |
73 |
#%{basedir}/lib/*/*.a |
74 |
%{_bindir}/cli-generate |
75 |
%{_bindir}/crc-gentab |
76 |
%{_mandir}/*/* |
77 |
|
78 |
%changelog |
79 |
* Sat Mar 05 2022 Jean-Philippe Pialasse <tests@pialasse.com> 2.04-1.sme |
80 |
- initial build for SME10 [SME: 11883] |
81 |
patched selftests.sh to avoid net/resolve_ipv4addr.c test which fails under mock |
82 |
added BuildRequires glibc glibc-static glibc-devel mtools autoconf |
83 |
commented out files for devel %{basedir}/lib/*.lib and %{basedir}/lib/*/*.a |
84 |
as they fails. |
85 |
|