1 |
%define basedir /usr/local/bglibs |
2 |
%define _libdir %{basedir}/lib |
3 |
%define _includedir %{basedir}/include |
4 |
|
5 |
Name: bglibs |
6 |
Summary: BG Libraries Collection |
7 |
Version: 1.102 |
8 |
Release: 1%{?dist} |
9 |
License: GPL |
10 |
Group: Development/Libraries |
11 |
Source: http://untroubled.org/bglibs/bglibs-1.102.tar.gz |
12 |
BuildRoot: %{_tmppath}/bglibs-buildroot |
13 |
BuildRequires: libtool |
14 |
URL: http://untroubled.org/bglibs/ |
15 |
Provides: bglibs-devel = %{version} |
16 |
|
17 |
%description |
18 |
BG Libraries Collection |
19 |
|
20 |
%prep |
21 |
%setup |
22 |
echo gcc "%{optflags}" -g >conf-cc |
23 |
echo gcc -g -L. >conf-ld |
24 |
echo %{_includedir} >conf-include |
25 |
echo %{_libdir} >conf-lib |
26 |
echo %{_bindir} >conf-bin |
27 |
echo %{_mandir} >conf-man |
28 |
|
29 |
%build |
30 |
make |
31 |
|
32 |
%install |
33 |
rm -fr %{buildroot} |
34 |
make install_prefix=%{buildroot} install |
35 |
|
36 |
cp -a doc %{buildroot}%{basedir} |
37 |
|
38 |
%clean |
39 |
rm -rf %{buildroot} |
40 |
|
41 |
%post |
42 |
fgrep -x /usr/local/bglibs/lib /etc/ld.so.conf >/dev/null \ |
43 |
|| echo /usr/local/bglibs/lib >>/etc/ld.so.conf |
44 |
/sbin/ldconfig |
45 |
|
46 |
%files |
47 |
%defattr(-,root,root) |
48 |
%doc ANNOUNCEMENT COPYING NEWS README |
49 |
%{basedir} |
50 |
%{_bindir}/* |
51 |
%{_mandir}/*/* |