1 |
# $Id: buffer.spec,v 1.3 2016/02/07 19:29:59 vip-ire Exp $ |
2 |
|
3 |
Summary: general purpose buffer programm |
4 |
Name: buffer |
5 |
Version: 1.19 |
6 |
Release: 9%{?dist} |
7 |
License: GPL |
8 |
Group: Applications/System |
9 |
Source: http://sunsite.org.uk/public/public/packages/buffer/buffer-1.19.shar |
10 |
Patch0: buffer-1.19.patch |
11 |
Patch1: buffer-largefile.patch |
12 |
Patch2: no_shmat.patch |
13 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
14 |
|
15 |
%description |
16 |
This is a program designed to speed up writing tapes on remote tape |
17 |
drives. After startup it splits itself into two processes. The first |
18 |
process reads (and reblocks) from stdin into a shared memory buffer. |
19 |
The second writes from the shared memory buffer to stdout. Doing it this way |
20 |
means that the writing side effectly sits in a tight write loop and |
21 |
doesn't have to wait for input. Similarly for the input side. It is |
22 |
this waiting that slows down other reblocking processes, like dd. |
23 |
|
24 |
%prep |
25 |
%setup -q -c %{name}-%{version} -T |
26 |
sh $RPM_SOURCE_DIR/%{name}-%{version}.shar |
27 |
|
28 |
%patch0 -p1 |
29 |
%patch1 -p1 |
30 |
%patch2 -p1 |
31 |
|
32 |
%build |
33 |
make CFLAGS="$RPM_OPT_FLAGS -Wall -s" |
34 |
|
35 |
%install |
36 |
install -m 755 -D buffer $RPM_BUILD_ROOT%{_bindir}/buffer |
37 |
install -m 644 -D buffer.man $RPM_BUILD_ROOT%{_mandir}/man1/buffer.1 |
38 |
|
39 |
%clean |
40 |
rm -rf $RPM_BUILD_ROOT |
41 |
|
42 |
%files |
43 |
%defattr(-,root,root) |
44 |
%doc COPYING README |
45 |
%{_bindir}/buffer |
46 |
%{_mandir}/man1/buffer.1* |
47 |
|
48 |
%changelog |
49 |
* Sun Feb 7 2016 Daniel Berteaud <daniel@firewall-services.com> 1.19-9.sme |
50 |
- Rebase patches so it builds on el7 [SME: 9233] |
51 |
|
52 |
* Sun Feb 7 2016 stephane de Labrusse <stephdl@de-labrusse.fr> 1.19-7.sme |
53 |
- Build for sme10 |
54 |
|
55 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
56 |
- Clean up spec so package can be built by koji/plague |
57 |
|
58 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
59 |
- Update to new release naming. No functional changes. |
60 |
- Make Packager generic |
61 |
|
62 |
* Mon Mar 13 2006 Shad L. Lords <slords@mail.com> 1.19-6sme |
63 |
- Remove shmat definition so x86_64 builds correctly |
64 |
|
65 |
* Thu Jun 19 2003 Charlie Brady <charlieb@e-smith.com> 1.19-5es |
66 |
- Rebuild in-house to ensure library version compatibility. |
67 |
|
68 |
* Sun Jan 5 2003 Edwin Huffstutler <edwinh@computer.org> |
69 |
- added O_LARGEFILE |
70 |
|
71 |
* Mon Jul 24 2000 Prospector <prospector@redhat.com> |
72 |
- rebuilt |
73 |
|
74 |
* Tue Jul 11 2000 Than Ngo <than@redhat.de> |
75 |
- rebuilt |
76 |
|
77 |
* Wed Jun 07 2000 Than Ngo <than@redhat.de> |
78 |
- use rpm macros |
79 |
|
80 |
* Mon Jun 05 2000 Michael Stefaniuc <mstefani@redhat.com> |
81 |
- rewrote the spec file |
82 |
- rewrote and extended the buffer patch |