1 |
# $Id: buffer.spec,v 1.2 2008/04/09 13:51:45 slords Exp $ |
2 |
|
3 |
Summary: general purpose buffer programm |
4 |
Name: buffer |
5 |
Version: 1.19 |
6 |
Release: 7%{?dist} |
7 |
License: GPL |
8 |
Group: Applications/System |
9 |
Source: http://sunsite.org.uk/public/public/packages/buffer/buffer-1.19.shar |
10 |
Patch0: buffer-1.19.patch |
11 |
Patch1: buffer-largefile.patch |
12 |
Patch2: no_shmat.patch |
13 |
BuildRoot: %{_tmppath}/%{name}-%{version}-root |
14 |
|
15 |
%description |
16 |
This is a program designed to speed up writing tapes on remote tape |
17 |
drives. After startup it splits itself into two processes. The first |
18 |
process reads (and reblocks) from stdin into a shared memory buffer. |
19 |
The second writes from the shared memory buffer to stdout. Doing it this way |
20 |
means that the writing side effectly sits in a tight write loop and |
21 |
doesn't have to wait for input. Similarly for the input side. It is |
22 |
this waiting that slows down other reblocking processes, like dd. |
23 |
|
24 |
%prep |
25 |
%setup -q -c %{name}-%{version} -T |
26 |
sh $RPM_SOURCE_DIR/%{name}-%{version}.shar |
27 |
|
28 |
%patch0 -p1 |
29 |
|
30 |
%patch1 -p1 |
31 |
|
32 |
%patch2 -p1 |
33 |
|
34 |
%build |
35 |
make CFLAGS="$RPM_OPT_FLAGS -Wall -s" |
36 |
|
37 |
%install |
38 |
install -m 755 -D buffer $RPM_BUILD_ROOT%{_bindir}/buffer |
39 |
install -m 644 -D buffer.man $RPM_BUILD_ROOT%{_mandir}/man1/buffer.1 |
40 |
|
41 |
%clean |
42 |
rm -rf $RPM_BUILD_ROOT |
43 |
|
44 |
%files |
45 |
%defattr(-,root,root) |
46 |
%doc COPYING README |
47 |
%{_bindir}/buffer |
48 |
%{_mandir}/man1/buffer.1* |
49 |
|
50 |
%changelog |
51 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
52 |
- Clean up spec so package can be built by koji/plague |
53 |
|
54 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
55 |
- Update to new release naming. No functional changes. |
56 |
- Make Packager generic |
57 |
|
58 |
* Mon Mar 13 2006 Shad L. Lords <slords@mail.com> 1.19-6sme |
59 |
- Remove shmat definition so x86_64 builds correctly |
60 |
|
61 |
* Thu Jun 19 2003 Charlie Brady <charlieb@e-smith.com> 1.19-5es |
62 |
- Rebuild in-house to ensure library version compatibility. |
63 |
|
64 |
* Sun Jan 5 2003 Edwin Huffstutler <edwinh@computer.org> |
65 |
- added O_LARGEFILE |
66 |
|
67 |
* Mon Jul 24 2000 Prospector <prospector@redhat.com> |
68 |
- rebuilt |
69 |
|
70 |
* Tue Jul 11 2000 Than Ngo <than@redhat.de> |
71 |
- rebuilt |
72 |
|
73 |
* Wed Jun 07 2000 Than Ngo <than@redhat.de> |
74 |
- use rpm macros |
75 |
|
76 |
* Mon Jun 05 2000 Michael Stefaniuc <mstefani@redhat.com> |
77 |
- rewrote the spec file |
78 |
- rewrote and extended the buffer patch |