1 |
slords |
1.1 |
Name: buildsys-macros |
2 |
|
|
Summary: Macros for the Fedora Buildsystem |
3 |
|
|
# The value for version should match the version of Fedora Core. |
4 |
|
|
Version: 4 |
5 |
|
|
Release: 2%{?dist} |
6 |
|
|
License: GPL |
7 |
|
|
Group: Development/Buildsystem |
8 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
9 |
|
|
Buildarch: noarch |
10 |
|
|
Requires: rpmdevtools |
11 |
|
|
|
12 |
|
|
%description |
13 |
|
|
Macros for the Fedora Buildsystem |
14 |
|
|
|
15 |
|
|
%prep |
16 |
|
|
|
17 |
|
|
%build |
18 |
|
|
|
19 |
|
|
%install |
20 |
|
|
rm -rf $RPM_BUILD_ROOT |
21 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/rpm/ |
22 |
|
|
VERSION=%{version} |
23 |
|
|
printf %s%b "%" "rhel $VERSION\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag |
24 |
|
|
printf %s%b "%" "dist .el$VERSION.sme\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag |
25 |
|
|
printf %s%b "%" "__arch_install_post /usr/lib/rpm/check-buildroot\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.checkbuild |
26 |
|
|
|
27 |
|
|
|
28 |
|
|
%clean |
29 |
|
|
rm -rf $RPM_BUILD_ROOT |
30 |
|
|
|
31 |
|
|
%files |
32 |
|
|
%defattr(-,root,root) |
33 |
|
|
/etc/rpm/macros.disttag |
34 |
|
|
/etc/rpm/macros.checkbuild |
35 |
|
|
|
36 |
|
|
%changelog |
37 |
|
|
* Wed May 2 2007 Shad L. Lords <slords@mail.com> |
38 |
|
|
- Add sme to end of dist |
39 |
|
|
|
40 |
|
|
* Tue May 1 2007 Shad L. Lords <slords@mail.com> |
41 |
|
|
- Initial build. |