/[smeserver]/rpms/clamav/sme10/clamav.spec
ViewVC logotype

Annotation of /rpms/clamav/sme10/clamav.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.9 - (hide annotations) (download)
Thu Mar 7 04:07:33 2019 UTC (5 years, 3 months ago) by jpp
Branch: MAIN
CVS Tags: clamav-0_100_2-2_el7_sme, HEAD
Changes since 1.8: +15 -4 lines
* Wed Mar 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 0.100.2-2.sme
- Update clamav-db as per epel last spec file [SME: 10754]
  to add clamav-update as provides
-
* Wed Oct 24 2018 Daniel Berteaud <daniel@firewall-services.com> - 0.100.2-1.sme
- Update to 0.100.2 [SME: 10578]

1 jpp 1.9 # $Id: clamav.spec,v 1.8 2018/10/24 11:37:38 dani Exp $
2 vip-ire 1.1 # Authority: dag
3     # Upstream: <clamav-devel$lists,sf,net>
4    
5     ### FIXME: Sysv script does not have condrestart option (redo sysv script)
6     ### FIXME: amavisd-new requires clamd to run as user vscan, solution needed
7     ### REMINDER: Look and sync with Petr Kristof's work
8    
9     %{?el3:%define _without_milter 1}
10     %{?rh9:%define _without_milter 1}
11     %{?rh7:%define _without_milter 1}
12     %{?el2:%define _without_milter 1}
13    
14     Summary: Anti-virus software
15     Name: clamav
16 dani 1.8 Version: 0.100.2
17 jpp 1.9 Release: 2%{?dist}
18 vip-ire 1.1 License: GPL
19     Group: Applications/System
20     URL: http://www.clamav.net/
21    
22     Source: http://downloads.sourceforge.net/project/clamav/clamav/%{version}/clamav-%{version}.tar.gz
23     Source1: clamav.init
24     Source2: clamav-milter.init
25     Source10: http://db.local.clamav.net/main.cvd
26     Source11: http://db.local.clamav.net/daily.cvd
27     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28    
29     BuildRequires: bzip2-devel
30     BuildRequires: curl-devel
31     BuildRequires: gmp-devel
32     BuildRequires: ncurses-devel
33     BuildRequires: zlib-devel
34     %{!?_without_milter:BuildRequires: sendmail-devel >= 8.12}
35     BuildRequires: check-devel
36     BuildRequires: openssl-devel
37     BuildRequires: libxml2-devel
38 vip-ire 1.2 BuildRequires: pcre-devel
39 vip-ire 1.1
40    
41     ### Do not require the latest release of clamav-db specifically (people may use freshclam onward)
42     #Requires: clamav-db = %{version}-%{release}
43     Requires: clamav-db
44    
45     ### Fedora Extras introduced them differently :(
46     Obsoletes: libclamav <= %{version}-%{release}
47     Obsoletes: clamav-lib <= %{version}-%{release}
48     Provides: libclamav
49    
50     %description
51     Clam AntiVirus is a GPL anti-virus toolkit for UNIX. The main purpose of
52     this software is the integration with mail servers (attachment scanning).
53     The package provides a flexible and scalable multi-threaded daemon, a
54     command line scanner, and a tool for automatic updating via Internet.
55    
56     The programs are based on a shared library distributed with the Clam
57     AntiVirus package, which you can use with your own software. Most
58     importantly, the virus database is kept up to date
59    
60     %package -n clamd
61     Summary: The Clam AntiVirus Daemon
62     Group: System Environment/Daemons
63     Requires: clamav = %{version}-%{release}
64     Requires(pre): /usr/sbin/groupadd
65     Requires(pre): /usr/sbin/useradd
66    
67     ### Fedora Extras introduced them differently :(
68     Obsoletes: clamav-server <= %{version}-%{release}
69    
70     %description -n clamd
71     The Clam AntiVirus Daemon
72    
73     %package milter
74     Summary: The Clam AntiVirus sendmail-milter Daemon
75     Group: Applications/System
76     Requires: clamd = %{version}-%{release}
77     Requires: smtpdaemon
78    
79     %description milter
80     The Clam AntiVirus sendmail-milter Daemon
81    
82     %package db
83     Summary: Virus database for %{name}
84     Group: Applications/Databases
85     ### Remove circular dependency
86     #Requires: clamav = %{version}-%{release}
87     Requires(pre): /usr/sbin/groupadd
88     Requires(pre): /usr/sbin/useradd
89    
90     ### Fedora Extras introduced them differently :(
91 jpp 1.9 Provides: clamav-update = %{version}-%{release}
92     Obsoletes: clamav-update < %{version}-%{release}
93     Provides: clamav-data = %{version}-%{release}
94     Obsoletes: clamav-data < %{version}-%{release}
95     Obsoletes: clamav-data-empty <= %{version}-%{release}
96     # Ugly to put these in the db-package, but needed
97     # here to handle upgrades on EL5.
98     Provides: clamav-filesystem = %{version}-%{release}
99     Obsoletes: clamav-filesystem < %{version}-%{release}
100 vip-ire 1.1
101     %description db
102     The actual virus database for %{name}
103    
104     %package devel
105     Summary: Header files, libraries and development documentation for %{name}
106     Group: Development/Libraries
107     Requires: clamav = %{version}-%{release}
108    
109     ### Fedora Extras introduced them differently :(
110     Obsoletes: libclamav-static-devel <= %{version}-%{release}
111     Obsoletes: libclamav-devel <= %{version}-%{release}
112     Provides: libclamav-static-devel, libclamav-devel
113    
114     %description devel
115     This package contains the header files, static libraries and development
116     documentation for %{name}. If you like to develop programs using %{name},
117     you will need to install %{name}-devel.
118    
119     %prep
120     %setup
121    
122     %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g;' libtool configure
123    
124     %{__perl} -pi.orig -e '
125     s|\@DBDIR\@|\$(localstatedir)/clamav|g;
126     s|\@DBINST\@|\$(localstatedir)/clamav|g;
127     s|\@CFGDIR\@|\$(sysconfdir)|g;
128     s|\@CFGINST\@|\$(sysconfdir)|g;
129     s|^\@INSTALL_CLAMAV_CONF_TRUE\@|\t|g;
130     s|^\@INSTALL_FRESHCLAM_CONF_TRUE\@|\t|g;
131     ' database/Makefile.in etc/Makefile.in
132    
133     %{__perl} -pi -e '
134     s|^(Example)|#$1|;
135     s|^#(LogFile) .+$|$1 %{_localstatedir}/log/clamav/clamd.log|;
136     s|^#(LogFileMaxSize) .*|$1 0|;
137     s|^#(LogTime)|$1|;
138     s|^#(LogSyslog)|$1|;
139     s|^#(PidFile) .+$|$1 %{_localstatedir}/run/clamav/clamd.pid|;
140     s|^#(TemporaryDirectory) .+$|$1 %{_localstatedir}/tmp|;
141     s|^#(DatabaseDirectory) .+$|$1 %{_localstatedir}/clamav|;
142     s|^#(LocalSocket) .+$|$1 %{_localstatedir}/run/clamav/clamd.sock|;
143     s|^#(FixStaleSocket)|$1|;
144     s|^#(TCPSocket) .+$|$1 3310|;
145     s|^#(TCPAddr) .+$|$1 127.0.0.1|;
146     s|^#(MaxConnectionQueueLength) .+$|$1 30|;
147     s|^#(StreamSaveToDisk)|$1|;
148     s|^#(MaxThreads) .+$|$1 50|;
149     s|^#(ReadTimeout) .+$|$1 300|;
150     s|^#(User) .+$|$1 clamav|;
151     s|^#(AllowSupplementaryGroups).*$|$1 yes|;
152     s|^#(ScanPE) .+$|$1 yes|;
153     s|^#(ScanELF) .+$|$1 yes|;
154     s|^#(DetectBrokenExecutables)|$1|;
155     s|^#(ScanOLE2) .+$|$1 yes|;
156     s|^#(ScanMail)|$1|;
157     s|^#(ScanArchive) .+$|$1 yes|;
158     s|^#(ArchiveMaxCompressionRatio) .+|$1 300|;
159     s|^#(ArchiveBlockEncrypted)|$1|;
160     s|^#(ArchiveBlockMax)|$1|;
161     ' etc/clamd.conf.sample >etc/clamd.conf
162    
163     %{__perl} -pi -e '
164     s|^(Example)|#$1|;
165     s|^#(AllowSupplementaryGroups) .+$|$1 yes|;
166     s|^#(ClamdSocket) .+$|$1 unix:%{_localstatedir}/run/clamav/clamd.sock|;
167     s|^#(LogFile) .+$|$1 %{_localstatedir}/log/clamav/clamav-milter.log|;
168     s|^#(LogFileMaxSize) .*|$1 0|;
169     s|^#(LogSyslog)|$1|;
170     s|^#(LogTime)|$1|;
171     s|^#(MilterSocket) /.*$|$1 unix:%{_localstatedir}/clamav/clmilter.socket|;
172     s|^#(User) .+$|$1 clamav|;
173     ' etc/clamav-milter.conf.sample >etc/clamav-milter.conf
174    
175     %{__perl} -p -e '
176     s|^(Checks) .+$|$1 24|;
177     s|^(Example)|#$1|;
178     s|^#(DatabaseDirectory) .+$|$1 %{_localstatedir}/clamav|;
179     s|^#(DatabaseOwner) .+$|$1 clamav|;
180     s|^#(LogSyslog)|$1|;
181     s|^#(NotifyClamd) .+$|$1 %{_sysconfdir}/clamd.conf|;
182     s|^#(UpdateLogFile) .+$|$1 %{_localstatedir}/log/clamav/freshclam.log|;
183     ' etc/freshclam.conf.sample >etc/freshclam.conf
184    
185     %{__cat} <<EOF >clamd.logrotate
186     %{_localstatedir}/log/clamav/clamd.log {
187     missingok
188     notifempty
189     create 644 clamav clamav
190     postrotate
191     killall -HUP clamd 2>/dev/null || :
192     endscript
193     }
194     EOF
195    
196     %{__cat} <<EOF >freshclam.logrotate
197     %{_localstatedir}/log/clamav/freshclam.log {
198     missingok
199     notifempty
200     create 644 clamav clamav
201     }
202     EOF
203    
204     %{__cat} <<'EOF' >freshclam.cron
205     #!/bin/sh
206    
207     ### A simple update script for the clamav virus database.
208     ### This could as well be replaced by a SysV script.
209    
210     %{_bindir}/freshclam --quiet
211     EOF
212    
213     %{__cat} <<EOF >clamav-milter.sysconfig
214     ### Simple config file for clamav-milter, you should
215     ### read the documentation and tweak it as you wish.
216    
217     CLAMAV_FLAGS="--config-file=%{_sysconfdir}/clamav-milter.conf"
218     EOF
219    
220     %build
221     %configure \
222     --program-prefix="%{?_program_prefix}" \
223     --disable-clamav \
224     --disable-llvm \
225     --disable-static \
226     --disable-zlib-vcheck \
227     --enable-check \
228     --enable-clamdtop \
229     --enable-dns \
230     --enable-id-check \
231     %{!?_without_milter:--enable-milter} \
232     --with-dbdir="%{_localstatedir}/clamav" \
233     --with-group="clamav" \
234     --with-libcurl=%{_prefix} \
235     --with-user="clamav"
236     ### Disable JIT until it is implemented securely (RHbz #573191)
237     # --enable-llvm \
238     %{__make} %{?_smp_mflags}
239    
240     %install
241     %{__rm} -rf %{buildroot}
242     %{__make} install DESTDIR="%{buildroot}"
243    
244     %{__install} -Dp -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/clamd
245     %{__install} -Dp -m0644 etc/freshclam.conf %{buildroot}%{_sysconfdir}/freshclam.conf
246     %{__install} -Dp -m0755 freshclam.cron %{buildroot}%{_sysconfdir}/cron.daily/freshclam
247     %{__install} -Dp -m0644 freshclam.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/freshclam
248     %{__install} -Dp -m0644 etc/clamd.conf %{buildroot}%{_sysconfdir}/clamd.conf
249     %{__install} -Dp -m0644 clamd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/clamav
250    
251     %if %{!?_without_milter:1}0
252     %{__install} -Dp -m0644 etc/clamav-milter.conf %{buildroot}%{_sysconfdir}/clamav-milter.conf
253     %{__install} -Dp -m0755 %{SOURCE2} %{buildroot}%{_initrddir}/clamav-milter
254     %{__install} -Dp -m0644 clamav-milter.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/clamav-milter
255     %else
256     %{__rm} %{buildroot}%{_mandir}/man8/clamav-milter.8*
257     %endif
258    
259     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/log/clamav/
260     touch %{buildroot}%{_localstatedir}/log/clamav/freshclam.log
261     touch %{buildroot}%{_localstatedir}/log/clamav/clamd.log
262    
263     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/clamav/
264     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/run/clamav/
265    
266     #touch %{buildroot}%{_localstatedir}/clamav/daily.cld
267     #touch %{buildroot}%{_localstatedir}/clamav/main.cld
268    
269     %{__install} -Dp -m0644 %SOURCE10 %{buildroot}%{_localstatedir}/clamav/main.cvd
270     %{__install} -Dp -m0644 %SOURCE11 %{buildroot}%{_localstatedir}/clamav/daily.cvd
271    
272     %post
273     /sbin/ldconfig
274    
275     ZONES="/usr/share/zoneinfo/zone.tab"
276     CONFIG="/etc/sysconfig/clock"
277    
278     if [ -r "$CONFIG" -a -r "$ZONES" ]; then
279     source "$CONFIG"
280     export CODE="$(grep -E "\b$ZONE\b" "$ZONES" | head -1 | cut -f1 | tr '[A-Z]' '[a-z]')"
281     fi
282    
283     if [ -z "$CODE" ]; then
284     export CODE="local"
285     fi
286    
287     %{__perl} -pi -e '
288     s|^(DatabaseMirror) database\.clamav\.net$|$1 db.$ENV{"CODE"}.clamav.net\n$1 db.local.clamav.net|;
289     s|^(DatabaseMirror) db\.\.clamav\.net$|$1 db.$ENV{"CODE"}.clamav.net\n$1 db.local.clamav.net|;
290     ' %{_sysconfdir}/freshclam.conf{,.rpmnew} &>/dev/null || :
291    
292     %postun -p /sbin/ldconfig
293    
294     %pre -n clamd
295     /usr/sbin/groupadd -r clamav 2>/dev/null || :
296     /usr/sbin/useradd -r -d /var/clamav -s /sbin/nologin -c "Clam Anti Virus Checker" -g clamav clamav 2>/dev/null || :
297    
298     %post -n clamd
299 vip-ire 1.5 %systemd_post clamav-daemon.service
300 vip-ire 1.1
301     %preun -n clamd
302 vip-ire 1.5 %systemd_preun clamav-daemon.service
303 vip-ire 1.1
304     %postun -n clamd
305 vip-ire 1.5 %systemd_postun
306 vip-ire 1.1
307     %post milter
308     /sbin/chkconfig --add clamav-milter
309    
310     %preun milter
311     if [ $1 -eq 0 ]; then
312     /sbin/service clamav-milter stop &>/dev/null || :
313     /sbin/chkconfig --del clamav-milter
314     fi
315    
316     %postun milter
317     /sbin/service clamav-milter condrestart &>/dev/null || :
318    
319     %pre db
320     /usr/sbin/groupadd -r clamav 2>/dev/null || :
321     /usr/sbin/useradd -r -d /var/clamav -s /sbin/nologin -c "Clam Anti Virus Checker" -g clamav clamav 2>/dev/null || :
322    
323 vip-ire 1.5 %post db
324     %systemd_post clamav-freshclam.service
325    
326     %preun db
327     %systemd_preun clamav-freshclam.service
328    
329     %postun db
330     %systemd_postun
331    
332 vip-ire 1.1 %clean
333     %{__rm} -rf %{buildroot}
334    
335     %files
336     %defattr(-, root, root, 0755)
337 dani 1.8 %doc ChangeLog.md COPYING* INSTALL.md NEWS.md README.md
338 vip-ire 1.1 %doc etc/freshclam.conf.sample
339     %doc docs/*.pdf
340     ### Remove test virus documents as they trigger clamav
341     #%doc test/
342     %doc %{_mandir}/man1/sigtool.1*
343     %doc %{_mandir}/man1/clambc.1*
344     %doc %{_mandir}/man1/clamscan.1*
345     %doc %{_mandir}/man1/freshclam.1*
346     %doc %{_mandir}/man5/freshclam.conf.5*
347     %config(noreplace) %{_sysconfdir}/freshclam.conf
348 vip-ire 1.5 %{_unitdir}/clamav-freshclam.service
349 vip-ire 1.1 %{_bindir}/clambc
350     %{_bindir}/clamscan
351     %{_bindir}/freshclam
352     %{_bindir}/sigtool
353     %{_libdir}/libclamav.so.*
354     %{_libdir}/libclamunrar.so.*
355     %{_libdir}/libclamunrar_iface.so.*
356 dani 1.8 %{_libdir}/libclammspack.so.*
357 vip-ire 1.1 # moved from -devel to here so clamd can work with rars when clamav-devel is not installed.
358     %{_libdir}/libclamav.so
359     %{_libdir}/libclamunrar.so
360     %{_libdir}/libclamunrar_iface.so
361 dani 1.8 %{_libdir}/libclammspack.so
362 vip-ire 1.1 %exclude %{_sysconfdir}/freshclam.conf.sample
363    
364     %files -n clamd
365     %defattr(-, root, root, 0755)
366     %doc etc/clamd.conf.sample
367     %doc %{_mandir}/man1/clambc.1*
368     %doc %{_mandir}/man1/clamconf.1*
369     %doc %{_mandir}/man1/clamdscan.1*
370     %doc %{_mandir}/man1/clamdtop.1*
371     %doc %{_mandir}/man5/clamd.conf.5*
372     %doc %{_mandir}/man8/clamd.8*
373     %config(noreplace) %{_sysconfdir}/clamd.conf
374     %config(noreplace) %{_sysconfdir}/logrotate.d/clamav
375     %config %{_initrddir}/clamd
376 vip-ire 1.5 %{_unitdir}/clamav-daemon.service
377     %{_unitdir}/clamav-daemon.socket
378 vip-ire 1.1 %{_sbindir}/clamd
379     %{_bindir}/clamconf
380     %{_bindir}/clamdscan
381     %{_bindir}/clamdtop
382    
383     %defattr(0644, clamav, clamav, 0755)
384     %{_localstatedir}/run/clamav/
385     %dir %{_localstatedir}/clamav/
386     %dir %{_localstatedir}/log/clamav/
387     %ghost %{_localstatedir}/log/clamav/clamd.log
388    
389     %exclude %{_localstatedir}/clamav/*
390     %exclude %{_sysconfdir}/clamd.conf.sample
391    
392     %if %{!?_without_milter:1}0
393     %files milter
394     %defattr(-, root, root, 0755)
395     %doc etc/clamav-milter.conf.sample
396     %doc %{_mandir}/man5/clamav-milter.conf.5*
397     %doc %{_mandir}/man8/clamav-milter.8*
398     %config(noreplace) %{_sysconfdir}/clamav-milter.conf
399     %config(noreplace) %{_sysconfdir}/sysconfig/clamav-milter
400     %config %{_initrddir}/clamav-milter
401     %{_sbindir}/clamav-milter
402     %else
403     %exclude %{_mandir}/man5/clamav-milter.conf.5*
404     %endif
405     %exclude %{_sysconfdir}/clamav-milter.conf.sample
406    
407     %files db
408     %defattr(-, root, root, 0755)
409     %config(noreplace) %{_sysconfdir}/cron.daily/freshclam
410     %config(noreplace) %{_sysconfdir}/logrotate.d/freshclam
411    
412     %defattr(0644, clamav, clamav, 0755)
413     %config(noreplace) %verify(user group mode) %{_localstatedir}/clamav/
414     %dir %{_localstatedir}/log/clamav/
415     %ghost %{_localstatedir}/log/clamav/freshclam.log
416    
417     %files devel
418     %defattr(-, root, root, 0755)
419     %{_bindir}/clamav-config
420     %{_includedir}/clamav.h
421     %{_libdir}/pkgconfig/libclamav.pc
422 dani 1.8 %{_libdir}/pkgconfig/libclammspack.pc
423 vip-ire 1.1 %exclude %{_libdir}/libclamav.la
424     %exclude %{_libdir}/libclamunrar.la
425     %exclude %{_libdir}/libclamunrar_iface.la
426 dani 1.8 %exclude %{_libdir}/libclammspack.la
427 vip-ire 1.1
428     %changelog
429 jpp 1.9 * Wed Mar 06 2019 Jean-Philipe Pialasse <tests@pialasse.com> 0.100.2-2.sme
430     - Update clamav-db as per epel last spec file [SME: 10754]
431     to add clamav-update as provides
432     -
433 dani 1.8 * Wed Oct 24 2018 Daniel Berteaud <daniel@firewall-services.com> - 0.100.2-1.sme
434     - Update to 0.100.2 [SME: 10578]
435    
436 dani 1.7 * Wed Mar 14 2018 Daniel Berteaud <daniel@firewall-services.com> - 0.99.4-1.sme
437     - Update to 0.99.4 [SME: 10528]
438    
439 dani 1.6 * Sat Jan 27 2018 Daniel Berteaud <daniel@firewall-services.com> - 0.99.3-1.sme
440     - Update to 0.99.3 [SME: 10500]
441    
442 vip-ire 1.4 * Tue May 3 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99.2-1.sme
443 vip-ire 1.5 - Update to 0.99.2 [SME: 9487]
444     - Adapt to use systemd unit [SME: 9487]
445 vip-ire 1.4
446 vip-ire 1.3 * Thu Mar 3 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99.1-1.sme
447     - Update to 0.99.1 [SME: 9268]
448    
449 vip-ire 1.2 * Tue Jan 12 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99-2.sme
450     - Add pcre-devel to BuildRequires [SME: 9151]
451    
452     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99-1.sme
453     - Update to release 0.99 [SME: 9151]
454    
455 vip-ire 1.1 * Wed May 13 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.98.7-1.sme
456     - Updated to release 0.98.7 [SME: 8922]
457    
458     * Thu Jan 29 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.98.6-1.sme
459     - Updated to release 0.98.6 [SME: 8822]
460    
461     * Tue Dec 16 2014 Daniel Berteaud <daniel@firewall-services.com> - 0.98.5-1.sme
462     - Updated to release 0.98.5 [SME: 8729]
463    
464     * Sat Jun 21 2014 Ian Wells <esmith@wellsi.com> - 0.98.4-2.sme
465     - Add BuildRequires for openssl-devel and libxml2-devel [SME: 8457]
466     - Remove Packager and Vendor from spec file.
467    
468     * Thu Jun 17 2014 David Beveridge <dave@bevhost.com> - 0.98.4-1
469     - Updates to release 0.98.4.
470    
471     * Thu May 8 2014 David Beveridge <dave@bevhost.com> - 0.98.3-1
472     - Updated to release 0.98.3.
473    
474     * Sun Jan 26 2014 David Beveridge <dave@bevhost.com> - 0.98.1-1
475     - Updates to release 0.98.1.
476    
477     * Tue Sep 24 2013 Dag Wieers <dag@wieers.com> - 0.98-1
478     - Updated to release 0.98.
479    
480     * Tue May 07 2013 David Hrbáč <david@hrbac.cz> - 0.97.8-1
481     - Updated to release 0.97.8.
482    
483     * Wed Mar 20 2013 Dag Wieers <dag@wieers.com> - 0.97.7-1
484     - Updated to release 0.97.7.
485    
486     * Sun Sep 23 2012 Dag Wieers <dag@wieers.com> - 0.97.6-1
487     - Updated to release 0.97.6.
488    
489     * Mon Jun 25 2012 David Hrbáč <david@hrbac.cz> - 0.97.5-2
490     - removed missing *.cld files (#183)
491    
492     * Thu Jun 21 2012 David Hrbáč <david@hrbac.cz> - 0.97.5-1
493     - corrected missing DBs
494     - new upstream release
495    
496     * Sat Jun 16 2012 Dag Wieers <dag@wieers.com> - 0.97.5-1
497     - Updated to release 0.97.5.
498    
499     * Thu Mar 15 2012 Dag Wieers <dag@wieers.com> - 0.97.4-1
500     - Updated to release 0.97.4.
501    
502     * Sat Dec 13 2011 Philip J Perry <phil@elrepo.org> - 0.97.3-2
503     - Fix Requires for clamav-milter to also allow use with Postfix.
504    
505     * Mon Oct 17 2011 Dag Wieers <dag@wieers.com> - 0.97.3-1
506     - Updated to release 0.97.3.
507    
508     * Mon Jul 25 2011 Dag Wieers <dag@wieers.com> - 0.97.2-1
509     - Updated to release 0.97.2.
510    
511     * Thu Jun 09 2011 Dag Wieers <dag@wieers.com> - 0.97.1-1
512     - Updated to release 0.97.1.
513    
514     * Tue Feb 08 2011 Dag Wieers <dag@wieers.com> - 0.97-1
515     - Updated to release 0.97.
516    
517     * Tue Nov 30 2010 Dag Wieers <dag@wieers.com> - 0.96.5-1
518     - Updated to release 0.96.5.
519    
520     * Mon Oct 25 2010 Dag Wieers <dag@wieers.com> - 0.96.4-1
521     - Updated to release 0.96.4.
522    
523     * Tue Sep 21 2010 David Hrbáč <david@hrbac.cz> - 0.96.3-2
524     - Added buildrequires check-devel.
525    
526     * Tue Sep 21 2010 Dag Wieers <dag@wieers.com> - 0.96.3-1
527     - Updated to release 0.96.3.
528    
529     * Tue Aug 17 2010 Dag Wieers <dag@wieers.com> - 0.96.2-2
530     - Added patch that fixes segfault when using SELinux. (Beat Siegenthaler)
531    
532     * Thu Aug 12 2010 Dag Wieers <dag@wieers.com> - 0.96.2-1
533     - Updated to release 0.96.2.
534    
535     * Wed May 19 2010 Dag Wieers <dag@wieers.com> - 0.96.1-1
536     - Updated to release 0.96.1.
537    
538     * Mon May 03 2010 Dag Wieers <dag@wieers.com> - 0.96-3
539     - Restored the LocalSocket configuration option to what it used to be. (Chris Butler)
540    
541     * Wed Apr 07 2010 Dag Wieers <dag@wieers.com> - 0.96-2
542     - Removed test virus documents to prevent triggering clamav itself. (Patrick Mulvany)
543    
544     * Wed Mar 31 2010 Dag Wieers <dag@wieers.com> - 0.96-1
545     - Updated to release 0.96.
546    
547     * Thu Oct 29 2009 Dag Wieers <dag@wieers.com> - 0.95.3-1
548     - Updated to release 0.95.3.
549    
550     * Fri Jun 12 2009 Christoph Maser <cmr@financial.com> - 0.95.2-1
551     - Updated to release 0.95.2.
552    
553     * Mon May 04 2009 Dag Wieers <dag@wieers.com> - 0.95.1-4
554     - Fix the inconsistency between LocalSocket in clamd.conf and clamav-milter.conf. (Gerald Teschl)
555    
556     * Sat May 02 2009 Dag Wieers <dag@wieers.com> - 0.95.1-3
557     - Fix the LocalSocket in clamd.conf. (Gerald Teschl)
558    
559     * Wed Apr 15 2009 Fabian Arrotin <fabian.arrotin@arrfab.net> - 0.95.1-2
560     - Added a missing BuildRequires: ncurses-devel to build clamdtop.
561    
562     * Fri Apr 10 2009 Dag Wieers <dag@wieers.com> - 0.95.1-2
563     - Corrected LogFile definition. (Vadim Druzhin)
564    
565     * Wed Apr 8 2009 Dag Wieers <dag@wieers.com> - 0.95.1-1
566     - Updated to release 0.95.1.
567    
568     * Tue Apr 7 2009 Dries Verachtert <dries@ulyssis.org> - 0.95-3
569     - Ugly fix for clamd which needs the .so files.
570    
571     * Tue Mar 24 2009 Dag Wieers <dag@wieers.com> - 0.95-1
572     - Updated to release 0.95.
573    
574     * Thu Nov 27 2008 Dag Wieers <dag@wieers.com> - 0.94.2-1
575     - Updated to release 0.94.2.
576    
577     * Mon Nov 03 2008 Dag Wieers <dag@wieers.com> - 0.94.1-1
578     - Updated to release 0.94.1.
579    
580     * Tue Sep 02 2008 Dag Wieers <dag@wieers.com> - 0.94-1
581     - Updated to release 0.94.
582    
583     * Wed Jul 09 2008 Dag Wieers <dag@wieers.com> - 0.93.3-1
584     - Updated to release 0.93.3.
585    
586     * Mon Jul 07 2008 Dag Wieers <dag@wieers.com> - 0.93.2-1
587     - Updated to release 0.93.2.
588    
589     * Mon Jun 09 2008 Dag Wieers <dag@wieers.com> - 0.93.1-1
590     - Updated to release 0.93.1.
591    
592     * Wed Apr 16 2008 Dag Wieers <dag@wieers.com> - 0.93-2
593     - Normal build causes linkage against installed library.
594    
595     * Mon Apr 14 2008 Dag Wieers <dag@wieers.com> - 0.93-1
596     - Updated to release 0.93.
597    
598     * Wed Feb 27 2008 Dag Wieers <dag@wieers.com> - queued
599     - Do not require the latest release of clamav-db. (Federico Simoncelli)
600    
601     * Mon Feb 11 2008 Dag Wieers <dag@wieers.com> - 0.92.1-1
602     - Updated to release 0.92.1.
603    
604     * Thu Dec 13 2007 Dag Wieers <dag@wieers.com> - 0.92-1
605     - Updated to release 0.92.
606    
607     * Tue Aug 21 2007 Dag Wieers <dag@wieers.com> - 0.91.2-1
608     - Updated to release 0.91.2.
609    
610     * Tue Jul 17 2007 Dag Wieers <dag@wieers.com> - 0.91.1-1
611     - Updated to release 0.91.1.
612    
613     * Wed Jul 11 2007 Dag Wieers <dag@wieers.com> - 0.91-1
614     - Updated to release 0.91.
615    
616     * Thu May 31 2007 Dag Wieers <dag@wieers.com> - 0.90.3-1
617     - Updated to release 0.90.3.
618    
619     * Fri Apr 27 2007 Dag Wieers <dag@wieers.com> - 0.90.2-2
620     - Added clamav-milter support for EL2.1 now that it comes with a newer sendmail. (Tom G. Christensen)
621    
622     * Sun Apr 15 2007 Dag Wieers <dag@wieers.com> - 0.90.2-1
623     - Updated to release 0.90.2.
624    
625     * Fri Mar 09 2007 Dag Wieers <dag@wieers.com> - 0.90.1-4
626     - Removed circular dependency.
627    
628     * Thu Mar 08 2007 Dag Wieers <dag@wieers.com> - 0.90.1-3
629     - Cleaned up default options to clamav-milter. (Adam T. Bowen)
630     - Removed -b/--bounce as it is no longer recognized. (Gerald Teschl)
631    
632     * Mon Mar 05 2007 Dag Wieers <dag@wieers.com> - 0.90.1-2
633     - Removed the erroneous --dont-clean-log from the clamav-milter sysconfig. (Gerald Teschl)
634    
635     * Fri Mar 02 2007 Dag Wieers <dag@wieers.com> - 0.90.1-1
636     - Updated to release 0.90.1.
637    
638     * Tue Feb 20 2007 Dag Wieers <dag@wieers.com> - 0.90-3
639     - Do the right thing...
640    
641     * Mon Feb 19 2007 Dag Wieers <dag@wieers.com> - 0.90-2
642     - The tarball was re-rolled before public release. Sigh.
643    
644     * Tue Feb 13 2007 Dag Wieers <dag@wieers.com> - 0.90-1
645     - Updated to release 0.90.
646    
647     * Tue Dec 12 2006 Dag Wieers <dag@wieers.com> - 0.88.7-1
648     - Updated to release 0.88.7.
649    
650     * Sun Nov 05 2006 Dag Wieers <dag@wieers.com> - 0.88.6-1
651     - Updated to release 0.88.6.
652     - Added condrestart to sysv scripts. (Tsai Li Ming)
653    
654     * Sat Oct 28 2006 Dag Wieers <dag@wieers.com> - 0.88.5-2
655     - Added missing clamav dependency to clamav-db.
656    
657     * Sun Oct 15 2006 Dag Wieers <dag@wieers.com> - 0.88.5-1
658     - Updated to release 0.88.5.
659    
660     * Mon Aug 07 2006 Dag Wieers <dag@wieers.com> - 0.88.4-1
661     - Updated to release 0.88.4.
662    
663     * Mon Aug 07 2006 Dag Wieers <dag@wieers.com> - 0.88.3-2
664     - Incorporated UPX heap overflow fix.
665    
666     * Sat Jul 01 2006 Dag Wieers <dag@wieers.com> - 0.88.3-1
667     - Updated to release 0.88.3.
668    
669     * Sun Apr 30 2006 Dag Wieers <dag@wieers.com> - 0.88.2-1
670     - Updated to release 0.88.2.
671    
672     * Tue Apr 04 2006 Dag Wieers <dag@wieers.com> - 0.88.1-1
673     - Updated to release 0.88.1.
674    
675     * Mon Jan 09 2006 Dag Wieers <dag@wieers.com> - 0.88-1
676     - Updated to release 0.88.
677    
678     * Sun Nov 13 2005 Dries Verachtert <dries@ulyssis.org> - 0.87.1-1
679     - Updated to release 0.87.1.
680    
681     * Sat Sep 17 2005 Dag Wieers <dag@wieers.com> - 0.87-1
682     - Updated to release 0.87.
683    
684     * Mon Jul 25 2005 Dag Wieers <dag@wieers.com> - 0.86.2-1
685     - Updated to release 0.86.2.
686    
687     * Mon Jul 11 2005 Dag Wieers <dag@wieers.com> - 0.86.1-1
688     - Updated to release 0.86.1.
689    
690     * Mon May 16 2005 Dag Wieers <dag@wieers.com> - 0.85.1-1
691     - Updated to release 0.85.1.
692    
693     * Fri Apr 29 2005 Dag Wieers <dag@wieers.com> - 0.84-1
694     - Updated to release 0.84.
695    
696     * Mon Feb 14 2005 Dag Wieers <dag@wieers.com> - 0.83-1
697     - Updated to release 0.83.
698    
699     * Thu Feb 10 2005 Dag Wieers <dag@wieers.com> - 0.82-2
700     - Fix for false positive on RIFF files. (Roger Jochem)
701    
702     * Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 0.82-1
703     - Updated to release 0.82.
704    
705     * Thu Jan 27 2005 Dag Wieers <dag@wieers.com> - 0.81-1
706     - Improved logrotate scripts. (Filippo Grassilli)
707     - Updated to release 0.81.
708    
709     * Wed Dec 01 2004 Dag Wieers <dag@wieers.com> - 0.80-2
710     - Added %dir /var/clamav/log. (Adam Bowns)
711     - Changed logrotate script to use clamd.log. (Stuart Schneider)
712     - Added curl dependency. (Petr Kristof)
713     - Synchronized some options from Petr. (Petr Kristof)
714     - Fixed another clamav.conf reference. (Michael Best)
715    
716     * Mon Nov 01 2004 Dag Wieers <dag@wieers.com> - 0.80-1
717     - Updated package description. (Arvin Troels)
718     - Incorporated fixes from Jima. (Jima)
719     - Config clamav.conf renamed to clamd.conf.
720     - Removed obsolete patch.
721     - Added macros for building without milter.
722     - Updated to release 0.80.
723    
724     * Fri Jul 30 2004 Dag Wieers <dag@wieers.com> - 0.75.1-1
725     - Added obsoletes for fedora.us.
726     - Updated to release 0.75.1.
727    
728     * Mon Jul 26 2004 Dag Wieers <dag@wieers.com> - 0.75-2
729     - Fixed a problem where $CODE was empty.
730    
731     * Fri Jul 23 2004 Dag Wieers <dag@wieers.com> - 0.75-1
732     - Updated to release 0.75.
733    
734     * Wed Jun 30 2004 Dag Wieers <dag@wieers.com> - 0.74-1
735     - Updated to release 0.74.
736    
737     * Tue Jun 15 2004 Dag Wieers <dag@wieers.com> - 0.73-1
738     - Updated to release 0.73.
739    
740     * Thu Jun 03 2004 Dag Wieers <dag@wieers.com> - 0.72-1
741     - Updated to release 0.72.
742    
743     * Thu May 20 2004 Dag Wieers <dag@wieers.com> - 0.71-1
744     - Updated to release 0.71.
745    
746     * Sun May 02 2004 Dag Wieers <dag@wieers.com> - 0.70-2
747     - Fixed the installation check for conf files. (Richard Soderberg, Udo Ruecker)
748     - Changed the init-order of the sysv scripts. (Will McCutcheon)
749     - Changes to the default configuration files.
750    
751     * Sat Mar 17 2004 Dag Wieers <dag@wieers.com> - 0.70-1
752     - Updated to release 0.70.
753    
754     * Tue Mar 16 2004 Dag Wieers <dag@wieers.com> - 0.68-1
755     - Updated to release 0.68.
756    
757     * Fri Mar 12 2004 Dag Wieers <dag@wieers.com> - 0.67.1-1
758     - Updated to release 0.67-1.
759     - Added clamdwatch and trashcan to clamd.
760    
761     * Mon Mar 08 2004 Dag Wieers <dag@wieers.com> - 0.67-1
762     - Personalized SPEC file.
763    
764     * Mon Aug 22 2003 Matthias Saou/Che
765     - Added "--without milter" build option. (Matthias Saou)
766     - Fixed freshclam cron (Matthias Saou)
767     - Built the new package. (Che)
768    
769     * Tue Jun 24 2003 Che
770     - clamav-milter introduced.
771     - a few more smaller fixes.
772    
773     * Sun Jun 22 2003 Che
774     - version upgrade
775    
776     * Mon Jun 16 2003 Che
777     - rh9 build
778     - various fixes
779     - got rid of rpm-helper prereq
780    
781     * Fri Mar 24 2003 Che
782     - some cleanups and fixes
783     - new patch added
784    
785     * Fri Nov 22 2002 Che
786     - fixed a config patch issue
787    
788     * Fri Nov 22 2002 Che
789     - version upgrade and some fixes
790    
791     * Sat Nov 02 2002 Che
792     - version upgrade
793    
794     * Wed Oct 24 2002 Che
795     - some important changes for lsb compliance
796    
797     * Wed Oct 23 2002 Che
798     - initial rpm release

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed