/[smeserver]/rpms/clamav/sme10/clamav.spec
ViewVC logotype

Annotation of /rpms/clamav/sme10/clamav.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Tue May 3 19:41:59 2016 UTC (8 years, 2 months ago) by vip-ire
Branch: MAIN
CVS Tags: clamav-0_99_2-1_el7_sme
Changes since 1.4: +18 -8 lines
* Tue May 3 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99.2-1.sme
- Update to 0.99.2 [SME: 9487]
- Adapt to use systemd unit [SME: 9487]

1 vip-ire 1.5 # $Id: clamav.spec,v 1.4 2016/05/03 19:19:44 vip-ire Exp $
2 vip-ire 1.1 # Authority: dag
3     # Upstream: <clamav-devel$lists,sf,net>
4    
5     ### FIXME: Sysv script does not have condrestart option (redo sysv script)
6     ### FIXME: amavisd-new requires clamd to run as user vscan, solution needed
7     ### REMINDER: Look and sync with Petr Kristof's work
8    
9     %{?el3:%define _without_milter 1}
10     %{?rh9:%define _without_milter 1}
11     %{?rh7:%define _without_milter 1}
12     %{?el2:%define _without_milter 1}
13    
14     Summary: Anti-virus software
15     Name: clamav
16 vip-ire 1.4 Version: 0.99.2
17 vip-ire 1.3 Release: 1%{?dist}
18 vip-ire 1.1 License: GPL
19     Group: Applications/System
20     URL: http://www.clamav.net/
21    
22     Source: http://downloads.sourceforge.net/project/clamav/clamav/%{version}/clamav-%{version}.tar.gz
23     Source1: clamav.init
24     Source2: clamav-milter.init
25     Source10: http://db.local.clamav.net/main.cvd
26     Source11: http://db.local.clamav.net/daily.cvd
27     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28    
29     BuildRequires: bzip2-devel
30     BuildRequires: curl-devel
31     BuildRequires: gmp-devel
32     BuildRequires: ncurses-devel
33     BuildRequires: zlib-devel
34     %{!?_without_milter:BuildRequires: sendmail-devel >= 8.12}
35     BuildRequires: check-devel
36     BuildRequires: openssl-devel
37     BuildRequires: libxml2-devel
38 vip-ire 1.2 BuildRequires: pcre-devel
39 vip-ire 1.1
40    
41     ### Do not require the latest release of clamav-db specifically (people may use freshclam onward)
42     #Requires: clamav-db = %{version}-%{release}
43     Requires: clamav-db
44    
45     ### Fedora Extras introduced them differently :(
46     Obsoletes: libclamav <= %{version}-%{release}
47     Obsoletes: clamav-lib <= %{version}-%{release}
48     Provides: libclamav
49    
50     %description
51     Clam AntiVirus is a GPL anti-virus toolkit for UNIX. The main purpose of
52     this software is the integration with mail servers (attachment scanning).
53     The package provides a flexible and scalable multi-threaded daemon, a
54     command line scanner, and a tool for automatic updating via Internet.
55    
56     The programs are based on a shared library distributed with the Clam
57     AntiVirus package, which you can use with your own software. Most
58     importantly, the virus database is kept up to date
59    
60     %package -n clamd
61     Summary: The Clam AntiVirus Daemon
62     Group: System Environment/Daemons
63     Requires: clamav = %{version}-%{release}
64     Requires(pre): /usr/sbin/groupadd
65     Requires(pre): /usr/sbin/useradd
66    
67     ### Fedora Extras introduced them differently :(
68     Obsoletes: clamav-server <= %{version}-%{release}
69    
70     %description -n clamd
71     The Clam AntiVirus Daemon
72    
73     %package milter
74     Summary: The Clam AntiVirus sendmail-milter Daemon
75     Group: Applications/System
76     Requires: clamd = %{version}-%{release}
77     Requires: smtpdaemon
78    
79     %description milter
80     The Clam AntiVirus sendmail-milter Daemon
81    
82     %package db
83     Summary: Virus database for %{name}
84     Group: Applications/Databases
85     ### Remove circular dependency
86     #Requires: clamav = %{version}-%{release}
87     Requires(pre): /usr/sbin/groupadd
88     Requires(pre): /usr/sbin/useradd
89    
90     ### Fedora Extras introduced them differently :(
91     Obsoletes: clamav-update <= %{version}-%{release}
92     Obsoletes: clamav-data <= %{version}-%{release}
93    
94     %description db
95     The actual virus database for %{name}
96    
97     %package devel
98     Summary: Header files, libraries and development documentation for %{name}
99     Group: Development/Libraries
100     Requires: clamav = %{version}-%{release}
101    
102     ### Fedora Extras introduced them differently :(
103     Obsoletes: libclamav-static-devel <= %{version}-%{release}
104     Obsoletes: libclamav-devel <= %{version}-%{release}
105     Provides: libclamav-static-devel, libclamav-devel
106    
107     %description devel
108     This package contains the header files, static libraries and development
109     documentation for %{name}. If you like to develop programs using %{name},
110     you will need to install %{name}-devel.
111    
112     %prep
113     %setup
114    
115     %{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g;' libtool configure
116    
117     %{__perl} -pi.orig -e '
118     s|\@DBDIR\@|\$(localstatedir)/clamav|g;
119     s|\@DBINST\@|\$(localstatedir)/clamav|g;
120     s|\@CFGDIR\@|\$(sysconfdir)|g;
121     s|\@CFGINST\@|\$(sysconfdir)|g;
122     s|^\@INSTALL_CLAMAV_CONF_TRUE\@|\t|g;
123     s|^\@INSTALL_FRESHCLAM_CONF_TRUE\@|\t|g;
124     ' database/Makefile.in etc/Makefile.in
125    
126     %{__perl} -pi -e '
127     s|^(Example)|#$1|;
128     s|^#(LogFile) .+$|$1 %{_localstatedir}/log/clamav/clamd.log|;
129     s|^#(LogFileMaxSize) .*|$1 0|;
130     s|^#(LogTime)|$1|;
131     s|^#(LogSyslog)|$1|;
132     s|^#(PidFile) .+$|$1 %{_localstatedir}/run/clamav/clamd.pid|;
133     s|^#(TemporaryDirectory) .+$|$1 %{_localstatedir}/tmp|;
134     s|^#(DatabaseDirectory) .+$|$1 %{_localstatedir}/clamav|;
135     s|^#(LocalSocket) .+$|$1 %{_localstatedir}/run/clamav/clamd.sock|;
136     s|^#(FixStaleSocket)|$1|;
137     s|^#(TCPSocket) .+$|$1 3310|;
138     s|^#(TCPAddr) .+$|$1 127.0.0.1|;
139     s|^#(MaxConnectionQueueLength) .+$|$1 30|;
140     s|^#(StreamSaveToDisk)|$1|;
141     s|^#(MaxThreads) .+$|$1 50|;
142     s|^#(ReadTimeout) .+$|$1 300|;
143     s|^#(User) .+$|$1 clamav|;
144     s|^#(AllowSupplementaryGroups).*$|$1 yes|;
145     s|^#(ScanPE) .+$|$1 yes|;
146     s|^#(ScanELF) .+$|$1 yes|;
147     s|^#(DetectBrokenExecutables)|$1|;
148     s|^#(ScanOLE2) .+$|$1 yes|;
149     s|^#(ScanMail)|$1|;
150     s|^#(ScanArchive) .+$|$1 yes|;
151     s|^#(ArchiveMaxCompressionRatio) .+|$1 300|;
152     s|^#(ArchiveBlockEncrypted)|$1|;
153     s|^#(ArchiveBlockMax)|$1|;
154     ' etc/clamd.conf.sample >etc/clamd.conf
155    
156     %{__perl} -pi -e '
157     s|^(Example)|#$1|;
158     s|^#(AllowSupplementaryGroups) .+$|$1 yes|;
159     s|^#(ClamdSocket) .+$|$1 unix:%{_localstatedir}/run/clamav/clamd.sock|;
160     s|^#(LogFile) .+$|$1 %{_localstatedir}/log/clamav/clamav-milter.log|;
161     s|^#(LogFileMaxSize) .*|$1 0|;
162     s|^#(LogSyslog)|$1|;
163     s|^#(LogTime)|$1|;
164     s|^#(MilterSocket) /.*$|$1 unix:%{_localstatedir}/clamav/clmilter.socket|;
165     s|^#(User) .+$|$1 clamav|;
166     ' etc/clamav-milter.conf.sample >etc/clamav-milter.conf
167    
168     %{__perl} -p -e '
169     s|^(Checks) .+$|$1 24|;
170     s|^(Example)|#$1|;
171     s|^#(DatabaseDirectory) .+$|$1 %{_localstatedir}/clamav|;
172     s|^#(DatabaseOwner) .+$|$1 clamav|;
173     s|^#(LogSyslog)|$1|;
174     s|^#(NotifyClamd) .+$|$1 %{_sysconfdir}/clamd.conf|;
175     s|^#(UpdateLogFile) .+$|$1 %{_localstatedir}/log/clamav/freshclam.log|;
176     ' etc/freshclam.conf.sample >etc/freshclam.conf
177    
178     %{__cat} <<EOF >clamd.logrotate
179     %{_localstatedir}/log/clamav/clamd.log {
180     missingok
181     notifempty
182     create 644 clamav clamav
183     postrotate
184     killall -HUP clamd 2>/dev/null || :
185     endscript
186     }
187     EOF
188    
189     %{__cat} <<EOF >freshclam.logrotate
190     %{_localstatedir}/log/clamav/freshclam.log {
191     missingok
192     notifempty
193     create 644 clamav clamav
194     }
195     EOF
196    
197     %{__cat} <<'EOF' >freshclam.cron
198     #!/bin/sh
199    
200     ### A simple update script for the clamav virus database.
201     ### This could as well be replaced by a SysV script.
202    
203     %{_bindir}/freshclam --quiet
204     EOF
205    
206     %{__cat} <<EOF >clamav-milter.sysconfig
207     ### Simple config file for clamav-milter, you should
208     ### read the documentation and tweak it as you wish.
209    
210     CLAMAV_FLAGS="--config-file=%{_sysconfdir}/clamav-milter.conf"
211     EOF
212    
213     %build
214     %configure \
215     --program-prefix="%{?_program_prefix}" \
216     --disable-clamav \
217     --disable-llvm \
218     --disable-static \
219     --disable-zlib-vcheck \
220     --enable-check \
221     --enable-clamdtop \
222     --enable-dns \
223     --enable-id-check \
224     %{!?_without_milter:--enable-milter} \
225     --with-dbdir="%{_localstatedir}/clamav" \
226     --with-group="clamav" \
227     --with-libcurl=%{_prefix} \
228     --with-user="clamav"
229     ### Disable JIT until it is implemented securely (RHbz #573191)
230     # --enable-llvm \
231     %{__make} %{?_smp_mflags}
232    
233     %install
234     %{__rm} -rf %{buildroot}
235     %{__make} install DESTDIR="%{buildroot}"
236    
237     %{__install} -Dp -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/clamd
238     %{__install} -Dp -m0644 etc/freshclam.conf %{buildroot}%{_sysconfdir}/freshclam.conf
239     %{__install} -Dp -m0755 freshclam.cron %{buildroot}%{_sysconfdir}/cron.daily/freshclam
240     %{__install} -Dp -m0644 freshclam.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/freshclam
241     %{__install} -Dp -m0644 etc/clamd.conf %{buildroot}%{_sysconfdir}/clamd.conf
242     %{__install} -Dp -m0644 clamd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/clamav
243    
244     %if %{!?_without_milter:1}0
245     %{__install} -Dp -m0644 etc/clamav-milter.conf %{buildroot}%{_sysconfdir}/clamav-milter.conf
246     %{__install} -Dp -m0755 %{SOURCE2} %{buildroot}%{_initrddir}/clamav-milter
247     %{__install} -Dp -m0644 clamav-milter.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/clamav-milter
248     %else
249     %{__rm} %{buildroot}%{_mandir}/man8/clamav-milter.8*
250     %endif
251    
252     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/log/clamav/
253     touch %{buildroot}%{_localstatedir}/log/clamav/freshclam.log
254     touch %{buildroot}%{_localstatedir}/log/clamav/clamd.log
255    
256     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/clamav/
257     %{__install} -d -m0755 %{buildroot}%{_localstatedir}/run/clamav/
258    
259     #touch %{buildroot}%{_localstatedir}/clamav/daily.cld
260     #touch %{buildroot}%{_localstatedir}/clamav/main.cld
261    
262     %{__install} -Dp -m0644 %SOURCE10 %{buildroot}%{_localstatedir}/clamav/main.cvd
263     %{__install} -Dp -m0644 %SOURCE11 %{buildroot}%{_localstatedir}/clamav/daily.cvd
264    
265     %post
266     /sbin/ldconfig
267    
268     ZONES="/usr/share/zoneinfo/zone.tab"
269     CONFIG="/etc/sysconfig/clock"
270    
271     if [ -r "$CONFIG" -a -r "$ZONES" ]; then
272     source "$CONFIG"
273     export CODE="$(grep -E "\b$ZONE\b" "$ZONES" | head -1 | cut -f1 | tr '[A-Z]' '[a-z]')"
274     fi
275    
276     if [ -z "$CODE" ]; then
277     export CODE="local"
278     fi
279    
280     %{__perl} -pi -e '
281     s|^(DatabaseMirror) database\.clamav\.net$|$1 db.$ENV{"CODE"}.clamav.net\n$1 db.local.clamav.net|;
282     s|^(DatabaseMirror) db\.\.clamav\.net$|$1 db.$ENV{"CODE"}.clamav.net\n$1 db.local.clamav.net|;
283     ' %{_sysconfdir}/freshclam.conf{,.rpmnew} &>/dev/null || :
284    
285     %postun -p /sbin/ldconfig
286    
287     %pre -n clamd
288     /usr/sbin/groupadd -r clamav 2>/dev/null || :
289     /usr/sbin/useradd -r -d /var/clamav -s /sbin/nologin -c "Clam Anti Virus Checker" -g clamav clamav 2>/dev/null || :
290    
291     %post -n clamd
292 vip-ire 1.5 %systemd_post clamav-daemon.service
293 vip-ire 1.1
294     %preun -n clamd
295 vip-ire 1.5 %systemd_preun clamav-daemon.service
296 vip-ire 1.1
297     %postun -n clamd
298 vip-ire 1.5 %systemd_postun
299 vip-ire 1.1
300     %post milter
301     /sbin/chkconfig --add clamav-milter
302    
303     %preun milter
304     if [ $1 -eq 0 ]; then
305     /sbin/service clamav-milter stop &>/dev/null || :
306     /sbin/chkconfig --del clamav-milter
307     fi
308    
309     %postun milter
310     /sbin/service clamav-milter condrestart &>/dev/null || :
311    
312     %pre db
313     /usr/sbin/groupadd -r clamav 2>/dev/null || :
314     /usr/sbin/useradd -r -d /var/clamav -s /sbin/nologin -c "Clam Anti Virus Checker" -g clamav clamav 2>/dev/null || :
315    
316 vip-ire 1.5 %post db
317     %systemd_post clamav-freshclam.service
318    
319     %preun db
320     %systemd_preun clamav-freshclam.service
321    
322     %postun db
323     %systemd_postun
324    
325 vip-ire 1.1 %clean
326     %{__rm} -rf %{buildroot}
327    
328     %files
329     %defattr(-, root, root, 0755)
330     %doc AUTHORS BUGS ChangeLog COPYING FAQ INSTALL NEWS README
331     %doc etc/freshclam.conf.sample
332     %doc docs/*.pdf
333     ### Remove test virus documents as they trigger clamav
334     #%doc test/
335     %doc %{_mandir}/man1/sigtool.1*
336     %doc %{_mandir}/man1/clambc.1*
337     %doc %{_mandir}/man1/clamscan.1*
338     %doc %{_mandir}/man1/clamsubmit.1*
339     %doc %{_mandir}/man1/freshclam.1*
340     %doc %{_mandir}/man5/freshclam.conf.5*
341     %config(noreplace) %{_sysconfdir}/freshclam.conf
342 vip-ire 1.5 %{_unitdir}/clamav-freshclam.service
343 vip-ire 1.1 %{_bindir}/clambc
344     %{_bindir}/clamscan
345     %{_bindir}/freshclam
346     %{_bindir}/sigtool
347     %{_bindir}/clamsubmit
348     %{_libdir}/libclamav.so.*
349     %{_libdir}/libclamunrar.so.*
350     %{_libdir}/libclamunrar_iface.so.*
351     # moved from -devel to here so clamd can work with rars when clamav-devel is not installed.
352     %{_libdir}/libclamav.so
353     %{_libdir}/libclamunrar.so
354     %{_libdir}/libclamunrar_iface.so
355     %exclude %{_sysconfdir}/freshclam.conf.sample
356    
357     %files -n clamd
358     %defattr(-, root, root, 0755)
359     %doc etc/clamd.conf.sample
360     %doc %{_mandir}/man1/clambc.1*
361     %doc %{_mandir}/man1/clamconf.1*
362     %doc %{_mandir}/man1/clamdscan.1*
363     %doc %{_mandir}/man1/clamdtop.1*
364     %doc %{_mandir}/man5/clamd.conf.5*
365     %doc %{_mandir}/man8/clamd.8*
366     %config(noreplace) %{_sysconfdir}/clamd.conf
367     %config(noreplace) %{_sysconfdir}/logrotate.d/clamav
368     %config %{_initrddir}/clamd
369 vip-ire 1.5 %{_unitdir}/clamav-daemon.service
370     %{_unitdir}/clamav-daemon.socket
371 vip-ire 1.1 %{_sbindir}/clamd
372     %{_bindir}/clamconf
373     %{_bindir}/clamdscan
374     %{_bindir}/clamdtop
375    
376     %defattr(0644, clamav, clamav, 0755)
377     %{_localstatedir}/run/clamav/
378     %dir %{_localstatedir}/clamav/
379     %dir %{_localstatedir}/log/clamav/
380     %ghost %{_localstatedir}/log/clamav/clamd.log
381    
382     %exclude %{_localstatedir}/clamav/*
383     %exclude %{_sysconfdir}/clamd.conf.sample
384    
385     %if %{!?_without_milter:1}0
386     %files milter
387     %defattr(-, root, root, 0755)
388     %doc etc/clamav-milter.conf.sample
389     %doc %{_mandir}/man5/clamav-milter.conf.5*
390     %doc %{_mandir}/man8/clamav-milter.8*
391     %config(noreplace) %{_sysconfdir}/clamav-milter.conf
392     %config(noreplace) %{_sysconfdir}/sysconfig/clamav-milter
393     %config %{_initrddir}/clamav-milter
394     %{_sbindir}/clamav-milter
395     %else
396     %exclude %{_mandir}/man5/clamav-milter.conf.5*
397     %endif
398     %exclude %{_sysconfdir}/clamav-milter.conf.sample
399    
400     %files db
401     %defattr(-, root, root, 0755)
402     %config(noreplace) %{_sysconfdir}/cron.daily/freshclam
403     %config(noreplace) %{_sysconfdir}/logrotate.d/freshclam
404    
405     %defattr(0644, clamav, clamav, 0755)
406     %config(noreplace) %verify(user group mode) %{_localstatedir}/clamav/
407     %dir %{_localstatedir}/log/clamav/
408     %ghost %{_localstatedir}/log/clamav/freshclam.log
409    
410     %files devel
411     %defattr(-, root, root, 0755)
412     %{_bindir}/clamav-config
413     %{_includedir}/clamav.h
414     %{_libdir}/pkgconfig/libclamav.pc
415     %exclude %{_libdir}/libclamav.la
416     %exclude %{_libdir}/libclamunrar.la
417     %exclude %{_libdir}/libclamunrar_iface.la
418    
419     %changelog
420 vip-ire 1.4 * Tue May 3 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99.2-1.sme
421 vip-ire 1.5 - Update to 0.99.2 [SME: 9487]
422     - Adapt to use systemd unit [SME: 9487]
423 vip-ire 1.4
424 vip-ire 1.3 * Thu Mar 3 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99.1-1.sme
425     - Update to 0.99.1 [SME: 9268]
426    
427 vip-ire 1.2 * Tue Jan 12 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99-2.sme
428     - Add pcre-devel to BuildRequires [SME: 9151]
429    
430     * Wed Jan 6 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.99-1.sme
431     - Update to release 0.99 [SME: 9151]
432    
433 vip-ire 1.1 * Wed May 13 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.98.7-1.sme
434     - Updated to release 0.98.7 [SME: 8922]
435    
436     * Thu Jan 29 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.98.6-1.sme
437     - Updated to release 0.98.6 [SME: 8822]
438    
439     * Tue Dec 16 2014 Daniel Berteaud <daniel@firewall-services.com> - 0.98.5-1.sme
440     - Updated to release 0.98.5 [SME: 8729]
441    
442     * Sat Jun 21 2014 Ian Wells <esmith@wellsi.com> - 0.98.4-2.sme
443     - Add BuildRequires for openssl-devel and libxml2-devel [SME: 8457]
444     - Remove Packager and Vendor from spec file.
445    
446     * Thu Jun 17 2014 David Beveridge <dave@bevhost.com> - 0.98.4-1
447     - Updates to release 0.98.4.
448    
449     * Thu May 8 2014 David Beveridge <dave@bevhost.com> - 0.98.3-1
450     - Updated to release 0.98.3.
451    
452     * Sun Jan 26 2014 David Beveridge <dave@bevhost.com> - 0.98.1-1
453     - Updates to release 0.98.1.
454    
455     * Tue Sep 24 2013 Dag Wieers <dag@wieers.com> - 0.98-1
456     - Updated to release 0.98.
457    
458     * Tue May 07 2013 David Hrbáč <david@hrbac.cz> - 0.97.8-1
459     - Updated to release 0.97.8.
460    
461     * Wed Mar 20 2013 Dag Wieers <dag@wieers.com> - 0.97.7-1
462     - Updated to release 0.97.7.
463    
464     * Sun Sep 23 2012 Dag Wieers <dag@wieers.com> - 0.97.6-1
465     - Updated to release 0.97.6.
466    
467     * Mon Jun 25 2012 David Hrbáč <david@hrbac.cz> - 0.97.5-2
468     - removed missing *.cld files (#183)
469    
470     * Thu Jun 21 2012 David Hrbáč <david@hrbac.cz> - 0.97.5-1
471     - corrected missing DBs
472     - new upstream release
473    
474     * Sat Jun 16 2012 Dag Wieers <dag@wieers.com> - 0.97.5-1
475     - Updated to release 0.97.5.
476    
477     * Thu Mar 15 2012 Dag Wieers <dag@wieers.com> - 0.97.4-1
478     - Updated to release 0.97.4.
479    
480     * Sat Dec 13 2011 Philip J Perry <phil@elrepo.org> - 0.97.3-2
481     - Fix Requires for clamav-milter to also allow use with Postfix.
482    
483     * Mon Oct 17 2011 Dag Wieers <dag@wieers.com> - 0.97.3-1
484     - Updated to release 0.97.3.
485    
486     * Mon Jul 25 2011 Dag Wieers <dag@wieers.com> - 0.97.2-1
487     - Updated to release 0.97.2.
488    
489     * Thu Jun 09 2011 Dag Wieers <dag@wieers.com> - 0.97.1-1
490     - Updated to release 0.97.1.
491    
492     * Tue Feb 08 2011 Dag Wieers <dag@wieers.com> - 0.97-1
493     - Updated to release 0.97.
494    
495     * Tue Nov 30 2010 Dag Wieers <dag@wieers.com> - 0.96.5-1
496     - Updated to release 0.96.5.
497    
498     * Mon Oct 25 2010 Dag Wieers <dag@wieers.com> - 0.96.4-1
499     - Updated to release 0.96.4.
500    
501     * Tue Sep 21 2010 David Hrbáč <david@hrbac.cz> - 0.96.3-2
502     - Added buildrequires check-devel.
503    
504     * Tue Sep 21 2010 Dag Wieers <dag@wieers.com> - 0.96.3-1
505     - Updated to release 0.96.3.
506    
507     * Tue Aug 17 2010 Dag Wieers <dag@wieers.com> - 0.96.2-2
508     - Added patch that fixes segfault when using SELinux. (Beat Siegenthaler)
509    
510     * Thu Aug 12 2010 Dag Wieers <dag@wieers.com> - 0.96.2-1
511     - Updated to release 0.96.2.
512    
513     * Wed May 19 2010 Dag Wieers <dag@wieers.com> - 0.96.1-1
514     - Updated to release 0.96.1.
515    
516     * Mon May 03 2010 Dag Wieers <dag@wieers.com> - 0.96-3
517     - Restored the LocalSocket configuration option to what it used to be. (Chris Butler)
518    
519     * Wed Apr 07 2010 Dag Wieers <dag@wieers.com> - 0.96-2
520     - Removed test virus documents to prevent triggering clamav itself. (Patrick Mulvany)
521    
522     * Wed Mar 31 2010 Dag Wieers <dag@wieers.com> - 0.96-1
523     - Updated to release 0.96.
524    
525     * Thu Oct 29 2009 Dag Wieers <dag@wieers.com> - 0.95.3-1
526     - Updated to release 0.95.3.
527    
528     * Fri Jun 12 2009 Christoph Maser <cmr@financial.com> - 0.95.2-1
529     - Updated to release 0.95.2.
530    
531     * Mon May 04 2009 Dag Wieers <dag@wieers.com> - 0.95.1-4
532     - Fix the inconsistency between LocalSocket in clamd.conf and clamav-milter.conf. (Gerald Teschl)
533    
534     * Sat May 02 2009 Dag Wieers <dag@wieers.com> - 0.95.1-3
535     - Fix the LocalSocket in clamd.conf. (Gerald Teschl)
536    
537     * Wed Apr 15 2009 Fabian Arrotin <fabian.arrotin@arrfab.net> - 0.95.1-2
538     - Added a missing BuildRequires: ncurses-devel to build clamdtop.
539    
540     * Fri Apr 10 2009 Dag Wieers <dag@wieers.com> - 0.95.1-2
541     - Corrected LogFile definition. (Vadim Druzhin)
542    
543     * Wed Apr 8 2009 Dag Wieers <dag@wieers.com> - 0.95.1-1
544     - Updated to release 0.95.1.
545    
546     * Tue Apr 7 2009 Dries Verachtert <dries@ulyssis.org> - 0.95-3
547     - Ugly fix for clamd which needs the .so files.
548    
549     * Tue Mar 24 2009 Dag Wieers <dag@wieers.com> - 0.95-1
550     - Updated to release 0.95.
551    
552     * Thu Nov 27 2008 Dag Wieers <dag@wieers.com> - 0.94.2-1
553     - Updated to release 0.94.2.
554    
555     * Mon Nov 03 2008 Dag Wieers <dag@wieers.com> - 0.94.1-1
556     - Updated to release 0.94.1.
557    
558     * Tue Sep 02 2008 Dag Wieers <dag@wieers.com> - 0.94-1
559     - Updated to release 0.94.
560    
561     * Wed Jul 09 2008 Dag Wieers <dag@wieers.com> - 0.93.3-1
562     - Updated to release 0.93.3.
563    
564     * Mon Jul 07 2008 Dag Wieers <dag@wieers.com> - 0.93.2-1
565     - Updated to release 0.93.2.
566    
567     * Mon Jun 09 2008 Dag Wieers <dag@wieers.com> - 0.93.1-1
568     - Updated to release 0.93.1.
569    
570     * Wed Apr 16 2008 Dag Wieers <dag@wieers.com> - 0.93-2
571     - Normal build causes linkage against installed library.
572    
573     * Mon Apr 14 2008 Dag Wieers <dag@wieers.com> - 0.93-1
574     - Updated to release 0.93.
575    
576     * Wed Feb 27 2008 Dag Wieers <dag@wieers.com> - queued
577     - Do not require the latest release of clamav-db. (Federico Simoncelli)
578    
579     * Mon Feb 11 2008 Dag Wieers <dag@wieers.com> - 0.92.1-1
580     - Updated to release 0.92.1.
581    
582     * Thu Dec 13 2007 Dag Wieers <dag@wieers.com> - 0.92-1
583     - Updated to release 0.92.
584    
585     * Tue Aug 21 2007 Dag Wieers <dag@wieers.com> - 0.91.2-1
586     - Updated to release 0.91.2.
587    
588     * Tue Jul 17 2007 Dag Wieers <dag@wieers.com> - 0.91.1-1
589     - Updated to release 0.91.1.
590    
591     * Wed Jul 11 2007 Dag Wieers <dag@wieers.com> - 0.91-1
592     - Updated to release 0.91.
593    
594     * Thu May 31 2007 Dag Wieers <dag@wieers.com> - 0.90.3-1
595     - Updated to release 0.90.3.
596    
597     * Fri Apr 27 2007 Dag Wieers <dag@wieers.com> - 0.90.2-2
598     - Added clamav-milter support for EL2.1 now that it comes with a newer sendmail. (Tom G. Christensen)
599    
600     * Sun Apr 15 2007 Dag Wieers <dag@wieers.com> - 0.90.2-1
601     - Updated to release 0.90.2.
602    
603     * Fri Mar 09 2007 Dag Wieers <dag@wieers.com> - 0.90.1-4
604     - Removed circular dependency.
605    
606     * Thu Mar 08 2007 Dag Wieers <dag@wieers.com> - 0.90.1-3
607     - Cleaned up default options to clamav-milter. (Adam T. Bowen)
608     - Removed -b/--bounce as it is no longer recognized. (Gerald Teschl)
609    
610     * Mon Mar 05 2007 Dag Wieers <dag@wieers.com> - 0.90.1-2
611     - Removed the erroneous --dont-clean-log from the clamav-milter sysconfig. (Gerald Teschl)
612    
613     * Fri Mar 02 2007 Dag Wieers <dag@wieers.com> - 0.90.1-1
614     - Updated to release 0.90.1.
615    
616     * Tue Feb 20 2007 Dag Wieers <dag@wieers.com> - 0.90-3
617     - Do the right thing...
618    
619     * Mon Feb 19 2007 Dag Wieers <dag@wieers.com> - 0.90-2
620     - The tarball was re-rolled before public release. Sigh.
621    
622     * Tue Feb 13 2007 Dag Wieers <dag@wieers.com> - 0.90-1
623     - Updated to release 0.90.
624    
625     * Tue Dec 12 2006 Dag Wieers <dag@wieers.com> - 0.88.7-1
626     - Updated to release 0.88.7.
627    
628     * Sun Nov 05 2006 Dag Wieers <dag@wieers.com> - 0.88.6-1
629     - Updated to release 0.88.6.
630     - Added condrestart to sysv scripts. (Tsai Li Ming)
631    
632     * Sat Oct 28 2006 Dag Wieers <dag@wieers.com> - 0.88.5-2
633     - Added missing clamav dependency to clamav-db.
634    
635     * Sun Oct 15 2006 Dag Wieers <dag@wieers.com> - 0.88.5-1
636     - Updated to release 0.88.5.
637    
638     * Mon Aug 07 2006 Dag Wieers <dag@wieers.com> - 0.88.4-1
639     - Updated to release 0.88.4.
640    
641     * Mon Aug 07 2006 Dag Wieers <dag@wieers.com> - 0.88.3-2
642     - Incorporated UPX heap overflow fix.
643    
644     * Sat Jul 01 2006 Dag Wieers <dag@wieers.com> - 0.88.3-1
645     - Updated to release 0.88.3.
646    
647     * Sun Apr 30 2006 Dag Wieers <dag@wieers.com> - 0.88.2-1
648     - Updated to release 0.88.2.
649    
650     * Tue Apr 04 2006 Dag Wieers <dag@wieers.com> - 0.88.1-1
651     - Updated to release 0.88.1.
652    
653     * Mon Jan 09 2006 Dag Wieers <dag@wieers.com> - 0.88-1
654     - Updated to release 0.88.
655    
656     * Sun Nov 13 2005 Dries Verachtert <dries@ulyssis.org> - 0.87.1-1
657     - Updated to release 0.87.1.
658    
659     * Sat Sep 17 2005 Dag Wieers <dag@wieers.com> - 0.87-1
660     - Updated to release 0.87.
661    
662     * Mon Jul 25 2005 Dag Wieers <dag@wieers.com> - 0.86.2-1
663     - Updated to release 0.86.2.
664    
665     * Mon Jul 11 2005 Dag Wieers <dag@wieers.com> - 0.86.1-1
666     - Updated to release 0.86.1.
667    
668     * Mon May 16 2005 Dag Wieers <dag@wieers.com> - 0.85.1-1
669     - Updated to release 0.85.1.
670    
671     * Fri Apr 29 2005 Dag Wieers <dag@wieers.com> - 0.84-1
672     - Updated to release 0.84.
673    
674     * Mon Feb 14 2005 Dag Wieers <dag@wieers.com> - 0.83-1
675     - Updated to release 0.83.
676    
677     * Thu Feb 10 2005 Dag Wieers <dag@wieers.com> - 0.82-2
678     - Fix for false positive on RIFF files. (Roger Jochem)
679    
680     * Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 0.82-1
681     - Updated to release 0.82.
682    
683     * Thu Jan 27 2005 Dag Wieers <dag@wieers.com> - 0.81-1
684     - Improved logrotate scripts. (Filippo Grassilli)
685     - Updated to release 0.81.
686    
687     * Wed Dec 01 2004 Dag Wieers <dag@wieers.com> - 0.80-2
688     - Added %dir /var/clamav/log. (Adam Bowns)
689     - Changed logrotate script to use clamd.log. (Stuart Schneider)
690     - Added curl dependency. (Petr Kristof)
691     - Synchronized some options from Petr. (Petr Kristof)
692     - Fixed another clamav.conf reference. (Michael Best)
693    
694     * Mon Nov 01 2004 Dag Wieers <dag@wieers.com> - 0.80-1
695     - Updated package description. (Arvin Troels)
696     - Incorporated fixes from Jima. (Jima)
697     - Config clamav.conf renamed to clamd.conf.
698     - Removed obsolete patch.
699     - Added macros for building without milter.
700     - Updated to release 0.80.
701    
702     * Fri Jul 30 2004 Dag Wieers <dag@wieers.com> - 0.75.1-1
703     - Added obsoletes for fedora.us.
704     - Updated to release 0.75.1.
705    
706     * Mon Jul 26 2004 Dag Wieers <dag@wieers.com> - 0.75-2
707     - Fixed a problem where $CODE was empty.
708    
709     * Fri Jul 23 2004 Dag Wieers <dag@wieers.com> - 0.75-1
710     - Updated to release 0.75.
711    
712     * Wed Jun 30 2004 Dag Wieers <dag@wieers.com> - 0.74-1
713     - Updated to release 0.74.
714    
715     * Tue Jun 15 2004 Dag Wieers <dag@wieers.com> - 0.73-1
716     - Updated to release 0.73.
717    
718     * Thu Jun 03 2004 Dag Wieers <dag@wieers.com> - 0.72-1
719     - Updated to release 0.72.
720    
721     * Thu May 20 2004 Dag Wieers <dag@wieers.com> - 0.71-1
722     - Updated to release 0.71.
723    
724     * Sun May 02 2004 Dag Wieers <dag@wieers.com> - 0.70-2
725     - Fixed the installation check for conf files. (Richard Soderberg, Udo Ruecker)
726     - Changed the init-order of the sysv scripts. (Will McCutcheon)
727     - Changes to the default configuration files.
728    
729     * Sat Mar 17 2004 Dag Wieers <dag@wieers.com> - 0.70-1
730     - Updated to release 0.70.
731    
732     * Tue Mar 16 2004 Dag Wieers <dag@wieers.com> - 0.68-1
733     - Updated to release 0.68.
734    
735     * Fri Mar 12 2004 Dag Wieers <dag@wieers.com> - 0.67.1-1
736     - Updated to release 0.67-1.
737     - Added clamdwatch and trashcan to clamd.
738    
739     * Mon Mar 08 2004 Dag Wieers <dag@wieers.com> - 0.67-1
740     - Personalized SPEC file.
741    
742     * Mon Aug 22 2003 Matthias Saou/Che
743     - Added "--without milter" build option. (Matthias Saou)
744     - Fixed freshclam cron (Matthias Saou)
745     - Built the new package. (Che)
746    
747     * Tue Jun 24 2003 Che
748     - clamav-milter introduced.
749     - a few more smaller fixes.
750    
751     * Sun Jun 22 2003 Che
752     - version upgrade
753    
754     * Mon Jun 16 2003 Che
755     - rh9 build
756     - various fixes
757     - got rid of rpm-helper prereq
758    
759     * Fri Mar 24 2003 Che
760     - some cleanups and fixes
761     - new patch added
762    
763     * Fri Nov 22 2002 Che
764     - fixed a config patch issue
765    
766     * Fri Nov 22 2002 Che
767     - version upgrade and some fixes
768    
769     * Sat Nov 02 2002 Che
770     - version upgrade
771    
772     * Wed Oct 24 2002 Che
773     - some important changes for lsb compliance
774    
775     * Wed Oct 23 2002 Che
776     - initial rpm release

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed