1 |
unnilennium |
1.1 |
Summary: CPU frequency adjusting daemon |
2 |
|
|
Name: cpuspeed |
3 |
|
|
Version: 1.5 |
4 |
|
|
Release: 23%{?dist} |
5 |
|
|
Epoch: 1 |
6 |
|
|
Group: System Environment/Base |
7 |
|
|
License: GPLv2+ |
8 |
|
|
URL: http://carlthompson.net/Software/CPUSpeed |
9 |
|
|
Source0: http://carlthompson.net/downloads/cpuspeed/cpuspeed-%{version}.tar.bz2 |
10 |
|
|
Source1: http://carlthompson.net/downloads/cpuspeed/license.txt |
11 |
|
|
Source2: cpuspeed.init |
12 |
|
|
Source3: cpuspeed.conf |
13 |
|
|
Source4: cpuspeed.8 |
14 |
|
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
15 |
|
|
Requires(post): /sbin/chkconfig |
16 |
|
|
Requires(preun): /sbin/chkconfig |
17 |
|
|
Requires(preun): /sbin/service |
18 |
|
|
|
19 |
|
|
BuildRequires: automake util-linux groff gettext |
20 |
|
|
ExclusiveArch: %{ix86} x86_64 ppc ppc64 ia64 sparcv9 sparc64 |
21 |
|
|
Obsoletes: kernel-utils |
22 |
|
|
|
23 |
|
|
Patch1: cpuspeed-1.5-Makefile.patch |
24 |
|
|
Patch2: cpuspeed-1.5-no-affected_cpus-fallback.patch |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
cpuspeed is a daemon that dynamically changes the speed |
28 |
|
|
of your processor(s) depending upon its current workload |
29 |
|
|
if it is capable (needs Intel Speedstep, AMD PowerNow!, |
30 |
|
|
or similar support). |
31 |
|
|
|
32 |
|
|
This package also supports enabling cpu frequency scaling |
33 |
|
|
via in-kernel governors on Intel Centrino and AMD |
34 |
|
|
Athlon64/Opteron platforms. |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup -q |
38 |
|
|
cp %{SOURCE1} . |
39 |
|
|
%patch1 -p1 -b .make |
40 |
|
|
%patch2 -p1 -b .ac |
41 |
|
|
|
42 |
|
|
%build |
43 |
|
|
rm -rf $RPM_BUILD_ROOT |
44 |
|
|
|
45 |
|
|
RPM_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | sed -e 's/-fexceptions/-fno-exceptions/g') |
46 |
|
|
make CFLAGS="$RPM_OPT_FLAGS -fpie -pie" LDFLAGS="-Wl,-z,relro,-z,now" |
47 |
|
|
|
48 |
|
|
%install |
49 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_sbindir} |
50 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d |
51 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig |
52 |
|
|
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8/ |
53 |
|
|
|
54 |
|
|
make DESTDIR=$RPM_BUILD_ROOT install |
55 |
|
|
install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/cpuspeed |
56 |
|
|
install -m644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/cpuspeed |
57 |
|
|
install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man8/cpuspeed.8 |
58 |
|
|
|
59 |
|
|
%clean |
60 |
|
|
[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT; |
61 |
|
|
|
62 |
|
|
%files |
63 |
|
|
%defattr(-,root,root,-) |
64 |
|
|
%doc license.txt CHANGES CONTRIBUTORS EXAMPLES FEATURES README USAGE |
65 |
|
|
%{_sbindir}/cpuspeed |
66 |
|
|
%{_sysconfdir}/rc.d/init.d/cpuspeed |
67 |
|
|
%{_mandir}/man8/* |
68 |
|
|
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/cpuspeed |
69 |
|
|
|
70 |
|
|
%preun |
71 |
|
|
if [ "$1" = "0" ] ; then |
72 |
|
|
/sbin/service cpuspeed stop >/dev/null 2>&1 || : |
73 |
|
|
/sbin/chkconfig --del cpuspeed |
74 |
|
|
fi |
75 |
|
|
|
76 |
|
|
%post |
77 |
|
|
/sbin/chkconfig --add cpuspeed |
78 |
|
|
|
79 |
|
|
%triggerpostun -- kernel-utils |
80 |
|
|
/sbin/chkconfig --add cpuspeed |
81 |
|
|
exit 0 |
82 |
|
|
|
83 |
|
|
%changelog |
84 |
|
|
* Thu Mar 17 2016 JP Pialasse <tests@pialasse.com> - 1:1.5-23 |
85 |
|
|
- Import to Koozali SME Server |
86 |
|
|
|
87 |
|
|
* Tue Jun 16 2015 Petr Šabata <contyk@redhat.com> - 1:1.5-22 |
88 |
|
|
- Handle scaling governors properly on intel_pstate systems (#1230918) |
89 |
|
|
|
90 |
|
|
* Fri May 29 2015 Petr Šabata <contyk@redhat.com> - 1:1.5-21 |
91 |
|
|
- Bail out if performance is managed by intel_pstate (#1211828, #1219780, #1225024, #1196755) |
92 |
|
|
|
93 |
|
|
* Fri Jun 28 2013 Petr Šabata <contyk@redhat.com> - 1:1.5-20 |
94 |
|
|
- Read cpuinfo_max_speed instead of scaling_available_frequencies (#902134) |
95 |
|
|
|
96 |
|
|
* Tue Nov 27 2012 Petr Šabata <contyk@redhat.com> - 1:1.5-19 |
97 |
|
|
- Fix the naive method of getting the highest available scaling frequency (#876738) |
98 |
|
|
|
99 |
|
|
* Mon Oct 08 2012 Petr Šabata <contyk@redhat.com> - 1:1.5-18 |
100 |
|
|
- Fix #738463 for real this time. |
101 |
|
|
|
102 |
|
|
* Thu Sep 13 2012 Marcela Mašláňová <mmaslano@redhat.com> 1:1.5-17 |
103 |
|
|
- Cpuspeed init script still tries to adjust cpufreq sysfiles on a per core |
104 |
|
|
basis 738463 |
105 |
|
|
- IGNORE_NICE parameter does opposite of what it says (thanks to Minto Joseph) |
106 |
|
|
797055 |
107 |
|
|
- Cpuspeed does not reset MIN/MAX values when config file is emptied 616976 |
108 |
|
|
- Resolves: rhbz#738463, rhbz#797055, rhbz#616976 |
109 |
|
|
|
110 |
|
|
* Tue Sep 4 2012 Marcela Mašláňová <mmaslano@redhat.com> 1:1.5-16 |
111 |
|
|
- Whenever PCC driver is loaded, it loads the “userspace” governor, instead |
112 |
|
|
of the “ondemand” governor. |
113 |
|
|
- Resolves: rhbz#642838 |
114 |
|
|
|
115 |
|
|
* Tue Jul 20 2010 Matthew Garrett <mjg@redhat.com> 1:1.5-15 |
116 |
|
|
- Init scipt: Add support for loading the pcc-cpufreq driver |
117 |
|
|
- Resolves: rhbz#609659 |
118 |
|
|
|
119 |
|
|
* Wed Jun 30 2010 Petr Sabata <psabata@redhat.com> - 1:1.5-14 |
120 |
|
|
- Init script: added the reload function |
121 |
|
|
- Init script: the service now stops when using p4-clockmod driver |
122 |
|
|
- Resolves: rhbz#607223 |
123 |
|
|
|
124 |
|
|
* Fri Nov 13 2009 Jarod Wilson <jarod@redhat.com> 1.5-13 |
125 |
|
|
- Move startup prio so we start after syslog, so any notices during |
126 |
|
|
system startup actually get logged |
127 |
|
|
|
128 |
|
|
* Tue Aug 04 2009 Adam Jackson <ajax@redhat.com> 1.5-12 |
129 |
|
|
- Move buildroot dir creation to %%install |
130 |
|
|
|
131 |
|
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.5-11 |
132 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
133 |
|
|
|
134 |
|
|
* Fri Jun 26 2009 Jarod Wilson <jarod@redhat.com> 1.5-10 |
135 |
|
|
- Fix #505837 for real this time, even tested on an actual |
136 |
|
|
p4-clockmod system, seems to DTRT |
137 |
|
|
|
138 |
|
|
* Mon Jun 22 2009 Jarod Wilson <jarod@redhat.com> 1.5-9 |
139 |
|
|
- Un-pooch fix for #505837 (caused #507216 and didn't work right |
140 |
|
|
to begin with...) |
141 |
|
|
|
142 |
|
|
* Wed Jun 17 2009 Jarod Wilson <jarod@redhat.com> 1.5-8 |
143 |
|
|
- Let p4-clockmod users override defaults and set a governor, |
144 |
|
|
even if its generally a Bad Idea... (#505837) |
145 |
|
|
|
146 |
|
|
* Wed Jun 10 2009 Jarod Wilson <jarod@redhat.com> 1.5-7 |
147 |
|
|
- Fix up lsb compliance a bit (#246895) |
148 |
|
|
- Correct a few more exit codes (rhel5 bz, #495049) |
149 |
|
|
|
150 |
|
|
* Tue Mar 17 2009 Jarod Wilson <jarod@redhat.com> 1.5-6 |
151 |
|
|
- Fix up prior fix-up so that status and stop actually do the right thing |
152 |
|
|
on NON-p4-clockmod systems |
153 |
|
|
|
154 |
|
|
* Fri Mar 06 2009 Jarod Wilson <jarod@redhat.com> 1.5-5 |
155 |
|
|
- Fix up p4-clockmod support so start/stop/status actually report |
156 |
|
|
something sane to the user |
157 |
|
|
|
158 |
|
|
* Mon Mar 02 2009 Jarod Wilson <jarod@redhat.com> 1.5-4 |
159 |
|
|
- Fix up ExclusiveArch, now that 32-bit x86 is built i586 for F11 |
160 |
|
|
|
161 |
|
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.5-3 |
162 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
163 |
|
|
|
164 |
|
|
* Mon Nov 03 2008 Jarod Wilson <jarod@redhat.com> 1.5-2 |
165 |
|
|
- Revive p4-clockmod support, for passive cooling only, when |
166 |
|
|
all else fails on Intel boxes |
167 |
|
|
|
168 |
|
|
* Wed Oct 08 2008 Jarod Wilson <jarod@redhat.com> 1.5-1 |
169 |
|
|
- Update to v1.5 release |
170 |
|
|
|
171 |
|
|
* Fri Sep 26 2008 Jarod Wilson <jarod@redhat.com> 1.2.1-9 |
172 |
|
|
- backport proper multicore support for userspace governor |
173 |
|
|
(cpuspeed daemon) case from v1.5 cpuspeed snapshot |
174 |
|
|
|
175 |
|
|
* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.1-8 |
176 |
|
|
- fix license tag |
177 |
|
|
|
178 |
|
|
* Sun May 11 2008 Dennis Gilmore <dennis@ausil.us> 1.2.1-7 |
179 |
|
|
- add sparcv9 sparc64 to list of arches |
180 |
|
|
|
181 |
|
|
* Wed Mar 12 2008 Jarod Wilson <jwilson@redhat.com> 1.2.1-6 |
182 |
|
|
- Minor formatting and redirection fixups |
183 |
|
|
|
184 |
|
|
* Thu Feb 14 2008 Jarod Wilson <jwilson@redhat.com> 1.2.1-5 |
185 |
|
|
- Support for powernow-k8 as a kernel module |
186 |
|
|
|
187 |
|
|
* Tue Feb 12 2008 Jarod Wilson <jwilson@redhat.com> 1.2.1-4 |
188 |
|
|
- Fix up for gcc 4.3 |
189 |
|
|
- Work around multi-core step detection problems (#392781) |
190 |
|
|
|
191 |
|
|
* Wed Aug 29 2007 Jarod Wilson <jwilson@redhat.com> 1.2.1-3 |
192 |
|
|
- Bump and rebuild, due to busted ppc32 |
193 |
|
|
|
194 |
|
|
* Sat Jul 07 2007 Jarod Wilson <jwilson@redhat.com> 1.2.1-2 |
195 |
|
|
- Account for the cpuidle feature in rawhide kernels, |
196 |
|
|
slated for release in kernel 2.6.23 (#247352) |
197 |
|
|
|
198 |
|
|
* Mon Jun 11 2007 Jarod Wilson <jwilson@redhat.com> |
199 |
|
|
- Add e_powersaver (new Via C3 cpufreq driver) to list |
200 |
|
|
of those which should use ondemand governor by default |
201 |
|
|
|
202 |
|
|
* Thu Apr 26 2007 Jarod Wilson <jwilson@redhat.com> |
203 |
|
|
- Add a bit to the config file documentation |
204 |
|
|
- Use variable for program name |
205 |
|
|
- Fix up exit codes (#237942) |
206 |
|
|
|
207 |
|
|
* Mon Mar 12 2007 Jarod Wilson <jwilson@redhat.com> |
208 |
|
|
- Try loading acpi-cpufreq even on machines that don't |
209 |
|
|
report est flag (#231783, #216702) |
210 |
|
|
- Tighten up formatting in initscript |
211 |
|
|
|
212 |
|
|
* Wed Feb 21 2007 Jarod Wilson <jwilson@redhat.com> |
213 |
|
|
- Default to ondemand governor w/acpi-cpufreq driver |
214 |
|
|
- Minor initscript output cleanup |
215 |
|
|
|
216 |
|
|
* Sun Feb 04 2007 Jarod Wilson <jwilson@redhat.com> |
217 |
|
|
- Fix up compile flags and misc other fixes for |
218 |
|
|
core/extras merge review (#225658) |
219 |
|
|
|
220 |
|
|
* Thu Jan 11 2007 Jarod Wilson <jwilson@redhat.com> |
221 |
|
|
- Fix error-suppression for systems that report support |
222 |
|
|
for est, but have it disabled in the bios (#220200) |
223 |
|
|
|
224 |
|
|
* Thu Jan 11 2007 Jarod Wilson <jwilson@redhat.com> |
225 |
|
|
- Fix up documentation in config file (#219926) |
226 |
|
|
- Fall back cleanly to userspace governor on |
227 |
|
|
non-centrino/powernow-k8/p4-clockmod systems |
228 |
|
|
- Update description to reflect support for |
229 |
|
|
kernel-space freq scaling |
230 |
|
|
|
231 |
|
|
* Wed Jan 10 2007 Jarod Wilson <jwilson@redhat.com> |
232 |
|
|
- Fix governor validation check |
233 |
|
|
- Use ondemand by default on p4-clockmod systems |
234 |
|
|
|
235 |
|
|
* Wed Jan 10 2007 Jarod Wilson <jwilson@redhat.com> |
236 |
|
|
- Minor fix for cpuspeed daemon stop function |
237 |
|
|
|
238 |
|
|
* Tue Jan 09 2007 Jarod Wilson <jwilson@redhat.com> |
239 |
|
|
- Turn on ia64 builds (#216702) |
240 |
|
|
- Fix status on xen kernels |
241 |
|
|
|
242 |
|
|
* Tue Jan 09 2007 Jarod Wilson <jwilson@redhat.com> |
243 |
|
|
- Move config file to /etc/sysconfig/cpuspeed, more |
244 |
|
|
appropriate for initscript configs (#152305) |
245 |
|
|
- Manify 'cpuspeed --help' along with other details (#172655) |
246 |
|
|
- Tweak cpuspeed default thresholds (#147565) |
247 |
|
|
|
248 |
|
|
* Mon Jan 08 2007 Jarod Wilson <jwilson@redhat.com> |
249 |
|
|
- Let non-centrino/powernow-k8 systems also use other |
250 |
|
|
validated governors (#219926) |
251 |
|
|
- Fix cpuspeed daemon options settings (#221829) |
252 |
|
|
|
253 |
|
|
* Fri Jan 05 2007 Jarod Wilson <jwilson@redhat.com> |
254 |
|
|
- Fix status and condrestart for centrino/powernow-k8 (#219926) |
255 |
|
|
- Give feedback when loading/unloading a cpufreq governor |
256 |
|
|
- Rework config file and initscript to make it much easier |
257 |
|
|
for end-users to adjust frequency scaling setup (#151761) |
258 |
|
|
- Log start/stop events with useful info |
259 |
|
|
- Don't start on xen kernels (freq scaling not supported) |
260 |
|
|
|
261 |
|
|
* Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> |
262 |
|
|
- Set lock file for centrino/powernow-k8 so status |
263 |
|
|
indicates we do have scaling working |
264 |
|
|
- Fix up centrino/powernow-k8 stop function (#213999) |
265 |
|
|
|
266 |
|
|
* Wed Nov 29 2006 Jarod Wilson <jwilson@redhat.com> |
267 |
|
|
- Fix busted config file sourcing |
268 |
|
|
|
269 |
|
|
* Mon Nov 27 2006 Jarod Wilson <jwilson@redhat.com> |
270 |
|
|
- Spec tweaks to bring in line with Fedora packaging guidelines |
271 |
|
|
- Add docs to package |
272 |
|
|
- Mark config file as noreplace |
273 |
|
|
- Be sure to stop service before uninstall |
274 |
|
|
|
275 |
|
|
* Tue Nov 21 2006 Dave Jones <davej@redhat.com> |
276 |
|
|
- Merge one more patch from Michal Jaegermann <michal@harddata.com> (#216816) |
277 |
|
|
|
278 |
|
|
* Mon Nov 20 2006 Dave Jones <davej@redhat.com> |
279 |
|
|
- Merge patch from Michal Jaegermann <michal@harddata.com> |
280 |
|
|
that solves the acpi-cpufreq problem in an improved |
281 |
|
|
way and fixes several other nits. |
282 |
|
|
|
283 |
|
|
* Sat Oct 28 2006 Dave Jones <davej@redhat.com> |
284 |
|
|
- Only load acpi-cpufreq on speedstep capable machines. |
285 |
|
|
- Unload acpi-cpufreq if BIOS tables didn't exist or |
286 |
|
|
other acpi-cpufreq failures occured. |
287 |
|
|
|
288 |
|
|
* Sat Jul 29 2006 Dave Jones <davej@redhat.com> |
289 |
|
|
- Don't try to load acpi-cpufreq on non-ACPI machines. (#196446) |
290 |
|
|
|
291 |
|
|
* Wed Jul 26 2006 Dave Jones <davej@redhat.com> |
292 |
|
|
- Fix up retval & /var/lock/subsys/cpuspeed handling in initscript. |
293 |
|
|
|
294 |
|
|
* Thu Jul 20 2006 Jim Paradis <jparadis@redhat.com> |
295 |
|
|
- Enable on-demand governor usage for powernow-k8 as well as centrino |
296 |
|
|
|
297 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2.1-1.35%{dist}.1 |
298 |
|
|
- rebuild |
299 |
|
|
|
300 |
|
|
* Sat Jul 1 2006 Dave Jones <davej@redhat.com> |
301 |
|
|
- Fix sched_mc_power_savings warning on centrino laptops. |
302 |
|
|
|
303 |
|
|
* Wed Jun 7 2006 Dave Jones <davej@redhat.com> |
304 |
|
|
- Remove a bunch of no-longer needed gunk from the initscript. |
305 |
|
|
- Use on-demand governor on centrino/core based systems for now, |
306 |
|
|
as it seems to have a better effect. |
307 |
|
|
|
308 |
|
|
* Thu Feb 23 2006 Dave Jones <davej@redhat.com> |
309 |
|
|
- Fix broken init script. (Alexandre Oliva) [#182691] |
310 |
|
|
Taking ugly shell script to the next level. |
311 |
|
|
|
312 |
|
|
* Tue Feb 21 2006 Dave Jones <davej@redhat.com> |
313 |
|
|
- Missed another occurance of the same problem I fixed yesterday. |
314 |
|
|
|
315 |
|
|
* Mon Feb 20 2006 Dave Jones <davej@redhat.com> |
316 |
|
|
- Some ACPI BIOSes start counting CPUs at 0, some at 1. *sigh* (#181673) |
317 |
|
|
|
318 |
|
|
* Sat Feb 11 2006 Dave Jones <davej@redhat.com> |
319 |
|
|
- rebuild. |
320 |
|
|
|
321 |
|
|
* Thu Feb 09 2006 Dave Jones <davej@redhat.com> |
322 |
|
|
- rebuild. |
323 |
|
|
|
324 |
|
|
* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com> |
325 |
|
|
- rebuilt for new gcj |
326 |
|
|
|
327 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
328 |
|
|
- rebuilt |
329 |
|
|
|
330 |
|
|
* Mon Nov 14 2005 Dave Jones <davej@redhat.com> |
331 |
|
|
- Don't try and load acpi-cpufreq if we have no throttling states. |
332 |
|
|
|
333 |
|
|
* Thu Sep 29 2005 Dave Jones <davej@redhat.com> |
334 |
|
|
- On shutdown, restore speed to maximum before daemon exit. |
335 |
|
|
|
336 |
|
|
* Fri Sep 23 2005 Dave Jones <davej@redhat.com> |
337 |
|
|
- Use ACPI as a fallback driver if possible, if one didn't get loaded. (#160788) |
338 |
|
|
|
339 |
|
|
* Mon May 9 2005 Dave Jones <davej@redhat.com> |
340 |
|
|
- Fix debuginfo generation. |
341 |
|
|
|
342 |
|
|
* Wed Apr 6 2005 Dave Jones <davej@redhat.com> |
343 |
|
|
- Don't count nice time as idle time. (#132383) |
344 |
|
|
|
345 |
|
|
* Tue Mar 1 2005 Dave Jones <davej@redhat.com> |
346 |
|
|
- Rebuild for gcc4. |
347 |
|
|
|
348 |
|
|
* Tue Feb 8 2005 Dave Jones <davej@redhat.com> |
349 |
|
|
- Rebuild with -D_FORTIFY_SOURCE=2 |
350 |
|
|
|
351 |
|
|
* Fri Feb 4 2005 Dave Jones <davej@redhat.com> |
352 |
|
|
- Enable builds for PPC (#147089) |
353 |
|
|
|
354 |
|
|
* Tue Jan 11 2005 Dave Jones <davej@redhat.com> |
355 |
|
|
- Add missing Obsoletes: kernel-utils |
356 |
|
|
|
357 |
|
|
* Mon Jan 10 2005 Dave Jones <davej@redhat.com> |
358 |
|
|
- Update to upstream 1.2.1 release. |
359 |
|
|
|
360 |
|
|
* Sat Dec 18 2004 Dave Jones <davej@redhat.com> |
361 |
|
|
- Initial packaging, split out from kernel-utils. |
362 |
|
|
|