1 |
slords |
1.1 |
Name: cvm |
2 |
|
|
Summary: Credential Validation Modules |
3 |
|
|
Version: 0.82 |
4 |
|
|
Release: 1%{?dist} |
5 |
|
|
License: GPL |
6 |
|
|
Group: Utilities/System |
7 |
|
|
Source: http://untroubled.org/cvm/cvm-0.82.tar.gz |
8 |
|
|
BuildRoot: %{_tmppath}/cvm-buildroot |
9 |
|
|
URL: http://untroubled.org/cvm/ |
10 |
|
|
BuildRequires: libtool |
11 |
|
|
BuildRequires: bglibs >= 1.100 |
12 |
|
|
BuildRequires: mysql-devel |
13 |
|
|
BuildRequires: postgresql-devel |
14 |
|
|
Obsoletes: cvm-vmailmgr |
15 |
|
|
|
16 |
|
|
%description |
17 |
|
|
This package implements the CVM interface as a client (cvm-testclient), |
18 |
|
|
and as a module (cvm-unix, cvm-pwfile). |
19 |
|
|
|
20 |
|
|
%package devel |
21 |
|
|
Summary: Development libraries for CVM |
22 |
|
|
Group: Development/Libraries |
23 |
|
|
|
24 |
|
|
%description devel |
25 |
|
|
This package includes all the development libraries and headers for |
26 |
|
|
building CVM clients or modules. |
27 |
|
|
|
28 |
|
|
%package mysql |
29 |
|
|
Group: Utilities/System |
30 |
|
|
Summary: MySQL Credential Validation Modules |
31 |
|
|
|
32 |
|
|
%description mysql |
33 |
|
|
Credential Validation Modules that authenticate against a MySQL server. |
34 |
|
|
|
35 |
|
|
%package pgsql |
36 |
|
|
Group: Utilities/System |
37 |
|
|
Summary: PostgreSQL Credential Validation Modules |
38 |
|
|
|
39 |
|
|
%description pgsql |
40 |
|
|
Credential Validation Modules that authenticate against a PostgreSQL server. |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup |
44 |
|
|
|
45 |
|
|
%build |
46 |
|
|
%ifarch x86_64 |
47 |
|
|
echo gcc "%{optflags}" -fPIC -I%{_includedir}/pgsql >conf-cc |
48 |
|
|
echo gcc -s -fPIC -L%{_libdir}/mysql >conf-ld |
49 |
|
|
%else |
50 |
|
|
echo gcc "%{optflags}" -I%{_includedir}/pgsql >conf-cc |
51 |
|
|
echo gcc -s -L%{_libdir}/mysql >conf-ld |
52 |
|
|
%endif |
53 |
|
|
echo %{_bindir} >conf-bin |
54 |
|
|
echo %{_includedir} >conf-include |
55 |
|
|
echo %{_libdir} >conf-lib |
56 |
|
|
make libraries programs mysql pgsql |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -fr %{buildroot} |
60 |
|
|
mkdir -p %{buildroot}%{_bindir} |
61 |
|
|
mkdir -p %{buildroot}%{_includedir} |
62 |
|
|
mkdir -p %{buildroot}%{_libdir} |
63 |
|
|
|
64 |
|
|
make install_prefix=%{buildroot} install |
65 |
|
|
|
66 |
|
|
%clean |
67 |
|
|
rm -rf %{buildroot} |
68 |
|
|
|
69 |
|
|
%post |
70 |
|
|
/sbin/ldconfig |
71 |
|
|
|
72 |
|
|
%files |
73 |
|
|
%defattr(-,root,root) |
74 |
|
|
%doc COPYING NEWS README *.html |
75 |
|
|
%{_bindir}/cvm-[^mp]* |
76 |
|
|
%{_bindir}/cvm-pwfile |
77 |
|
|
%{_libdir}/*.so.* |
78 |
|
|
|
79 |
|
|
%files devel |
80 |
|
|
%defattr(-,root,root) |
81 |
|
|
%{_includedir}/* |
82 |
|
|
%{_libdir}/*.a |
83 |
|
|
%{_libdir}/*.la |
84 |
|
|
%{_libdir}/*.so |
85 |
|
|
|
86 |
|
|
%files mysql |
87 |
|
|
%defattr(-,root,root) |
88 |
|
|
%{_bindir}/cvm-mysql* |
89 |
|
|
|
90 |
|
|
%files pgsql |
91 |
|
|
%defattr(-,root,root) |
92 |
|
|
%{_bindir}/cvm-pgsql* |