1 |
# $Id$ |
2 |
|
3 |
Name: cvm |
4 |
Summary: Credential Validation Modules |
5 |
Version: 0.82 |
6 |
Release: 1%{?dist} |
7 |
License: GPL |
8 |
Group: Utilities/System |
9 |
Source: http://untroubled.org/cvm/cvm-0.82.tar.gz |
10 |
BuildRoot: %{_tmppath}/cvm-buildroot |
11 |
URL: http://untroubled.org/cvm/ |
12 |
BuildRequires: libtool |
13 |
BuildRequires: bglibs >= 1.100 |
14 |
BuildRequires: mysql-devel |
15 |
BuildRequires: postgresql-devel |
16 |
Obsoletes: cvm-vmailmgr |
17 |
|
18 |
%description |
19 |
This package implements the CVM interface as a client (cvm-testclient), |
20 |
and as a module (cvm-unix, cvm-pwfile). |
21 |
|
22 |
%package devel |
23 |
Summary: Development libraries for CVM |
24 |
Group: Development/Libraries |
25 |
|
26 |
%description devel |
27 |
This package includes all the development libraries and headers for |
28 |
building CVM clients or modules. |
29 |
|
30 |
%package mysql |
31 |
Group: Utilities/System |
32 |
Summary: MySQL Credential Validation Modules |
33 |
|
34 |
%description mysql |
35 |
Credential Validation Modules that authenticate against a MySQL server. |
36 |
|
37 |
%package pgsql |
38 |
Group: Utilities/System |
39 |
Summary: PostgreSQL Credential Validation Modules |
40 |
|
41 |
%description pgsql |
42 |
Credential Validation Modules that authenticate against a PostgreSQL server. |
43 |
|
44 |
%prep |
45 |
%setup |
46 |
|
47 |
%build |
48 |
%ifarch x86_64 |
49 |
echo gcc "%{optflags}" -fPIC -I%{_includedir}/pgsql >conf-cc |
50 |
echo gcc -s -fPIC -L%{_libdir}/mysql >conf-ld |
51 |
%else |
52 |
echo gcc "%{optflags}" -I%{_includedir}/pgsql >conf-cc |
53 |
echo gcc -s -L%{_libdir}/mysql >conf-ld |
54 |
%endif |
55 |
echo %{_bindir} >conf-bin |
56 |
echo %{_includedir} >conf-include |
57 |
echo %{_libdir} >conf-lib |
58 |
make libraries programs mysql pgsql |
59 |
|
60 |
%install |
61 |
rm -fr %{buildroot} |
62 |
mkdir -p %{buildroot}%{_bindir} |
63 |
mkdir -p %{buildroot}%{_includedir} |
64 |
mkdir -p %{buildroot}%{_libdir} |
65 |
|
66 |
make install_prefix=%{buildroot} install |
67 |
|
68 |
%clean |
69 |
rm -rf %{buildroot} |
70 |
|
71 |
%post |
72 |
/sbin/ldconfig |
73 |
|
74 |
%files |
75 |
%defattr(-,root,root) |
76 |
%doc COPYING NEWS README *.html |
77 |
%{_bindir}/cvm-[^mp]* |
78 |
%{_bindir}/cvm-pwfile |
79 |
%{_libdir}/*.so.* |
80 |
|
81 |
%files devel |
82 |
%defattr(-,root,root) |
83 |
%{_includedir}/* |
84 |
%{_libdir}/*.a |
85 |
%{_libdir}/*.la |
86 |
%{_libdir}/*.so |
87 |
|
88 |
%files mysql |
89 |
%defattr(-,root,root) |
90 |
%{_bindir}/cvm-mysql* |
91 |
|
92 |
%files pgsql |
93 |
%defattr(-,root,root) |
94 |
%{_bindir}/cvm-pgsql* |