/[smeserver]/rpms/daemontools/sme7/daemontools.spec
ViewVC logotype

Annotation of /rpms/daemontools/sme7/daemontools.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jun 12 14:57:32 2007 UTC (16 years, 11 months ago) by slords
Branch: MAIN
CVS Tags: daemontools-0_76-6_el4_sme
Import on branch sme7 of package daemontools-0.76-6.el4.sme.src.rpm

1 slords 1.1 %define destdir %buildroot
2     %global myhome /usr/local
3     Buildroot: %_builddir/%name-%version-root
4     License: Check with djb
5     Group: Utilities/System
6     Name: daemontools
7     Provides: daemontools
8     Release: 6%{?dist}
9     Source: http://cr.yp.to/%name/%name-%version.tar.gz
10     Summary: Various tools to start/stop/monitor daemons.
11     %define debug_package %{nil}
12     %define __arch_install_post %{nil}
13     URL: http://cr.yp.to/%name.html
14     Version: 0.76
15    
16     %description
17     daemontools is a collection of tools for managing UNIX services.
18    
19     supervise monitors a service. It starts the service and restarts the
20     service if it dies. Setting up a new service is easy: all supervise
21     needs is a directory with a run script that runs the service.
22    
23     multilog saves error messages to one or more logs. It optionally
24     timestamps each line and, for each log, includes or excludes lines
25     matching specified patterns. It automatically rotates logs to limit
26     the amount of disk space used. If the disk fills up, it pauses and
27     tries again, without losing any data.
28    
29     %prep
30     %setup -c -n %destdir/package
31    
32     %build
33     mkdir -p %destdir%myhome/bin
34     cd admin/%name-%version
35     sed -e 's}^parent.*}parent=/package/admin}' \
36     -e 's} /command/} %destdir/command/}g' \
37     -e 's}-p /command}-p %destdir/command}' \
38     -e 's}ln -s %destdir/command/}ln -s /command/}' \
39     -e 's} /usr/local/bin/} %destdir/usr/local/bin/}g' \
40     -e 's}/usr/local}%myhome}g' \
41     package/upgrade > package/upgrade'{new}'
42    
43     if [ "$?" != 0 ]; then
44     exit 1
45     else
46     mv package/upgrade'{new}' package/upgrade
47     chmod 755 package/upgrade
48     fi
49    
50     echo gcc -O2 --include /usr/include/errno.h > src/conf-cc
51     package/compile
52    
53     COMPILER="Compiler: $(gcc -v 2>&1 | tail -1)"
54     HARDWARE="Hardware: $(uname -m)"
55     LIBRARY="Library: $(rpm -q glibc)"
56     OSVERSION="OSversion: $(uname -sr)"
57     PACKAGER="Packager: %packager"
58     REDHATRELEASE="RedHat release: $(cat /etc/redhat-release)"
59     RPMVERSION="rpm version: $(rpm -q rpm)"
60    
61     echo "The %name rpm was created in the following environment:
62     " > README.rpm
63     echo "$COMPILER
64     $HARDWARE
65     $LIBRARY
66     $OSVERSION
67     $PACKAGER
68     $REDHATRELEASE
69     $RPMVERSION
70    
71     The packager above has made an honest attempt to make sure
72     the package behaves correctly.
73     " >> README.rpm
74    
75     if test "%myhome" != "/usr/local"; then
76     echo "" >> README.rpm
77     echo "You cannot distribute this rpm publicly" >> README.rpm
78     fi
79    
80     mkdir -p %destdir/%{_docdir}/%name-%version
81     mv README.rpm %destdir/%{_docdir}/%name-%version
82     mv package/README %destdir/%{_docdir}/%name-%version
83     mv src/{CHANGES,TODO} %destdir/%{_docdir}/%name-%version
84     mkdir -p %destdir/service
85    
86     %install
87     cd admin/%name-%version
88     package/upgrade
89     /bin/rm %destdir/package/admin/%name-%version/src/*
90     /bin/rm -r %destdir/package/admin/%name-%version/compile
91    
92    
93     %post
94     cd /package/admin/%name-%version
95     package/run
96     echo You may want to add /command to PATH.
97    
98     %clean
99     rm -rf %destdir
100    
101    
102     %changelog
103     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
104     - Clean up spec so package can be built by koji/plague
105    
106     * Tue Apr 24 2007 Charlie Brady <charlieb@e-smith.com> 0.76-6
107     - disable build of debuginfo package.
108    
109     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
110     - Update to new release naming. No functional changes.
111     - Make Packager generic
112    
113     * Tue Dec 20 2005 Charlie Brady <charlieb@e-smith.com> 0.76-4es1
114     - Fixes for build under CentOS4 and FC4.
115     - Move documentation to RedHat canonical location.
116    
117     * Wed Jun 23 2004 Charlie Brady <charlieb@e-smith.com> 0.76-3es1
118     - Adjust compiler configuration to work around glibc errno issue
119    
120     * Thu Aug 23 2001 Mate Wierdl <mw@csi.hu>
121     - adjusted for slashpackage setup
122    
123     %files
124     %defattr(-,root,root)
125     %doc %dir %{_docdir}/%name-%version
126     %doc %{_docdir}/%name-%version/CHANGES
127     %doc %{_docdir}/%name-%version/README*
128     %doc %{_docdir}/%name-%version/TODO
129     %dir%attr(1755,root,root) /package
130     %dir%attr(755,root,root) /command
131     %dir%attr(755,root,root) /service
132     %dir /package/admin/%name-%version/src
133     /package/admin/%name-%version/command
134     /package/admin/%name-%version/package
135     /package/admin/%name
136     /command/*
137     %myhome/bin/*
138    
139    
140    
141    
142    
143    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed