1 |
# $Id: daemontools.spec,v 1.1 2013/02/06 21:59:42 slords Exp $ |
2 |
|
3 |
%define destdir %buildroot |
4 |
%global myhome /usr/local |
5 |
Buildroot: %_builddir/%name-%version-root |
6 |
License: Check with djb |
7 |
Group: Utilities/System |
8 |
Name: daemontools |
9 |
Provides: daemontools |
10 |
Release: 6%{?dist} |
11 |
Source: http://cr.yp.to/%name/%name-%version.tar.gz |
12 |
Summary: Various tools to start/stop/monitor daemons. |
13 |
%define debug_package %{nil} |
14 |
%define __arch_install_post %{nil} |
15 |
URL: http://cr.yp.to/%name.html |
16 |
Version: 0.76 |
17 |
|
18 |
%description |
19 |
daemontools is a collection of tools for managing UNIX services. |
20 |
|
21 |
supervise monitors a service. It starts the service and restarts the |
22 |
service if it dies. Setting up a new service is easy: all supervise |
23 |
needs is a directory with a run script that runs the service. |
24 |
|
25 |
multilog saves error messages to one or more logs. It optionally |
26 |
timestamps each line and, for each log, includes or excludes lines |
27 |
matching specified patterns. It automatically rotates logs to limit |
28 |
the amount of disk space used. If the disk fills up, it pauses and |
29 |
tries again, without losing any data. |
30 |
|
31 |
%prep |
32 |
%setup -c -n package |
33 |
|
34 |
%build |
35 |
cd admin/%name-%version |
36 |
sed -e 's}^parent.*}parent=/package/admin}' \ |
37 |
-e 's} /command/} %destdir/command/}g' \ |
38 |
-e 's}-p /command}-p %destdir/command}' \ |
39 |
-e 's}ln -s %destdir/command/}ln -s /command/}' \ |
40 |
-e 's} /usr/local/bin/} %destdir/usr/local/bin/}g' \ |
41 |
-e 's}/usr/local}%myhome}g' \ |
42 |
package/upgrade > package/upgrade'{new}' |
43 |
|
44 |
if [ "$?" != 0 ]; then |
45 |
exit 1 |
46 |
else |
47 |
mv package/upgrade'{new}' package/upgrade |
48 |
chmod 755 package/upgrade |
49 |
fi |
50 |
|
51 |
echo gcc -O2 --include /usr/include/errno.h > src/conf-cc |
52 |
package/compile |
53 |
|
54 |
cd ../.. |
55 |
|
56 |
COMPILER="Compiler: $(gcc -v 2>&1 | tail -1)" |
57 |
HARDWARE="Hardware: $(uname -m)" |
58 |
LIBRARY="Library: $(rpm -q glibc)" |
59 |
OSVERSION="OSversion: $(uname -sr)" |
60 |
PACKAGER="Packager: %packager" |
61 |
REDHATRELEASE="RedHat release: $(cat /etc/redhat-release)" |
62 |
RPMVERSION="rpm version: $(rpm -q rpm)" |
63 |
|
64 |
echo "The %name rpm was created in the following environment: |
65 |
" > README.rpm |
66 |
echo "$COMPILER |
67 |
$HARDWARE |
68 |
$LIBRARY |
69 |
$OSVERSION |
70 |
$PACKAGER |
71 |
$REDHATRELEASE |
72 |
$RPMVERSION |
73 |
|
74 |
The packager above has made an honest attempt to make sure |
75 |
the package behaves correctly. |
76 |
" >> README.rpm |
77 |
|
78 |
if test "%myhome" != "/usr/local"; then |
79 |
echo "" >> README.rpm |
80 |
echo "You cannot distribute this rpm publicly" >> README.rpm |
81 |
fi |
82 |
|
83 |
%install |
84 |
mkdir -p %destdir/%myhome/bin |
85 |
mkdir -p %destdir/service |
86 |
mkdir -p %destdir/package |
87 |
mkdir -p %destdir/%{_docdir}/%name-%version |
88 |
mv README.rpm %destdir/%{_docdir}/%name-%version |
89 |
|
90 |
cd admin/%name-%version |
91 |
mv package/README %destdir/%{_docdir}/%name-%version |
92 |
mv src/{CHANGES,TODO} %destdir/%{_docdir}/%name-%version |
93 |
package/upgrade |
94 |
cd ../.. |
95 |
|
96 |
cp -a admin %destdir/package/ |
97 |
/bin/rm %destdir/package/admin/%name-%version/src/* |
98 |
/bin/rm -r %destdir/package/admin/%name-%version/compile |
99 |
|
100 |
%post |
101 |
cd /package/admin/%name-%version |
102 |
package/run |
103 |
echo You may want to add /command to PATH. |
104 |
|
105 |
%clean |
106 |
rm -rf %destdir |
107 |
|
108 |
|
109 |
%changelog |
110 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
111 |
- Clean up spec so package can be built by koji/plague |
112 |
|
113 |
* Tue Apr 24 2007 Charlie Brady <charlieb@e-smith.com> 0.76-6 |
114 |
- disable build of debuginfo package. |
115 |
|
116 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
117 |
- Update to new release naming. No functional changes. |
118 |
- Make Packager generic |
119 |
|
120 |
* Tue Dec 20 2005 Charlie Brady <charlieb@e-smith.com> 0.76-4es1 |
121 |
- Fixes for build under CentOS4 and FC4. |
122 |
- Move documentation to RedHat canonical location. |
123 |
|
124 |
* Wed Jun 23 2004 Charlie Brady <charlieb@e-smith.com> 0.76-3es1 |
125 |
- Adjust compiler configuration to work around glibc errno issue |
126 |
|
127 |
* Thu Aug 23 2001 Mate Wierdl <mw@csi.hu> |
128 |
- adjusted for slashpackage setup |
129 |
|
130 |
%files |
131 |
%defattr(-,root,root) |
132 |
%doc %dir %{_docdir}/%name-%version |
133 |
%doc %{_docdir}/%name-%version/CHANGES |
134 |
%doc %{_docdir}/%name-%version/README* |
135 |
%doc %{_docdir}/%name-%version/TODO |
136 |
%dir%attr(1755,root,root) /package |
137 |
%dir%attr(755,root,root) /command |
138 |
%dir%attr(755,root,root) /service |
139 |
%dir /package/admin/%name-%version/src |
140 |
/package/admin/%name-%version/command |
141 |
/package/admin/%name-%version/package |
142 |
/package/admin/%name |
143 |
/command/* |
144 |
%myhome/bin/* |
145 |
|