1 |
slords |
1.1 |
# |
2 |
|
|
# Specfile for DAR, the disk archiver |
3 |
|
|
# |
4 |
|
|
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210790 |
5 |
|
|
# |
6 |
|
|
|
7 |
|
|
# Static build is disabled by default by fedora policy, but also because the |
8 |
|
|
# latest versions of glibc don't seem to compile proper static binaries. Use |
9 |
|
|
# "--with static" to enable the static subpackage |
10 |
|
|
%define with_static %{?_with_static: 1} %{?!_with_static: 0} |
11 |
|
|
|
12 |
|
|
# |
13 |
|
|
# Basic descriptive tags for this package: |
14 |
|
|
# |
15 |
|
|
Name: dar |
16 |
|
|
Version: 2.3.5 |
17 |
|
|
Release: 1%{?dist} |
18 |
|
|
Summary: Software for making/restoring incremental CD/DVD backups |
19 |
|
|
|
20 |
|
|
URL: http://dar.linux.free.fr/ |
21 |
|
|
License: GPL |
22 |
|
|
Group: Applications/Archiving |
23 |
|
|
|
24 |
|
|
################################################################################ |
25 |
|
|
|
26 |
|
|
Source: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz |
27 |
|
|
Source1: README.Fedora |
28 |
|
|
|
29 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
30 |
|
|
|
31 |
|
|
################################################################################ |
32 |
|
|
|
33 |
|
|
BuildRequires: bzip2-devel |
34 |
|
|
BuildRequires: openssl-devel |
35 |
|
|
|
36 |
|
|
# Recommended, but no package yet in Epel. |
37 |
|
|
#Requires: par2cmdline |
38 |
|
|
|
39 |
|
|
################################################################################ |
40 |
|
|
|
41 |
|
|
%description |
42 |
|
|
DAR is a command line tool to backup a directory tree and files. DAR is |
43 |
|
|
able to make differential backups, split them over a set of disks or files |
44 |
|
|
of a given size, use compression, filter files or subtrees to be saved or |
45 |
|
|
not saved, directly access and restore given files. DAR is also able |
46 |
|
|
to handle extented attributes, and can make remote backups through an |
47 |
|
|
ssh session for example. Finally, DAR handles save and restore of hard |
48 |
|
|
and symbolic links. |
49 |
|
|
|
50 |
|
|
################################################################################ |
51 |
|
|
|
52 |
|
|
%package -n libdar |
53 |
|
|
Group: System Environment/Libraries |
54 |
|
|
Summary: Library providing support for the DAR API |
55 |
|
|
|
56 |
|
|
%description -n libdar |
57 |
|
|
Common library code for DAR. |
58 |
|
|
|
59 |
|
|
################################################################################ |
60 |
|
|
|
61 |
|
|
%package -n libdar-devel |
62 |
|
|
Group: Development/Libraries |
63 |
|
|
Summary: Development files for libdar |
64 |
|
|
Requires: libdar = %{version}-%{release} |
65 |
|
|
|
66 |
|
|
%description -n libdar-devel |
67 |
|
|
This package contains the header files and libraries for developing |
68 |
|
|
programs that use the DAR API (libdar). |
69 |
|
|
|
70 |
|
|
################################################################################ |
71 |
|
|
# The following two subpackages are only built when enabled via "--with static" |
72 |
|
|
################################################################################ |
73 |
|
|
|
74 |
|
|
%if %{with_static} |
75 |
|
|
|
76 |
|
|
%package -n dar-static |
77 |
|
|
Group: Applications/System |
78 |
|
|
Summary: Statically linked version of dar |
79 |
|
|
|
80 |
|
|
%description -n dar-static |
81 |
|
|
Statically linked version of dar that can be installed onto backup disks for |
82 |
|
|
easier file retrieval. |
83 |
|
|
|
84 |
|
|
%package -n libdar-static-devel |
85 |
|
|
Group: Development/Libraries |
86 |
|
|
Summary: Statically linked dar library files |
87 |
|
|
|
88 |
|
|
%description -nlibdar-static-devel |
89 |
|
|
Statically linked version of dar libraries that can be installed onto backup |
90 |
|
|
disks for easier file retrieval. |
91 |
|
|
|
92 |
|
|
%endif |
93 |
|
|
|
94 |
|
|
################################################################################ |
95 |
|
|
|
96 |
|
|
%prep |
97 |
|
|
%setup -q |
98 |
|
|
|
99 |
|
|
################################################################################ |
100 |
|
|
|
101 |
|
|
%build |
102 |
|
|
|
103 |
|
|
# Options |
104 |
|
|
%if %{with_static} |
105 |
|
|
STATIC="" |
106 |
|
|
%else |
107 |
|
|
STATIC="--disable-dar-static --disable-static" |
108 |
|
|
%endif |
109 |
|
|
|
110 |
|
|
%configure --disable-build-html $STATIC |
111 |
|
|
|
112 |
|
|
make %{?_smp_mflags} |
113 |
|
|
|
114 |
|
|
################################################################################ |
115 |
|
|
|
116 |
|
|
%install |
117 |
|
|
rm -rf $RPM_BUILD_ROOT |
118 |
|
|
make install DESTDIR=$RPM_BUILD_ROOT |
119 |
|
|
%find_lang %{name} |
120 |
|
|
|
121 |
|
|
# Remove the libtool archive files |
122 |
|
|
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la |
123 |
|
|
rm -rf $RPM_BUILD_ROOT/%{_libdir}/pkgconfig |
124 |
|
|
|
125 |
|
|
# Delete the sample files that we can't seem to disable |
126 |
|
|
rm -rf $RPM_BUILD_ROOT/%{_datadir}/dar/ |
127 |
|
|
|
128 |
|
|
# Remove the doc makefiles so they don't get installed along with the other files. |
129 |
|
|
rm -f doc/Makefile* |
130 |
|
|
rm -f doc/*/Makefile* |
131 |
|
|
|
132 |
|
|
# Rename the documentation directory so it makes more sense after installation. |
133 |
|
|
mv doc html |
134 |
|
|
|
135 |
|
|
# Sample scripts should not be executable |
136 |
|
|
chmod 0644 html/samples/* |
137 |
|
|
|
138 |
|
|
# Install the fedora readme |
139 |
|
|
cp -a %{SOURCE1} . |
140 |
|
|
|
141 |
|
|
################################################################################ |
142 |
|
|
|
143 |
|
|
%clean |
144 |
|
|
rm -rf $RPM_BUILD_ROOT |
145 |
|
|
|
146 |
|
|
################################################################################ |
147 |
|
|
|
148 |
|
|
%post -n libdar -p /sbin/ldconfig |
149 |
|
|
%postun -n libdar -p /sbin/ldconfig |
150 |
|
|
|
151 |
|
|
|
152 |
|
|
%files -f %{name}.lang |
153 |
|
|
%defattr(-,root,root,-) |
154 |
|
|
%doc html/ ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO README.Fedora |
155 |
|
|
|
156 |
|
|
%{_bindir}/dar |
157 |
|
|
%{_bindir}/dar_cp |
158 |
|
|
%{_bindir}/dar_manager |
159 |
|
|
%{_bindir}/dar_slave |
160 |
|
|
%{_bindir}/dar_xform |
161 |
|
|
%{_mandir}/man1/* |
162 |
|
|
|
163 |
|
|
################################################################################ |
164 |
|
|
|
165 |
|
|
%files -n libdar |
166 |
|
|
%defattr(-,root,root,-) |
167 |
|
|
%{_libdir}/*.so.* |
168 |
|
|
|
169 |
|
|
################################################################################ |
170 |
|
|
|
171 |
|
|
%files -n libdar-devel |
172 |
|
|
%defattr(-,root,root,-) |
173 |
|
|
%{_includedir}/* |
174 |
|
|
%{_libdir}/*.so |
175 |
|
|
|
176 |
|
|
################################################################################ |
177 |
|
|
|
178 |
|
|
%if %{with_static} |
179 |
|
|
|
180 |
|
|
%files -n dar-static |
181 |
|
|
%defattr(-,root,root,-) |
182 |
|
|
%{_bindir}/dar_static |
183 |
|
|
|
184 |
|
|
################################################################################ |
185 |
|
|
|
186 |
|
|
%files -n libdar-static-devel |
187 |
|
|
%defattr(-,root,root,-) |
188 |
|
|
%{_libdir}/*.a |
189 |
|
|
|
190 |
|
|
################################################################################ |
191 |
|
|
%endif |
192 |
|
|
|
193 |
|
|
%changelog |
194 |
|
|
|
195 |
|
|
* Mon Sep 17 2007 Shad L. Lords <slords@lordsfam.net>> 2.3.5-1 |
196 |
|
|
- Update to 2.3.4 |
197 |
|
|
|
198 |
|
|
* Sun Jul 22 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-2 |
199 |
|
|
- Coment par2cmdline requirement. It's not really necessary, and not in Epel |
200 |
|
|
|
201 |
|
|
* Tue Jul 03 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-1 |
202 |
|
|
- Update to 2.3.4 |
203 |
|
|
|
204 |
|
|
* Mon May 28 2007 Chris Petersen <rpm@forevermore.net> 2.3.3-1 |
205 |
|
|
- Update to 2.3.3 |
206 |
|
|
- Remove man.dar.patch, which was added upstream |
207 |
|
|
|
208 |
|
|
* Wed Nov 15 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-4 |
209 |
|
|
- Change the main summary -- this is no longer a "collection of scripts" |
210 |
|
|
|
211 |
|
|
* Tue Nov 14 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-3 |
212 |
|
|
- Fix/standardize Requires/Provides for libdar and libdar-devel |
213 |
|
|
- Remove redundant zlib-devel (covered by openssl-devel) |
214 |
|
|
- Update README.Fedora with my name/date, as requested in the ticket |
215 |
|
|
- Add a patch to fix a funky character in man/dar.1 |
216 |
|
|
|
217 |
|
|
* Fri Nov 04 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-2 |
218 |
|
|
- Add README.Fedora explaining why we do not include static binaries (upstream's request) |
219 |
|
|
- Add libdar-static-devel subpackage to hold the *.a files |
220 |
|
|
- Disable static subpackages by default, enabled via "--with static" for those who want to compile them |
221 |
|
|
|
222 |
|
|
* Thu May 11 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-1 |
223 |
|
|
- Initial package, compiled from half a dozen third party packages |
224 |
|
|
|