/[smeserver]/rpms/dar/sme8/dar.spec
ViewVC logotype

Annotation of /rpms/dar/sme8/dar.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Fri Mar 5 20:07:37 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
Changes since 1.4: +4 -4 lines
Update email addresses

1 slords 1.5 # $Id: dar.spec,v 1.4 2008/10/11 18:30:58 slords Exp $
2 slords 1.3
3 slords 1.1 #
4     # Specfile for DAR, the disk archiver
5     #
6     # https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210790
7     #
8    
9     # Static build is disabled by default by fedora policy, but also because the
10     # latest versions of glibc don't seem to compile proper static binaries. Use
11     # "--with static" to enable the static subpackage
12     %define with_static %{?_with_static: 1} %{?!_with_static: 0}
13    
14     #
15     # Basic descriptive tags for this package:
16     #
17     Name: dar
18 slords 1.4 Version: 2.3.8
19 slords 1.1 Release: 1%{?dist}
20     Summary: Software for making/restoring incremental CD/DVD backups
21    
22     URL: http://dar.linux.free.fr/
23     License: GPL
24     Group: Applications/Archiving
25    
26     ################################################################################
27    
28     Source: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
29     Source1: README.Fedora
30    
31     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
32    
33     ################################################################################
34    
35     BuildRequires: bzip2-devel
36     BuildRequires: openssl-devel
37    
38     # Recommended, but no package yet in Epel.
39     #Requires: par2cmdline
40    
41     ################################################################################
42    
43     %description
44     DAR is a command line tool to backup a directory tree and files. DAR is
45     able to make differential backups, split them over a set of disks or files
46     of a given size, use compression, filter files or subtrees to be saved or
47     not saved, directly access and restore given files. DAR is also able
48     to handle extented attributes, and can make remote backups through an
49     ssh session for example. Finally, DAR handles save and restore of hard
50     and symbolic links.
51    
52     ################################################################################
53    
54     %package -n libdar
55     Group: System Environment/Libraries
56     Summary: Library providing support for the DAR API
57    
58     %description -n libdar
59     Common library code for DAR.
60    
61     ################################################################################
62    
63     %package -n libdar-devel
64     Group: Development/Libraries
65     Summary: Development files for libdar
66     Requires: libdar = %{version}-%{release}
67    
68     %description -n libdar-devel
69     This package contains the header files and libraries for developing
70     programs that use the DAR API (libdar).
71    
72     ################################################################################
73     # The following two subpackages are only built when enabled via "--with static"
74     ################################################################################
75    
76     %if %{with_static}
77    
78     %package -n dar-static
79     Group: Applications/System
80     Summary: Statically linked version of dar
81    
82     %description -n dar-static
83     Statically linked version of dar that can be installed onto backup disks for
84     easier file retrieval.
85    
86     %package -n libdar-static-devel
87     Group: Development/Libraries
88     Summary: Statically linked dar library files
89    
90     %description -nlibdar-static-devel
91     Statically linked version of dar libraries that can be installed onto backup
92     disks for easier file retrieval.
93    
94     %endif
95    
96     ################################################################################
97    
98     %prep
99     %setup -q
100    
101     ################################################################################
102    
103     %build
104    
105     # Options
106     %if %{with_static}
107     STATIC=""
108     %else
109     STATIC="--disable-dar-static --disable-static"
110     %endif
111    
112     %configure --disable-build-html $STATIC
113    
114     make %{?_smp_mflags}
115    
116     ################################################################################
117    
118     %install
119     rm -rf $RPM_BUILD_ROOT
120     make install DESTDIR=$RPM_BUILD_ROOT
121     %find_lang %{name}
122    
123     # Remove the libtool archive files
124     rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
125     rm -rf $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
126    
127     # Delete the sample files that we can't seem to disable
128     rm -rf $RPM_BUILD_ROOT/%{_datadir}/dar/
129    
130     # Remove the doc makefiles so they don't get installed along with the other files.
131     rm -f doc/Makefile*
132     rm -f doc/*/Makefile*
133    
134     # Rename the documentation directory so it makes more sense after installation.
135     mv doc html
136    
137     # Sample scripts should not be executable
138     chmod 0644 html/samples/*
139    
140     # Install the fedora readme
141     cp -a %{SOURCE1} .
142    
143     ################################################################################
144    
145     %clean
146     rm -rf $RPM_BUILD_ROOT
147    
148     ################################################################################
149    
150     %post -n libdar -p /sbin/ldconfig
151     %postun -n libdar -p /sbin/ldconfig
152    
153    
154     %files -f %{name}.lang
155     %defattr(-,root,root,-)
156     %doc html/ ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO README.Fedora
157    
158     %{_bindir}/dar
159     %{_bindir}/dar_cp
160     %{_bindir}/dar_manager
161     %{_bindir}/dar_slave
162     %{_bindir}/dar_xform
163     %{_mandir}/man1/*
164    
165     ################################################################################
166    
167     %files -n libdar
168     %defattr(-,root,root,-)
169     %{_libdir}/*.so.*
170    
171     ################################################################################
172    
173     %files -n libdar-devel
174     %defattr(-,root,root,-)
175     %{_includedir}/*
176     %{_libdir}/*.so
177    
178     ################################################################################
179    
180     %if %{with_static}
181    
182     %files -n dar-static
183     %defattr(-,root,root,-)
184     %{_bindir}/dar_static
185    
186     ################################################################################
187    
188     %files -n libdar-static-devel
189     %defattr(-,root,root,-)
190     %{_libdir}/*.a
191    
192     ################################################################################
193     %endif
194    
195     %changelog
196    
197 slords 1.5 * Sat Oct 11 2008 Shad L. Lords <slords@mail.com>> 2.3.8-1
198 slords 1.4 - Update to 2.3.8
199    
200 slords 1.5 * Fri Nov 30 2007 Shad L. Lords <slords@mail.com>> 2.3.6-1
201 slords 1.2 - Update to 2.3.6
202    
203 slords 1.5 * Mon Sep 17 2007 Shad L. Lords <slords@mail.com>> 2.3.5-1
204 slords 1.2 - Update to 2.3.5
205 slords 1.1
206     * Sun Jul 22 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-2
207     - Coment par2cmdline requirement. It's not really necessary, and not in Epel
208    
209     * Tue Jul 03 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-1
210     - Update to 2.3.4
211    
212     * Mon May 28 2007 Chris Petersen <rpm@forevermore.net> 2.3.3-1
213     - Update to 2.3.3
214     - Remove man.dar.patch, which was added upstream
215    
216     * Wed Nov 15 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-4
217     - Change the main summary -- this is no longer a "collection of scripts"
218    
219     * Tue Nov 14 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-3
220     - Fix/standardize Requires/Provides for libdar and libdar-devel
221     - Remove redundant zlib-devel (covered by openssl-devel)
222     - Update README.Fedora with my name/date, as requested in the ticket
223     - Add a patch to fix a funky character in man/dar.1
224    
225     * Fri Nov 04 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-2
226     - Add README.Fedora explaining why we do not include static binaries (upstream's request)
227     - Add libdar-static-devel subpackage to hold the *.a files
228     - Disable static subpackages by default, enabled via "--with static" for those who want to compile them
229    
230     * Thu May 11 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-1
231     - Initial package, compiled from half a dozen third party packages
232    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed