1 |
# $Id: dar.spec,v 1.5 2010/03/05 20:07:37 slords Exp $ |
2 |
|
3 |
# |
4 |
# Specfile for DAR, the disk archiver |
5 |
# |
6 |
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210790 |
7 |
# |
8 |
|
9 |
# Static build is disabled by default by fedora policy, but also because the |
10 |
# latest versions of glibc don't seem to compile proper static binaries. Use |
11 |
# "--with static" to enable the static subpackage |
12 |
%define with_static %{?_with_static: 1} %{?!_with_static: 0} |
13 |
|
14 |
# |
15 |
# Basic descriptive tags for this package: |
16 |
# |
17 |
Name: dar |
18 |
Version: 2.4.11 |
19 |
Release: 1%{?dist} |
20 |
Summary: Software for making/restoring incremental CD/DVD backups |
21 |
|
22 |
URL: http://dar.linux.free.fr/ |
23 |
License: GPLv2+ |
24 |
Group: Applications/Archiving |
25 |
|
26 |
################################################################################ |
27 |
|
28 |
Source: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz |
29 |
Source1: README.Fedora |
30 |
|
31 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
32 |
|
33 |
################################################################################ |
34 |
|
35 |
BuildRequires: zlib-devel |
36 |
BuildRequires: bzip2-devel |
37 |
BuildRequires: openssl-devel |
38 |
BuildRequires: libattr-devel |
39 |
BuildRequires: e2fsprogs-devel |
40 |
#Requires: par2cmdline |
41 |
|
42 |
################################################################################ |
43 |
|
44 |
%description |
45 |
DAR is a command line tool to backup a directory tree and files. DAR is |
46 |
able to make differential backups, split them over a set of disks or files |
47 |
of a given size, use compression, filter files or subtrees to be saved or |
48 |
not saved, directly access and restore given files. DAR is also able |
49 |
to handle extented attributes, and can make remote backups through an |
50 |
ssh session for example. Finally, DAR handles save and restore of hard |
51 |
and symbolic links. |
52 |
|
53 |
################################################################################ |
54 |
|
55 |
%package -n libdar |
56 |
Group: System Environment/Libraries |
57 |
Summary: Library providing support for the DAR API |
58 |
|
59 |
%description -n libdar |
60 |
Common library code for DAR. |
61 |
|
62 |
################################################################################ |
63 |
|
64 |
%package -n libdar-devel |
65 |
Group: Development/Libraries |
66 |
Summary: Development files for libdar |
67 |
Requires: libdar = %{version}-%{release} |
68 |
|
69 |
%description -n libdar-devel |
70 |
This package contains the header files and libraries for developing |
71 |
programs that use the DAR API (libdar). |
72 |
|
73 |
################################################################################ |
74 |
# The following two subpackages are only built when enabled via "--with static" |
75 |
################################################################################ |
76 |
|
77 |
%if %{with_static} |
78 |
|
79 |
%package -n dar-static |
80 |
Group: Applications/System |
81 |
Summary: Statically linked version of dar |
82 |
|
83 |
%description -n dar-static |
84 |
Statically linked version of dar that can be installed onto backup disks for |
85 |
easier file retrieval. |
86 |
|
87 |
%package -n libdar-static-devel |
88 |
Group: Development/Libraries |
89 |
Summary: Statically linked dar library files |
90 |
|
91 |
%description -nlibdar-static-devel |
92 |
Statically linked version of dar libraries that can be installed onto backup |
93 |
disks for easier file retrieval. |
94 |
|
95 |
%endif |
96 |
|
97 |
################################################################################ |
98 |
|
99 |
%prep |
100 |
%setup -q |
101 |
|
102 |
################################################################################ |
103 |
|
104 |
%build |
105 |
|
106 |
# Options |
107 |
%if %{with_static} |
108 |
STATIC="" |
109 |
%else |
110 |
STATIC="--disable-dar-static --disable-static" |
111 |
%endif |
112 |
|
113 |
%configure --disable-build-html $STATIC |
114 |
|
115 |
# Remove Rpath |
116 |
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool |
117 |
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
118 |
|
119 |
make %{?_smp_mflags} |
120 |
|
121 |
################################################################################ |
122 |
|
123 |
%install |
124 |
rm -rf $RPM_BUILD_ROOT |
125 |
make install DESTDIR=$RPM_BUILD_ROOT |
126 |
%find_lang %{name} |
127 |
|
128 |
# Remove the libtool archive files |
129 |
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la |
130 |
rm -rf $RPM_BUILD_ROOT/%{_libdir}/pkgconfig |
131 |
|
132 |
# Delete the sample files that we can't seem to disable |
133 |
rm -rf $RPM_BUILD_ROOT/%{_datadir}/dar/ |
134 |
|
135 |
# Remove the doc makefiles so they don't get installed along with the other files. |
136 |
rm -f doc/Makefile* |
137 |
rm -f doc/*/Makefile* |
138 |
|
139 |
# Rename the documentation directory so it makes more sense after installation. |
140 |
mv doc html |
141 |
|
142 |
# Sample scripts should not be executable |
143 |
chmod 0644 html/samples/* |
144 |
|
145 |
# Install the fedora readme |
146 |
cp -a %{SOURCE1} . |
147 |
|
148 |
################################################################################ |
149 |
|
150 |
%clean |
151 |
rm -rf $RPM_BUILD_ROOT |
152 |
|
153 |
################################################################################ |
154 |
|
155 |
%post -n libdar -p /sbin/ldconfig |
156 |
%postun -n libdar -p /sbin/ldconfig |
157 |
|
158 |
|
159 |
%files -f %{name}.lang |
160 |
%defattr(-,root,root,-) |
161 |
%doc html/ AUTHORS ChangeLog COPYING NEWS README THANKS TODO README.Fedora |
162 |
|
163 |
%{_bindir}/dar |
164 |
%{_bindir}/dar_cp |
165 |
%{_bindir}/dar_manager |
166 |
%{_bindir}/dar_slave |
167 |
%{_bindir}/dar_xform |
168 |
%{_sysconfdir}/darrc |
169 |
%{_mandir}/man1/* |
170 |
|
171 |
################################################################################ |
172 |
|
173 |
%files -n libdar |
174 |
%defattr(-,root,root,-) |
175 |
%{_libdir}/*.so.* |
176 |
|
177 |
################################################################################ |
178 |
|
179 |
%files -n libdar-devel |
180 |
%defattr(-,root,root,-) |
181 |
%{_includedir}/dar/ |
182 |
%{_libdir}/*.so |
183 |
|
184 |
################################################################################ |
185 |
|
186 |
%if %{with_static} |
187 |
|
188 |
%files -n dar-static |
189 |
%defattr(-,root,root,-) |
190 |
%{_bindir}/dar_static |
191 |
|
192 |
################################################################################ |
193 |
|
194 |
%files -n libdar-static-devel |
195 |
%defattr(-,root,root,-) |
196 |
%{_libdir}/*.a |
197 |
|
198 |
################################################################################ |
199 |
%endif |
200 |
|
201 |
%changelog |
202 |
* Fri Dec 6 2013 Ian Wells <esmith@wellsi.com> - 2.4.11-1 |
203 |
- New Upstream version, 2.4.11 [SME: 8036] |
204 |
|
205 |
* Thu May 30 2013 Luis Bazan <lbazan@fedoraproject.org> - 2.4.10-1 |
206 |
- New Upstream version |
207 |
|
208 |
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.3.8-5 |
209 |
- rebuilt with new openssl |
210 |
|
211 |
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-4 |
212 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
213 |
|
214 |
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-3 |
215 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
216 |
|
217 |
* Thu Jan 15 2009 Tomas Mraz <tmraz@redhat.com> 2.3.8-2 |
218 |
- rebuild with new openssl |
219 |
|
220 |
* Mon Aug 04 2008 Marcin Garski <mgarski[AT]post.pl> 2.3.8-1 |
221 |
- Update to 2.3.8 (#434519, #438953) |
222 |
- Own dar's include directory |
223 |
- Remove Rpath |
224 |
- Update BR's |
225 |
|
226 |
* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.3.6-5 |
227 |
- fix license tag |
228 |
|
229 |
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.3.6-4 |
230 |
- Autorebuild for GCC 4.3 |
231 |
|
232 |
* Wed Dec 05 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-3 |
233 |
- Add openssl requirement |
234 |
|
235 |
* Sun Nov 18 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-2 |
236 |
- failed "make tag" |
237 |
|
238 |
* Sun Nov 18 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-1 |
239 |
- Update to 2.3.6 |
240 |
|
241 |
* Mon Sep 17 2007 Shad L. Lords <slords@mail.com>> 2.3.5-1 |
242 |
- Update to 2.3.5 |
243 |
|
244 |
* Sun Jul 22 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-2 |
245 |
- Coment par2cmdline requirement. It's not really necessary, and not in Epel |
246 |
|
247 |
* Tue Jul 03 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-1 |
248 |
- Update to 2.3.4 |
249 |
|
250 |
* Mon May 28 2007 Chris Petersen <rpm@forevermore.net> 2.3.3-1 |
251 |
- Update to 2.3.3 |
252 |
- Remove man.dar.patch, which was added upstream |
253 |
|
254 |
* Wed Nov 15 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-4 |
255 |
- Change the main summary -- this is no longer a "collection of scripts" |
256 |
|
257 |
* Tue Nov 14 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-3 |
258 |
- Fix/standardize Requires/Provides for libdar and libdar-devel |
259 |
- Remove redundant zlib-devel (covered by openssl-devel) |
260 |
- Update README.Fedora with my name/date, as requested in the ticket |
261 |
- Add a patch to fix a funky character in man/dar.1 |
262 |
|
263 |
* Fri Nov 04 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-2 |
264 |
- Add README.Fedora explaining why we do not include static binaries (upstream's request) |
265 |
- Add libdar-static-devel subpackage to hold the *.a files |
266 |
- Disable static subpackages by default, enabled via "--with static" for those who want to compile them |
267 |
|
268 |
* Thu May 11 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-1 |
269 |
- Initial package, compiled from half a dozen third party packages |
270 |
|