1 |
# |
2 |
# Specfile for DAR, the disk archiver |
3 |
# |
4 |
# https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210790 |
5 |
# |
6 |
|
7 |
# Static build is disabled by default by fedora policy, but also because the |
8 |
# latest versions of glibc don't seem to compile proper static binaries. Use |
9 |
# "--with static" to enable the static subpackage |
10 |
%define with_static %{?_with_static: 1} %{?!_with_static: 0} |
11 |
|
12 |
# |
13 |
# Basic descriptive tags for this package: |
14 |
# |
15 |
Name: dar |
16 |
Version: 2.3.8 |
17 |
Release: 7%{?dist} |
18 |
Summary: Software for making/restoring incremental CD/DVD backups |
19 |
|
20 |
Group: Applications/Archiving |
21 |
License: GPLv2+ |
22 |
URL: http://dar.linux.free.fr/ |
23 |
|
24 |
################################################################################ |
25 |
|
26 |
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz |
27 |
Source1: README.Fedora |
28 |
|
29 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
30 |
|
31 |
################################################################################ |
32 |
|
33 |
BuildRequires: zlib-devel |
34 |
BuildRequires: bzip2-devel |
35 |
BuildRequires: openssl-devel |
36 |
BuildRequires: libattr-devel |
37 |
BuildRequires: e2fsprogs-devel |
38 |
|
39 |
Requires: par2cmdline |
40 |
|
41 |
################################################################################ |
42 |
|
43 |
%description |
44 |
DAR is a command line tool to backup a directory tree and files. DAR is |
45 |
able to make differential backups, split them over a set of disks or files |
46 |
of a given size, use compression, filter files or subtrees to be saved or |
47 |
not saved, directly access and restore given files. DAR is also able |
48 |
to handle extented attributes, and can make remote backups through an |
49 |
ssh session for example. Finally, DAR handles save and restore of hard |
50 |
and symbolic links. |
51 |
|
52 |
################################################################################ |
53 |
|
54 |
%package -n libdar |
55 |
Group: System Environment/Libraries |
56 |
Summary: Library providing support for the DAR API |
57 |
|
58 |
%description -n libdar |
59 |
Common library code for DAR. |
60 |
|
61 |
################################################################################ |
62 |
|
63 |
%package -n libdar-devel |
64 |
Group: Development/Libraries |
65 |
Summary: Development files for libdar |
66 |
Requires: libdar = %{version}-%{release} |
67 |
|
68 |
%description -n libdar-devel |
69 |
This package contains the header files and libraries for developing |
70 |
programs that use the DAR API (libdar). |
71 |
|
72 |
################################################################################ |
73 |
# The following two subpackages are only built when enabled via "--with static" |
74 |
################################################################################ |
75 |
|
76 |
%if %{with_static} |
77 |
|
78 |
%package -n dar-static |
79 |
Group: Applications/System |
80 |
Summary: Statically linked version of dar |
81 |
|
82 |
%description -n dar-static |
83 |
Statically linked version of dar that can be installed onto backup disks for |
84 |
easier file retrieval. |
85 |
|
86 |
%package -n libdar-static-devel |
87 |
Group: Development/Libraries |
88 |
Summary: Statically linked dar library files |
89 |
|
90 |
%description -nlibdar-static-devel |
91 |
Statically linked version of dar libraries that can be installed onto backup |
92 |
disks for easier file retrieval. |
93 |
|
94 |
%endif |
95 |
|
96 |
################################################################################ |
97 |
|
98 |
%prep |
99 |
%setup -q |
100 |
|
101 |
################################################################################ |
102 |
|
103 |
%build |
104 |
|
105 |
# Options |
106 |
%if %{with_static} |
107 |
STATIC="" |
108 |
%else |
109 |
STATIC="--disable-dar-static --disable-static" |
110 |
%endif |
111 |
|
112 |
%configure --disable-build-html $STATIC |
113 |
|
114 |
# Remove Rpath |
115 |
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool |
116 |
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
117 |
|
118 |
make %{?_smp_mflags} |
119 |
|
120 |
################################################################################ |
121 |
|
122 |
%install |
123 |
rm -rf $RPM_BUILD_ROOT |
124 |
make install DESTDIR=$RPM_BUILD_ROOT |
125 |
%find_lang %{name} |
126 |
|
127 |
# Remove the libtool archive files |
128 |
rm -rf $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/ |
129 |
rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la |
130 |
|
131 |
# Delete the sample files that we can't seem to disable |
132 |
rm -rf $RPM_BUILD_ROOT/%{_datadir}/dar/ |
133 |
|
134 |
# Remove the doc makefiles so they don't get installed along with the other files. |
135 |
rm -f doc/Makefile* |
136 |
rm -f doc/*/Makefile* |
137 |
|
138 |
# Rename the documentation directory so it makes more sense after installation. |
139 |
mv doc html |
140 |
|
141 |
# Sample scripts should not be executable |
142 |
chmod 0644 html/samples/* |
143 |
|
144 |
# Install the fedora readme |
145 |
cp -a %{SOURCE1} . |
146 |
|
147 |
################################################################################ |
148 |
|
149 |
%clean |
150 |
rm -rf $RPM_BUILD_ROOT |
151 |
|
152 |
################################################################################ |
153 |
|
154 |
%post -n libdar -p /sbin/ldconfig |
155 |
%postun -n libdar -p /sbin/ldconfig |
156 |
|
157 |
|
158 |
%files -f %{name}.lang |
159 |
%defattr(-,root,root,-) |
160 |
%doc html/ AUTHORS ChangeLog COPYING NEWS README THANKS TODO README.Fedora |
161 |
|
162 |
%{_bindir}/dar |
163 |
%{_bindir}/dar_cp |
164 |
%{_bindir}/dar_manager |
165 |
%{_bindir}/dar_slave |
166 |
%{_bindir}/dar_xform |
167 |
%{_mandir}/man1/* |
168 |
|
169 |
################################################################################ |
170 |
|
171 |
%files -n libdar |
172 |
%defattr(-,root,root,-) |
173 |
%{_libdir}/*.so.* |
174 |
|
175 |
################################################################################ |
176 |
|
177 |
%files -n libdar-devel |
178 |
%defattr(-,root,root,-) |
179 |
%{_includedir}/dar/ |
180 |
%{_libdir}/*.so |
181 |
|
182 |
################################################################################ |
183 |
|
184 |
%if %{with_static} |
185 |
|
186 |
%files -n dar-static |
187 |
%defattr(-,root,root,-) |
188 |
%{_bindir}/dar_static |
189 |
|
190 |
################################################################################ |
191 |
|
192 |
%files -n libdar-static-devel |
193 |
%defattr(-,root,root,-) |
194 |
%{_libdir}/*.a |
195 |
|
196 |
################################################################################ |
197 |
%endif |
198 |
|
199 |
%changelog |
200 |
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-7 |
201 |
- Rebuilt for glibc bug#747377 |
202 |
|
203 |
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-6 |
204 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
205 |
|
206 |
* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.3.8-5 |
207 |
- rebuilt with new openssl |
208 |
|
209 |
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-4 |
210 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
211 |
|
212 |
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.8-3 |
213 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
214 |
|
215 |
* Thu Jan 15 2009 Tomas Mraz <tmraz@redhat.com> 2.3.8-2 |
216 |
- rebuild with new openssl |
217 |
|
218 |
* Mon Aug 04 2008 Marcin Garski <mgarski[AT]post.pl> 2.3.8-1 |
219 |
- Update to 2.3.8 (#434519, #438953) |
220 |
- Own dar's include directory |
221 |
- Remove Rpath |
222 |
- Update BR's |
223 |
|
224 |
* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.3.6-5 |
225 |
- fix license tag |
226 |
|
227 |
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.3.6-4 |
228 |
- Autorebuild for GCC 4.3 |
229 |
|
230 |
* Wed Dec 05 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-3 |
231 |
- Add openssl requirement |
232 |
|
233 |
* Sun Nov 18 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-2 |
234 |
- failed "make tag" |
235 |
|
236 |
* Sun Nov 18 2007 Chris Petersen <rpm@forevermore.net> 2.3.6-1 |
237 |
- Update to 2.3.6 |
238 |
|
239 |
* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.3.4-2 |
240 |
- Rebuild for selinux ppc32 issue. |
241 |
|
242 |
* Tue Jul 03 2007 Chris Petersen <rpm@forevermore.net> 2.3.4-1 |
243 |
- Update to 2.3.4 |
244 |
|
245 |
* Mon May 28 2007 Chris Petersen <rpm@forevermore.net> 2.3.3-1 |
246 |
- Update to 2.3.3 |
247 |
- Remove man.dar.patch, which was added upstream |
248 |
|
249 |
* Wed Nov 15 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-4 |
250 |
- Change the main summary -- this is no longer a "collection of scripts" |
251 |
|
252 |
* Tue Nov 14 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-3 |
253 |
- Fix/standardize Requires/Provides for libdar and libdar-devel |
254 |
- Remove redundant zlib-devel (covered by openssl-devel) |
255 |
- Update README.Fedora with my name/date, as requested in the ticket |
256 |
- Add a patch to fix a funky character in man/dar.1 |
257 |
|
258 |
* Fri Nov 04 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-2 |
259 |
- Add README.Fedora explaining why we do not include static binaries (upstream's request) |
260 |
- Add libdar-static-devel subpackage to hold the *.a files |
261 |
- Disable static subpackages by default, enabled via "--with static" for those who want to compile them |
262 |
|
263 |
* Thu May 11 2006 Chris Petersen <rpm@forevermore.net> 2.3.1-1 |
264 |
- Initial package, compiled from half a dozen third party packages |
265 |
|