/[smeserver]/rpms/djbdns/sme10/djbdns.spec
ViewVC logotype

Annotation of /rpms/djbdns/sme10/djbdns.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Jul 12 16:43:25 2017 UTC (6 years, 11 months ago) by unnilennium
Branch: MAIN
CVS Tags: djbdns-1_05-10_el7_sme
Changes since 1.2: +7 -3 lines
* Wed Jul 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-10.sme
- improve short ttl cname resolution and glueless answer from akadns [SME: 8362]
- 500-cutom-dnscache-maxloop.patch: increase QUERY_MAXLEVEL 5->10 , set  QUERY_MAXLOOP 160

1 unnilennium 1.3 # $Id: djbdns.spec,v 1.2 2017/07/12 03:39:09 unnilennium Exp $
2 vip-ire 1.1
3     #
4     # RPM spec file for Dan Bernstein's djbdns package
5     #
6 unnilennium 1.3 # $Id: djbdns.spec,v 1.2 2017/07/12 03:39:09 unnilennium Exp $
7 vip-ire 1.1 #
8     Summary: collection of Domain Name System tools
9     %define name djbdns
10     Name: %{name}
11     %define version 1.05
12 unnilennium 1.3 %define release 10
13 vip-ire 1.1 Version: %{version}
14     Release: %{release}%{?dist}
15     License: Public Domain
16     Group: Networking/Daemons
17     Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz
18     URL: http://cr.yp.to/%{name}.html
19     Patch0: %{name}-%{version}.patch.2001022000
20     Patch1: dns_transmit-bug.patch
21 unnilennium 1.2 #Patch2: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-cname-handling.patch
22 vip-ire 1.1 Patch3: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/dnscache-strict-forwardonly.patch
23 unnilennium 1.2 #Patch4: http://homepages.tesco.net./~J.deBoynePollard/Softwares/djbdns/tinydns-alias-chain-truncation.patch
24    
25     # openwrt patches
26     Patch20: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/020-dnsroots-update.patch
27     Patch30: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/030-srv-records-and-axfrget.patch
28     Patch50: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/050-tinydns-mmap-leak.patch
29     Patch60: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/060-dnscache-big-udp-packets.patch
30     Patch70: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/070-dnscache-dpos-tcp-servfail.patch
31     Patch90: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/090-tinydns-one-second.patch
32     Patch80: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/080-dnscache-cache-negatives.patch
33     Patch120: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/120-compiler-temporary-filename.patch
34     Patch200: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/200-dnscache-cname-handling.patch
35     Patch210: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/210-dnscache-strict-forwardonly.patch
36     Patch230: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/230-tinydns-data-semantic-error.patch
37     Patch240: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/240-tinydns-alias-chain-truncation.patch
38     Patch270: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/270-dnscache-sigpipe-fix.patch
39     Patch300: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/300-bugfix-dnscache-dempsky-poison.patch
40     Patch310: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/310-bugfix-dnscache-merge-outgoing-requests.patch
41     Patch320: https://dev.openwrt.org/export/HEAD/packages/net/djbdns/patches/320-bugfix-dnscache-cache-soa-records.patch
42     Patch330: https://dev.openwrt.org/raw-attachment/ticket/5881/330-fix-dnscache-cname-handling.patch
43    
44     #after openwrt applied patches
45     Patch450: 450-dnscache-ghost-domain-CVE-2012-1191.patch
46     Patch500: 500-cutom-dnscache-maxloop.patch
47    
48    
49 vip-ire 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
50     Provides: djbdns
51     AutoReqProv: no
52    
53     %description
54     djbdns is a collection of Domain Name System tools. It includes several
55     components:
56    
57     - The dnscache program is a local DNS cache. It accepts recursive
58     DNS queries from local clients such as web browsers. It collects
59     responses from remote DNS servers.
60    
61     - The tinydns program is a fast, UDP-only DNS server. It makes
62     local DNS information available to the Internet. It supports load
63     balancing and client differentiation.
64    
65     - The walldns program is a reverse DNS wall. It provides matching
66     reverse and forward records while hiding local host information.
67    
68     - The rbldns program is an IP-address-listing DNS server. It uses
69     DNS to publish a list of IP addresses, such as RBL or DUL.
70    
71     - The dns library handles outgoing and incoming DNS packets. It can
72     be used by clients such as web browsers to look up host addresses,
73     host names, MX records, etc. It supports asynchronous resolution.
74    
75     - The dnsfilter program is a parallel IP-address-to-host-name
76     converter.
77    
78     - The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple
79     command-line interfaces to DNS.
80    
81     - The dnsq and dnstrace programs are DNS debugging tools.
82    
83     djbdns was written by Daniel J Bernstein, and was placed into the public
84     domain on Dec 28, 2007.
85    
86     %changelog
87 unnilennium 1.3 * Wed Jul 12 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-10.sme
88     - improve short ttl cname resolution and glueless answer from akadns [SME: 8362]
89     - 500-cutom-dnscache-maxloop.patch: increase QUERY_MAXLEVEL 5->10 , set QUERY_MAXLOOP 160
90    
91 unnilennium 1.2 * Tue Jul 11 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.05-9.sme
92     --import patches from openwrt and rename already applied patches
93     --fix security issues [SME: 10374]
94     - 020-dnsroots-update.patch: update list of root DNS servers
95     - 070-dnscache-dpos-tcp-servfail.patch: SERVFAIL rename previous patch dns_transmit-bug.patch
96     - 080-dnscache-cache-negatives.patch: rfc2308 ?
97     - 210-dnscache-strict-forwardonly.patch: rename previous patch dnscache-strict-forwardonly.patch
98     - 240-tinydns-alias-chain-truncation.patch: rename previous patch tinydns-alias-chain-truncation.patch
99     - 270-dnscache-sigpipe-fix.patch: SIGPIPE
100     - 300-bugfix-dnscache-dempsky-poison.patch: CVE-2009-0858
101     - 310-bugfix-dnscache-merge-outgoing-requests.patch: CVE-2008-4392
102     - 320-bugfix-dnscache-cache-soa-records.patch: CVE-2008-4392
103     - 450-dnscache-ghost-domain-CVE-2012-1191.patch: CVE-2012-1191 http://marc.info/?l=djbdns&m=134190748729079&w=2
104     --bug fixes [SME: 10374]
105     - 060-dnscache-big-udp-packets.patch: accept and handle longer than 512 bytes UDP packets
106     - 230-tinydns-data-semantic-error.patch: handle semantic error to avoid publishing false dns records
107     --fix issue with short ttl cname like akamaid [SME: 8362]
108     - 200-dnscache-cname-handling.patch: rename previous patch dnscache-cname-handling.patch
109     - 330-fix-dnscache-cname-handling.patch: fix dnscache cname for short ttl
110     - 500-cutom-dnscache-maxloop.patch: set max loop to 200
111     --needed for previous patches to apply cleanly
112     - 030-srv-records-and-axfrget.patch: add SRV record type and axfr-get decompose SRC and PTR records (for 230-*.patch)
113     - 050-tinydns-mmap-leak.patch: report cdb leak
114     - 080-dnscache-cache-negatives.patch: rfc2308 ?
115     - 090-tinydns-one-second.patch: improve tinydns with 8 or more concurent connections (for 240-*.patch)
116     - 120-compiler-temporary-filename.patch: change tmp filename to avoid conflicts (for 230-*.patch)
117    
118 vip-ire 1.1 * Mon Mar 24 2008 Shad L. Lords <slords@mail.com> 1.05-8
119     - Comment out contentious patches for now [SME: 3826] [SME: 3824]
120    
121     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-7
122     - Patch tinydns to publish complete client-side alias chains. [SME: 3826]
123    
124     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-6
125     - Patch to fix problems with delegation loops. [SME: 3825]
126    
127     * Mon Jan 28 2008 Charlie Brady <charlie_brady@mitel.com> 1.05-5
128     - Patch to fix various problems in dnscache CNAME record handling. [SME: 3824]
129    
130     * Thu Jan 10 2008 Charlie Brady <charlieb@e-smith.com> 1.05-4
131     - Patch around TCP bug: http://alkemio.org/dns_transmit-bug.html
132     - Change license to "Public Domain' - http://cr.yp.to/distributors.html
133    
134     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
135     - Clean up spec so package can be built by koji/plague
136    
137     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
138     - Update to new release naming. No functional changes.
139     - Make Packager generic
140    
141     * Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02
142     - Use "conf-cc" value which works around errno problem.
143    
144     * Tue Feb 20 2001 Peter Samuel <peters@e-smith.com>
145     - [1.05-01]
146     - Updated for djbdns-1.05.
147    
148     * Tue Feb 6 2001 Peter Samuel <peters@e-smith.com>
149     - [1.04-01]
150     - Now installs in its own root area prior to creating binary RPM.
151    
152     %prep
153     %setup
154    
155     # This patch allows files to be installed in a relative directory prior
156     # to creating the binary RPM. It does not change the installed files or
157     # their final installed locations.
158    
159     %patch0 -p1
160    
161     # Create the relative installation directories.
162    
163     mkdir -p ./root/usr
164     mkdir -p ./root/etc
165    
166 unnilennium 1.2 #%patch1 -p1
167     ##%patch2 -p1
168     #%patch3 -p1
169     ##%patch4 -p1
170     #%patch5 -p1
171     #%patch6 -p1
172     ##%patch7 -p1
173    
174     %patch20 -p1
175     %patch30 -p1
176     %patch50 -p1
177     %patch60 -p1
178     %patch70 -p1
179     %patch80 -p1
180     %patch90 -p1
181     %patch120 -p1
182     %patch200 -p1
183     %patch210 -p1
184     %patch230 -p1
185     %patch240 -p1
186     %patch270 -p1
187     %patch300 -p1
188     %patch310 -p1
189     %patch320 -p1
190     %patch330 -p1
191     %patch450 -p1
192     %patch500 -p1
193    
194 vip-ire 1.1
195     %build
196     echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc
197     echo "gcc -s -Os -pipe" > conf-ld
198     make
199    
200     %install
201     make setup
202     make check
203     rm -rf $RPM_BUILD_ROOT
204     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
205    
206     %clean
207     rm -rf $RPM_BUILD_ROOT
208    
209     %files
210     %attr(644,root,root) /etc/dnsroots.global
211     %attr(755,root,root) /usr/local/bin/axfrdns
212     %attr(755,root,root) /usr/local/bin/axfrdns-conf
213     %attr(755,root,root) /usr/local/bin/axfr-get
214     %attr(755,root,root) /usr/local/bin/dnscache
215     %attr(755,root,root) /usr/local/bin/dnscache-conf
216     %attr(755,root,root) /usr/local/bin/dnsfilter
217     %attr(755,root,root) /usr/local/bin/dnsip
218     %attr(755,root,root) /usr/local/bin/dnsipq
219     %attr(755,root,root) /usr/local/bin/dnsmx
220     %attr(755,root,root) /usr/local/bin/dnsname
221     %attr(755,root,root) /usr/local/bin/dnsq
222     %attr(755,root,root) /usr/local/bin/dnsqr
223     %attr(755,root,root) /usr/local/bin/dnstrace
224     %attr(755,root,root) /usr/local/bin/dnstracesort
225     %attr(755,root,root) /usr/local/bin/dnstxt
226     %attr(755,root,root) /usr/local/bin/pickdns
227     %attr(755,root,root) /usr/local/bin/pickdns-conf
228     %attr(755,root,root) /usr/local/bin/pickdns-data
229     %attr(755,root,root) /usr/local/bin/random-ip
230     %attr(755,root,root) /usr/local/bin/rbldns
231     %attr(755,root,root) /usr/local/bin/rbldns-conf
232     %attr(755,root,root) /usr/local/bin/rbldns-data
233     %attr(755,root,root) /usr/local/bin/tinydns
234     %attr(755,root,root) /usr/local/bin/tinydns-conf
235     %attr(755,root,root) /usr/local/bin/tinydns-data
236     %attr(755,root,root) /usr/local/bin/tinydns-edit
237     %attr(755,root,root) /usr/local/bin/tinydns-get
238     %attr(755,root,root) /usr/local/bin/walldns
239     %attr(755,root,root) /usr/local/bin/walldns-conf

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed