1 |
slords |
1.1 |
# |
2 |
|
|
# RPM spec file for Dan Bernstein's djbdns package |
3 |
|
|
# |
4 |
|
|
# $Id: djbdns.spec,v 1.5 2004/11/11 21:03:51 charlieb Exp $ |
5 |
|
|
# |
6 |
|
|
Summary: collection of Domain Name System tools |
7 |
|
|
%define name djbdns |
8 |
|
|
Name: %{name} |
9 |
|
|
%define version 1.05 |
10 |
|
|
%define release 3 |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: Daniel J. Bernstein |
14 |
|
|
Group: Networking/Daemons |
15 |
|
|
Source: http://cr.yp.to/%{name}/%{name}-%{version}.tar.gz |
16 |
|
|
URL: http://cr.yp.to/%{name}.html |
17 |
|
|
Patch0: %{name}-%{version}.patch.2001022000 |
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
Provides: djbdns |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
djbdns is a collection of Domain Name System tools. It includes several |
24 |
|
|
components: |
25 |
|
|
|
26 |
|
|
- The dnscache program is a local DNS cache. It accepts recursive |
27 |
|
|
DNS queries from local clients such as web browsers. It collects |
28 |
|
|
responses from remote DNS servers. |
29 |
|
|
|
30 |
|
|
- The tinydns program is a fast, UDP-only DNS server. It makes |
31 |
|
|
local DNS information available to the Internet. It supports load |
32 |
|
|
balancing and client differentiation. |
33 |
|
|
|
34 |
|
|
- The walldns program is a reverse DNS wall. It provides matching |
35 |
|
|
reverse and forward records while hiding local host information. |
36 |
|
|
|
37 |
|
|
- The rbldns program is an IP-address-listing DNS server. It uses |
38 |
|
|
DNS to publish a list of IP addresses, such as RBL or DUL. |
39 |
|
|
|
40 |
|
|
- The dns library handles outgoing and incoming DNS packets. It can |
41 |
|
|
be used by clients such as web browsers to look up host addresses, |
42 |
|
|
host names, MX records, etc. It supports asynchronous resolution. |
43 |
|
|
|
44 |
|
|
- The dnsfilter program is a parallel IP-address-to-host-name |
45 |
|
|
converter. |
46 |
|
|
|
47 |
|
|
- The dnsip, dnsipq, dnsname, dnstxt, and dnsmx programs are simple |
48 |
|
|
command-line interfaces to DNS. |
49 |
|
|
|
50 |
|
|
- The dnsq and dnstrace programs are DNS debugging tools. |
51 |
|
|
|
52 |
|
|
%changelog |
53 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
54 |
|
|
- Clean up spec so package can be built by koji/plague |
55 |
|
|
|
56 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
57 |
|
|
- Update to new release naming. No functional changes. |
58 |
|
|
- Make Packager generic |
59 |
|
|
|
60 |
|
|
* Thu Nov 11 2004 Charlie Brady <charlieb@e-smith.com> 1.05-02 |
61 |
|
|
- Use "conf-cc" value which works around errno problem. |
62 |
|
|
|
63 |
|
|
* Tue Feb 20 2001 Peter Samuel <peters@e-smith.com> |
64 |
|
|
- [1.05-01] |
65 |
|
|
- Updated for djbdns-1.05. |
66 |
|
|
|
67 |
|
|
* Tue Feb 6 2001 Peter Samuel <peters@e-smith.com> |
68 |
|
|
- [1.04-01] |
69 |
|
|
- Now installs in its own root area prior to creating binary RPM. |
70 |
|
|
|
71 |
|
|
%prep |
72 |
|
|
%setup |
73 |
|
|
|
74 |
|
|
# This patch allows files to be installed in a relative directory prior |
75 |
|
|
# to creating the binary RPM. It does not change the installed files or |
76 |
|
|
# their final installed locations. |
77 |
|
|
|
78 |
|
|
%patch0 -p1 |
79 |
|
|
|
80 |
|
|
# Create the relative installation directories. |
81 |
|
|
|
82 |
|
|
mkdir -p ./root/usr |
83 |
|
|
mkdir -p ./root/etc |
84 |
|
|
|
85 |
|
|
%build |
86 |
|
|
echo "gcc -O2 -Wall --include /usr/include/errno.h" > conf-cc |
87 |
|
|
echo "gcc -s -Os -pipe" > conf-ld |
88 |
|
|
make |
89 |
|
|
|
90 |
|
|
%install |
91 |
|
|
make setup |
92 |
|
|
make check |
93 |
|
|
rm -rf $RPM_BUILD_ROOT |
94 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
95 |
|
|
|
96 |
|
|
%clean |
97 |
|
|
rm -rf $RPM_BUILD_ROOT |
98 |
|
|
|
99 |
|
|
%files |
100 |
|
|
%attr(644,root,root) /etc/dnsroots.global |
101 |
|
|
%attr(755,root,root) /usr/local/bin/axfrdns |
102 |
|
|
%attr(755,root,root) /usr/local/bin/axfrdns-conf |
103 |
|
|
%attr(755,root,root) /usr/local/bin/axfr-get |
104 |
|
|
%attr(755,root,root) /usr/local/bin/dnscache |
105 |
|
|
%attr(755,root,root) /usr/local/bin/dnscache-conf |
106 |
|
|
%attr(755,root,root) /usr/local/bin/dnsfilter |
107 |
|
|
%attr(755,root,root) /usr/local/bin/dnsip |
108 |
|
|
%attr(755,root,root) /usr/local/bin/dnsipq |
109 |
|
|
%attr(755,root,root) /usr/local/bin/dnsmx |
110 |
|
|
%attr(755,root,root) /usr/local/bin/dnsname |
111 |
|
|
%attr(755,root,root) /usr/local/bin/dnsq |
112 |
|
|
%attr(755,root,root) /usr/local/bin/dnsqr |
113 |
|
|
%attr(755,root,root) /usr/local/bin/dnstrace |
114 |
|
|
%attr(755,root,root) /usr/local/bin/dnstracesort |
115 |
|
|
%attr(755,root,root) /usr/local/bin/dnstxt |
116 |
|
|
%attr(755,root,root) /usr/local/bin/pickdns |
117 |
|
|
%attr(755,root,root) /usr/local/bin/pickdns-conf |
118 |
|
|
%attr(755,root,root) /usr/local/bin/pickdns-data |
119 |
|
|
%attr(755,root,root) /usr/local/bin/random-ip |
120 |
|
|
%attr(755,root,root) /usr/local/bin/rbldns |
121 |
|
|
%attr(755,root,root) /usr/local/bin/rbldns-conf |
122 |
|
|
%attr(755,root,root) /usr/local/bin/rbldns-data |
123 |
|
|
%attr(755,root,root) /usr/local/bin/tinydns |
124 |
|
|
%attr(755,root,root) /usr/local/bin/tinydns-conf |
125 |
|
|
%attr(755,root,root) /usr/local/bin/tinydns-data |
126 |
|
|
%attr(755,root,root) /usr/local/bin/tinydns-edit |
127 |
|
|
%attr(755,root,root) /usr/local/bin/tinydns-get |
128 |
|
|
%attr(755,root,root) /usr/local/bin/walldns |
129 |
|
|
%attr(755,root,root) /usr/local/bin/walldns-conf |